Joined: 12 May 2004
|Posted: Sun Oct 16, 2011 11:26 am Post subject: [ GLSA 201110-01 ] OpenSSL: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: OpenSSL: Multiple vulnerabilities (GLSA 201110-01)
Exploitable: local, remote
Date: October 09, 2011
Updated: July 07, 2014
Bug(s): #303739, #308011, #322575, #332027, #345767, #347623, #354139, #382069
Multiple vulnerabilities were found in OpenSSL, allowing for the
execution of arbitrary code and other attacks.
OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.
Vulnerable: < 1.0.0e
Unaffected: >= 1.0.0e
Unaffected: >= 0.9.8r < 0.9.9
Unaffected: >= 0.9.8s < 0.9.9
Unaffected: >= 0.9.8t < 0.9.9
Unaffected: >= 0.9.8u < 0.9.9
Unaffected: >= 0.9.8v < 0.9.9
Unaffected: >= 0.9.8w < 0.9.9
Unaffected: >= 0.9.8x < 0.9.9
Unaffected: >= 0.9.8y < 0.9.9
Unaffected: >= 0.9.8z_p1 < 0.9.9
Unaffected: >= 0.9.8z_p2 < 0.9.9
Unaffected: >= 0.9.8z_p3 < 0.9.9
Unaffected: >= 0.9.8z_p4 < 0.9.9
Unaffected: >= 0.9.8z_p5 < 0.9.9
Architectures: All supported architectures
Multiple vulnerabilities have been discovered in OpenSSL. Please review
the CVE identifiers referenced below for details.
A context-dependent attacker could cause a Denial of Service, possibly
execute arbitrary code, bypass intended key requirements, force the
downgrade to unintended ciphers, bypass the need for knowledge of shared
secrets and successfully authenticate, bypass CRL validation, or obtain
sensitive information in applications that use OpenSSL.
There is no known workaround at this time.
All OpenSSL users should upgrade to the latest version:
NOTE: This is a legacy GLSA. Updates for all affected architectures are
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.0e"
available since September 17, 2011. It is likely that your system is
already no longer affected by most of these issues.
Last edited by GLSA on Tue Jul 08, 2014 4:28 am; edited 8 times in total