Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Noyau] Configuration de l’ACPI et du multi-processeurs
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7894
Location: ~Brussels - Belgique

PostPosted: Wed Aug 03, 2011 6:28 am    Post subject: Reply with quote

Hello,

Ne serait-ce pas mieux de scinder ce message en deux ? Il y a deux sujets distincts : paquets bloqués (résolu) et configuration de GRUB.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Le Farfadet Spatial
n00b
n00b


Joined: 03 Jan 2011
Posts: 70

PostPosted: Wed Aug 03, 2011 7:18 pm    Post subject: Reply with quote

Salut à tous !

Cr0k wrote:

L'option root (hdX,X) doit contenir la partition /boot. Je n'ai pas bien compris ton schéma, en partition différente tu n'as que / et /home sur ton disque ?


J’ai deux disques. Le premier comporte deux partitions, la première montée sur « / », la deuxième sur « /home ». Le deuxième disque n’a qu’une seule partition, montée sur « /mnt/disque2 ». Donc, « /boot » est sur « sda1 ». Sauf erreur de ma part, dans la dénomination GRUB, cela s’écrit « (hd0,0) ». Par ailleurs, cette configuration fonctionne avec le noyau précédent, ce qui tend à me fait dire qu’il n’y a pas d’erreur quant à la dénomination de la partition sur laquelle se situe « /boot ». Je pense qu’il est peu probable que le problème vienne de là. D’autant que dans le message du kernel panic, aucune partition ne semble détectée, ce qui me parait plutôt signifier qu’il y a un problème dans la configuration des disques durs au niveau du noyau.

XavierMiller wrote:

Ne serait-ce pas mieux de scinder ce message en deux ? Il y a deux sujets distincts : paquets bloqués (résolu) et configuration de GRUB.


Je n’en suis pas certain : de ce qui ressort de ce fil, le blocage d’Emerge était en fait un symptôme révélant un problème de configuration du noyau, lequel problème n’est toujours pas résolu – j’ai voulu utiliser le nouveau noyau pour remettre la configuration à plat. Par ailleurs, pour l’instant les éléments ne m’ont pas l’air révélateurs d’un problème de configuration de GRUB. En revanche, le titre porte à confusion, je vais donc le changer.

À bientôt.

Le Farfadet Spatial
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Thu Aug 04, 2011 8:15 am    Post subject: Reply with quote

Bien sûr tu ne serais pas victime de ça https://forums.gentoo.org/viewtopic-p-6763612.html#6763612 ?
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Le Farfadet Spatial
n00b
n00b


Joined: 03 Jan 2011
Posts: 70

PostPosted: Thu Aug 04, 2011 6:56 pm    Post subject: Reply with quote

Salut à tous !

guilc wrote:

Bien sûr tu ne serais pas victime de ça https://forums.gentoo.org/viewtopic-p-6763612.html#6763612 ?


Franchement, je n’étais sûr de rien. J’ai donc vérifié : j’ai bien CONFIG_MSDOS_PARTITION configuré en dur (built-in). Cependant, la piste m’a l’air bonne : j’ai sans doute fait une bêtise de ce genre.

À bientôt.

Le Farfadet Spatial
Back to top
View user's profile Send private message
Le Farfadet Spatial
n00b
n00b


Joined: 03 Jan 2011
Posts: 70

PostPosted: Sat Aug 06, 2011 10:29 pm    Post subject: Reply with quote

Salut à tous !

J’ai fait de petites modifications régulières dans la configuration du noyau. Au bout d’un moment, le noyau a enfin pu s’initialiser. Je ne sais toujours pas exactement quel était le fond du problème. Je ne désespère pas de vraiment comprendre le fonctionnement interne du noyau, mais pour l’instant je n’ai pas encore assez d’expérience pour cela, alors je vais dans l’immédiat me contenter de ça.

J’ai encore des problèmes et je ne suis pour l’instant pas certain que l’initial soit réglé, mais là ça commence vraiment à se ramifier, je vais donc mettre fin à ce fil de discussion pour l’instant et en commencer de nouveaux.

À bientôt.

Le Farfadet Spatial
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum