Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ide-scsi help
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
gimp2x
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2002
Posts: 112
Location: Atlanta, GA

PostPosted: Fri Jul 19, 2002 8:25 pm    Post subject: ide-scsi help Reply with quote

i recompiled my kernel with scsi emulation built in

i also compiled with scsi cdrom support and generic scsi support, i'm using devfs

i still get this error:

Code:
bedroom root # cdrecord -scanbus
Cdrecord 1.11a26 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.


and on dmesg:
Kernel command line: root=/dev/hda5 /dev/hdd=ide-scsi /dev/hdc=ide-scsi
PIIX4: IDE controller on PCI bus 00 dev f9
PIIX4: chipset revision 4
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:DMA
hda: WDC WD1200JB-75CRA0, ATA DISK drive
hdc: LITEON DVD-ROM LTD163, ATAPI CD/DVD-ROM drive
hdd: LITE-ON LTR-24102M, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: setmax LBA 234375120, native  234375000
hda: 234375000 sectors (120000 MB) w/8192KiB Cache, CHS=14589/255/63, UDMA(100)
hdc: ATAPI 40X DVD-ROM drive, 512kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
hdd: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Partition check:
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4 < p5 p6 >
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices


Last edited by gimp2x on Fri Jul 19, 2002 8:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
metalhedd
l33t
l33t


Joined: 30 May 2002
Posts: 692
Location: Ontario Canada

PostPosted: Fri Jul 19, 2002 8:39 pm    Post subject: Reply with quote

did you include the required /dev/hda=ide-scsi in your /boot/grub/menu.lst?
Back to top
View user's profile Send private message
gimp2x
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2002
Posts: 112
Location: Atlanta, GA

PostPosted: Fri Jul 19, 2002 8:45 pm    Post subject: Reply with quote

did you not see the line?

Code:
Kernel command line: root=/dev/hda5 /dev/hdd=ide-scsi /dev/hdc=ide-scsi
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Fri Jul 19, 2002 8:51 pm    Post subject: Reply with quote

you dont use /dev/hd?, just hd?=scsi

atleast thats what i have and it works

default 0
timeout 30
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux
root (hd0,0)
kernel /boot/bzImage root=/dev/md0 hdc=scsi vga=788

title=backup
root (hd0,0)
kernel /boot/bzImage.old root=/dev/md0 hdc=scsi vga=788
Back to top
View user's profile Send private message
gimp2x
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2002
Posts: 112
Location: Atlanta, GA

PostPosted: Fri Jul 19, 2002 9:10 pm    Post subject: Reply with quote

tried that, didn't work =( still have the /dev/pg** missing problem
Back to top
View user's profile Send private message
rac
Bodhisattva
Bodhisattva


Joined: 30 May 2002
Posts: 6553
Location: Japanifornia

PostPosted: Fri Jul 19, 2002 9:40 pm    Post subject: Reply with quote

How about "hdc=ide-scsi hdd=ide-scsi"?
_________________
For every higher wall, there is a taller ladder
Back to top
View user's profile Send private message
unexist
n00b
n00b


Joined: 19 Jul 2002
Posts: 65

PostPosted: Fri Jul 26, 2002 7:06 pm    Post subject: Reply with quote

hi,
i had the same problem, but finally it's really easy to solve.
there must be several things compiled into the kernel or build as a module:

atapi / ide / mfm / rll support menu
o disable ide / atapi cdrom support
o enable scsi emulation support

scsi support menu
o enable scsi cd-rom support
o enable scsi generic support

there's no need of adding 'hd*=ide-scsi' in lilo / grub.

after rebooting there's sth like 'scsi0 : SCSI host adapter emulation for IDE ATAPI devices' in your dmesg. :)

last step: change your devfsd config. here's an example (my config)

- - %< - - - - - - - - - - %< - - - - - - - - - - %< - - - - - - - - - - %< - - - - - - - - - - %< - -
# Give the cdrw group write permissions to /dev/sg0
# This is done to have non root user use the burner (scan the scsi bus)
REGISTER ^sg0$ PERMISSIONS root.cdrw 660

# Create /dev/dvd for the second cdrom drive
# (change 'cdroms/cdrom1' to suite your setup)
LOOKUP ^dvd$ CFUNCTION GLOBAL mksymlink sr0 dvd
REGISTER ^sr0$ CFUNCTION GLOBAL mksymlink $devname dvd
UNREGISTER ^sr0$ CFUNCTION GLOBAL unlink dvd

# Create /dev/cdrw for the first cdrom on the scsi bus
# (change 'sr0' to suite your setup)
LOOKUP ^cdrw$ CFUNCTION GLOBAL mksymlink sr1 cdrw
REGISTER ^sr1$ CFUNCTION GLOBAL mksymlink $devname cdrw
UNREGISTER ^sr1$ CFUNCTION GLOBAL unlink cdrw
- - %< - - - - - - - - - - %< - - - - - - - - - - %< - - - - - - - - - - %< - - - - - - - - - - %< - -

i guess this is self-explanatory. :)
_________________
subtle window manager | dotfiles
Back to top
View user's profile Send private message
proxy
Apprentice
Apprentice


Joined: 20 Apr 2002
Posts: 253
Location: Chantilly, VA

PostPosted: Fri Jul 26, 2002 7:54 pm    Post subject: Reply with quote

i had this prob, you probably didnt incldue "generic scsi support" from the scsi section of the kernel config

give that a try. for me that made the correct /dev entries.

proxy
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum