Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Sandy Bridge] Toujours des problèmes ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Damiatux
Apprentice
Apprentice


Joined: 23 Feb 2008
Posts: 194

PostPosted: Fri Jul 08, 2011 8:26 pm    Post subject: [Sandy Bridge] Toujours des problèmes ? Reply with quote

Bonjour,

Ayant envie de changer de configuration, je penche sur le fait de savoir si avec les Sandy Bridge il y a encore des problèmes avec le noyau. J'ai lu quelques sujets en Anglais, mais n'étant pas très fort sur ce point, je demande confirmation.

Damiatux
Back to top
View user's profile Send private message
Zoboulo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Apr 2007
Posts: 97

PostPosted: Mon Jul 11, 2011 11:45 am    Post subject: Reply with quote

Oui, toujours des problèmes ! Chez moi le suspend-to-ram ne fonctionne pas ... sur un pc fixe ! Attends encore quelques mois à mon avis ! Et vu qu'Ivy bridge est prévu pour dans moins d'un an ...
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Sat Aug 27, 2011 7:24 pm    Post subject: Reply with quote

Je up ce topic car je me suis fait une config récemment à base de Sandy Bridge. Avec l'IGP du processeur, je suis limité à du 1024x768@60Hz, ce qui n'est vraiment pas top. Heureusement je dispose d'un IGP sur la carte mère qui est un bête Intel classique retrouvé dans de nombreuses cartes-mères. Ce n'est pas un gros souci puisque j'envisage rapidement de m'acheter une vraie carte graphique. Ce pendant je suis curieux de savoir si quelqu'un a réussi à faire tourner une plateforme Sandy Bridge parfaitement.
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sat Aug 27, 2011 9:06 pm    Post subject: Reply with quote

La question est : fais-tu tourner du arch ou du ~arch ?
A priori les version ~arch devraient suffire pour faire tourner correctement du sandy bridge (ceci dit, je n'ai pas testé, c'est juste ce que me disent mes lectures).
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Enlight
Advocate
Advocate


Joined: 28 Oct 2004
Posts: 3519
Location: Alsace (France)

PostPosted: Sun Aug 28, 2011 12:41 am    Post subject: Reply with quote

Il me semble avoir lu récemment que linux 3.0 supporte correctement le sandy bridge.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Mon Aug 29, 2011 12:14 am    Post subject: Reply with quote

Moi aussi j'ai vu passé ça. Je pense que j'ai lu ça sur phoronix.
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Tue Aug 30, 2011 7:27 pm    Post subject: Reply with quote

Testé avec les gentoo-sources 3.0.4. Je suis toujours limité en 1024x768. Tant pis.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Aug 31, 2011 3:33 am    Post subject: Reply with quote

Même GCC n'aime pas les Sandy : https://bugs.gentoo.org/show_bug.cgi?id=360927

Il est plus sage d'utiliser GCC 4.6 avec ce genre de processeur.
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Wed Aug 31, 2011 8:28 pm    Post subject: Reply with quote

Bon,j'ai réussi à avoir autre chose que du 1024x768 avec les Modeline, heureusement pour me yeux. C'est franchement dommage que ça ne le fasse pas automatiquement.
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3084
Location: Paris

PostPosted: Wed Sep 14, 2011 3:09 pm    Post subject: Reply with quote

d2_racing wrote:
Même GCC n'aime pas les Sandy : https://bugs.gentoo.org/show_bug.cgi?id=360927

Il est plus sage d'utiliser GCC 4.6 avec ce genre de processeur.


AAaaaah, je me suis fait plaisir en me payant ce bug, je suis passé à gcc 4.6.1 sur mon desktop.
Hahaaaaa, vite, emerge -e world, qu'on vérifie si un truc pète et.... ben non, juste thunderbird-3.1.12, en passant à la thunderbird 6.0 nickel.

Raaah, j'ai rien cassé! Bouuuuuh! :roll:
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Sep 14, 2011 4:28 pm    Post subject: Reply with quote

AS-tu pris native ou corei7 ?
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3084
Location: Paris

PostPosted: Wed Sep 14, 2011 5:00 pm    Post subject: Reply with quote

Ah, native, pourquoi? Aurais-je involontairement esquivé des difficultés? Diantre! :o
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3084
Location: Paris

PostPosted: Thu Sep 15, 2011 2:11 pm    Post subject: Reply with quote

d2_racing wrote:
AS-tu pris native ou corei7 ?


Bon, j'ai appliqué la "méthode guilc (c)" et... je n'ai pas compris le résultat, qu'on pourrait considérer comme contraire à ce qui est attendu (ou bien j'ai encore raté quelque chose :? ):

Code:
# gcc -Q -march=native --help=target > native
# gcc -Q -march=corei7-avx --help=target > corei7
# colordiff native corei7
13c13
<   -maes                                       [enabled]
---
>   -maes                                       [disabled]
22c22
<   -mavx                                       [enabled]
---
>   -mavx                                       [disabled]
30c30
<   -mcx16                                      [enabled]
---
>   -mcx16                                      [disabled]
58c58
<   -mno-sse4                                   [disabled]
---
>   -mno-sse4                                   [enabled]
61,62c61,62
<   -mpclmul                                    [enabled]
<   -mpopcnt                                    [enabled]
---
>   -mpclmul                                    [disabled]
>   -mpopcnt                                    [disabled]
71c71
<   -msahf                                      [enabled]
---
>   -msahf                                      [disabled]
73,74c73,74
<   -msse                                       [enabled]
<   -msse2                                      [enabled]
---
>   -msse                                       [disabled]
>   -msse2                                      [disabled]
76,79c76,79
<   -msse3                                      [enabled]
<   -msse4                                      [enabled]
<   -msse4.1                                    [enabled]
<   -msse4.2                                    [enabled]
---
>   -msse3                                      [disabled]
>   -msse4                                      [disabled]
>   -msse4.1                                    [disabled]
>   -msse4.2                                    [disabled]
83c83
<   -mssse3                                     [enabled]
---
>   -mssse3                                     [disabled]
90c90
<   -mtune=                                     corei7-avx
---
>   -mtune=


"Et là, c'est le drame"
Comment, par exemple, l'AVX peut-il est non activé sur un profile "corei7-avx"
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Thu Sep 15, 2011 3:05 pm    Post subject: Reply with quote

Original... A croire que le profil native active plus d'options pour ton CPU... Le profil corei7-avx n'aurait pas fini de sécher ?
Y a même un truc qui me semble étrange, march=native positionnerait un mtune=corei7-avx ??? Tu es sûr de ne pas avoir inversé les diff ? :?
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3084
Location: Paris

PostPosted: Thu Sep 15, 2011 3:59 pm    Post subject: Reply with quote

guilc wrote:
Tu es sûr de ne pas avoir inversé les diff ? :?

Sûr de chez sûr chef, j'ai même utiliser des mots clés bidons à la place d'un profil valable, ça renvoie toujours le même résultat. 8O
Précisément "gcc -Q -march=truc --help=target" renvoit la même chose que "gcc -Q -march=corei7-avx --help=target", pareil avec core2, machin, pouet...

Il y a pas gamelle, genre je spécifie mal quelque chose?

--
edit:
je viens de faire le même test sur un atom avec un gcc 4.4, même symptôme, dès que ce n'est pas native, le résultat est identique à un profile incorrect:
Code:
elgo@twat ~/tmp $  colordiff native core2
23c23
<   -mcx16                                      [enabled]
---
>   -mcx16                                      [disabled]
56c56
<   -msahf                                      [enabled]
---
>   -msahf                                      [disabled]
74c74
<   -mtune=                                     core2
---
>   -mtune=
elgo@twat ~/tmp $ colordiff truc core2
17c17
<   -march=                                     truc
---
>   -march=                                     core2

_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1677
Location: 127.0.0.1

PostPosted: Sat Feb 18, 2012 10:17 am    Post subject: Reply with quote

Petit up, je viens de tomber sur le problème, et après quelques recherches, bug gcc, apparemment toujours d'actualité (gcc-4.5.3-r1) :
gcc -Q --help=target does not list extensions selected by -march=
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum