Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Tecken med Alt-Gr i X
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
Hubbe
n00b
n00b


Joined: 21 Sep 2003
Posts: 18
Location: Gothenburg, Sweden

PostPosted: Tue Sep 23, 2003 7:30 pm    Post subject: Tecken med Alt-Gr i X Reply with quote

åäö fungerar som de ska i X, men jag kan inte få @ $ [ ] osv. (copy paste är inte så värst kul...)
Alt-gr tecknena fungerar som de ska i consolen, men inte när jag startat X. Någon som vet vad det kan vara?
Kan det vara att jag valde 101 tangenters keyboard? Eller något annat?

/Johan
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Tue Sep 23, 2003 8:06 pm    Post subject: Reply with quote

Det borde räcka med
Code:
    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "se"

men du kan ju testa med att lägga till
Code:
    Option "XkbVariant"  "nodeadkeys"

eller ta bort om du har den redan.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Hubbe
n00b
n00b


Joined: 21 Sep 2003
Posts: 18
Location: Gothenburg, Sweden

PostPosted: Tue Sep 23, 2003 9:08 pm    Post subject: Reply with quote

okej, tack.
Ska testa det!
/Johan
Back to top
View user's profile Send private message
hegga
Apprentice
Apprentice


Joined: 04 Jun 2003
Posts: 210
Location: Norway

PostPosted: Fri Oct 10, 2003 8:17 am    Post subject: Reply with quote

Jeg har samme problemet, men å skru av eller på "nodeadkeys" hjelper ingenting.
XF86Config ser slik ut:

Code:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbRules" "xfree86"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "no"
        #Option     "XkbVariant" "nodeadkeys"
EndSection


Er det noen som kan hjelpe meg ?
_________________
hegga
Back to top
View user's profile Send private message
professorn
Apprentice
Apprentice


Joined: 18 Sep 2003
Posts: 235
Location: Stockholm, Sweden

PostPosted: Fri Oct 10, 2003 1:20 pm    Post subject: Reply with quote

Code:

Section "InputDevice"
    Identifier   "Keyboard1"
    Driver   "Keyboard"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc101"
    Option "XkbLayout"   "se"

EndSection

Har inte tangentbords inställningarna sen jag körde xf86config (programet). @ och Co. funkar utmärkt
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Fri Oct 10, 2003 1:38 pm    Post subject: Reply with quote

Du kan använda
Code:
showkey (-a)

för att se vilka koder som tangentbordet kastar ur sig.

Sen har jag också
Code:
InputDevice "Keyboard1" "CoreKeyboard"

i min ServerLayout section, om det nu spelar någon roll.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Kodama
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jan 2003
Posts: 85
Location: Linköping, Sweden

PostPosted: Sat Oct 11, 2003 12:56 pm    Post subject: Reply with quote

Halloj Xpilot spelare Hubbe ;-)

För ditt problem; testa ha med denna rad i XF86Config.

Code:
Option "RightAlt"    "ModeShift"


(PS. Spela mer Xpilot!)

edit: kolla den här länken https://forums.gentoo.org/viewtopic.php?t=41987&highlight=altgr
Back to top
View user's profile Send private message
independence
n00b
n00b


Joined: 06 Dec 2003
Posts: 21
Location: Sweden

PostPosted: Mon Dec 15, 2003 5:55 pm    Post subject: Reply with quote

Jag hade exakt samma problem men det löste sig när jag bytte XkbVariant från "se" till "nodeadkeys", kolla om ni har två st. rader med Option "XkbVariant", jag har 123 kommenterade rader som skapades av autokonfig saken, svårt att se om en rad inte är kommenterad..
_________________
http://www.blinkenlights.se/ - En webbsida om programmering och spelutveckling
http://blinkenshell.org/ - Free UNIX shell service
Back to top
View user's profile Send private message
SwedishElk
Tux's lil' helper
Tux's lil' helper


Joined: 19 Nov 2003
Posts: 79
Location: Stockholm, Sweden

PostPosted: Sun Dec 21, 2003 6:18 pm    Post subject: Reply with quote

Har samma problem här.

XF86Config:

Option "XkbRules" "xfree86"
Option "XkbModel" "microsoft"
Option "XkbVariant" "nodeadkeys"
Option "XkbLayout" "se"
Option "RightAlt" "ModeShift"

Det funkar bra i konsolläge men inte i X.

Om jag trycker på Alt-Gr och exempelvis (Dollar) i en XConsol så får jag

#
(arg: 2)
Back to top
View user's profile Send private message
SwedishElk
Tux's lil' helper
Tux's lil' helper


Joined: 19 Nov 2003
Posts: 79
Location: Stockholm, Sweden

PostPosted: Mon Dec 22, 2003 10:57 am    Post subject: Reply with quote

Hittade följande fel ifrån X:

Code:

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Cannot open "/var/tmp/server-0.xkm" to write keyboard description
>                   Exiting
Couldn't load XKB keymap, falling back to pre-XKB keymap
Back to top
View user's profile Send private message
rafo
Apprentice
Apprentice


Joined: 18 Nov 2003
Posts: 159
Location: Sollentuna, Sweden

PostPosted: Tue Dec 23, 2003 8:46 pm    Post subject: Reply with quote

Också jag hade detta fel,

> Error: Cannot open "/var/tmp/server-0.xkm" to write keyboard description

med resultat att Alt-2, Alt-4, Alt-8, Alt-9 och några till inte fungerade. Efter att jag gjort `chmod 777 /usr/tmp' som root och startat om X så fungerar min Alt-tangent igen. Vad som kan ha orsakat 755 rättigheter för /usr/tmp vet jag inte, men jag har provat olika fönsterhanterare och någon av dem kanske har löpt amok.
Back to top
View user's profile Send private message
SwedishElk
Tux's lil' helper
Tux's lil' helper


Joined: 19 Nov 2003
Posts: 79
Location: Stockholm, Sweden

PostPosted: Thu Dec 25, 2003 6:54 pm    Post subject: Reply with quote

Men det skumma är ju att en annan dator här hemma som fungerar superbt har 755 på /var/tmp utan problem. Men jag kom på en sak som jag vill tillföra, jag flyttade hela /var till en ny hårddisk, kan det ha skapat problemet? Det är samma rättigheter på den iofs.
Back to top
View user's profile Send private message
johtib
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2004
Posts: 128

PostPosted: Wed Jun 23, 2004 6:35 am    Post subject: Reply with quote

Vad ar skillnaden mellan XkbLayout "se" och "sv-latin1"?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum