Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[terminal] mauvaise recup de taille: nano et make [Résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
betalebeta
n00b
n00b


Joined: 26 Jun 2011
Posts: 5

PostPosted: Sun Jun 26, 2011 3:00 pm    Post subject: [terminal] mauvaise recup de taille: nano et make [Résolu] Reply with quote

Bonjour !

Me voila à vous écrire suite à plusieurs googlage pas vraiment fructueux

Suite à un "emerge -e @system" (sur les dix premières ebuilds puis interruption de celui-ci) je me retrouve avec nano refusant de demarrer sous le pretexte que le terminal est trop petit ainsi que ce message d'erreur de la par de "make menuconfig" :

Your display is too small to run Menuconfig!
It must be at least 19 lines by 80 columns.
make[1]: *** [menuconfig] Erreur 1
make: *** [menuconfig] Erreur 2

Bien évidement si je poste c'est que cela se produit alors même que mon terminal a plus de 19 lines by 80 columns (vérifié via une commande trouvée lors du googlage dont je ne me souvient plus de la teneur, mais qui à mon souvenir utilisait des variables d'environnement du type $LINES et $COLUMNS me renvoyant 36 et 143 en plein écran)!

Je souhaite savoir quel ebuild dois-je reemerger pour que le problème soit corrigé, ou bien quel fichier de configuration doit être tripatouillé, car bien qu'il m'ais suffit d'utiliser vi à la place de nano cela est plus embêtant en ce qui concerne la configuration du noyau !

Si vous souhaitez que je vous montre mon "emerge --info" pourriez vous me donner la balise secret pour eviter de mettre deux pages d'infos pas forcement utile et pas trés estétique en direct dans le corps du message!

Merci à vous de m'avoir lu et pour vos future réponses !


Last edited by betalebeta on Mon Jun 27, 2011 7:38 am; edited 2 times in total
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sun Jun 26, 2011 3:05 pm    Post subject: Reply with quote

Il n'y a pas de balise secret. Tu peux utiliser la balise
Code:
[code] ... [/code]


1/ Quels sont les paquets que tu as mis à jour?
2/ As-tu lu les elogs de ces paquets et effectué les recommandations s'il y en avait?
3/ As-tu mis à jour les fichiers de configuration des paquets?
Back to top
View user's profile Send private message
betalebeta
n00b
n00b


Joined: 26 Jun 2011
Posts: 5

PostPosted: Sun Jun 26, 2011 3:40 pm    Post subject: Reply with quote

re-Bonjour et merci de la vitesse de la réponse !

1) Tout d'abord il n'y a pas eu de mise à jour dans les paquets mais de la rebuild (je souhaitais voir quels paquets acceptais que je mettent LDFLAGS+="-flto" et CFLAGS+="-flto flto-report" apparrement ce dernier ne fait jamais échouer la compilation alors que le premier peut le faire pour certain paquets) mais je n'est pas gardé les noms des paquets ( mais ce doit être ceux que l'on obtient dans les premier quand on fait "emerge @system" mais je suis même plus sûr de les avoir activés à ce moment là )

2) et 3) le 1) y répond (je n'est rien touché)!

Tout d'abord je ne suis pas sûr à 100% que ce soit les rebuild qui ais fait merder le bignou mais je n'est rien fait d'autre à ce moment !

En fait si vous savez quels ebuilds sont responssable du terminal que je rebuild tout ça pour voir le résultat (pas trés propres mais bon) ce serait vraiment bien! (je sais que j'en demande beaucoup pour pas grand chose)

Je sais que j'aide pas beaucoup a résoudre mon propre problème mais je n'ais aucune idée de ce qui fait croire à nano et make menuconfig que mon terminal est trop petit (alors qu'il ne l'est pas)!

Je sais pas si ça peut jouer mais ces paquets system on été installed en tant que paquets binaire par le systeme d'installation de sabayon et je ne crois pas les avoir rebuildé avant cette fois (mais les uses flags n'ont pas été modifié)

Je crois que je vais tout reemerger via un "emerge -ea @installed" et voir ce que ça donne (on sait jamais)
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sun Jun 26, 2011 3:57 pm    Post subject: Reply with quote

Tu peux connaître les derniers paquets installer et regardant les elog, ou l'emerge.log (genlop si tu préfère ne pas le parser en live mentalement)

On ne sait meme pas si tu parles des consoles TTY, d'un terminal style xterm, ou autre. Difficile de t'aider avec si peu d'infos.

Un petit conseil, évite les CFLAGS exotiques, spécialement pour le système. Si tu en as besoin pour certains paquets en particuliers, configure ces variables pour les paquets concernés, mais, vraiment, je te déconseille de le faire pour tout le système! Même le manuel GCC le déconseille. Dans 99,99% des cas, un -O2 -march=native -pipe sera un très bon choix.

Je te conseille aussi de lire ceci avant de te faire fumer par la BMM :roll:
Back to top
View user's profile Send private message
betalebeta
n00b
n00b


Joined: 26 Jun 2011
Posts: 5

PostPosted: Sun Jun 26, 2011 4:25 pm    Post subject: Reply with quote

Pour répondre à ta question le problème survient sur tous les types de console !

Et je n'utilise pas vraiment de CFLAGS exotique je test juste lto !!!

PS:c'est quoi/qui la BMM ? et qu'est ce qui ne va pas avec mon poste ( si c'est le manque d'info a vrai dire je sais pas quel est le problème moi même donc il est vrai que j'en donne pas beaucoups , si c'est le titre pourrais-tu m'aiguiller pour le rendre plus clair là je vois pas)
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sun Jun 26, 2011 5:26 pm    Post subject: Reply with quote

Le document dans le lien explique bien à quoi doit ressembler un titre de sujet.

BMM Brigade des méchants modérateurs :roll:

Ca donne quoi
Code:
echo "$COLUMNS - $LINES"


Et tu as bien USE=lto pour gcc? (mais je persiste, pour le systeme, je resterais le plus simple possible concernant le flags...)

Par contre, je ne suis pas certain de comment gérer le machin avec des paquets qui viennent de sabayon, je passe la main à ce niveau
Back to top
View user's profile Send private message
betalebeta
n00b
n00b


Joined: 26 Jun 2011
Posts: 5

PostPosted: Sun Jun 26, 2011 5:42 pm    Post subject: Reply with quote

Comme dit dans le premier message
Code:
 echo "$COLUMNS - $LINES"
renvoit 143-36 et c'est pourquoi je trouve bizar le message de make menuconfig !!!

aucune des ebuild system ne vient de sabayon et j'utilise les flags normalement habituellemnt (le lto était juste un test et oui je les mis dans les uses)

Pour le titre je vois toujours pas comment le rendre clair vu que je sais pas à quel endroit sa merde ! je met quoi en [THEME] ???

EDIT: je viens de lancer un
Code:
emerge -e @installed
pour voir si cela corrige le probleme !
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sun Jun 26, 2011 9:22 pm    Post subject: Reply with quote

Genre [terminal] pour le titre, c'est aussi simple que ça...

Et en partant d'une base Sabayon au lieu d'une vraie Gentoo, t'es parti pour pas mal de problèmes... Sabayon n'est pas Gentoo. :)
Back to top
View user's profile Send private message
betalebeta
n00b
n00b


Joined: 26 Jun 2011
Posts: 5

PostPosted: Sun Jun 26, 2011 9:37 pm    Post subject: Reply with quote

Pour le moment je n'ais pas eu plus de problème avec la base sabayon que je n'en ais avec celle gentoo je dirais même que j'en ais eu moins ^^ !!!


EDIT: Après le reemerge globale sur system le problème a disparu comme il était venu !!!

Merci de vos réponse et désolé pour le dérangement inutile !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum