Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Installation] Ext3-fs : barriers not enable
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Hoxydav
n00b
n00b


Joined: 16 Jun 2011
Posts: 5

PostPosted: Thu Jun 16, 2011 2:33 am    Post subject: [Installation] Ext3-fs : barriers not enable Reply with quote

Bonjour à vous,
je veux préparer un serveur sous gentoo mais après plusieurs essais je n'arrive pas à finir mon installation.
Je suis donc sous Xp, ma machine virtuel est sous vmware workstation 7.1.0, le disque dur est SCSI.

Voilà mon dernier bloc d'erreur.
Code:

input2 ImPS/2 Generic Uheel Mouse as /devices/platform/i8B42/seri
NET2 Registered protocol family 18
ip6Atables2 (C) 2B88~2@86 Netfilter Core Team
IPv6 over IPv4 tunneling driver
NET2 Registered protocol family 17
Registering the dnsgresolver key type
Using IPI No'Shortcut mode
registered taskstats version 1
Magic number2 1534455363
2 Uaiting for all devices to be available before autodetect
2 If you don`t use raid. use raid=noautodetect
md
md
md2 Hutodetecting RHID arrays.
md2 Scanned 8 and added 8 devices.
md2 autorun .H
md2 ... autorun DONE.
EXT3-fs : barriers not enabled
kjournald starting. Commit interval 5 seconds
EXT3~fs (sda3)2 mounted filesystem with uriteback data mode
UFS2 Mounted root (ext3 filesystem) readonly on device 823.
Freeing unused kernel memory2 428k freed
Urite protecting the kernel text2 5828k
Urite protecting the kernel read~only ddfdi 1868k
initaearly.sh used greatest stack depth2 5944 bytes left


J'ai vraiment besoin de votre aide.
Cordialement.
Alexis Montoro
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Thu Jun 16, 2011 7:20 am    Post subject: Reply with quote

Hello,

Je me trompe peut-être, mais çà me fait penser au bug #368597, il semblerait que les stage3 actuels soient défaillants.
Tu as quoi dans /dev ? Jette un oeil ici.
Quote:

At the end of the handbook when i have to reboot my kernel stop and do nothing
because my root fs was missing /dev/console device
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Jun 16, 2011 11:47 am    Post subject: Reply with quote

En effet,ça ressemble étrangement à ton problème.

J'espère que Gentoo va corriger ce problème rapidement.
Back to top
View user's profile Send private message
Hoxydav
n00b
n00b


Joined: 16 Jun 2011
Posts: 5

PostPosted: Thu Jun 16, 2011 1:44 pm    Post subject: Reply with quote

Merci beaucoup je regarde ça mais j'ai voulu recompiler mon noyaux avec de nouvelles cfg et j'ai un autre bug. Mais merci encore pour vos indications. J'essayerai de revenir dire ce qui m'a aider à réussir tout ça.
Back to top
View user's profile Send private message
Hoxydav
n00b
n00b


Joined: 16 Jun 2011
Posts: 5

PostPosted: Thu Jun 16, 2011 4:55 pm    Post subject: Reply with quote

Bon c'est incroyable comme je n'y arrive pas ça fait 10 fois que je refais toute les manipes possibles et rien n'y fait cette fois ci j'ai un kernel panic du genre :

Quote:

Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)


Sachant que j'ai fait les test sous grub et lilo

j'en peux plus les amis ...
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Thu Jun 16, 2011 5:27 pm    Post subject: Reply with quote

Donne le contenu de ton fstab et de ton grub.conf.
Back to top
View user's profile Send private message
Hoxydav
n00b
n00b


Joined: 16 Jun 2011
Posts: 5

PostPosted: Thu Jun 16, 2011 5:40 pm    Post subject: Reply with quote

Mon fstab :

Code:

/dev/sda1               /boot           ext2            noauto,noatime  1 2
/dev/sda3               /               ext3            noatime         0 1
/dev/sda2               none            swap            sw              0 0
/dev/cdrom              /mnt/cdrom      auto            noauto,ro       0 0
/dev/fd0                /mnt/floppy     auto            noauto          0 0

none                    /proc           proc            defaults        0 0
none                    /dev/shm        tmpfs           nodev,nosuid,noexec  0 0


mon lilo.cfg (je peux switcher sur grub au cas ou ça arrange)
Code:

boot=/dev/sda     # Installe LILO dans le MBR.
prompt            # Permet à l'utilisateur de sélectionner
                  #  une autre entrée.

timeout=50        # Délai de 5 (cinq) secondes avant de démarrer
                  #  l'entrée par défaut.

default=myGentoo    # Définit l'entrée par défaut.

# Uniquement si vous utilisez le framebuffer. Supprimez la ligne
# suivante dans le cas contraire.
#vga=788           # Mode graphique du framebuffer

# Sans genkernel
image=/boot/newBoot
  label=myGentoo    # Nom que nous avons attribué à cette entrée
  read-only       # Démarre avec root en lecture seule. Ne pas modifier
  root=/dev/sda3  # Endroit où se trouve le système de fichier root

Back to top
View user's profile Send private message
Hoxydav
n00b
n00b


Joined: 16 Jun 2011
Posts: 5

PostPosted: Thu Jun 16, 2011 7:45 pm    Post subject: Reply with quote

personne ne peut m'aider? j'ai encore été faire un tour dans la config du noyaux en ayant suivie les explications suivantes :
https://forums.gentoo.org/viewtopic-t-476734-start-0.html

Mais rien n'y fait et j'ai toujours mon kernel panic j'ai vraiment besoin de vous.
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Fri Jun 17, 2011 9:25 am    Post subject: Reply with quote

Je n'ai jamais utilisé lilo. Tu es sûr d'avoir configuré correctement ton kernel ? donne nous la config que tu utilises (pastebin) et ton lspci.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Jun 17, 2011 12:37 pm    Post subject: Reply with quote

Je te conseille d'utiliser Grub.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum