Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Servizi di rete non partono con wifi
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
geps2
Apprentice
Apprentice


Joined: 12 Jul 2006
Posts: 267

PostPosted: Sun Jun 12, 2011 7:52 am    Post subject: [RISOLTO] Servizi di rete non partono con wifi Reply with quote

Ciao a tutti.
Ho un portatile con gentoo e due interfacce di rete: eth0 (LAN cablata) e eth1 (WiFi).
Ho notato una cosa strana, che forse dipende dall'ultimo aggiornamento di baselayout: tutti i servizi che hanno "need net" o "use net" nello script di avvio di init.d, non partono se non è collegato il cavo ethernet, nonostante l'interfaccia eth1 sia up & running
Code:
init.d # /etc/init.d/samba start                                                                                         
 * Bringing up interface eth0
 *   dhcp ...
 *     Running dhcpcd ...
dhcpcd[4997]: version 5.2.12 starting                                                                                           
dhcpcd[4997]: eth0: waiting for carrier
dhcpcd[4997]: timed out
dhcpcd[4997]: allowing 8 seconds for IPv4LL timeout
dhcpcd[4997]: timed out                                                                                                   [ !! ]
 * ERROR: net.eth0 failed to start
 * ERROR: cannot start samba as net.eth0 would not start

Mi piacerebbe che i servizi di rete partissero indipendente da quale interfaccia di rete è up: dov'è il problema?
Grazie per l'attenzione, ciao!


Last edited by geps2 on Sun Jun 12, 2011 8:25 am; edited 1 time in total
Back to top
View user's profile Send private message
geps2
Apprentice
Apprentice


Joined: 12 Jul 2006
Posts: 267

PostPosted: Sun Jun 12, 2011 8:25 am    Post subject: Reply with quote

Trovato da solo: cambiare il valore di default (YES) di rc_depend_strict nel file /etc/rc.conf:

Code:
rc_depend_strict="NO"


Ciao!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum