Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Résolu][Proxy] monter automatiquement le proxy
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 179

PostPosted: Fri Jun 03, 2011 8:07 am    Post subject: [Résolu][Proxy] monter automatiquement le proxy Reply with quote

Bonjour,

J'ai un souci sur l'ordi du bureau que je viens de passer sous gentoo.
On utilise un proxy pour accéder à internet. Le souci c'est qu'au boot du PC les variables http_proxy et compagnie ne sont pas settées.

J'ai ajouté les lignes suivantes dans /etc/env.d/99local :
http_proxy="http://.......:8080/"
https_proxy="http://.......:8080/"
ftp_proxy="http://.......:8080/"

Le souci c'est que les proxy ne montent pas tout seul. Et si je les ajoute à la main avec un export,
mon navigateur et autres applis ne fonctionnent pas. par contre emerge et ncftp fonctionnent. Une petite idée svp ?

Merci d'avance pour votre aide.
_________________
- zerros -


Last edited by zerros on Tue Jun 07, 2011 3:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
StinGer_Uesugi
Tux's lil' helper
Tux's lil' helper


Joined: 12 Nov 2010
Posts: 139
Location: Milky Way > Solar System > Earth > France > Paris > Home

PostPosted: Fri Jun 03, 2011 8:39 am    Post subject: Reply with quote

Salut !

Première chose : au sujet des tes variables. Ou plus exactement de leur contenu. Personnellement, je ne mets pas le "http://" devant. Par exemple, j'ai des trucs comme ça :
Code:
http_proxy="proxy.domain:8080"


Ensuite, si l'adresse est la même pour tous les proxy, je te conseille plutôt de les rentrer ainsi :
Code:
http_proxy="proxy.domain:8080"
https_proxy=$http_proxy
ftp_proxy=$http_proxy


Enfin, pour ton navigateur, j'ai déjà eu des problèmes avec les navigateurs GUI qui ne prenait pas en compte la variable d'environnement. Soit tu les redéfinis à la main dans les options du navigateur. Soit tu lui fait utiliser les variables "systèmes". Si tu es sous Gnome, tu dois régler ça dans GConf; sous KDE, tu dois installer Konqueror faire apparaître les options dans les réglages "Réseaux" de systemsettings. Et pour les autres, je sais pas.
_________________
Why drink and drive when you can smoke and fly ?
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 179

PostPosted: Fri Jun 03, 2011 8:45 am    Post subject: Reply with quote

Merci pour ces infos. Mon navigateur fonctionne. Il a juste mis un peu de temps.

Par contre je ne vois toujours pas pourquoi mon 99local n'est pas pris en charge au démarrage de ma session.
Je suis sous awesome. Pas de gnome, ni de kde.
_________________
- zerros -
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 179

PostPosted: Mon Jun 06, 2011 8:02 am    Post subject: Reply with quote

Bonjour,

J'ai finalement réussi à le faire monter automatiquement.

Je suis sur awesome, et je ne trouve pas comment exclure certaines adresses url
du proxy. J'utilise google chrome qui prend sa configuration proxy du système.

une idée ?
_________________
- zerros -
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum