Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No reconoce onboard de nvidia... [RESUELTO]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Oicraman
n00b
n00b


Joined: 14 Apr 2011
Posts: 20

PostPosted: Fri May 27, 2011 6:37 am    Post subject: No reconoce onboard de nvidia... [RESUELTO] Reply with quote

Hola a todos, tengo un problema con mi onboard de nvidia, mi placa madre es una ASROCK N61P-S, mi video onboard es NVIDIA GeForce 6150SE / nForce 430.
Sin xorg.conf me arranca el video como fbdev pero no funciona teclado ni mouse.
No me funciona "X -configure" o "Xorg -configure"
Entonces me decidi a configurar manualmente el xorg.conf, estuve tentando configurar para haber si agarra el driver de nvidia en la configuracion, o el nouveau o vesa ( y nada de ellos lo logro hacer que funcione) me manda mensaje de error "no screens found".

scanpci da errores como:
scanpci: Couldn't initialize PCI system: No such file or directory

les mostrare a continuacion mis archivos de configuracion para ver si hice algo mal:

xorg.conf
Code:

Section "ServerLayout"
   Identifier   "Layout0"
   Screen 0   "Screen0"         0 0
   InputDevice   "Mouse0"         "CorePointer"
   InputDevice   "Keyboard0"         "CoreKeyboard"
   Option      "AllowEmptyInput"      "false"
   Option      "Xinerama"         "0"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath   "/usr/share/fonts/misc/"
   FontPath   "/usr/share/fonts/TTF/"
   FontPath   "/usr/share/fonts/OTF/"
   FontPath   "/usr/share/fonts/Type1/"
   FontPath   "/usr/share/fonts/100dpi/"
   FontPath   "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Disable      "dri"
   Disable      "dri2"
   Load      "dbe"
   Load      "glx"
   Load      "extmod"
   Load      "record"
EndSection

Section "InputDevice"
   Identifier   "Keyboard0"
   Driver      "kbd"
   Option      "XkbLayout"         "es"
   Option      "XkbModel"         "pc105"
   Option      "XkbRules"         "xorg"
   Option      "XkbOptions"         "grp:alt_shift_toggle,grp:switch,grp_led:scroll,compose:rwin,terminate:ctrl_alt_bksp"
EndSection

Section "InputClass"
   Identifier   "keyboard0"
   Driver      "evdev"
   MatchIsKeyboard "on"
EndSection

Section "InputDevice"
   Identifier   "Mouse0"
   Driver      "mouse"
   Option      "Protocol"         "auto"
   Option      "Device"         "/dev/input/mice"
   Option      "ZAxisMapping"         "4 5 6 7"
   Option      "Emulate3Buttons"      "no"
EndSection

Section "InputClass"
   Identifier      "Mouse0"
   Driver          "evdev"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Unknown"
   ModelName   "AOC Spectrum 4Vn"
   HorizSync   31.0 - 53.0
   VertRefresh   60.0 - 85.0
   Option      "DPMS"
EndSection

Section "Device"
   Identifier   "Card0"
#   Driver      "fbdev"
#   Driver      "vesa"
#   Driver      "nouveau"
#   Driver      "nvidia"
   VendorName   "nVidia Corporation"
   BoardName   "GeForce 6150SE nForce 430"
#   BusID      "PCI:2:0:0"
   Option      "NoLogo"         "true"
EndSection

Section "Screen"
   Identifier   "Screen0"
   Device      "Card0"
   Monitor      "Monitor0"
   DefaultDepth   24
   Option      "TwinView"         "0"
   Option      "TwinViewXineramaInfoOrder"   "CRT-0"
   Option      "metamodes"         "1024x768_60 +0+0; 1024x768 +0+0"
   SubSection "Display"
      Viewport   0 0
      Depth      1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth      4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth      8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth      15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth      16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth      24
   EndSubSection
EndSection


emerge --info
Code:

app-shells/bash:     4.1_p9
dev-lang/python:     2.7.1-r1, 3.2
dev-util/cmake:      2.8.4-r1
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
sys-kernel/linux-headers: 2.6.38
sys-libs/glibc:      2.13-r2
virtual/os-headers:  0
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64-sse3 -mtune=athlon64-sse3 -msse3 -msahf -mcx16 -m3dnow -O2 -pipe -fPIC"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=athlon64-sse3 -mtune=athlon64-sse3 -msse3 -msahf -mcx16 -m3dnow -O2 -pipe -fPIC"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="rsync://192.168.0.1/gentoo-portage/"
LANG="es_UY.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="es es_ES es_LA es_UY en en_US en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://192.168.0.1/gentoo-portage/"
Portage 2.1.9.42 (default/linux/amd64/10.0/desktop, gcc-4.4.5, libc-0-r0, 2.6.39-gentoo x86_64)
=================================================================
System uname: Linux-2.6.39-gentoo-x86_64-AMD_Athlon-tm-_Processor_LE-1640-with-gentoo-2.0.2
Timestamp of tree: Tue, 24 May 2011 15:45:01 +0000
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 apic berkdb bluetooth branding bzip2 cairo cdr clflush cli cmov consolekit cr8_legacy cracklib crypt cups cx16 cx8 cxx dbus de deblob dri dts dvd dvdr emboss encode exif extapic extd_apicid fam fbcon firefox flac fortran fpu fxsr fxsr_opt gdbm gdu gif gnome gpm gtk iconv ipv6 jpeg kdrive lahf_lm lcms ldap libnotify lm mad mca mce mmx mmxext mng modules mp3 mp4 mpeg msr mtrr mudflap multilib ncurses nls nptl nptlonly nx ogg opengl openmp pae pam pango pat pcre pdf perl pge png pni policykit ppds pppd pse pse36 python python3 qt3support qt4 rdtscp readline rep_good sdl sep session spell sqlite sse sse2 ssl startup-notification svg svm symlink syscall sysfs tcpd tiff truetype tsc udev unicode up usb vdpau vme vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="directory template" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES es_LA es_UY en en_US en_GB" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev nouveau nvidia v4l vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


lspci
Code:

00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce 430] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control


Xorg.0.log
Code:

[  3131.494]
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.
[  3131.536]
X.Org X Server 1.10.1.902 (1.10.2 RC 2)
Release Date: 2011-05-20
[  3131.551] X Protocol Version 11, Revision 0
[  3131.556] Build Operating System: Linux 2.6.39-gentoo x86_64 Gentoo
[  3131.561] Current Operating System: Linux pc-client2 2.6.39-gentoo #11 Fri May 27 00:53:52 UYT 2011 x86_64
[  3131.567] Kernel command line: root=/dev/sda7 3 resume=/dev/sda9 video=uvesafb,mtrr:3,ywrap,1024x768-32@60 vga=0x318
[  3131.572] Build Date: 27 May 2011  02:16:51AM
[  3131.578] 
[  3131.583] Current version of pixman: 0.22.0
[  3131.588]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  3131.599] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3131.614] (==) Log file: "/var/log/Xorg.0.log", Time: Fri May 27 02:49:57 2011
[  3131.620] (==) Using config file: "/etc/X11/xorg.conf"
[  3131.625] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  3131.630] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3131.636] (==) ServerLayout "Layout0"
[  3131.636] (**) |-->Screen "Screen0" (0)
[  3131.636] (**) |   |-->Monitor "Monitor0"
[  3131.636] (**) |   |-->Device "Card0"
[  3131.636] (**) |-->Input Device "Mouse0"
[  3131.636] (**) |-->Input Device "Keyboard0"
[  3131.636] (**) Option "Xinerama" "0"
[  3131.636] (==) Automatically adding devices
[  3131.636] (==) Automatically enabling devices
[  3131.636] (**) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/,
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[  3131.636] (**) ModulePath set to "/usr/lib/xorg/modules"
[  3131.636] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  3131.636] (WW) Disabling Mouse0
[  3131.636] (WW) Disabling Keyboard0
[  3131.636] (II) Loader magic: 0x7c9160
[  3131.636] (II) Module ABI versions:
[  3131.636]    X.Org ANSI C Emulation: 0.4
[  3131.636]    X.Org Video Driver: 10.0
[  3131.636]    X.Org XInput driver : 12.2
[  3131.636]    X.Org Server Extension : 5.0
[  3131.636] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  3131.636] (WW) "dri" will not be loaded unless you've specified it to be loaded elsewhere.
[  3131.636] (WW) "dri2" will not be loaded unless you've specified it to be loaded elsewhere.
[  3131.636] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[  3131.636] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[  3131.636] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  3131.636] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[  3131.636] (II) "dri" will be loaded even though the default is to disable it.
[  3131.636] (II) "dri2" will be loaded even though the default is to disable it.
[  3131.636] (II) LoadModule: "dbe"
[  3131.637] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[  3131.637] (II) Module dbe: vendor="X.Org Foundation"
[  3131.637]    compiled for 1.10.1.902, module version = 1.0.0
[  3131.637]    Module class: X.Org Server Extension
[  3131.637]    ABI class: X.Org Server Extension, version 5.0
[  3131.637] (II) Loading extension DOUBLE-BUFFER
[  3131.637] (II) LoadModule: "glx"
[  3131.637] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  3131.652] (II) Module glx: vendor="NVIDIA Corporation"
[  3131.652]    compiled for 4.0.2, module version = 1.0.0
[  3131.652]    Module class: X.Org Server Extension
[  3131.652] (II) NVIDIA GLX Module  270.41.19  Mon May 16 23:48:30 PDT 2011
[  3131.652] (II) Loading extension GLX
[  3131.652] (II) LoadModule: "extmod"
[  3131.652] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[  3131.653] (II) Module extmod: vendor="X.Org Foundation"
[  3131.653]    compiled for 1.10.1.902, module version = 1.0.0
[  3131.653]    Module class: X.Org Server Extension
[  3131.653]    ABI class: X.Org Server Extension, version 5.0
[  3131.653] (II) Loading extension MIT-SCREEN-SAVER
[  3131.653] (II) Loading extension XFree86-VidModeExtension
[  3131.653] (II) Loading extension XFree86-DGA
[  3131.653] (II) Loading extension DPMS
[  3131.653] (II) Loading extension XVideo
[  3131.653] (II) Loading extension XVideo-MotionCompensation
[  3131.653] (II) Loading extension X-Resource
[  3131.653] (II) LoadModule: "record"
[  3131.653] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[  3131.653] (II) Module record: vendor="X.Org Foundation"
[  3131.653]    compiled for 1.10.1.902, module version = 1.13.0
[  3131.653]    Module class: X.Org Server Extension
[  3131.653]    ABI class: X.Org Server Extension, version 5.0
[  3131.653] (II) Loading extension RECORD
[  3131.653] (II) LoadModule: "vesa"
[  3131.653] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  3131.653] (II) Module vesa: vendor="X.Org Foundation"
[  3131.653]    compiled for 1.10.1.902, module version = 2.3.0
[  3131.653]    Module class: X.Org Video Driver
[  3131.653]    ABI class: X.Org Video Driver, version 10.0
[  3131.653] (II) VESA: driver for VESA chipsets: vesa
[  3131.653] (--) using VT number 7

[  3131.667] (WW) Falling back to old probe method for vesa
[  3131.667] (EE) No devices detected.
[  3131.667]
Fatal server error:
[  3131.667] no screens found
[  3131.667]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  3131.667] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  3131.667]


configuracion de mi video en el kernel 2.6.39
Code:

Linux Kernel Gentoo 2.6.39

Device Drivers  --->
 Graphics support  --->
  <*> /dev/agpgart (AGP Support)  --->
       <*>   AMD Opteron/Athlon64 on-CPU GART support
       < >   Intel 440LX/BX/GX, I8xx and E7x05 chipset support
       < >   SiS chipset support
       < >   VIA chipset support
  -*- VGA Arbitration
  (1)   Maximum number of GPUs
  [ ] Laptop Hybrid Graphics - GPU switching support
  <*> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)  --->
       < >   3dfx Banshee/Voodoo3+
       < >   ATI Rage 128
       < >   ATI Radeon
       < >   Matrox g200/g400
       < >   SiS video cards
       < >   Via unichrome video cards
       < >   Savage video cards
  < > Intel GMA500 Stub Driver
  <*> Lowlevel video output switch controls
  {*} Support for frame buffer devices  --->
       [*]   Enable firmware EDID
       [*]   Framebuffer foreign endianness support  --->
              Choice endianness support (Support for Big- and Little-Endian framebuffers)  --->
       -*-   Enable Video Mode Handling Helpers
       [*]   Enable Tile Blitting Support
             *** Frame buffer hardware drivers ***
       <*>   Userspace VESA VGA graphics support
       [*]   VESA VGA graphics support
  -*- Backlight & LCD device support  --->
       <*>   Lowlevel LCD controls
       <*>     Platform LCD controls
       -*-   Lowlevel Backlight controls
       <*>     Generic (aka Sharp Corgi) Backlight Driver
       < >     Frontpath ProGear Backlight Driver
       < >     Apple Backlight Driver
       < >     Tabletkiosk Sahara Touch-iT Backlight Driver
       < >     Backlight Driver for ADP8860/ADP8861/ADP8863 using WLED
      Display device support  --->
      Console display driver support  --->
       -*- VGA text console
       [*]   Enable Scrollback Buffer in System RAM
       (64)    Scrollback Buffer Size (in KB)
       {*} Framebuffer Console support
       -*-   Map the console to the primary display device
       [*]   Framebuffer Console Rotation
       [*] Select compiled-in fonts
       [*]   VGA 8x8 font
       -*-   VGA 8x16 font
       [*]   Mac console 6x11 font (not supported by all drivers)
       [*]   console 7x14 font (not supported by all drivers)
       [*]   Pearl (old m68k) console 8x8 font
       [*]   Acorn console 8x8 font
       [*]   Mini 4x6 font
       [*] Sparc console 8x16 font
       [*] Sparc console 12x22 font (not supported by all drivers)
       [*] console 10x18 font (not supported by all drivers)
  [*] Bootup logo  --->
       [*]   Standard black and white Linux logo
       [*]   Standard 16-color Linux logo
       [*]   Standard 224-color Linux logo

 [*] Staging drivers  --->
      [ ]   Exclude Staging drivers from being built
      <M>     Nouveau (nVidia) cards
      [*]       Support for backlight control
      [ ]       Build in Nouveau's debugfs support

Bus options (PCI etc.)  --->
 [*] PCI support
 [*]   Support mmconfig PCI config space access
 [ ] Support for DMA Remapping Devices (EXPERIMENTAL)
 [ ] Support for Interrupt Remapping (EXPERIMENTAL)
 [*] PCI Express support
 < >   PCI Express Hotplug driver
 [*]   Root Port Advanced Error Reporting support
 [ ]     PCI Express ECRC settings control
 < >     PCIe AER error injector support
 -*-   PCI Express ASPM control
 [ ]     Debug PCI Express ASPM
 -*- Message Signaled Interrupts (MSI and MSI-X)
 [ ] PCI Debugging
 < > PCI Stub driver
 [*] Interrupts on hypertransport devices
 [ ] PCI IOV support
 < > PCCard (PCMCIA/CardBus) support  --->
 <*> Support for PCI Hotplug  --->
      < >   Fake PCI Hotplug driver
      < >   ACPI PCI Hotplug driver
      [ ]   CompactPCI Hotplug driver
      < >   SHPC PCI Hotplug driver
 [ ] RapidIO support


Sin mas, quien me pudiera ayudar, estaria totalmente agradecido


Last edited by Oicraman on Sat May 28, 2011 9:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
Txema
l33t
l33t


Joined: 20 May 2008
Posts: 772
Location: Granada

PostPosted: Fri May 27, 2011 10:39 am    Post subject: Reply with quote

Tienes un lío en xorg.conf que es algo, ¿ese es el archivo que estás usando actualmente?

Al usar evdev toda referencia a los inputdevices mouse y keyboard no tienen nada que ver en este archivo así que los puedes comentar o quitar.

Además en la sección de la tarjeta (Device) no tienes ningún driver seleccionado y no tienes puesto el BusID (y si lo tenías antes está mal porque ese no es su ID, es 0:13:0 si no me equivoco)

Yo probaría primero con vesa para ver que la tarjeta y la pantalla funcionan y luego ya me pondría con su driver.

Un saludo.
Back to top
View user's profile Send private message
duryodhana
n00b
n00b


Joined: 13 Jan 2008
Posts: 66

PostPosted: Fri May 27, 2011 12:56 pm    Post subject: Reply with quote

si quieres utilizar nvidia-drivers


pon nvidia en /etc/make.conf en VIDEO_CARDS

pon en /etc/X11/xorg.conf

Code:
Section "Device"
   Identifier   "My Graphics Card"
   Driver      "nvidia"
EndSection


nada más es necesario.

en Konsole como root da
Code:
eselect opengl set nvidia


y en cofiguración del kernel no seleccionas el nouveau driver
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1208
Location: La Plata, Argentina

PostPosted: Fri May 27, 2011 3:36 pm    Post subject: Reply with quote

el kernel esta bien, tenes nouveau en el make.conf?
Quote:
VIDEO_CARDS="nouveau"


una vez que cambias eso, hace un
Code:
emerge -1 x11-base/xorg-drivers
eselect opengl set xorg-x11


con eso deberia cargar sin dramas nouveau.
para el driver de nvidia, es similar, solo que con nvidia en video_cards
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Oicraman
n00b
n00b


Joined: 14 Apr 2011
Posts: 20

PostPosted: Fri May 27, 2011 8:08 pm    Post subject: Reply with quote

Hola chicos, hice todos los pasos dados como uds dijeron, me pretensión es poner el driver propietario de nvidia, el cual gracias a uds y al foro ingles, lo lograron. pero sigo con problemas en el teclado y mouse cuando arranco.
Ordene el INPUT_DEVICES, borrando todo, y dejando solamente el evdev, hice otra vez emerge en xorg-server y xf86-input-evdev, pero siguen los problemas. Les paso mi situacion actual que esta alla en el foro ingles, donde deje mi log actual, con las ultimas configuraciones correspondientes https://forums.gentoo.org/viewtopic-t-879973.html
Back to top
View user's profile Send private message
Pablo S. Barrera
l33t
l33t


Joined: 16 May 2006
Posts: 642
Location: Mataderos. Argentina. America del Sur

PostPosted: Sat May 28, 2011 1:08 am    Post subject: Reply with quote

Hola!

Mostranos tu /etc/make.conf

Creo no haberlo visto por ningun lado. Hace un emerge -uNDav world a ver que te pide
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1208
Location: La Plata, Argentina

PostPosted: Sat May 28, 2011 1:11 am    Post subject: Reply with quote

/etc/X11/xorg.conf.d/30-keyboard.conf
Quote:

Section "InputClass"
Identifier "keyboard-all"
Driver "evdev"
Option "XkbLayout" "es"
# Option "XkbModel" "logitech_g15"
Option "XkbRules" "xorg"
# Option "XkbOptions" "grp:alt_shift_toggle,grp:switch,grp_led:scroll,compose:rwin,ter$
Option "XkbVariant" ",qwerty"
MatchIsKeyboard "on"
EndSection

/etc/X11/xorg.conf.d/50-mouse.conf
Quote:
Section "InputClass"
Identifier "mouse-all"
Driver "evdev"
#MatchVendor "Genius"
MatchIsPointer "on"
EndSection



puede ir todo en xorg.conf o en ficheros como lo tengo yo.
asi anda con teclado y mouse usb.
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Oicraman
n00b
n00b


Joined: 14 Apr 2011
Posts: 20

PostPosted: Sat May 28, 2011 8:16 am    Post subject: Reply with quote

He llegado probar todos los intentos para hacer funcionar pero no logro hacerlo funcionar, entonces en un comentario sobre DawgG (del foro ingles donde deje tmb un post traducido para aquel idioma https://forums.gentoo.org/viewtopic-t-879973.html) él me comentaba acerca de yo activar el servicio de sysfs, logicamente active ese servicio, pero aun asi esto me llego a pensar en una conclusión.
Me decidí a fijarme la pc de mi hermano (que por cierto tiene gentoo instalado), el servidor de mi casa y me di cuenta que tenia el sysinit configurado de forma diferente.

el de mi hermano tenia así (fue instalado como baselayout 1 y actualizado a baselayout 2)

devfs | sysinit
udev | sysinit
dmesg | sysinit

pero mi pc fue instalado así (con baselayout 2)
devfs | sysinit
dmesg | sysinit

entonces cambie mi sysinit agregando udev como lo tiene la otra pc y comenzó a funcionar el pciutils cuando antes era imposible iniciar.
Reinicie la pc, y me aparecio unos problemas en el arranque, que fueron asi:

Code:

* Mounting /proc ...
 * Mounting /sys ...
 * Mounting security filesystem ...
 * Mounting debug filesystem ...
 * /dev is already mounted
 * Starting udevd ...
 * Populating /dev with existing devices through uevents ...
 * Waiting for uevents to be processed ...                                                                                [ ok ]
* Mounting /dev/pts ...                                                                                                  [ ok ]
* Mounting /dev/shm ...                                                                                                  [ ok ]
 * Setting system clock using the hardware clock [Local Time] ...
 * Loading module nvidia ...
FATAL: Error inserting nvidia (/lib/modules/2.6.39-gentoo/video/nvidia.ko): No such device
 * Failed to load nvidia                                                                                                  [ !! ]
 * Autoloaded 0 module(s)


Nota: me cambia la resolución del monitor cuando arranca udev.

No entiendo porque me sucede esto cuando en las otras pcs con esta configuracion corre correctamente, y ademas las pcs son semejantes en cuestion de caracteristicas tecnicas!
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1208
Location: La Plata, Argentina

PostPosted: Sat May 28, 2011 8:06 pm    Post subject: Reply with quote

cambia la reso xq udev detecta nouveau, y activa el framebuffer si no me confundo.
en la linea kernel del menu.lst tendrias que agregar algo como esto:
video=VGA-1:1024x768@85

algo asi quedaria la linea:
Quote:
kernel /boot/kernel-nuevo root=/dev/sda5 quiet video=VGA-1:1024x768@85

VGA-1 es la salida a la que tenes enchufado el moni.
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Oicraman
n00b
n00b


Joined: 14 Apr 2011
Posts: 20

PostPosted: Sat May 28, 2011 9:10 pm    Post subject: Reply with quote

Saque sysfs en sysinit, y puse udev, luego segun lo que me dijo gusar en el foro en ingles puse en el blacklist el modulo nouveau, y soluciono el problema!

Quiero agradecer a todos uds del foro en español y a todos los del foro en ingles, por toda la ayuda que he recibido, y lo que lograron! Estoy muy agradecido, gracias :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum