Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]HP Proliant DL380 G6 Smart Array Controller problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
akordic
n00b
n00b


Joined: 26 May 2011
Posts: 5

PostPosted: Thu May 26, 2011 1:59 pm    Post subject: [SOLVED]HP Proliant DL380 G6 Smart Array Controller problem Reply with quote

Hello everybody,

last week I installed Gentoo on a HP Proliant DL380 G5 with the following SA Controller and everything went fine:

lspci
...
06:00.0 RAID bus controller: Hewlett-Packard Company Smart Array Controller (rev 04)
...

* disks were normally detected (using cciss module)
* created partitions
* built the kernel with the following options

Generic Driver Options --->
-> Device Drivers
-> Block devices (BLK_DEV [=y])
<*> Compaq SMART2 support
<*> Compaq Smart Array 5xxx support

Generic Driver Options --->
-> Device Drivers
<*> Serial ATA (prod) and Parallel ATA (experimental) drivers --->
[*] ATA SFF support
<*> Intel ESB, ICH, PIIX3, PIIX4 PATA/SATA support

Device Drivers --->
[*] Network device support --->
[*] Ethernet (1000 Mbit) --->
<M> Broadcom NetXtremeII support
< > Alteon AceNIC/3Com 3C985/NetGear GA620 Gigabit support
< > DL2000/TC902x-based Gigabit Ethernet support
<*> Intel(R) PRO/1000 Gigabit Ethernet support
<*> Intel(R) PRO/1000 PCI-Express Gigabit Ethernet support

Device Drivers --->
[*] USB support --->
<*> EHCI HCD (USB 2.0) support
[*] Root Hub Transaction Translators
<*> UHCI HCD (most Intel and VIA) support

* edited grub
* rebooted and it WORKED!

####################################################
My issue is that today I tried to install Gentoo on a Generation 6 Proliant DL380 with

lspci
...
03:00.0 RAID bus controller: Hewlett-Packard Company Smart Array G6 controllers (rev 01)
...

No disks were detected.
fdisk -l gave no result.

The actual name of the controller is Hewlett-Packard Company Smart Array P410i

Using the SmartStart Utility I configured the logical disk using RAID 1.

I also found out that the G6 controller is using hpsa module according to http://cciss.sourceforge.net/ but I have no idea how to load this module.

Can anyone help?

How to load hpsa module from liveCD?

Thank you in advance!


Last edited by akordic on Sat May 28, 2011 9:43 am; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6251
Location: Goose Creek SC

PostPosted: Thu May 26, 2011 3:31 pm    Post subject: Reply with quote

Code:
modprobe hpsa
should do it if the module is present on the livecd.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
akordic
n00b
n00b


Joined: 26 May 2011
Posts: 5

PostPosted: Thu May 26, 2011 5:19 pm    Post subject: Reply with quote

I tried that, of course, but the module couldn't be found on the latest liveCD.

Thanks for your reply, though.

Maybe the liveDVD has more resources including the missing hpsa module??
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6251
Location: Goose Creek SC

PostPosted: Thu May 26, 2011 6:54 pm    Post subject: Reply with quote

I'd try system rescue cd as an alternate, not the dvd. Ubuntu as next alternate.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
akordic
n00b
n00b


Joined: 26 May 2011
Posts: 5

PostPosted: Fri May 27, 2011 12:42 pm    Post subject: Reply with quote

I tried it with the Gentoo liveDVD and the Smart Array controller was recognized, meaning the DVD has the module hpsa included..

Still I have an issue causing kernel panic, after reboot.. probably because I'm still using the Compaq Smart Array 5xxx support and the SMART2 support under Block devices in the kernel configuration..

I know I should use some kind of SCSI support now, because of the hpsa module, but I have no clue which option to enable?

Anyone?
Back to top
View user's profile Send private message
akordic
n00b
n00b


Joined: 26 May 2011
Posts: 5

PostPosted: Fri May 27, 2011 1:09 pm    Post subject: Reply with quote

VFS : Cannot open root device "sda3" or unknown-block(2,0)
Please append a correct "root=" boot partitionl here are the available partitions:
0b00 1048575 sr0 driver: sr
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)


cciss uses /dev/cciss/c0d0pX notation
hpsa should be using the normal notation /dev/sda

so I don't see an issue there.. I even tried rebuilding the kernel without cciss (smart array 5xxx support) still the same..
Back to top
View user's profile Send private message
akordic
n00b
n00b


Joined: 26 May 2011
Posts: 5

PostPosted: Fri May 27, 2011 2:15 pm    Post subject: Reply with quote

Fixed it!!

I had to enable the following:

SCSI low-level drivers
<*> HP Smart Array SCSI driver

after reboot the system was sloooooooooow.. so I enabled in kernel:

Generic Driver Options
[*]Maintain devtmpfs ...
[*] Automount devtmpfs ...

And the issue gone.. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum