Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] unable to initialize libusb: -99
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2506
Location: Edmonton, AB

PostPosted: Tue May 24, 2011 5:50 am    Post subject: [SOLVED] unable to initialize libusb: -99 Reply with quote

My system does not recognize USB drives, kernel configuration seems to be OK
Code:
cat .config|grep -i usb
CONFIG_I2C_TINY_USB=m
CONFIG_SND_USB=y
CONFIG_USB_HID=y
CONFIG_USB_HIDDEV=y
CONFIG_USB_SUPPORT=y
CONFIG_USB_ARCH_HAS_HCD=y
CONFIG_USB_ARCH_HAS_OHCI=y
CONFIG_USB_ARCH_HAS_EHCI=y
CONFIG_USB=y
CONFIG_USB_DEVICEFS=y
CONFIG_USB_DEVICE_CLASS=y
CONFIG_USB_MON=y
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_OHCI_HCD=y
CONFIG_USB_UHCI_HCD=y
CONFIG_USB_PRINTER=y
CONFIG_USB_STORAGE=y

Code:
dmesg |grep -i usb
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
uhci_hcd: USB Universal Host Controller Interface driver
usbcore: registered new interface driver usblp
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usbcore: registered new interface driver hiddev
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver

Code:
lsusb
unable to initialize libusb: -99


What to check next?
Maybe the motherboard is not working, correctly (I got it for free). Motherboard is: ASUS m2npv-vm

Note: My original Motherboard failed so I've swap a used Motherboard but don't remember recompiling anything related to the system.
What should I recompile with regards to USB?
_________________
#Thelma


Last edited by Joseph_sys on Wed May 25, 2011 12:26 am; edited 1 time in total
Back to top
View user's profile Send private message
tomtom69
Apprentice
Apprentice


Joined: 09 Nov 2010
Posts: 170
Location: Bavaria

PostPosted: Tue May 24, 2011 7:13 pm    Post subject: Reply with quote

Hi Joseph,

Error -99 from lsusb is IMHO an indication that the usb host controller drivers were not loaded properly.
The filtered dmesg output does not show whether the usb hcd driver was installed correctly.
Look for messages containing "ohci_hcd", "ehci_hcd" and "uhci_hcd" - they should give more information about the drivers actually loaded (use "dmesg | grep -i hcd" and post the output).

tomtom
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2506
Location: Edmonton, AB

PostPosted: Tue May 24, 2011 7:17 pm    Post subject: Reply with quote

tomtom69 wrote:
Hi Joseph,

Error -99 from lsusb is IMHO an indication that the usb host controller drivers were not loaded properly.
The filtered dmesg output does not show whether the usb hcd driver was installed correctly.
Look for messages containing "ohci_hcd", "ehci_hcd" and "uhci_hcd" - they should give more information about the drivers actually loaded (use "dmesg | grep -i hcd" and post the output).

tomtom


The driver seems to be loaded
Code:
dmesg | grep -i hcd
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
uhci_hcd: USB Universal Host Controller Interface driver


The USB cable had a loose cable ends so I double check by wire colors that I did not mess something up; they seem to be connected OK.
_________________
#Thelma
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2506
Location: Edmonton, AB

PostPosted: Wed May 25, 2011 12:25 am    Post subject: Reply with quote

Solved.
Mother board USB is not working :-/
_________________
#Thelma
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Fri Jun 06, 2014 1:01 pm    Post subject: Reply with quote

Joseph_sys wrote:
Solved.
Mother board USB is not working :-/

No, it's not solved. :?
I have the same issue, and my MBO is working fine.
( booted Sysreccd and connect usb devices fine).

I posted a little on the issue here:
Uninstalling dbus and *kits (to Unfacilitate Remote Seats)
https://forums.gentoo.org/viewtopic-p-7563836.html#7563836

Since I suspect it's some of my lack of understanding of the udev/eude/mdev concepts, and that
some of my changes somehow broght this usbfs not found up, I posted it there.

Miroslav Rovis
www.CroatiaFidelis.hr
Back to top
View user's profile Send private message
dustfinger
Guru
Guru


Joined: 15 Aug 2004
Posts: 447

PostPosted: Thu Apr 02, 2015 7:28 am    Post subject: Reply with quote

Hi,

If anyone else sees this error then do the following to find out the reason why you are getting the error:
Code:

# export LIBUSB_DEBUG=9
# lsusb

I ran into this same issue and by setting debug to 9 I found out that the libusb could not find usbfs. I searched around and found this in /sys/bus/usb. After reading over this ticket on the lsusb site I realized that the reason why it could not find usbfs is because it was not in /dev/usb. After trying many different things I realized something. My system has an initramfs with a custom script that mounts /proc /sys and /dev, but the lines of code to unmount these were placed after the switch to the real root. I updated my init script to unmount those partitions before the switch to the real root, rebooted and viola, /dev was properly populated with /dev/usb. lsusb worked once again and I have rejoiced ;-)

I hope this helps someone out there. I have spent my whole evening figuring this out and It could have easily taken me much longer.

Sincerely,

dustfinger
_________________
Unanswered Post Initiative:
https://forums.gentoo.org/viewtopic.php?t=119906
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum