Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KDM] Localisation clavier (Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
versus8
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2005
Posts: 130

PostPosted: Fri May 20, 2011 4:24 pm    Post subject: [KDM] Localisation clavier (Résolu) Reply with quote

Bonjour à tous,

Je me permet de vous soumettre un problème plutôt récalcitrant. J'ai beau rechercher un peu partout sur les forums et l'Internet, je n'ai trouvé aucune information pouvant me donner une solution que je n'ai pas essayé.

Tout mon système est bien localisé sauf KDM.

Voilà ce que j'ai déjà réalisé comme configuration :


xorg.conf :

Code:

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option       "XkbLayout" "fr"
   Option      "XkbModel" "pc104"  # pour les claviers internationaux
   Option      "XkbVariant" "latin9"
EndSection


30-keyboard.conf :

Code:

Section "InputClass"
        Identifier "keyboard-all"
        Driver "evdev"
        Option "XkbLayout" "fr"
#       Option "XkbModel" "logitech_g15"
#       Option "XkbRules" "xorg"
        Option "XkbOptions" "grp:alt_shift_toggle,grp:switch,grp_led:scroll,compose:rwin,terminate:ctrl_alt_bksp"
#       Option "XkbVariant" ",qwerty"
        MatchIsKeyboard "on"
EndSection


Je souligne ici le fait que la combinaison des touches [Ctrl] + [Alt] + [<-Bck] ne fonctionne pas non plus (rwin,terminate:ctrl_alt_bksp), même en mettant dans xorg.conf :

Code:

Section "ServerFlags"
   Option  "DontZap"       "false"


Je suppose donc que c'est la configuration de X et coince.

KDM quant à lui semble bien paramétré ; kdmrc :

Code:

Language=fr_FR
Charset=iso8859-15
Country=fr



Informations sur Xorg :

Code:
X.Org X Server 1.9.5    USE="dmx nptl udev xorg (...) -kdrive"




J'ai également configuré le HAL (étant donné que KDE le requière).


Ici 10-xinput-configuration.fdi :

Code:

<?xml version="1.0" encoding="UTF-8"?>
<!--
Section "InputDevice"
   Driver "evdev"
   Option "XkbLayout" "fr"
EndSection
-->
<deviceinfo version="0.2">
   <match key="info.capabilities" contains="input.keyboard">
      <merge key="input.x11_options.XkbLayout" type="string">fr</merge>
   </match>
</deviceinfo>


Ici 10-keymap.fdi :

Code:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <merge key="input.xkb.layout" type="string">fr</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>



Extrait du log Xorg0.log (je suppose que c'est celui là qui nous intéresse ?)

Code:

[    12.531] (**) Option "xkb_rules" "evdev"
[    12.531] (**) Option "xkb_model" "evdev"
[    12.531] (**) Option "xkb_layout" "us"


Je continue de rechercher, si quelqu'un à un tuyau, je prends !

Merci ;)


Last edited by versus8 on Thu May 26, 2011 10:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
inky-full-bash
n00b
n00b


Joined: 01 Mar 2011
Posts: 12
Location: France

PostPosted: Sat May 21, 2011 11:56 am    Post subject: Reply with quote

Bonjour

En fait, dès que l'on a HAL, le xorg.conf n'est plus pris en compte. De plus, il me semble que KDE configure le clavier tout seul, sans passer par HAL. Il faut donc changer les paramètres clavier de KDE. Cependant, KDM est géré par la session root, donc il faut accéder aux paramètres KDE en root !

Par exemple, via "kdesu systemsettings" qui ouvrira le panneau de config en mode root (donc très dangereux ...). Ensuite je ne me rappelle plus s'il faut aller dans la section "localisation", "clavier" ou "gestionnaire de connexion" ; mais l'un des trois modifie la keymap de KDM.

Ou alors c'est bien HAL qui pose problème, et dans ce cas là il faut soit trouver le fdi concerné, soit passer à kde-4.6 (qui n'a pas besoin de HAL).

C'est à cause de ce problème que j'ai quitté KDE dès la version 4.5, pour passer à fluxbox ^^
Back to top
View user's profile Send private message
versus8
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2005
Posts: 130

PostPosted: Wed May 25, 2011 11:23 pm    Post subject: Reply with quote

Merci pour tout tes conseils, mais j'avais déjà été voir les settings dans KDE concernant KDM.

Si je trouve pas, tant pis. Sinon je reviendrai le dire ici ;)
Back to top
View user's profile Send private message
Kalax
n00b
n00b


Joined: 22 May 2011
Posts: 5
Location: Galaxie 42, Étoile Ⴖ, 3e planète

PostPosted: Thu May 26, 2011 6:52 am    Post subject: Reply with quote

Salut à tous,

As-tu essayé de configurer ton clavier par le pilote evdev?

Voici la marche à suivre si tu ne l'as pas encore fait :
    Tu crées le dossier xorg.conf.d dans X11 :
    Code:
    mkdir -p /etc/X11/xorg.conf.d/

    Ensuite tu crées le fichier 10-evdev.conf à l'intérieur :
    Code:
    nano -w /etc/X11/xorg.conf.d/10-evdev.conf

    Dans 10-evdev.conf tu ajoutes ceci :
    Code:
    Section "InputClass"
       Identifier "evdev keyboard catchall"
       MatchIsKeyboard "on"
       MatchDevicePath "/dev/input/event*"
       Driver "evdev"
       Option "XkbLayout" "fr"
       Option "XkbVariant" "oss_latin9"
    EndSection

Redémarre ton serveur X et ton clavier devrait être en français.

Normalement si ton clavier est bien configuré dans Xorg, tu n'as pas besoin de le spécifier dans KDE.

@+
_________________
Clavier [url=http://bepo.fr/wiki/Présentation]Bépo[/url]
Back to top
View user's profile Send private message
versus8
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2005
Posts: 130

PostPosted: Thu May 26, 2011 2:58 pm    Post subject: Reply with quote

Et bien merci a toi Kalax ! Le clavier dans X est bien mappé grace à toi :)


Afin de mettre le tag "Résolu", pourrais-tu me dire où pourrais-je trouver la documentation udev concernant xorg.conf.d (ou du moins la source de tes infos) ?
Back to top
View user's profile Send private message
Kalax
n00b
n00b


Joined: 22 May 2011
Posts: 5
Location: Galaxie 42, Étoile Ⴖ, 3e planète

PostPosted: Thu May 26, 2011 3:37 pm    Post subject: Reply with quote

Je pourrais pas te dire exactement, ça fait un petit bail que j'ai fait ce fichier.

Il me semble que j'avais obtenu des infos par ci par là que j'avais ensuite concaténées.

Je me souviens que le wiki de Archlinux m'avait été très utile.

Désolé de ne pas pouvoir être plus précis.

@+
_________________
Clavier [url=http://bepo.fr/wiki/Présentation]Bépo[/url]
Back to top
View user's profile Send private message
versus8
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2005
Posts: 130

PostPosted: Thu May 26, 2011 10:47 pm    Post subject: Reply with quote

C'est pas grave, merci quant même.
Back to top
View user's profile Send private message
ekryyn
n00b
n00b


Joined: 04 Jun 2011
Posts: 5
Location: Paris, France

PostPosted: Sat Jun 04, 2011 7:49 pm    Post subject: Reply with quote

Merci Kalax,
Juste pour préciser que ta solution a résolu mon problème de clavier us dans GDM (histoire de donner des billes à google pour les malheureux qui triment)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum