Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Gnome 3][Install'] Un emerge qui ne fonctionne paâÂÂâas !
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Le Barde
n00b
n00b


Joined: 13 Jul 2008
Posts: 36

PostPosted: Wed May 18, 2011 7:54 pm    Post subject: [Gnome 3][Install'] Un emerge qui ne fonctionne paâÂÂâas ! Reply with quote

Salut les gens,

Je suis en train de m'installer une 'tite Gentoo pour mon Fixe / Serveur (I am currently on a Debian basis for first).
J'ai envie de tester Gnome3 mais la paquet du nom de glib-9999 met tout en vrac.

Si quelqu'un a une idée, je suis tout à fait preneur...

Je pense qu'il s'agit du même problème que pour ce post, mais il n'y a pas eu de solution proposée.
Merci d'avance !

Le Barde.

Output of # emerge -NDuav gnome emacs nmap vlc rhythmbox firefox-bin:
>>> Emerging (51 of 249) dev-libs/glib-9999 from gnome
 * Package:    dev-libs/glib-9999
 * Repository: gnome
 * USE:        elibc_glibc introspection kernel_linux userland_GNU x86
 * FEATURES:   sandbox
>>> Unpacking source...
 * GIT update -->
 *    repository:       git://git.gnome.org/glib
 *    at the commit:       aeac5de2f8eeaadcdc7e021694d92470834fece8
 *    branch:          master
 *    storage directory:    "/usr/portage/distfiles/git-src/glib"
Cloning into /var/tmp/portage/dev-libs/glib-9999/work/glib-9999...
done.
>>> Unpacked to /var/tmp/portage/dev-libs/glib-9999/work/glib-9999
>>> Source unpacked in /var/tmp/portage/dev-libs/glib-9999/work
>>> Preparing source in /var/tmp/portage/dev-libs/glib-9999/work/glib-9999 ...
 * Running gtkdocize ...                                                                                                                                                  [ ok ]
 * Running eautoreconf in '/var/tmp/portage/dev-libs/glib-9999/work/glib-9999' ...
 * Running aclocal -I m4macros ...                                                                                                                                        [ ok ]
 * Running libtoolize --copy --force --install --automake ...                                                                                                             [ ok ]
 * Running aclocal -I m4macros ...                                                                                                                                        [ ok ]
 * Running autoconf ...                                                                                                                                                   [ ok ]
 * Running autoheader ...                                                                                                                                                 [ ok ]
 * Running automake --add-missing --copy --foreign ...                                                                                                                    [ ok ]
 * Running elibtoolize in: glib-9999/
 *   Applying portage-2.2.patch ...
 *   Applying sed-1.5.6.patch ...
 *   Applying as-needed-2.2.6.patch ...
 * Fixing OMF Makefiles ...                                                                                                                                               [ ok ]
 * Applying glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch ...                                                                                            [ ok ]
 * Applying glib-2.12.12-fbsd.patch ...                                                                                                                                   [ ok ]
 * Applying glib-2.25-punt-python-check.patch ...                                                                                                                         [ ok ]
 * Applying glib-2.24-assert-test-failure.patch ...                                                                                                                       [ ok ]
 * Running eautoreconf in '/var/tmp/portage/dev-libs/glib-9999/work/glib-9999' ...
 * Running aclocal -I m4macros ...                                                                                                                                        [ ok ]
 * Running libtoolize --copy --force --install --automake ...                                                                                                             [ ok ]
 * Running aclocal -I m4macros ...                                                                                                                                        [ ok ]
 * Running autoconf ...                                                                                                                                                   [ ok ]
 * Running autoheader ...                                                                                                                                                 [ ok ]
 * Running automake --add-missing --copy --foreign ...                                                                                                                    [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/dev-libs/glib-9999/temp/automake-26841.out

 * ERROR: dev-libs/glib-9999 failed (prepare phase):
 *   Failed Running automake !
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_prepare
 *   environment, line 6317:  Called eautoreconf
 *   environment, line 1663:  Called eautomake
 *   environment, line 1632:  Called autotools_run_tool 'automake' '--add-missing' '--copy' '--foreign'
 *   environment, line 1254:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of 'emerge --info =dev-libs/glib-9999',
 * the complete build log and the output of 'emerge -pqv =dev-libs/glib-9999'.
 * This ebuild used the following eclasses from overlays:
 *   /var/lib/layman/gnome/eclass/gnome2-live.eclass
 *   /var/lib/layman/gnome/eclass/gnome2.eclass
 * This ebuild is from an overlay named 'gnome': '/var/lib/layman/gnome/'
 * The complete build log is located at '/var/tmp/portage/dev-libs/glib-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/glib-9999/temp/environment'.
 * S: '/var/tmp/portage/dev-libs/glib-9999/work/glib-9999'

>>> Failed to emerge dev-libs/glib-9999, Log file:

>>>  '/var/tmp/portage/dev-libs/glib-9999/temp/build.log'


Le fichier de log :
/var/tmp/portage/dev-libs/glib-9999/temp/build.log:

localhost portage # cat /var/tmp/portage/dev-libs/glib-9999/temp/build.log
 * Package:    dev-libs/glib-9999
 * Repository: gnome
 * USE:        elibc_glibc introspection kernel_linux userland_GNU x86
 * FEATURES:   sandbox
>>> Unpacking source...
 * GIT update -->
 *    repository:       git://git.gnome.org/glib
 *    at the commit:       aeac5de2f8eeaadcdc7e021694d92470834fece8
 *    branch:          master
 *    storage directory:    "/usr/portage/distfiles/git-src/glib"
Cloning into /var/tmp/portage/dev-libs/glib-9999/work/glib-9999...
done.
>>> Unpacked to /var/tmp/portage/dev-libs/glib-9999/work/glib-9999
>>> Source unpacked in /var/tmp/portage/dev-libs/glib-9999/work
>>> Preparing source in /var/tmp/portage/dev-libs/glib-9999/work/glib-9999 ...
 * Running gtkdocize ...                                                                                                                                                  [ ok ]
 * Running eautoreconf in '/var/tmp/portage/dev-libs/glib-9999/work/glib-9999' ...
 * Running aclocal -I m4macros ...                                                                                                                                        [ ok ]
 * Running libtoolize --copy --force --install --automake ...                                                                                                             [ ok ]
 * Running aclocal -I m4macros ...                                                                                                                                        [ ok ]
 * Running autoconf ...                                                                                                                                                   [ ok ]
 * Running autoheader ...                                                                                                                                                 [ ok ]
 * Running automake --add-missing --copy --foreign ...                                                                                                                    [ ok ]
 * Running elibtoolize in: glib-9999/
 *   Applying portage-2.2.patch ...
 *   Applying sed-1.5.6.patch ...
 *   Applying as-needed-2.2.6.patch ...
 * Fixing OMF Makefiles ...                                                                                                                                               [ ok ]
 * Applying glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch ...                                                                                            [ ok ]
 * Applying glib-2.12.12-fbsd.patch ...                                                                                                                                   [ ok ]
 * Applying glib-2.25-punt-python-check.patch ...                                                                                                                         [ ok ]
 * Applying glib-2.24-assert-test-failure.patch ...                                                                                                                       [ ok ]
 * Running eautoreconf in '/var/tmp/portage/dev-libs/glib-9999/work/glib-9999' ...
 * Running aclocal -I m4macros ...                                                                                                                                        [ ok ]
 * Running libtoolize --copy --force --install --automake ...                                                                                                             [ ok ]
 * Running aclocal -I m4macros ...                                                                                                                                        [ ok ]
 * Running autoconf ...                                                                                                                                                   [ ok ]
 * Running autoheader ...                                                                                                                                                 [ ok ]
 * Running automake --add-missing --copy --foreign ...                                                                                                                    [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/dev-libs/glib-9999/temp/automake-26841.out

 * ERROR: dev-libs/glib-9999 failed (prepare phase):
 *   Failed Running automake !
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_prepare
 *   environment, line 6317:  Called eautoreconf
 *   environment, line 1663:  Called eautomake
 *   environment, line 1632:  Called autotools_run_tool 'automake' '--add-missing' '--copy' '--foreign'
 *   environment, line 1254:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of 'emerge --info =dev-libs/glib-9999',
 * the complete build log and the output of 'emerge -pqv =dev-libs/glib-9999'.
 * This ebuild used the following eclasses from overlays:
 *   /var/lib/layman/gnome/eclass/gnome2-live.eclass
 *   /var/lib/layman/gnome/eclass/gnome2.eclass
 * This ebuild is from an overlay named 'gnome': '/var/lib/layman/gnome/'
 * The complete build log is located at '/var/tmp/portage/dev-libs/glib-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/glib-9999/temp/environment'.
 * S: '/var/tmp/portage/dev-libs/glib-9999/work/glib-9999'
localhost portage #


...et également :
Code:
localhost portage # cat /var/tmp/portage/dev-libs/glib-9999/temp/automake-26841.out
***** automake *****
***** PWD: /var/tmp/portage/dev-libs/glib-9999/work/glib-9999
***** automake --add-missing --copy --foreign

configure.ac:508: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4macros/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4macros/libtool.m4:4220: _LT_LINKER_SHLIBS is expanded from...
m4macros/libtool.m4:5352: _LT_LANG_C_CONFIG is expanded from...
m4macros/libtool.m4:143: _LT_SETUP is expanded from...
m4macros/libtool.m4:69: LT_INIT is expanded from...
configure.ac:508: the top level
configure.ac:508: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4macros/libtool.m4:4220: _LT_LINKER_SHLIBS is expanded from...
m4macros/libtool.m4:5352: _LT_LANG_C_CONFIG is expanded from...
m4macros/libtool.m4:143: _LT_SETUP is expanded from...
m4macros/libtool.m4:69: LT_INIT is expanded from...
configure.ac:508: the top level
configure.ac:508: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2662: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2679: AC_LINK_IFELSE is expanded from...
m4macros/libtool.m4:1084: _LT_SYS_MODULE_PATH_AIX is expanded from...
m4macros/libtool.m4:5437: _LT_LANG_CXX_CONFIG is expanded from...
m4macros/libtool.m4:816: _LT_LANG is expanded from...
m4macros/libtool.m4:799: LT_LANG is expanded from...
m4macros/libtool.m4:827: _LT_LANG_DEFAULT_CONFIG is expanded from...
m4macros/libtool.m4:143: _LT_SETUP is expanded from...
m4macros/libtool.m4:69: LT_INIT is expanded from...
configure.ac:508: the top level
gtk-doc.make:26: EXTRA_DIST multiply defined in condition TRUE ...
docs/reference/gio/Makefile.am:169:   `gtk-doc.make' included from here
Makefile.decl:8: ... `EXTRA_DIST' previously defined here
docs/reference/gio/Makefile.am:1:   `Makefile.decl' included from here
gtk-doc.make:26: EXTRA_DIST multiply defined in condition TRUE ...
docs/reference/glib/Makefile.am:76:   `gtk-doc.make' included from here
Makefile.decl:8: ... `EXTRA_DIST' previously defined here
docs/reference/glib/Makefile.am:2:   `Makefile.decl' included from here
gtk-doc.make:26: EXTRA_DIST multiply defined in condition TRUE ...
docs/reference/gobject/Makefile.am:60:   `gtk-doc.make' included from here
Makefile.decl:8: ... `EXTRA_DIST' previously defined here
docs/reference/gobject/Makefile.am:2:   `Makefile.decl' included from here
gio/gdbus-codegen/Makefile.am:8: Python sources seen but `PYTHON' is undefined
gio/gdbus-codegen/Makefile.am:8:   The usual way to define `PYTHON' is to add `AM_PATH_PYTHON'
gio/gdbus-codegen/Makefile.am:8:   to `configure.ac' and run `aclocal' and `autoconf' again.
localhost portage #

_________________
War does not decide who's right, but who's left.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum