Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Se aggiorno udev la macchina non parte udev> 146-r1[risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
eleaffar
n00b
n00b


Joined: 09 May 2011
Posts: 43

PostPosted: Thu May 12, 2011 11:54 am    Post subject: Se aggiorno udev la macchina non parte udev> 146-r1[risol Reply with quote

Ho un problema :
se aggiorno udev (nella mia macchina c'e' una versione sys-fs/udev-146-r1) la macchina non parte regolamente x' perde "quasi" tutto il contenuto della mia /dev, quindi non riesce a trovare la partizione dove e' montata la /usr.

Ho provato sia con la versione 151-r4 che con la versione 149 ma sempre la stessa cosa, carica il kernel e dopo senza messaggi particolari ma non mi fa 'automount /usr /home /var ... x' in /udev non esiste nessun file che si chiama /dev/cciss/c0d0p5

Devo per forza partire con un cd di installazione e fare un chroot e ri-installarmi la versione precedente di udev.
Ho provato a googlare ma niente.

Ho un kernel Linux mente 2.6.36-gentoo-r5 #9 SMP Tue May 10 14:43:24 CEST 2011 x86_64 AMD Opteron(tm) Processor 280 AuthenticAMD GNU/Linux

I dischi sono in raid 5, cciss.
Cortesemente mi potreste aiutare o darmi una dritta x poter risolvere il mio problems
Grazie a chi mi vorra' rispondere .
Raffa
_________________
Ho visto il film Memento ... non me lo ricordo !


Last edited by eleaffar on Fri May 13, 2011 8:31 am; edited 1 time in total
Back to top
View user's profile Send private message
eleaffar
n00b
n00b


Joined: 09 May 2011
Posts: 43

PostPosted: Fri May 13, 2011 8:31 am    Post subject: Ho risolto :-) Reply with quote

Prima avevo verificato che che c'era questa incongruenza :
mente / # emerge -pv udev

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] sys-fs/udev-151-r4 [146-r1] USE="extras -devfs-compat* -old-hd-rules% (-selinux) -test%" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

mente / # echo ">=sys-fs/udev-147" >> /etc/portage/package.mask
mente / # emerge -pv udev

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] sys-fs/udev-146-r1 USE="devfs-compat extras (-selinux)" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

mente / #

Ma non portava da nessuna parte !

Caricato udev-151-r4 e fatto ripartire mi dava sempre lo stesso errore ...
"error initializing inotify"

Googleando ho trovato la soluzione :

Reemerging glibc against latest kernel headers helped.

ho verificato che glibc era stato compilato dopo : sys-kernel/linux-headers

Ricompilato glibc udev ANDAVA :8O 8O 8O senza fare altro.
Non ho compilato niente altro tranne glibc ...

Qualcuno mi sa spiegare come e' potuto accadere ? e che forza e' glibc da influire su udev ?
_________________
Ho visto il film Memento ... non me lo ricordo !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum