Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rEFInd troubleshooting [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Sat Nov 12, 2016 1:03 am    Post subject: rEFInd troubleshooting [Solved] Reply with quote

rEFInd stopped working. When set it default the box will not boot. It will just sit and wait for something. Three finger salute will reboot. I still can boot my EFI stub kernel. I do not reboot often, so I can't tell if the firmware upgrade is to blame or something else.
Any ideas how to troubleshoot this issue are welcome.
This is in my refind.conf. At some point I edited it, so maybe you see a mistake here? The paths are correct.
Code:
menuentry Gentoo {
    loader /EFI/Boot/bootx64.efi
    icon /EFI/refind/icons/os_linux.png
    options "ro root=/dev/sda2"
}

menuentry "Gentoo Backup" {
    loader /EFI/Boot/bootx64_pre.efi
    icon /EFI/refind/icons/os_linux.png
    options "ro root=/dev/sda2"
}


Last edited by Buffoon on Sat Nov 12, 2016 7:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
i4dnf
Apprentice
Apprentice


Joined: 18 Sep 2005
Posts: 218
Location: Bucharest, Romania

PostPosted: Sat Nov 12, 2016 8:17 am    Post subject: Reply with quote

What useflags did you set for refind and/or did you update it recently?
There were some issues with versions post refind-0.10.2 in portage since the ebuild was forcing the make.conf cflags/ldflags on the refind efi binary.
https://bugs.gentoo.org/show_bug.cgi?id=598587#c3
Also here refind-0.10.4-r1 doesn't work if built with USE="-gnuefi" so that it uses the udk to build the binary.
_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Sat Nov 12, 2016 3:29 pm    Post subject: Reply with quote

Thank you, i4dnf! Getting on it ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum