Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[compiz] marche plus ... [resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
lbr
Guru
Guru


Joined: 05 Apr 2004
Posts: 503
Location: Paris

PostPosted: Tue May 03, 2011 3:04 pm    Post subject: [compiz] marche plus ... [resolu] Reply with quote

Bonjour les amis,

Depuis quelques temps je ne peux plus lancer COMPIZ, et ca me rend triste...
Je m'explique :
GNOME est paramétré pour lancer fusion-icon au démarrage et ce dernier lance compiz.
Pour comprendre ce qu'il se passe, j'ai quitté fusion-icon du tableau de bord puis je l'ai lancé "à la main". Clic droit sur l'icone puis sélection de COMPIZ comme window manager et voici le message :
Code:

lbr@lbroque-mob ~ $ fusion-icon
 * Detected Session: gnome
 * Searching for installed applications...
 * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
 * Using the GTK Interface
Gtk-Message: Failed to load module "gnomebreakpad"
 * Metacity is already running
 * Setting window manager to Compiz
 ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --loose-binding --indirect-rendering
**
GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
 * Setting window manager to Metacity

Or quand je lance fusion-icon en root, et que je sélectionne COMPIZ : ca marche :?:
J'ai beau farfouiller google en tout sens ; ce qu'il en ressort c'est que dbus n'accepte pas mes connections ??? ....


--info :
Code:

lbroque-mob lbr # emerge --info
Portage 2.1.9.46 (default/linux/x86/10.0/desktop, gcc-4.5.2, libc-0-r0, 2.6.38-gentoo-r3LBR i686)
=================================================================
System uname: Linux-2.6.38-gentoo-r3LBR-i686-Intel-R-_Core-TM-2_Duo_CPU_T5870_@_2.00GHz-with-gentoo-2.0.2
Timestamp of tree: Mon, 02 May 2011 22:15:01 +0000
app-shells/bash:     4.2_p8-r1
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4-r1
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2-r1
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.11.1-r1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
sys-kernel/linux-headers: 2.6.38
sys-libs/glibc:      2.13-r2
virtual/os-headers:  0
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="fr_FR@euro"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr fr_FR"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://proxy.gw.paris.cityway.fr/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdr cleartype cli consolekit corefonts cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode exif fam firefox flac fortran fuse gdbm gdu gif glx gnome gnutls gpm gtk gtk2 iconv iphone ipv6 java jpeg laptop lcms libnotify mad mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl nptlonly nsplugin nss nvidia ogg opengl openmp pam pango pcre pdf perl png policykit postgres ppds pppd python qt3support readline samba sdl session spell ssl startup-notification svg sysfs tcpd tiff truetype type1 ubicode udev unicode usb vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Si qqun a une petite idée ....
merci par avance.


Last edited by lbr on Wed May 04, 2011 11:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Tue May 03, 2011 3:41 pm    Post subject: Reply with quote

Si cela fonctionne sous root (c'est mal!!!), cela doit probablement être un problème de droits.

Dans quels groupes se trouvent ton utilisateur?
Back to top
View user's profile Send private message
lbr
Guru
Guru


Joined: 05 Apr 2004
Posts: 503
Location: Paris

PostPosted: Tue May 03, 2011 3:48 pm    Post subject: Reply with quote

Merci pour ta réponse. Oui root c'est mal. Mais je ne le lancais pas sous root ! C'est juste pour tester que j'ai lancé fusion-icon en root .... pour voir, pour comprendre, quoi !

sinon pour répondre à ta question :
Code:
lbroque-mob lbr # more /etc/group|grep lbr
wheel:x:10:root,lbr
audio:x:18:lbr
video:x:27:root,lbr
usb:x:85:haldaemon,lbr
users:x:100:lbr
portage:x:250:portage,lbr
cron:x:16:lbr
lbr:x:1002:lbr
haldaemon:x:1005:haldaemon,lbr
plugdev:x:1006:haldaemon,root,lbr,usbmux
vboxusers:x:1009:lbr
fingerprint:x:1010:lbr
wireshark:x:1015:lbr
tcpdump:x:1016:lbr
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Wed May 04, 2011 4:15 pm    Post subject: Reply with quote

Salut,

même problème il y a quelques jours, réglé en faisant un petit rm -rf /~/.config/compiz/...

Comme j'avais sauvegardé mon profil j'ai pu le réimporté ensuite sans problème... si c'est pas le cas pour toi et que tu veux être sur que ma solution marche et éviter ainsi cette methode "bourrine" pour rien, créé un autre utilisateur sur ta machine et voit si compiz marche avec une config vierge..

Espérant que ça puisse t'aider
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
lbr
Guru
Guru


Joined: 05 Apr 2004
Posts: 503
Location: Paris

PostPosted: Wed May 04, 2011 11:12 pm    Post subject: Reply with quote

Merci,

C'est un peu ce que j'ai fini par faire :
j'ai recompilé tout ce qui avait compiz dans le nom
Code:
emerge -avtD dev-python/compizconfig-python x11-libs/compiz-bcop x11-libs/compizconfig-backend-gconf x11-libs/libcompizconfig x11-plugins/compiz-plugins-extra x11-plugins/compiz-plugins-main x11-plugins/compiz-plugins-unsupported x11-wm/compiz x11-wm/compiz-fusion

mais avant j'ai ajouté le use flag GCONF dans make.conf (oui carrément !).
Après j'avais un beau compiz tout neuf à reparamétrer ;)
Mais ca c'est pas trop compliqué
Mais entre temps je me suis "bouffé" la doc de dbus et autre glib .... ;)

Merci à tous et à bentôt.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum