Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Using --auth-user-pass openvpn
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Qu4rk
n00b
n00b


Joined: 22 Mar 2005
Posts: 74

PostPosted: Sun May 01, 2011 12:16 am    Post subject: [SOLVED] Using --auth-user-pass openvpn Reply with quote

Ok. I'm trying to return to gentoo after a 3 year stint with Ubuntu.

I'm trying to use --auth-user-pass with openvpn to read a plain text username & password. It works flawlessly with Ubuntu. My log file says this:

Code:
Sat Apr 30 15:48:05 2011 us=413588 Current Parameter Settings:
Sat Apr 30 15:48:05 2011 us=413851   mode = 0
Sat Apr 30 15:48:05 2011 us=413877   persist_config = DISABLED
Sat Apr 30 15:48:05 2011 us=413901   persist_mode = 1
Sat Apr 30 15:48:05 2011 us=413926 NOTE: --mute triggered...
Sat Apr 30 15:48:05 2011 us=413974 206 variation(s) on previous 5 message(s) suppressed by --mute
Sat Apr 30 15:48:05 2011 us=414007 OpenVPN 2.1.4 i686-pc-linux-gnu [SSL] [LZO2] [EPOLL] [MH] [PF_INET6] built on Apr 30 2011
Sat Apr 30 15:48:05 2011 us=414102 Sorry, 'Auth' password cannot be read from a file
Sat Apr 30 15:48:05 2011 us=414128 Exiting


I've looked on the net & here is what I've come up with. Everyone says you need to recompile using this:

Code:
./configure --enable-password-save


Well I've looked at the ebuilds & they it looks like this:
Code:
econf ${myconf} \
                $(use_enable passwordsave password-save) \


I assume this is the same thing. But I could be wrong. So, I need a little help getting openvpn to work. Thanks.


Last edited by Qu4rk on Mon May 09, 2011 10:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
fumtu99
n00b
n00b


Joined: 05 Sep 2002
Posts: 59

PostPosted: Thu May 05, 2011 5:43 am    Post subject: Reply with quote

Try doing an "emerge -pv openvpn"; if the USE flag "passwordsave" is not set, I'd suggest setting it in /etc/make.conf, then re-emerging openvpn. What you showed from the ebuild file is the kind of construction used to set configuration parameters from USE flags, if my rather foggy understanding of how ebuild files is correct... If setting the flag globally in make.conf hoses some other package's configuration, you could also set it for just openvpn, using a line in the /etc/portage/package.use file, too.
Back to top
View user's profile Send private message
Qu4rk
n00b
n00b


Joined: 22 Mar 2005
Posts: 74

PostPosted: Mon May 09, 2011 10:36 pm    Post subject: Reply with quote

MAN! THANKS! That hit the spot! That was exactly what I needed to do.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum