Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema installazione VLC
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
dursino
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2010
Posts: 83

PostPosted: Fri Apr 29, 2011 9:25 pm    Post subject: Problema installazione VLC Reply with quote

Salve, sapete perchè nel momento in cui do:
emerge -av vlc
mi restituisce:
Quote:
* IMPORTANT: 1 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!
[ebuild N ] dev-libs/libebml-1.2.0
[ebuild N ] media-plugins/live-2011.03.14
[ebuild N ] sys-libs/libutempter-1.1.5
[ebuild N ] dev-util/automoc-0.9.88
[ebuild N ] kde-base/oxygen-icons-4.6.2 USE="(-aqua) (-kdeenablefinal) (-kdeprefix)"
[ebuild N ] media-libs/qimageblitz-0.0.6 USE="-3dnow (-altivec) -debug -mmx -sse -sse2"
[ebuild N ] dev-libs/fribidi-0.19.2-r1
[ebuild N ] media-libs/svgalib-1.9.25-r1 USE="kernel-helper -build"
[ebuild N ] media-libs/libmatroska-1.1.0
[ebuild N ] app-crypt/qca-2.0.3 USE="(-aqua) -debug -doc -examples"
[ebuild N ] dev-libs/libattica-0.2.0 USE="-debug"
[ebuild N ] dev-libs/libdbusmenu-qt-0.7.0 USE="-debug -test"
[ebuild N ] kde-base/kde-env-4.6.2 USE="(-aqua) (-kdeenablefinal) (-kdeprefix)"
[ebuild N ] www-misc/htdig-3.2.0_beta6-r3 USE="ssl"
[ebuild N ] media-gfx/exiv2-0.21.1 USE="nls zlib -contrib -doc -examples -xmp" LINGUAS="-de -es -fi -fr -pl -ru -sk"
[ebuild N ] dev-cpp/clucene-0.9.21b-r1 USE="threads -debug -doc -static-libs"
[ebuild U ] dev-libs/glib-2.28.6 [2.24.1-r1] USE="static-libs%* (-introspection) -test%"
[ebuild U ] media-libs/x264-0.0.20110223 [0.0.20100605]
[ebuild U ] media-sound/lame-3.98.4 [3.98.2-r1] USE="-static-libs%"
[ebuild N ] app-misc/strigi-0.7.2 USE="clucene dbus exif fam qt4 -debug -hyperestraier -inotify (-log) -test"
[ebuild U ] media-video/ffmpeg-0.6.90_rc0-r2 [0.6] USE="bzip2%* threads* truetype%* -avx% -frei0r% -qt-faststart% -static-libs%"
[ebuild N ] virtual/ffmpeg-0.6.90 USE="X encode mp3 sdl threads x264 -theora -vaapi -vdpau"
[ebuild U ] x11-libs/qt-core-4.7.2-r1 [4.7.1-r1]
[ebuild U ] x11-libs/qt-script-4.7.2 [4.7.1-r1]
[ebuild U ] x11-libs/qt-sql-4.7.2 [4.7.1-r1]
[ebuild U ] x11-libs/qt-dbus-4.7.2 [4.7.1]
[ebuild U ] x11-libs/qt-gui-4.7.2 [4.6.3] USE="-egl% -gtkstyle% -private-headers%"
[ebuild U ] x11-libs/qt-svg-4.7.2 [4.6.3] USE="accessibility%*"
[ebuild U ] x11-libs/qt-qt3support-4.7.2 [4.6.3] USE="kde*"
[blocks b ] <x11-libs/qt-qt3support-4.7.2 ("<x11-libs/qt-qt3support-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[ebuild N ] x11-libs/qt-test-4.7.2 USE="exceptions iconv (-aqua) -debug -pch"
[ebuild N ] x11-libs/qt-opengl-4.7.2 USE="exceptions qt3support (-aqua) -debug -egl -pch"
[ebuild N ] x11-libs/qt-xmlpatterns-4.7.2 USE="(-aqua) -debug -pch"
[ebuild N ] x11-libs/qt-declarative-4.7.2-r1 USE="exceptions qt3support (-aqua) -debug -pch -private-headers -webkit"
[ebuild N ] media-libs/phonon-4.5.0 USE="gstreamer vlc (-aqua) -debug -pulseaudio -xine"
[ebuild N ] media-libs/phonon-gstreamer-4.5.0 USE="alsa -debug"
[ebuild N ] x11-libs/qt-webkit-4.7.2 USE="dbus exceptions jit kde (-aqua) -debug -pch"
[ebuild U ] sys-auth/polkit-0.101-r1 [0.96-r1] USE="gtk%* kde%* (-introspection)"
[ebuild U ] gnome-extra/polkit-gnome-0.101-r1 [0.96-r1] USE="(-introspection)"
[ebuild N ] sys-auth/polkit-qt-0.99.0 USE="-debug -examples"
[ebuild N ] kde-base/kdelibs-4.6.2-r2 USE="acl alsa bzip2 fam handbook nls opengl policykit spell ssl udev -3dnow (-altivec) (-aqua) -bindist -debug -doc -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma -mmx -openexr -semantic-desktop -sse -sse2 -test -zeroconf"
[ebuild N ] sys-auth/polkit-kde-agent-0.99.0 USE="(-aqua) -debug (-kdeenablefinal)" LINGUAS="it -ca -ca@valencia -cs -da -de -en_GB -eo -es -et -fi -fr -ga -gl -hr -hu -is -ja -km -lt -mai -ms -nb -nds -nl -pa -pt -pt_BR -ro -ru -sk -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -uk -zh_TW"
[ebuild N ] kde-misc/polkit-kde-kcmodules-0.98_pre20101127 USE="(-aqua) -debug (-kdeenablefinal)"
[ebuild N ] media-video/vlc-1.1.9 USE="X a52 aac alsa bidi cdda dbus dts dvd ffmpeg flac gcrypt gnome httpd kde libnotify live lua matroska mp3 mpeg ncurses nsplugin ogg opengl png qt4 sdl stream svg svga theora truetype udev vlm vorbis x264 xcb xml xv -aalib (-altivec) -atmo -avahi -cddb -dc1394 -debug -dirac -directfb -dvb -fbcon -fluidsynth -fontconfig -ggi -gme -gnutls -id3tag -ieee1394 -jack -kate -libass -libcaca -libproxy -libtiger -libv4l -libv4l2 -lirc -mmx -modplug -mtp -musepack -optimisememory -oss -projectm -pulseaudio -pvr -remoteosd -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -skins -speex -sqlite -sse -taglib -twolame -upnp -v4l -v4l2 -vaapi -vcdx -win32codecs -wma-fixed -xosd -zvbi"
[ebuild N ] kde-base/kdesu-4.6.2 USE="handbook (-aqua) -debug (-kdeenablefinal) (-kdeprefix)"
[ebuild N ] media-libs/phonon-vlc-0.3.2 USE="-debug -v4l2"
[ebuild N ] kde-base/khelpcenter-4.6.2 USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)"
[blocks B ] >x11-libs/qt-test-4.6.3-r9999 (">x11-libs/qt-test-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-svg-4.6.3)
[blocks B ] >x11-libs/qt-qt3support-4.7.1-r9999 (">x11-libs/qt-qt3support-4.7.1-r9999" is blocking x11-libs/qt-dbus-4.7.1, x11-libs/qt-core-4.7.1-r1, x11-libs/qt-sql-4.7.1-r1, x11-libs/qt-script-4.7.1-r1)
[blocks B ] >x11-libs/qt-svg-4.6.3-r9999 (">x11-libs/qt-svg-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-qt3support-4.6.3)
[blocks B ] <x11-libs/qt-sql-4.7.2 ("<x11-libs/qt-sql-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B ] sys-auth/policykit ("sys-auth/policykit" is blocking sys-auth/polkit-0.101-r1)
[blocks B ] >x11-libs/qt-opengl-4.7.1-r9999 (">x11-libs/qt-opengl-4.7.1-r9999" is blocking x11-libs/qt-dbus-4.7.1, x11-libs/qt-core-4.7.1-r1, x11-libs/qt-sql-4.7.1-r1, x11-libs/qt-script-4.7.1-r1)
[blocks B ] <x11-libs/qt-dbus-4.7.2 ("<x11-libs/qt-dbus-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B ] >x11-libs/qt-qt3support-4.6.3-r9999 (">x11-libs/qt-qt3support-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-svg-4.6.3)
[blocks B ] >x11-libs/qt-svg-4.7.1-r9999 (">x11-libs/qt-svg-4.7.1-r9999" is blocking x11-libs/qt-dbus-4.7.1, x11-libs/qt-core-4.7.1-r1, x11-libs/qt-sql-4.7.1-r1, x11-libs/qt-script-4.7.1-r1)
[blocks B ] >x11-libs/qt-test-4.7.1-r9999 (">x11-libs/qt-test-4.7.1-r9999" is blocking x11-libs/qt-dbus-4.7.1, x11-libs/qt-core-4.7.1-r1, x11-libs/qt-sql-4.7.1-r1, x11-libs/qt-script-4.7.1-r1)
[blocks B ] >x11-libs/qt-opengl-4.6.3-r9999 (">x11-libs/qt-opengl-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-svg-4.6.3)
[blocks B ] >x11-libs/qt-xmlpatterns-4.7.1-r9999 (">x11-libs/qt-xmlpatterns-4.7.1-r9999" is blocking x11-libs/qt-dbus-4.7.1, x11-libs/qt-core-4.7.1-r1, x11-libs/qt-sql-4.7.1-r1, x11-libs/qt-script-4.7.1-r1)
[blocks B ] <x11-libs/qt-gui-4.7.2 ("<x11-libs/qt-gui-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B ] >x11-libs/qt-webkit-4.6.3-r9999 (">x11-libs/qt-webkit-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-svg-4.6.3)
[blocks B ] <x11-libs/qt-script-4.7.2 ("<x11-libs/qt-script-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B ] >x11-libs/qt-xmlpatterns-4.6.3-r9999 (">x11-libs/qt-xmlpatterns-4.6.3-r9999" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-svg-4.6.3)
[blocks B ] >x11-libs/qt-webkit-4.7.1-r9999 (">x11-libs/qt-webkit-4.7.1-r9999" is blocking x11-libs/qt-dbus-4.7.1, x11-libs/qt-core-4.7.1-r1, x11-libs/qt-sql-4.7.1-r1, x11-libs/qt-script-4.7.1-r1)
[blocks B ] <x11-libs/qt-core-4.7.2 ("<x11-libs/qt-core-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(x11-libs/qt-test-4.7.2, ebuild scheduled for merge) pulled in by
>=x11-libs/qt-test-4.7.0:4 required by (kde-base/kdelibs-4.6.2-r2, ebuild scheduled for merge)
>=x11-libs/qt-test-4.6.3:4 required by (kde-misc/polkit-kde-kcmodules-0.98_pre20101127, ebuild scheduled for merge)
>=x11-libs/qt-test-4.7.0:4 required by (kde-base/khelpcenter-4.6.2, ebuild scheduled for merge)
(and 3 more)

(x11-libs/qt-opengl-4.7.2, ebuild scheduled for merge) pulled in by
~x11-libs/qt-opengl-4.7.2[-aqua,qt3support] required by (x11-libs/qt-declarative-4.7.2-r1, ebuild scheduled for merge)
>=x11-libs/qt-opengl-4.7.0:4 required by (kde-base/kdelibs-4.6.2-r2, ebuild scheduled for merge)
>=x11-libs/qt-opengl-4.6.0:4 required by (media-libs/phonon-gstreamer-4.5.0, ebuild scheduled for merge)

(x11-libs/qt-gui-4.6.3, installed) pulled in by
x11-libs/qt-gui:4 required by (app-misc/strigi-0.7.2, ebuild scheduled for merge)
>=x11-libs/qt-gui-4.6.3:4[dbus] required by (dev-libs/libdbusmenu-qt-0.7.0, ebuild scheduled for merge)
x11-libs/qt-gui[dbus,glib] required by (sys-auth/polkit-qt-0.99.0, ebuild scheduled for merge)
(and 7 more)

(x11-libs/qt-core-4.7.1-r1, installed) pulled in by
x11-libs/qt-core:4 required by (dev-util/automoc-0.9.88, ebuild scheduled for merge)
>=x11-libs/qt-core-4.6.3:4[qt3support,ssl] required by (kde-misc/polkit-kde-kcmodules-0.98_pre20101127, ebuild scheduled for merge)
x11-libs/qt-core:4 required by (dev-libs/libattica-0.2.0, ebuild scheduled for merge)
(and 12 more)

(x11-libs/qt-qt3support-4.7.2, ebuild scheduled for merge) pulled in by
>=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (sys-auth/polkit-kde-agent-0.99.0, ebuild scheduled for merge)
~x11-libs/qt-qt3support-4.7.2[-aqua,-debug] required by (x11-libs/qt-gui-4.7.2, ebuild scheduled for merge)
>=x11-libs/qt-qt3support-4.7.0:4[accessibility,kde] required by (kde-base/kdesu-4.6.2, ebuild scheduled for merge)
(and 4 more)

(x11-libs/qt-sql-4.7.1-r1, installed) pulled in by
>=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/khelpcenter-4.6.2, ebuild scheduled for merge)
>=x11-libs/qt-sql-4.6.3:4[qt3support] required by (sys-auth/polkit-kde-agent-0.99.0, ebuild scheduled for merge)
>=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/kdesu-4.6.2, ebuild scheduled for merge)
(and 2 more)

(sys-auth/polkit-0.101-r1, ebuild scheduled for merge) pulled in by
>=sys-auth/polkit-0.99 required by (sys-auth/polkit-qt-0.99.0, ebuild scheduled for merge)
>=sys-auth/polkit-0.101 required by (gnome-extra/polkit-gnome-0.101-r1, ebuild scheduled for merge)

(x11-libs/qt-webkit-4.7.2, ebuild scheduled for merge) pulled in by
>=x11-libs/qt-webkit-4.7.0:4[kde] required by (kde-base/kdelibs-4.6.2-r2, ebuild scheduled for merge)

(x11-libs/qt-declarative-4.7.2-r1, ebuild scheduled for merge) pulled in by
>=x11-libs/qt-declarative-4.7.0:4 required by (kde-base/kdelibs-4.6.2-r2, ebuild scheduled for merge)

(x11-libs/qt-svg-4.7.2, ebuild scheduled for merge) pulled in by
>=x11-libs/qt-svg-4.6.3:4 required by (kde-misc/polkit-kde-kcmodules-0.98_pre20101127, ebuild scheduled for merge)
>=x11-libs/qt-svg-4.7.0:4 required by (kde-base/kdelibs-4.6.2-r2, ebuild scheduled for merge)
>=x11-libs/qt-svg-4.7.0:4 required by (kde-base/khelpcenter-4.6.2, ebuild scheduled for merge)
(and 3 more)

(x11-libs/qt-dbus-4.7.1, installed) pulled in by
>=x11-libs/qt-dbus-4.6.0:4 required by (media-libs/phonon-vlc-0.3.2, ebuild scheduled for merge)
x11-libs/qt-dbus:4 required by (app-misc/strigi-0.7.2, ebuild scheduled for merge)
>=x11-libs/qt-dbus-4.6.0:4 required by (media-libs/phonon-4.5.0, ebuild scheduled for merge)

(x11-libs/qt-script-4.7.1-r1, installed) pulled in by
>=x11-libs/qt-script-4.7.0:4 required by (kde-base/khelpcenter-4.6.2, ebuild scheduled for merge)
>=x11-libs/qt-script-4.6.3:4 required by (kde-misc/polkit-kde-kcmodules-0.98_pre20101127, ebuild scheduled for merge)
>=x11-libs/qt-script-4.6.3:4 required by (sys-auth/polkit-kde-agent-0.99.0, ebuild scheduled for merge)
(and 2 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Grazie per le risposte
Back to top
View user's profile Send private message
grifone87
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jun 2005
Posts: 81
Location: Rome, Italy

PostPosted: Fri Apr 29, 2011 10:41 pm    Post subject: Reply with quote

Ciao, mi sembra che il problema sia nella USE flag kde di Vlc: essendo attivata vuole installare diversi pacchetti base di KDE, che a loro volta si portano dietro quei pacchetti delle Qt che causano i blocchi. Disattivala e riprova, tanto da quello che leggo nell'output di emerge intuisco che non usi KDE.

Inoltre c'è quest'altro blocco:
Code:
[blocks B ] sys-auth/policykit ("sys-auth/policykit" is blocking sys-auth/polkit-0.101-r1)


Non ricordo dove ho letto che polkit è il successore di policykit, quindi andrebbe rimosso: infatti non è neanche più in portage. Magari fai una ricerchina sul forum a riguardo. :)
Back to top
View user's profile Send private message
dursino
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2010
Posts: 83

PostPosted: Sat Apr 30, 2011 1:06 pm    Post subject: Reply with quote

Grazie, ho eliminato la flags Kde , ma ora ho il seguente errore in fase di compilazione:
Quote:
/bin/grep: /usr/lib/libxcb.la: No such file or directory
/bin/sed: can't read /usr/lib/libxcb.la: No such file or directory
libtool: link: `/usr/lib/libxcb.la' is not a valid libtool archive
make[6]: *** [libglobalhotkeys_plugin.la] Error 1
make[6]: Leaving directory `/var/tmp/portage/media-video/vlc-1.1.9/work/vlc-1.1.9/modules/control/globalhotkeys'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/var/tmp/portage/media-video/vlc-1.1.9/work/vlc-1.1.9/modules/control/globalhotkeys'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/media-video/vlc-1.1.9/work/vlc-1.1.9/modules/control'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/media-video/vlc-1.1.9/work/vlc-1.1.9/modules/control'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-video/vlc-1.1.9/work/vlc-1.1.9/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-video/vlc-1.1.9/work/vlc-1.1.9'
make: *** [all] Error 2
emake failed
* ERROR: media-video/vlc-1.1.9 failed (compile phase):
* died running emake, base_src_make
*
* Call stack:
* ebuild.sh, line 56: Called src_compile
* environment, line 4089: Called base_src_compile
* environment, line 827: Called base_src_make
* environment, line 865: Called die
* The specific snippet of code:
* emake "$@" || die "died running emake, $FUNCNAME";
*
* If you need support, post the output of 'emerge --info =media-video/vlc-1.1.9',
* the complete build log and the output of 'emerge -pqv =media-video/vlc-1.1.9'.
* The complete build log is located at '/var/tmp/portage/media-video/vlc-1.1.9/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/media-video/vlc-1.1.9/temp/environment'.
* S: '/var/tmp/portage/media-video/vlc-1.1.9/work/vlc-1.1.9'

>>> Failed to emerge media-video/vlc-1.1.9, Log file:

>>> '/var/tmp/portage/media-video/vlc-1.1.9/temp/build.log'

* Messages for package media-video/vlc-1.1.9:

* ERROR: media-video/vlc-1.1.9 failed (compile phase):
* died running emake, base_src_make
*
* Call stack:
* ebuild.sh, line 56: Called src_compile
* environment, line 4089: Called base_src_compile
* environment, line 827: Called base_src_make
* environment, line 865: Called die
* The specific snippet of code:
* emake "$@" || die "died running emake, $FUNCNAME";
*
* If you need support, post the output of 'emerge --info =media-video/vlc-1.1.9',
* the complete build log and the output of 'emerge -pqv =media-video/vlc-1.1.9'.
* The complete build log is located at '/var/tmp/portage/media-video/vlc-1.1.9/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/media-video/vlc-1.1.9/temp/environment'.
* S: '/var/tmp/portage/media-video/vlc-1.1.9/work/vlc-1.1.9'

Qualche idea?
Grazie per il supporto
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Apr 30, 2011 2:10 pm    Post subject: Reply with quote

dursino wrote:
Qualche idea?
Grazie per il supporto


una cosa per volta
Code:
emerge lafilefixer;lafilefixer --justfixit

_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
grifone87
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jun 2005
Posts: 81
Location: Rome, Italy

PostPosted: Sat Apr 30, 2011 3:03 pm    Post subject: Reply with quote

ago wrote:

una cosa per volta
Code:
emerge lafilefixer;lafilefixer --justfixit


Ma le nuove versioni di portage non fanno in automatico il lavoro di lafilefixer?
Back to top
View user's profile Send private message
dursino
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2010
Posts: 83

PostPosted: Sat Apr 30, 2011 5:06 pm    Post subject: Reply with quote

Ho seguito il suggerimento di Grifone87 eliminando la vecchia versione di Polkit ma adesso non riesco ad emergere la nuova versione e dunque Hald non parte, e dunque non vanno tastiera e mouse!!
Cosa posso farE?
Back to top
View user's profile Send private message
grifone87
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jun 2005
Posts: 81
Location: Rome, Italy

PostPosted: Sat Apr 30, 2011 9:09 pm    Post subject: Reply with quote

È strano che tu non sia riuscito ad aggiornare polkit visto che il suo update veniva prima dell'installazione di VLC.

Per quanto riguarda HAL: è deprecato, quindi devi aggiornare X ad una nuova versione che usa Udev al posto di HAL. Questa è la guida per l'aggiornamento alla versione 1.9 di X.
Back to top
View user's profile Send private message
dursino
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2010
Posts: 83

PostPosted: Sun May 01, 2011 8:57 am    Post subject: Reply with quote

Ho aggiornato Xorg con la flag Udev e eliminato Hal ,adesso ovviamente non parte la grafica.
Non trova:
failed to load /usr/lib/xorg/modules/drivers/intel_drv.so
Ma il vecchio Xorg.conf lo devo cancellare,e inserire da capo?
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sun May 01, 2011 9:30 am    Post subject: Reply with quote

dopo aver aggiornato xorg bisogna ricompilare i driver ad esso associati:

Code:
emerge -1 `qlist -I -C x11-drivers/`


se non hai qlist installato se non sbaglio fa parte di app-portage/portage-utils.

xorg.conf non dovrebbe essere necessario, prova a vedere se ti funziona senza, tutto in automatico
Back to top
View user's profile Send private message
dursino
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2010
Posts: 83

PostPosted: Sun May 01, 2011 9:40 am    Post subject: Reply with quote

Mira Mira chi si rivede!
Comunque avevo pensato anche io ai driver e l'ho fatto.
Intanto ho ricompilato anche il Kernel,appena finisce faccio sapere!
Grazie
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sun May 01, 2011 9:51 am    Post subject: Reply with quote

grifone87 wrote:
Ma le nuove versioni di portage non fanno in automatico il lavoro di lafilefixer?


In teoria si
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
dursino
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2010
Posts: 83

PostPosted: Sun May 01, 2011 10:28 am    Post subject: Reply with quote

Ho aggiornato Xorg ed adesso funziona bene anche senza HAL.
Adesso però ho un nuovo problemino ancora con polkit:
In particolare il sistema non riesce a far partire Network manager a causa della mancanza di Polkit:
Quote:
Calculating dependencies... done!
[ebuild U ] dev-libs/glib-2.28.6 [2.24.1-r1] USE="fam static-libs%* -debug -doc (-introspection) (-selinux) -test% -xattr" 6,793 kB
[ebuild N ] sys-auth/polkit-0.101-r1 USE="gtk nls pam -debug -doc -examples (-introspection) -kde" 1,048 kB
[ebuild U ] gnome-extra/polkit-gnome-0.101-r1 [0.96-r1] USE="-doc -examples (-introspection) (-debug%)" 399 kB
[blocks B ] <gnome-base/gvfs-1.6.4-r990 ("<gnome-base/gvfs-1.6.4-r990" is blocking dev-libs/glib-2.28.6)

Total: 3 packages (2 upgrades, 1 new), Size of downloads: 8,240 kB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(gnome-base/gvfs-1.6.3, installed) pulled in by
>=gnome-base/gvfs-1.6.2[gdu] required by (gnome-base/gnome-2.30.2, installed)
>=gnome-base/gvfs-0.1.2 required by (gnome-base/nautilus-2.30.1-r1, installed)
gnome-base/gvfs required by (gnome-base/libgnome-2.30.0, installed)

(dev-libs/glib-2.28.6, ebuild scheduled for merge) pulled in by
>=dev-libs/glib-2.22.0 required by (x11-libs/vte-0.24.3, installed)
>=dev-libs/glib-2.4:2 required by (x11-libs/wxGTK-2.8.11.0, installed)
>=dev-libs/glib-2.8 required by (gnome-base/orbit-2.14.18, installed)
(and 115 more)


Eliminare questo: gnome-base/gvfs-1.6.4-r990
Potrebbe risolvere?
Edit: Ha risolto AGGIORNANDO lo stesso
Back to top
View user's profile Send private message
dursino
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2010
Posts: 83

PostPosted: Sun May 01, 2011 12:00 pm    Post subject: Reply with quote

Qucluno di voi ha già affrontato:
Quote:
dursino@edge ~ $ vlc
VLC media player 1.1.9 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
Blocked: call to setlocale(6, "")
Cannot mix incompatible Qt library (version 0x40603) with this library (version 0x40701)
Back to top
View user's profile Send private message
grifone87
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jun 2005
Posts: 81
Location: Rome, Italy

PostPosted: Sun May 01, 2011 2:56 pm    Post subject: Reply with quote

Le righe che cominciano con "Blocked" le ho anch'io e non so cosa sono, però VLC mi funziona.

L'ultima riga penso si riferisca al fatto che hai dei pacchetti di Qt alla versione 4.6 e altri alla 4.7 (si vede dal primo output di emerge che hai postato). Quindi le soluzioni potrebbero essere due: o aggiorni tutti i pacchetti Qt alla versione 4.7 oppure, visto che hai disabilitato la flag kde, puoi disabilitare anche la flag qt4 (però non so quali librerie andrà ad usare).
Back to top
View user's profile Send private message
dursino
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2010
Posts: 83

PostPosted: Sun May 01, 2011 3:07 pm    Post subject: Reply with quote

Come posso aggiornare a 4.7 con emerge?
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Mon May 02, 2011 6:52 am    Post subject: Reply with quote

grifone87 wrote:

Ma le nuove versioni di portage non fanno in automatico il lavoro di lafilefixer?


Sì, se attivi la FEATURE corrispondente.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Mon May 02, 2011 9:09 am    Post subject: Reply with quote

Onip wrote:
Sì, se attivi la FEATURE corrispondente.


E' attiva di default
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
grifone87
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jun 2005
Posts: 81
Location: Rome, Italy

PostPosted: Wed May 04, 2011 6:07 pm    Post subject: Reply with quote

dursino wrote:
Come posso aggiornare a 4.7 con emerge?


O smascheri i pacchetti che sono alla versione 4.6 mettendoli in /etc/portage/package.keywords oppure aspetti qualche giorno, visto che Qt 4.7 sta per essere stabilizzata.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum