Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can't emerge anything
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
hamilito
n00b
n00b


Joined: 18 Aug 2010
Posts: 33

PostPosted: Wed Apr 27, 2011 3:40 pm    Post subject: Reply with quote

CurtE thats the same I got. read my previous post. follow chiefbag post.
Back to top
View user's profile Send private message
hamilito
n00b
n00b


Joined: 18 Aug 2010
Posts: 33

PostPosted: Wed Apr 27, 2011 3:44 pm    Post subject: Reply with quote

CurtE wrote:
Now I have two Python's but before it only showed 3.1, unless this is a false positive and Python isn't really there.

If you read the sticky Python 2.7 upgrade? you'll see that the python upgrade creates a new slot so you will have both slots 2.7 and 3.1 in case you wanted to switch back to the old one.
Back to top
View user's profile Send private message
hamilito
n00b
n00b


Joined: 18 Aug 2010
Posts: 33

PostPosted: Wed Apr 27, 2011 3:48 pm    Post subject: Reply with quote

Just
Code:
eselect python update

then
Code:
python-updater

and sit back and take two or three naps
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Wed Apr 27, 2011 4:01 pm    Post subject: Reply with quote

Okay, in hindsight, running "emerge --depclean" apparently was the cause of the problem because it unmerged python? Is that correct?

Wouldn't it make sense to never let "emerge --depclean" do this?
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Wed Apr 27, 2011 4:06 pm    Post subject: Reply with quote

python-updater:

The last of the output,
Code:

 * The following 11 packages have failed to build or install:
 *
 *  (dev-vcs/git-1.7.3.4-r1, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-vcs/git-1.7.3.4-r1/temp/build.log'
 *  (dev-libs/libxml2-2.7.8, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-libs/libxml2-2.7.8/temp/build.log'
 *  (dev-python/pysqlite-2.6.3, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/pysqlite-2.6.3/temp/build.log'
 *  (media-libs/lcms-1.19, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-libs/lcms-1.19/temp/build.log'
 *  (dev-libs/libxslt-1.1.26-r1, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-libs/libxslt-1.1.26-r1/temp/build.log'
 *  (dev-python/imaging-1.1.7, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/imaging-1.1.7/temp/build.log'
 *  (sys-apps/file-5.05, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/sys-apps/file-5.05/temp/build.log'
 *  (dev-python/mysql-python-1.2.3, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/mysql-python-1.2.3/temp/build.log'
 *  (net-analyzer/net-snmp-5.4.2.1-r4, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/net-analyzer/net-snmp-5.4.2.1-r4/temp/build.log'
 *  (sys-libs/cracklib-2.8.16, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/sys-libs/cracklib-2.8.16/temp/build.log'
 *  (app-editors/vim-7.3.50, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/app-editors/vim-7.3.50/temp/build.log'
 *

 * GNU info directory index is up-to-date.
Back to top
View user's profile Send private message
hamilito
n00b
n00b


Joined: 18 Aug 2010
Posts: 33

PostPosted: Wed Apr 27, 2011 4:12 pm    Post subject: Reply with quote

If
Code:
eselect python list
returns python 2.7 and 3.1 then you have python 2.7 and 3.1 installed.
If you type
Code:
which python
it should return the location where python is installed which should be /usr/bin/python
If
Code:
emerge --sync
or
Code:
emerge *anything
returns you to
Code:
#
then maybe is it your don't have python active which was my case, so far...
Thats why you need to select a version of python in which by reading your previous post I understand your computer have python2.7 as the system active version of python.
I had the same version of python active and running
Code:
revdep-rebuild
got me the same errors you are getting.
what I did was to select python3.1 by typing
Code:
eselect python update

and then typing
Code:
python-updater

then watch a few movies cause it'll take a while to compile.

--I have typed this same message for you like four times already CurtE, hope you're reading it now.--
Back to top
View user's profile Send private message
hamilito
n00b
n00b


Joined: 18 Aug 2010
Posts: 33

PostPosted: Wed Apr 27, 2011 4:27 pm    Post subject: Reply with quote

OK
Code:
python-updater
apparently fixed a lot (using python 3.1 as active system python).
I ran
Code:
revdep-rebuild
and still have two broken links using libpython2.6 (both openoffice) and it is compiling now so I guess my issue is resolved. I'll keep posting.
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Wed Apr 27, 2011 4:31 pm    Post subject: Reply with quote

Sorry if it doesn't look like I've read the message but I have.

csmn2 ~ # which python
/usr/bin/python

csmn2 ~ # emerge --sync
........
Number of files: 140528
Number of files transferred: 72
Total file size: 198268504 bytes
Total transferred file size: 745695 bytes
Literal data: 745695 bytes
Matched data: 0 bytes
File list size: 3349753
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 41554
Total bytes received: 4210859

sent 41554 bytes received 4210859 bytes 78025.93 bytes/sec
total size is 198268504 speedup is 46.62

csmn2 ~ # eselect python update
Switching to python3.1

csmn2 ~ # revdep-rebuild
* Configuring search environment for revdep-rebuild
File "<string>", line 1
import os; import pwd; print pwd.getpwuid(os.getuid())[0]
^
SyntaxError: invalid syntax

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
.....
Code:

 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-er.la (requires /usr/lib/libXfixes.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-er.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-er.la (requires /usr/lib/libX11.la)
[ 59% ]  *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-et.la (requires /usr/lib/libXi.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-et.la (requires /usr/lib/libXfixes.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-et.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-et.la (requires /usr/lib/libX11.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-viqr.la (requires /usr/lib/libXi.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-viqr.la (requires /usr/lib/libXfixes.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-viqr.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-viqr.la (requires /usr/lib/libX11.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.la (requires /usr/lib/libXi.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.la (requires /usr/lib/libXfixes.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.la (requires /usr/lib/libX11.la)
[ 60% ]  *   broken /usr/lib/gtk-2.0/2.10.0/loaders/svg_loader.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/loaders/svg_loader.la (requires /usr/lib/libX11.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.la (requires /usr/lib/libXi.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.la (requires /usr/lib/libXfixes.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.la (requires /usr/lib/libX11.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-file.la (requires /usr/lib/libXi.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-file.la (requires /usr/lib/libXfixes.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-file.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-file.la (requires /usr/lib/libX11.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.la (requires /usr/lib/libXi.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.la (requires /usr/lib/libXfixes.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.la (requires /usr/lib/libX11.la)
 *   broken /usr/lib/gtk-2.0/modules/libferret.la (requires /usr/lib/libXi.la)
 *   broken /usr/lib/gtk-2.0/modules/libferret.la (requires /usr/lib/libXfixes.la)
 *   broken /usr/lib/gtk-2.0/modules/libferret.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/gtk-2.0/modules/libferret.la (requires /usr/lib/libX11.la)
 *   broken /usr/lib/gtk-2.0/modules/libgail.la (requires /usr/lib/libXi.la)
 *   broken /usr/lib/gtk-2.0/modules/libgail.la (requires /usr/lib/libXfixes.la)
 *   broken /usr/lib/gtk-2.0/modules/libgail.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/gtk-2.0/modules/libgail.la (requires /usr/lib/libX11.la)
[ 61% ]  *   broken /usr/lib/libXdamage.la (requires /usr/lib/libXfixes.la)
 *   broken /usr/lib/libXdamage.la (requires /usr/lib/libX11.la)
 *   broken /usr/lib/libXrender.la (requires /usr/lib/libX11.la)
[ 62% ]  *   broken /usr/lib/libcairo.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/libcairo.la (requires /usr/lib/libX11.la)
[ 63% ]  *   broken /usr/lib/libgailutil.la (requires /usr/lib/libXi.la)
 *   broken /usr/lib/libgailutil.la (requires /usr/lib/libXfixes.la)
 *   broken /usr/lib/libgailutil.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/libgailutil.la (requires /usr/lib/libX11.la)
[ 64% ]  *   broken /usr/lib/libgdk_pixbuf_xlib-2.0.la (requires /usr/lib/libX11.la)
[ 67% ]  *   broken /usr/lib/librsvg-2.la (requires /usr/lib/libpixman-1.la)
 *   broken /usr/lib/librsvg-2.la (requires /usr/lib/libX11.la)
[ 79% ]  *   broken /usr/lib/python2.6/site-packages/PIL/_imaging.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib/python2.6/site-packages/PIL/_imagingcms.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib/python2.6/site-packages/PIL/_imagingft.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib/python2.6/site-packages/PIL/_imagingmath.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib/python2.6/site-packages/_cracklibmodule.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib/python2.6/site-packages/_lcms.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib/python2.6/site-packages/_mysql.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib/python2.6/site-packages/libxsltmod.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib/python2.6/site-packages/netsnmp/client_intf.so (requires libpython2.6.so.1.0)
 *   broken /usr/lib/python2.6/site-packages/pysqlite2/_sqlite.so (requires libpython2.6.so.1.0)
[ 100% ]
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/bin/vim -> app-editors/vim
 *   /usr/lib/ImageMagick-6.6.5/modules-Q16/coders/svg.la -> media-gfx/imagemagick
 *  !!! /usr/lib/apache2/modules/mod_wsgi.so not owned by any package is broken !!!
 *   /usr/lib/apache2/modules/mod_wsgi.so -> (none)
 *   /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/engines/libsvg.la -> gnome-base/librsvg
 *   /usr/lib/gtk-2.0/2.10.0/immodules/im-am-et.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/immodules/im-cyrillic-translit.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/immodules/im-inuktitut.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/immodules/im-ipa.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/immodules/im-multipress.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/immodules/im-thai.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-er.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/immodules/im-ti-et.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/immodules/im-viqr.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/loaders/svg_loader.la -> gnome-base/librsvg
 *   /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-file.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/modules/libferret.la -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/modules/libgail.la -> x11-libs/gtk+
 *   /usr/lib/libXdamage.la -> x11-libs/libXdamage
 *   /usr/lib/libXrender.la -> x11-libs/libXrender
 *   /usr/lib/libcairo.la -> x11-libs/cairo
 *   /usr/lib/libgailutil.la -> x11-libs/gtk+
 *   /usr/lib/libgdk_pixbuf_xlib-2.0.la -> x11-libs/gtk+
 *   /usr/lib/librsvg-2.la -> gnome-base/librsvg
 *   /usr/lib/python2.6/site-packages/PIL/_imaging.so -> dev-python/imaging
 *   /usr/lib/python2.6/site-packages/PIL/_imagingcms.so -> dev-python/imaging
 *   /usr/lib/python2.6/site-packages/PIL/_imagingft.so -> dev-python/imaging
 *   /usr/lib/python2.6/site-packages/PIL/_imagingmath.so -> dev-python/imaging
 *   /usr/lib/python2.6/site-packages/_cracklibmodule.so -> sys-libs/cracklib
 *   /usr/lib/python2.6/site-packages/_lcms.so -> media-libs/lcms
 *   /usr/lib/python2.6/site-packages/_mysql.so -> dev-python/mysql-python
 *   /usr/lib/python2.6/site-packages/libxsltmod.so -> dev-libs/libxslt
 *   /usr/lib/python2.6/site-packages/netsnmp/client_intf.so -> net-analyzer/net-snmp
 *   /usr/lib/python2.6/site-packages/pysqlite2/_sqlite.so -> dev-python/pysqlite
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
[ebuild   R   ] media-libs/lcms-1.19
[ebuild   R   ] dev-libs/libxslt-1.1.26-r1
[ebuild   R   ] dev-python/pysqlite-2.6.3
[ebuild   R   ] net-analyzer/net-snmp-5.4.2.1-r4
[ebuild   R   ] sys-libs/cracklib-2.8.16
[ebuild   R   ] dev-python/mysql-python-1.2.3
[ebuild   R   ] x11-libs/libXrender-0.9.6
[ebuild   R   ] x11-libs/libXdamage-1.1.3
[ebuild   R   ] dev-python/imaging-1.1.7
[ebuild  N    ] virtual/pam-0
[ebuild  N    ] virtual/mta-0
[ebuild     U ] x11-libs/cairo-1.10.2-r1 [1.8.10]
[ebuild   R   ] app-editors/vim-7.3.50
[ebuild  N    ] x11-libs/gdk-pixbuf-2.22.1
[ebuild     U ] x11-libs/gtk+-2.22.1-r1 [2.20.1-r1]
[blocks b     ] <x11-libs/gtk+-2.21.3:2 ("<x11-libs/gtk+-2.21.3:2" is blocking x11-libs/gdk-pixbuf-2.22.1)
[ebuild     U ] gnome-base/librsvg-2.32.1 [2.26.3]
[blocks b     ] <gnome-base/librsvg-2.31.0 ("<gnome-base/librsvg-2.31.0" is blocking x11-libs/gdk-pixbuf-2.22.1)
[ebuild   R   ] media-gfx/imagemagick-6.6.5.6

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/cairo:0

  (x11-libs/cairo-1.10.2-r1, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/cairo-1.8.10, installed) pulled in by
    >=x11-libs/cairo-1.6[X,svg] required by (x11-libs/gtk+-2.22.1-r1, ebuild scheduled for merge)
    (and 1 more with the same problem)


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might at least allow emerge to give a suggestions.

 *
 * Warning: Failed to resolve package order.
 * Will merge in arbitrary order
 *
Possible reasons:
- An ebuild is no longer in the portage tree.
- An ebuild is masked, use /etc/portage/packages.keyword
and/or /etc/portage/package.unmask to unmask it
.....
 * All prepared. Starting rebuild
emerge --oneshot   app-editors/vim:0
dev-libs/libxslt:0
dev-python/imaging:0
dev-python/mysql-python:0
dev-python/pysqlite:2
gnome-base/librsvg:2
media-gfx/imagemagick:0
media-libs/lcms:0
net-analyzer/net-snmp:0
sys-libs/cracklib:0
x11-libs/cairo:0
x11-libs/gtk+:2
x11-libs/libXdamage:0
x11-libs/libXrender:0
..........
Calculating dependencies... done!
[ebuild     U ] x11-libs/cairo-1.10.2-r1 [1.8.10] USE="qt4%* -X* (-drm) (-gallium) (-openvg) -static-libs%"
[ebuild   R   ] x11-libs/libXdamage-1.1.3
[ebuild   R   ] x11-libs/libXrender-0.9.6
[ebuild   R   ] app-editors/vim-7.3.50  USE="-X*"
[ebuild   R   ] dev-libs/libxslt-1.1.26-r1
[ebuild   R   ] dev-python/pysqlite-2.6.3
[ebuild   R   ] net-analyzer/net-snmp-5.4.2.1-r4  USE="-X*"
[ebuild   R   ] sys-libs/cracklib-2.8.16
[ebuild   R   ] dev-python/imaging-1.1.7  USE="-X*"
[ebuild   R   ] dev-python/mysql-python-1.2.3
[ebuild   R   ] media-libs/lcms-1.19
[ebuild  N    ] x11-libs/gdk-pixbuf-2.22.1  USE="X jpeg -debug -doc (-introspection) -jpeg2k -test -tiff"
[ebuild     U ] x11-libs/gtk+-2.22.1-r1 [2.20.1-r1] USE="-examples%"
[blocks b     ] <x11-libs/gtk+-2.21.3:2 ("<x11-libs/gtk+-2.21.3:2" is blocking x11-libs/gdk-pixbuf-2.22.1)
[ebuild     U ] gnome-base/librsvg-2.32.1 [2.26.3] USE="gtk%*"
[blocks b     ] <gnome-base/librsvg-2.31.0 ("<gnome-base/librsvg-2.31.0" is blocking x11-libs/gdk-pixbuf-2.22.1)
[ebuild   R   ] media-gfx/imagemagick-6.6.5.6  USE="-X*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/cairo:0

  (x11-libs/cairo-1.10.2-r1, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/cairo-1.8.10, installed) pulled in by
    >=x11-libs/cairo-1.6[X,svg] required by (x11-libs/gtk+-2.22.1-r1, ebuild scheduled for merge)


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might at least allow emerge to give a suggestions.

 *
 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 *
 * To remove temporary files, please run:
 * rm /tmp/revdep-rebuild.Ro4NSXGuEo/*.rr
 * Found some broken files that weren't associated with known packages
 * The broken files are:
 *   /usr/lib/apache2/modules/mod_wsgi.so
Back to top
View user's profile Send private message
hamilito
n00b
n00b


Joined: 18 Aug 2010
Posts: 33

PostPosted: Wed Apr 27, 2011 4:38 pm    Post subject: Reply with quote

Quote:
csmn2 ~ # eselect python update
Switching to python3.1

csmn2 ~ # revdep-rebuild
* Configuring search environment for revdep-rebuild
File "<string>", line 1
import os; import pwd; print pwd.getpwuid(os.getuid())[0]
^
SyntaxError: invalid syntax


Did you run
Code:
python-updater
after
Code:
eselect python update
with python3.1 selected active and before running
Code:
revdep-rebuild
?

python-updater will do a lot of compiling with 3.1 active it took a few hours on my pc (like 3).
Back to top
View user's profile Send private message
hamilito
n00b
n00b


Joined: 18 Aug 2010
Posts: 33

PostPosted: Wed Apr 27, 2011 4:46 pm    Post subject: Reply with quote

also you have this CurtE
Quote:
[ebuild U ] x11-libs/gtk+-2.22.1-r1 [2.20.1-r1]
[blocks b ] <x11-libs/gtk+-2.21.3:2 ("<x11-libs/gtk+-2.21.3:2" is blocking x11-libs/gdk-pixbuf-2.22.1)
[ebuild U ] gnome-base/librsvg-2.32.1 [2.26.3]
[blocks b ] <gnome-base/librsvg-2.31.0 ("<gnome-base/librsvg-2.31.0" is blocking x11-libs/gdk-pixbuf-2.22.1)
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
x11-libs/cairo:0
(x11-libs/cairo-1.10.2-r1, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)
(x11-libs/cairo-1.8.10, installed) pulled in by
>=x11-libs/cairo-1.6[X,svg] required by (x11-libs/gtk+-2.22.1-r1, ebuild scheduled for merge)
(and 1 more with the same problem)
!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might at least allow emerge to give a suggestions.

try running
Code:
emerge --newuse --update world
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Wed Apr 27, 2011 4:55 pm    Post subject: Reply with quote

Still no go:
Code:

csmn2 ~ # emerge --newuse --update world
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 5) sys-process/psmisc-22.12
 * psmisc-22.12.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                            [ ok ]
 * Package:    sys-process/psmisc-22.12
 * Repository: gentoo
 * Maintainer: base-system@gentoo.org
 * USE:        elibc_glibc kernel_linux nls userland_GNU x86
 * FEATURES:   sandbox
 * This profile has not been tested thoroughly and is not considered to be
 * a supported server profile at this time.  For a supported server
 * profile, please check the Hardened project (http://hardened.gentoo.org).

 * This profile is merely a convenience for people who require a more
 * minimal profile, yet are unable to use hardened due to restrictions in
 * the software being used on the server. This profile should also be used
 * if you require GCC 4.1 or Glibc 2.4 support. If you don't know if this
 * applies to you, then it doesn't and you should probably be using
 * Hardened, instead.

>>> Unpacking source...
>>> Unpacking psmisc-22.12.tar.gz to /var/tmp/portage/sys-process/psmisc-22.12/work
>>> Source unpacked in /var/tmp/portage/sys-process/psmisc-22.12/work
>>> Preparing source in /var/tmp/portage/sys-process/psmisc-22.12/work/psmisc-22.12 ...
 * Applying psmisc-22.12-peekfd.patch ...                                                                                         [ ok ]
 * Running eautoreconf in '/var/tmp/portage/sys-process/psmisc-22.12/work/psmisc-22.12' ...
 * Running aclocal -I m4 ...                                                                                                      [ ok ]
 * Running autoconf ...                                                                                                           [ ok ]
 * Running autoheader ...                                                                                                         [ ok ]
 * Running automake --add-missing --copy ...                                                                                      [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-process/psmisc-22.12/work/psmisc-22.12 ...
 * econf: updating psmisc-22.12/config/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating psmisc-22.12/config/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-dependency-tracking --disable-selinux --disable-ipv6 --enable-nls
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/sys-process/psmisc-22.12/work/psmisc-22.12':
configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-process/psmisc-22.12/work/psmisc-22.12/config.log
 * ERROR: sys-process/psmisc-22.12 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 2670:  Called econf '--disable-dependency-tracking' '--disable-selinux' '--disable-ipv6' '--enable-nls'
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =sys-process/psmisc-22.12',
 * the complete build log and the output of 'emerge -pqv =sys-process/psmisc-22.12'.
 * The complete build log is located at '/var/tmp/portage/sys-process/psmisc-22.12/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-process/psmisc-22.12/temp/environment'.
 * S: '/var/tmp/portage/sys-process/psmisc-22.12/work/psmisc-22.12'

>>> Failed to emerge sys-process/psmisc-22.12, Log file:

>>>  '/var/tmp/portage/sys-process/psmisc-22.12/temp/build.log'

 * Messages for package sys-process/psmisc-22.12:

 * This profile has not been tested thoroughly and is not considered to be
 * a supported server profile at this time.  For a supported server
 * profile, please check the Hardened project (http://hardened.gentoo.org).
 * This profile is merely a convenience for people who require a more
 * minimal profile, yet are unable to use hardened due to restrictions in
 * the software being used on the server. This profile should also be used
 * if you require GCC 4.1 or Glibc 2.4 support. If you don't know if this
 * applies to you, then it doesn't and you should probably be using
 * Hardened, instead.
 * ERROR: sys-process/psmisc-22.12 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 2670:  Called econf '--disable-dependency-tracking' '--disable-selinux' '--disable-ipv6' '--enable-nls'
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =sys-process/psmisc-22.12',
 * the complete build log and the output of 'emerge -pqv =sys-process/psmisc-22.12'.
 * The complete build log is located at '/var/tmp/portage/sys-process/psmisc-22.12/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-process/psmisc-22.12/temp/environment'.
 * S: '/var/tmp/portage/sys-process/psmisc-22.12/work/psmisc-22.12'
Back to top
View user's profile Send private message
hamilito
n00b
n00b


Joined: 18 Aug 2010
Posts: 33

PostPosted: Wed Apr 27, 2011 5:11 pm    Post subject: Reply with quote

that should be your last step.
first you gotta run
Code:
python-updater
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Wed Apr 27, 2011 7:00 pm    Post subject: Reply with quote

We are missing something here, still the same results:
Code:

......
 * Messages for package app-editors/vim-7.3.50:

 * This profile has not been tested thoroughly and is not considered to be
 * a supported server profile at this time.  For a supported server
 * profile, please check the Hardened project (http://hardened.gentoo.org).
 * This profile is merely a convenience for people who require a more
 * minimal profile, yet are unable to use hardened due to restrictions in
 * the software being used on the server. This profile should also be used
 * if you require GCC 4.1 or Glibc 2.4 support. If you don't know if this
 * applies to you, then it doesn't and you should probably be using
 * Hardened, instead.
 * ERROR: app-editors/vim-7.3.50 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 5193:  Called vim_src_configure
 *   environment, line 6300:  Called econf '--with-features=huge' '--enable-multibyte' '--disable-cscope' '--enable-gpm' '--enable-perlinterp' '--enable-pythoninterp' '--disable-rubyinterp' '--enable-gui=no' '--disable-darwin' '--without-x' '--enable-nls' '--enable-acl' '--with-tlib=curses' '--disable-selinux' '--with-modified-by=Gentoo-7.3.50'
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =app-editors/vim-7.3.50',
 * the complete build log and the output of 'emerge -pqv =app-editors/vim-7.3.50'.
 * The complete build log is located at '/var/tmp/portage/app-editors/vim-7.3.50/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-editors/vim-7.3.50/temp/environment'.
 * S: '/var/tmp/portage/app-editors/vim-7.3.50/work/vim73'
 *
 * The following 11 packages have failed to build or install:
 *
 *  (dev-vcs/git-1.7.3.4-r1, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-vcs/git-1.7.3.4-r1/temp/build.log'
 *  (dev-libs/libxml2-2.7.8, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-libs/libxml2-2.7.8/temp/build.log'
 *  (dev-python/pysqlite-2.6.3, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/pysqlite-2.6.3/temp/build.log'
 *  (media-libs/lcms-1.19, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-libs/lcms-1.19/temp/build.log'
 *  (dev-libs/libxslt-1.1.26-r1, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-libs/libxslt-1.1.26-r1/temp/build.log'
 *  (dev-python/imaging-1.1.7, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/imaging-1.1.7/temp/build.log'
 *  (sys-apps/file-5.05, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/sys-apps/file-5.05/temp/build.log'
 *  (dev-python/mysql-python-1.2.3, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/mysql-python-1.2.3/temp/build.log'
 *  (net-analyzer/net-snmp-5.4.2.1-r4, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/net-analyzer/net-snmp-5.4.2.1-r4/temp/build.log'
 *  (sys-libs/cracklib-2.8.16, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/sys-libs/cracklib-2.8.16/temp/build.log'
 *  (app-editors/vim-7.3.50, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/app-editors/vim-7.3.50/temp/build.log'
 *
Back to top
View user's profile Send private message
piedar
Tux's lil' helper
Tux's lil' helper


Joined: 09 Aug 2010
Posts: 80

PostPosted: Wed Apr 27, 2011 9:05 pm    Post subject: Reply with quote

Jaglover wrote:
May I add you should set a version of python-2 as system Python, Gentoo is not ready for python-3?

Quoted a second time and extra emphasis added.


CurtE wrote:
Okay, in hindsight, running "emerge --depclean" apparently was the cause of the problem because it unmerged python? Is that correct?

Wouldn't it make sense to never let "emerge --depclean" do this?

--depclean removed 2.6 because both 2.6 and 2.7 were in the same slot. This left you without an active python version because there were two possibilities and it left the choice up to you.
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Wed Apr 27, 2011 9:31 pm    Post subject: Reply with quote

Marshmallow,
At this point and time, I can't say with 100% certainty that Python 2.7 was my active python at the time of "emerge --depclean" but I believe it was. I'll not debate any part of it because it has long past. I'm only trying to recover the server back to 24 hours ago when it was stable.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 3907

PostPosted: Wed Apr 27, 2011 10:46 pm    Post subject: Reply with quote

use python2.7 don't use 3.1 as it's not ready yet.

and before doing revdep-rebuild (while you have python2.7 selected), run python-updater (at least, revdep-rebuild shouldn't catch imagemagik because python-updater should have catch it).

when python-updater's work end, go with your revdep-rebuild
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Wed Apr 27, 2011 11:12 pm    Post subject: Reply with quote

Obviously by now I have done revdep-rebuild, python-updater, revdep-rebuild and python-updater enough times that something else seems to be an issue and not the same as hamilito's problem (the original post of this thread). If we can determine the answer in a few more post, I'll have to start a thread on my own so we can do apples to apples.

I'm open to any other suggestions on what to do.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 3907

PostPosted: Wed Apr 27, 2011 11:27 pm    Post subject: Reply with quote

then start a new one because hamilton suggest to python-updater & revdep-rebuild while having python3.1 is a bad suggest.

and stop running --depclean
1/ you should never run it like that, but with --pretend first
2/ you won't have an issue not running it, just loosing some space on your harddisk. So before doing blind, dangerous & unuseful things, you better update your system. --depclean is just an option, and not one you should take as a full feature to keep your system update.

your last error show the "C compiler cannot create executable", a common one, but you'll have to correct it first to go anywhere.
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Wed Apr 27, 2011 11:58 pm    Post subject: Reply with quote

Okay, we'll start a new thread. :)
Back to top
View user's profile Send private message
hamilito
n00b
n00b


Joined: 18 Aug 2010
Posts: 33

PostPosted: Thu Apr 28, 2011 7:53 pm    Post subject: Reply with quote

Well for the sake of the thread my system is running like new now. Didn't really have any problems or troubles after running python-updater and I'm using python3.1. If I ever encounter another problem running 3.1 I'll switch to 2.7 and run python-updater. I just didn't know updating python would deactivate it and create two slots for me to chose.

The only thing I have are two broken links for openoffice which is asking for libpython2.6 but since I don't use that software much I'm not going to pay attention and just add the locations to make.conf so that revdep-rebuild skips them (until a future update for either python or openoffice correcting this). Apart from that my system is running perfectly now and I can run emerge again.

Thanks for all the help guys.
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Fri Apr 29, 2011 12:47 am    Post subject: Reply with quote

I had an additional problem, GCC was not working. Once that was restore, things went smoothly. Your thread was very helpful too.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum