Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Incoming/outgoing packet latency difference
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
zirtik
n00b
n00b


Joined: 15 Apr 2011
Posts: 13

PostPosted: Mon Apr 25, 2011 7:24 pm    Post subject: Incoming/outgoing packet latency difference Reply with quote

Hi,

I'm running a 64 bit Gentoo box recently installed on a 6 core machine with 6 GB memory. When I try to ping other machines in my local network, I get an average latency of 0.140 ms. If I do the reverse, ie. ping my Gentoo box from other machines in my local network, I see an average latency of 0.122. I'm confused since I believe the network round trip time must not differ so much, as in both cases I send and receive the same amount of data between the same pair of machines.

Here is a more detailed output:

From Gentoo to anoher machine running Ubuntu:

Code:
64 bytes from 192.168.59.13: icmp_req=170 ttl=64 time=0.136 ms
64 bytes from 192.168.59.13: icmp_req=171 ttl=64 time=0.140 ms
64 bytes from 192.168.59.13: icmp_req=172 ttl=64 time=0.135 ms
64 bytes from 192.168.59.13: icmp_req=173 ttl=64 time=0.142 ms
64 bytes from 192.168.59.13: icmp_req=174 ttl=64 time=0.139 ms
^C
--- 192.168.59.13 ping statistics ---
174 packets transmitted, 174 received, 0% packet loss, time 173011ms
rtt min/avg/max/mdev = 0.121/0.140/0.152/0.011 ms


From the same Ubuntu machine to Gentoo:

Code:
64 bytes from 192.168.59.103: icmp_req=161 ttl=64 time=0.119 ms
64 bytes from 192.168.59.103: icmp_req=162 ttl=64 time=0.118 ms
64 bytes from 192.168.59.103: icmp_req=163 ttl=64 time=0.127 ms
64 bytes from 192.168.59.103: icmp_req=164 ttl=64 time=0.120 ms
64 bytes from 192.168.59.103: icmp_req=165 ttl=64 time=0.119 ms
^C
--- 192.168.59.103 ping statistics ---
165 packets transmitted, 165 received, 0% packet loss, time 163999ms
rtt min/avg/max/mdev = 0.096/0.122/0.133/0.012 ms


Does anyone have any idea why this might happen? I don't observe the same latency difference between other machines running Ubuntu.

Thanks in advance.
Back to top
View user's profile Send private message
nemectic
Apprentice
Apprentice


Joined: 20 Aug 2004
Posts: 182

PostPosted: Mon Apr 25, 2011 9:21 pm    Post subject: Reply with quote

I can't help, but is a latency difference of 0.018 milliseconds really that vital? I'm guessing you've run this test several times to verify the difference seeing as it is so minute?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum