Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] mount.nfs: an incorrect mount option was specified
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sat Apr 23, 2011 7:10 pm    Post subject: [SOLVED] mount.nfs: an incorrect mount option was specified Reply with quote

I can not seem to make nfs to work.
I'm following instructions from:
http://en.gentoo-wiki.com/wiki/NFS/Server

Code:
 cat /etc/exports examples
# /etc/exports: NFS file systems being exported.  See exports(5).

/home/joseph 10.0.*.*(async,rw,no_subtree_check)
Code:
cat /etc/fstab
10.0.0.103:/home/joseph/   /home/joseph/mnt/syscon2/    nfs   defaults,users,noauto    0 0


nfs-utils is compiled without "nfsv4"
It starts OK, but when I try to mount it
Code:
mount -t nfs 10.0.0.103:/home/joseph /home/joseph/mnt/syscon2
mount.nfs: an incorrect mount option was specified
or
Code:
mount /home/joseph/mnt/syscon2/
mount.nfs: an incorrect mount option was specified

_________________
#Thelma


Last edited by Joseph_sys on Sat Apr 23, 2011 10:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sat Apr 23, 2011 7:23 pm    Post subject: Reply with quote

Code:
rpcinfo -p 10.0.0.103
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100024    1   udp  39346  status
    100024    1   tcp  49886  status
    100005    1   udp  43549  mountd
    100005    1   tcp  47665  mountd
    100005    2   udp  54395  mountd
    100005    2   tcp  46436  mountd
    100005    3   udp  47309  mountd
    100005    3   tcp  40399  mountd
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100021    1   udp  40997  nlockmgr
    100021    3   udp  40997  nlockmgr
    100021    4   udp  40997  nlockmgr
    100021    1   tcp  33762  nlockmgr
    100021    3   tcp  33762  nlockmgr
    100021    4   tcp  33762  nlockmgr

_________________
#Thelma
Back to top
View user's profile Send private message
bernd_b
Tux's lil' helper
Tux's lil' helper


Joined: 25 Nov 2003
Posts: 148

PostPosted: Sat Apr 23, 2011 7:25 pm    Post subject: Reply with quote

Just a wild guess:
I added "vers=3" to my mount options in /etc/fstab.
At least it gave me luck.

https://forums.gentoo.org/viewtopic-t-844778-highlight-nfs.html
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sat Apr 23, 2011 7:33 pm    Post subject: Reply with quote

I've change fstab entry to:
Code:
10.0.0.103:/home/joseph/   /home/joseph/mnt/syscon2/    nfs   nfsvers=3,users,noauto    0 0

and I get:
Code:
mount /home/joseph/mnt/syscon2/
mount.nfs: access denied by server while mounting 10.0.0.103:/home/joseph/

_________________
#Thelma
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7447

PostPosted: Sat Apr 23, 2011 7:40 pm    Post subject: Reply with quote

nfs-utils change behavior at some version that i forget, now it default to always try nfs4 first, the nfsv4 flag is there to add dependies for nfsv4 usage, but still nfsv4 will be use when querying a mount

try mount -t nfs 10.0.0.103:/home/joseph /home/joseph/mnt/syscon2 -v -o nfsvers=3,vers=3
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sat Apr 23, 2011 9:47 pm    Post subject: Reply with quote

krinn wrote:
nfs-utils change behavior at some version that i forget, now it default to always try nfs4 first, the nfsv4 flag is there to add dependies for nfsv4 usage, but still nfsv4 will be use when querying a mount

try mount -t nfs 10.0.0.103:/home/joseph /home/joseph/mnt/syscon2 -v -o nfsvers=3,vers=3


No go:
Code:
mount -t nfs 10.0.0.103:/home/joseph /home/joseph/mnt/syscon2 -v -o nfsvers=3,vers=3
mount.nfs: timeout set for Sat Apr 23 15:48:26 2011
mount.nfs: trying text-based options 'nfsvers=3,vers=3,addr=10.0.0.103'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 10.0.0.103 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 10.0.0.103 prog 100005 vers 3 prot UDP port 54976
mount.nfs: mount(2): Permission denied
mount.nfs: access denied by server while mounting 10.0.0.103:/home/joseph

_________________
#Thelma
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sat Apr 23, 2011 9:55 pm    Post subject: Reply with quote

bernd_b wrote:
Just a wild guess:
I added "vers=3" to my mount options in /etc/fstab.
At least it gave me luck.

https://forums.gentoo.org/viewtopic-t-844778-highlight-nfs.html


I've seen this link, it doesn't help.
Do you mean fstab entry like this:
Code:
10.0.0.103:/home/joseph   /home/joseph/mnt/syscon2    nfs   vers=3,nfsvers=3,users,noauto    0 0


Still same error:
Code:
mount -v /home/joseph/mnt/syscon2/
mount.nfs: timeout set for Sat Apr 23 15:57:31 2011
mount.nfs: trying text-based options 'vers=3,nfsvers=3,addr=10.0.0.103'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 10.0.0.103 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 10.0.0.103 prog 100005 vers 3 prot UDP port 54976
mount.nfs: mount(2): Permission denied
mount.nfs: access denied by server while mounting 10.0.0.103:/home/joseph

_________________
#Thelma
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Sat Apr 23, 2011 10:27 pm    Post subject: Reply with quote

SOLVED,
/etc/exports should be:
/home/joseph 10.0.0.0/255.255.0.0(async,rw,no_subtree_check)

The correct setting if somebody will encounter the same problem:
Code:
fstab:
...
10.0.0.103:/home/joseph   /home/joseph/mnt/syscon2    nfs   nfsvers=3,users,noauto    0 0
Code:
cat /etc/exports
/home/joseph 10.0.0.0/255.255.0.0(async,rw,no_subtree_check)

_________________
#Thelma
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum