Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge ruby 1.9.2 hard masked
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
effeuno
Apprentice
Apprentice


Joined: 23 Dec 2003
Posts: 292

PostPosted: Fri Apr 22, 2011 11:58 am    Post subject: emerge ruby 1.9.2 hard masked Reply with quote

da manuale Gentoo:
Quote:
3.c. Usare pacchetti mascherati

package.unmask

Importante: Gli sviluppatori di Gentoo non supportano l'uso di questa locazione. Si prega di usare cautela nel loro uso. Le richieste di supporto in relazione a package.unmask e/o package.mask non avranno risposta. Si è avvertiti.
Quando un pacchetto è stato mascherato dagli sviluppatori di Gentoo e si vuole comunque installare il file a dispetto della ragione menzionata nel file package.mask (ubicato di default in /usr/portage/profiles), aggiungere la stessa identica linea in /etc/portage/package.unmask (o in un file in questa directory se questa è una directory).

Per esempio, se =net-mail/hotwayd-0.8 è mascherato, si può comunque installarlo aggiungendo la stessa identica linea nella locazione package.unmask:


sul file /usr/portage/profiles/package.mask trovo:

Code:
...............
>dev-lang/ruby-1.9.1
~virtual/ruby-ssl-1
~virtual/ruby-rdoc-1
....
....


riporto pari pari su

/etc/portage/package.unmask


dando emerge -ap ruby ottengo sempre e solo:
Code:
emerge -ap dev-lang/ruby
...
...
[ebuild N  ] dev-lang/ruby-1.8.7_p324 USE="..........................


.. da un vecchio post di RANDOMAZE ( Ven Gen 02, 2004 1:22 pm Oggetto: Re: Pacchetti hard masked??? )


randomaze wrote:
dariello wrote:
Ho provato ad installare lumiere ma è hard masked, come faccio a forzarne l'installazione???
Grazie.


Code:

emerge /usr/portage/media-video/lumiere/lumiere-0.4.ebuild


procedo:

Code:

emerge -ap /usr/portage/dev-lang/ruby/ruby-1.9.2.ebuild

*** emerging by path is broken and may not always work!!!
....
....

*** You are emerging a masked package. It is MUCH better to use
*** /etc/portage/package.* to accomplish this. See portage (5) man
*** page for details.


Mi sembrava di averlo fatto, ma non ho i risultati sperati, almeno credo.
Qualche consiglio in merito ?????
Posso procedere !!!

Grazie in anticipo.[/code]


[/code]
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri Apr 22, 2011 12:23 pm    Post subject: Reply with quote

emergere indicando direttamente l'ebuild è assolutamente sconsigliato (leggi da non fare proprio).

prova a fare
Code:
# emerge -pv --autounmask dev-lang/ruby:1.9


ti dovrebbe spiegare cosa fare di passo in passo.

Per quello che ho visto io nella prova che ho fatto adesso prima di postare è importante specificare correttamente la variabile RUBY_TARGETS smascherando anche la use flag correlata (ruby_targets_ruby19) globalmente o pacchetto per pacchetto.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum