Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[E17] Impossible d'installer evas (résolu : pilote nouveau)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
DidgeriDude
Guru
Guru


Joined: 30 Jan 2005
Posts: 347

PostPosted: Sun Apr 17, 2011 10:54 am    Post subject: [E17] Impossible d'installer evas (résolu : pilote nouveau) Reply with quote

Bonjour à tous,

J'ai décidé de retester E17. D'après ce post, j'ai installé l'overlay Enlightenment, mais lors de l'emerge d'evas, j'obtiens cette erreur :

Code:
make[3]: entrant dans le répertoire « /var/tmp/portage/media-libs/evas-9999/work/evas/src/bin »
  CC     evas_cserve_tool.o
  CC     evas_cserve_main.o
  CCLD   evas_cserve_tool
  CCLD   evas_cserve
../../src/lib/.libs/libevas.so: undefined reference to `glBindFramebuffer'
../../src/lib/.libs/libevas.so: undefined reference to `glCheckFramebufferStatus'
../../src/lib/.libs/libevas.so: undefined reference to `glGenFramebuffers'
../../src/lib/.libs/libevas.so: undefined reference to `glBindRenderbuffer'
../../src/lib/.libs/libevas.so: undefined reference to `glFramebufferTexture2D'
../../src/lib/.libs/libevas.so: undefined reference to `glFramebufferRenderbuffer'
../../src/lib/.libs/libevas.so: undefined reference to `glGenRenderbuffers'
../../src/lib/.libs/libevas.so: undefined reference to `glDeleteRenderbuffers'
../../src/lib/.libs/libevas.so: undefined reference to `glRenderbufferStorage'
collect2: ld returned 1 exit status
make[3]: *** [evas_cserve_tool] Erreur 1
make[3]: *** Attente des tâches non terminées....
../../src/lib/.libs/libevas.so: undefined reference to `glBindFramebuffer'
../../src/lib/.libs/libevas.so: undefined reference to `glCheckFramebufferStatus'
../../src/lib/.libs/libevas.so: undefined reference to `glGenFramebuffers'
../../src/lib/.libs/libevas.so: undefined reference to `glBindRenderbuffer'
../../src/lib/.libs/libevas.so: undefined reference to `glFramebufferTexture2D'
../../src/lib/.libs/libevas.so: undefined reference to `glFramebufferRenderbuffer'
../../src/lib/.libs/libevas.so: undefined reference to `glGenRenderbuffers'
../../src/lib/.libs/libevas.so: undefined reference to `glDeleteRenderbuffers'
../../src/lib/.libs/libevas.so: undefined reference to `glRenderbufferStorage'
collect2: ld returned 1 exit status
make[3]: *** [evas_cserve] Erreur 1
make[3]: quittant le répertoire « /var/tmp/portage/media-libs/evas-9999/work/evas/src/bin »
make[2]: *** [all-recursive] Erreur 1
make[2]: quittant le répertoire « /var/tmp/portage/media-libs/evas-9999/work/evas/src »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /var/tmp/portage/media-libs/evas-9999/work/evas »
make: *** [all] Erreur 2
emake failed

Mes recherche sur le net ne donnant rien, peut-être pourriez-vous me donner un coup de main...

Merci d'avance.
Fab.


Last edited by DidgeriDude on Tue Aug 16, 2011 6:46 pm; edited 2 times in total
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Sun Apr 17, 2011 6:56 pm    Post subject: Reply with quote

Bonjour,
peux-tu nous donner les uses flags avec lesquels tu essaye de compiler evas ?

Visiblement, il y a une dépendance vers la bibliothèque OpenGL qui manque,
quel implémentation as-tu ? (eselect opengl show).
Back to top
View user's profile Send private message
DidgeriDude
Guru
Guru


Joined: 30 Jan 2005
Posts: 347

PostPosted: Sun Apr 17, 2011 7:21 pm    Post subject: Reply with quote

brubru wrote:
Visiblement, il y a une dépendance vers la bibliothèque OpenGL qui manque,
quel implémentation as-tu ? (eselect opengl show).

C'est la conclusion à laquelle je suis arrivé.
J'utilise l'opengl nvidia, mes pilotes sont les legacy ( 173.14.28 ) car ma carte est une GeForce 5900. Je me demande si cela ne viendrait pas de cela... (j'avoue être tombé sur une histoire de legacy sur google, mais le lien me paraissait vraiment ténu avec mon problème...)
Code:
[ebuild  N    ] media-libs/evas-9999  USE="X bmp cache directfb eet fbcon fontconfig gif ico jpeg mmx nls opengl png ppm sdl sse svg threads tiff xcb xpm (-altivec) -bidi -doc -gles -static-libs"

J'ai essayé avec les USE="-directfb -fbcon" mais pas de résultat.
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Mon Apr 18, 2011 9:06 pm    Post subject: Reply with quote

Quel version pour opengl (glxinfo) ?

Sinon, a essayer en vrac:
- compiler evas sans opengl: USE="-opengl", le rendu software est pas si mal !
- passer sous l'implémentation de mesa pour opengl le temps de la compilation:
eselect opengl set xorg-x11
si le problème viens de la libGL de nvidia, cela compilera peut-être, mais ne fonctionnera pas
dès que tu repassera sous l'impl nvidia
- essayer carrement avec le driver nouveau
Back to top
View user's profile Send private message
DidgeriDude
Guru
Guru


Joined: 30 Jan 2005
Posts: 347

PostPosted: Mon Apr 25, 2011 8:50 pm    Post subject: Reply with quote

Merci brubru,
j'ai fait le test, c'est bien les pilotes nvidia qui sont responsables.
Je vais donc voir les différentes options qui s'offrent à moi...
Merci encore.
Back to top
View user's profile Send private message
DidgeriDude
Guru
Guru


Joined: 30 Jan 2005
Posts: 347

PostPosted: Tue Aug 16, 2011 6:45 pm    Post subject: Reply with quote

Je passe ce post en résolu.

J'utilise maintenant les pilotes nouveau. Ma carte graphique (GeForce FX 5900 Ultra) étant (presque) une antiquité, les performances de ces pilotes me satisfont.
J'apprécie donc E17 dans toute sa splendeur ;)

Merci encore à brubu.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum