Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PowerManagement] PC qui ne s'éteint plus
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sat Apr 16, 2011 7:02 am    Post subject: [PowerManagement] PC qui ne s'éteint plus Reply with quote

Depuis quelques temps (et je n'arrive pas à voir avec quelle mise à jour ce serait lié) j'ai le PC qui ne s'éteint pas.

A la fin du processus d'extinction j'entends bien un changement au niveau du bruit (je pense que les disques durs s'éteignent), mais la carte mère reste allumée, je dois presser le bouton on/off pour réellement éteindre le PC.

Je suis une bille dans ces différents mécanismes de PowerManagement, je ne sais plus comment ça marche entre le BIOS, le kernel etc.

Qqu'un pourrait me dire comment vérifier tout cette chaîne ?

Merci !
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Sat Apr 16, 2011 4:53 pm    Post subject: Reply with quote

Dans le configuration de ton noyau Linux tu as bien l'option suivante de sélectionnée ?
Configuration de l'ACPI:
Power management options (ACPI, APM)
    ACPI (Advanced Configuration and Power Interface) Support
        [*] ACPI Support
        [*]   Button
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sun Apr 17, 2011 6:42 pm    Post subject: Reply with quote

Oui je confirme. D'ailleurs si j'appuie sur le bouton POWER, j'ai bien le menu qui arrive.

Au passage, j'ai fait un autre essai, j'ai mis un Live Ubuntu, et là ça fonctionne parfaitement. Donc j'ai pas l'impression que ce soit un paramétrage du BIOS.
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1699
Location: 127.0.0.1

PostPosted: Tue Apr 19, 2011 8:08 am    Post subject: Reply with quote

Donne ton emerge --info et la sortie de :
Code:

# rc-update show

Donne aussi ta config noyau (si possible, un lien vers un fichier). Tu utilises openrc ou toujours l'ancien système ? Rien dans les logs ?
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Tue Apr 19, 2011 8:56 pm    Post subject: Reply with quote

Pour le rc-update :

Code:
coyote guillaume # rc-update show
               acpid |      default                 
                 atd |      default                 
           bluetooth |      default                 
            bootmisc | boot                         
             checkfs | boot                         
           checkroot | boot                         
               clock | boot                         
         consolefont | boot                         
        cpufrequtils |      default                 
               cupsd |      default                 
                dbus |      default                 
             distccd |      default                 
                 gpm |      default                 
                hald |      default                 
            hostname | boot                         
             keymaps | boot                         
          lm_sensors |      default                 
               local |      default nonetwork       
          localmount | boot                         
             modules | boot                         
            net.eth0 |      default                 
              net.lo | boot                         
                 nfs |      default                 
            nfsmount |      default                 
          ntp-client |      default                 
           pipslited |      default                 
           rmnologin | boot                         
                sshd |      default                 
           syslog-ng |      default                 
      udev-postmount |      default                 
             urandom | boot                         
          vixie-cron |      default                 
                 xdm |      default                 


Pour la config du noyau... je suis un peu une bille en matière de "services web 2.0". Tu as un site à me conseiller pour déposer le fichier ?

Pour ta troisième question, vu que j'ai pas compris, j'en déduis que je suis resté à l'ancien système !

Enfin voici un log typique lors de l'extinction (fichier 'messages')

Code:

Apr 16 22:24:29 coyote shutdown[8532]: shutting down for system halt
Apr 16 22:24:30 coyote init: Switching to runlevel: 0
Apr 16 22:24:33 coyote sshd[4592]: Received signal 15; terminating.
Apr 16 22:24:34 coyote rpc.mountd[4405]: Caught signal 15, un-registering and exiting.
Apr 16 22:24:34 coyote kernel: [26932.925772] nfsd: last server has exited, flushing export cache
Apr 16 22:24:34 coyote rpc.statd[4342]: Caught signal 15, un-registering and exiting
Apr 16 22:24:38 coyote acpid: exiting
Apr 16 22:24:39 coyote syslog-ng[2926]: Termination requested via signal, terminating;
Apr 16 22:24:39 coyote syslog-ng[2926]: syslog-ng shutting down; version='3.1.4'
Apr 17 07:58:25 coyote syslog-ng[2925]: syslog-ng starting up; version='3.1.4'

_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1699
Location: 127.0.0.1

PostPosted: Fri Apr 22, 2011 8:11 am    Post subject: Reply with quote

C'est pas grave, colle la ici ta config kernel, c'etait juste histoire d'eviter d'avoir un post de 3 km de long :lol:

Sinon, pour ton problème, je commencerai par essayer de réinstaller certains paquets comme sys-apps/sysvinit et sys-apps/baselayout.
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sun Apr 24, 2011 2:15 am    Post subject: Reply with quote

netfab wrote:
C'est pas grave, colle la ici ta config kernel, c'etait juste histoire d'eviter d'avoir un post de 3 km de long :lol:

Non, je préfère que ça soit posté sur pastebin.com. ;)
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Mon Apr 25, 2011 7:55 am    Post subject: Reply with quote

Ok, allons-y pour pastebin.com : http://pastebin.com/4VYhen81

Je vais tenter de reemerger sys-apps/sysvinit et sys-apps/baselayout on verra bien !
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum