Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde pacchetti bloccati,[RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Fri Apr 01, 2011 2:51 pm    Post subject: kde pacchetti bloccati,[RISOLTO] Reply with quote

salve
sono stato un po impegnato nel lavoro, e non sono stato molto attento a gli aggiornamenti di gentoo, lanciando emerge -DuNav world
mi ha dato il seguente errore , è gia qualche ora che ci giro attorno senza venirne a capo, più che altro
faccio un po di confusione chiendo un aiuto o quache suggerimento per risolvere
grazie
Code:

 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] kde-base/kde-env-4.5.5  USE="(-aqua) (-kdeenablefinal) (-kdeprefix)" 0 kB
[ebuild     UD] www-client/firefox-bin-3.6.15 [3.6.16] USE="startup-notification" LINGUAS="it -af -ar -as -be -bg -bn -bn_BD -bn_IN -ca -cs -cy -da -de -el -en -en_GB -en_US -eo -es -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hr -hu -id -is -ja -ka -kk -kn -ko -ku -lt -lv -mk -ml -mr -nb -nb_NO -nl -nn -nn_NO -oc -or -pa -pa_IN -pl -pt -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh -zh_CN -zh_TW" 10,576 kB
[ebuild  N    ] x11-libs/qt-core-4.7.2-r1  USE="exceptions glib iconv jit qt3support ssl (-aqua) -debug -optimized-qmake -pch -private-headers" 0 kB
[ebuild  N    ] x11-libs/qt-script-4.7.2  USE="exceptions iconv jit (-aqua) -debug -pch -private-headers" 0 kB
[ebuild  N    ] x11-libs/qt-dbus-4.7.2  USE="exceptions (-aqua) -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-gui-4.7.2  USE="accessibility cups dbus exceptions glib gtk mng qt3support tiff (-aqua) -debug -egl -nas -nis -pch -private-headers -raster -trace -xinerama" 0 kB
[ebuild  N    ] x11-libs/qt-svg-4.7.2  USE="accessibility exceptions iconv (-aqua) -debug -pch" 0 kB
[ebuild     U ] dev-python/python-ldap-2.3.13 [2.3.12] USE="ssl -doc -examples -sasl" 0 kB
[ebuild  N    ] x11-libs/qt-core-4.6.3-r1  USE="exceptions glib iconv qt3support ssl (-aqua) -debug -doc -optimized-qmake -pch" 0 kB
[ebuild  N    ] x11-libs/qt-test-4.6.3  USE="exceptions iconv (-aqua) -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-dbus-4.6.3  USE="exceptions (-aqua) -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-xmlpatterns-4.6.3  USE="(-aqua) -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-script-4.6.3  USE="exceptions iconv (-aqua) -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-sql-4.7.2  USE="exceptions iconv mysql qt3support sqlite (-aqua) -debug -firebird -freetds -odbc -pch -postgres" 0 kB
[ebuild   R   ] dev-libs/apr-util-1.3.10  USE="berkdb gdbm ldap mysql* -doc -freetds -odbc -postgres -sqlite -sqlite3" 0 kB
[ebuild  N    ] x11-libs/qt-sql-4.6.3-r2  USE="exceptions iconv mysql qt3support sqlite (-aqua) -debug -firebird -freetds -odbc -pch -postgres" 0 kB
[ebuild   R   ] dev-libs/redland-1.0.10-r1  USE="berkdb mysql* ssl xml -iodbc -odbc -postgres -sqlite" 0 kB
[ebuild  N    ] x11-libs/qt-qt3support-4.7.2  USE="accessibility exceptions kde (-aqua) -debug -pch -phonon" 0 kB
[ebuild     U ] app-office/openoffice-bin-3.3.0 [3.2.1] USE="gnome -java (-kde%*)" LINGUAS="it -ar -as -ast -be_BY% -bg -bn -ca -ca_XV% -cs -da -de -dz -el -en -en_GB -eo -es -et -eu -fi -fr -ga -gl -gu -he% -hi -hu -id -is -ja -ka -km -kn -ko -ku -lt -lv -mk -ml -mr -my -nb -nl -nn -oc -om -or -pa_IN -pl -pt -pt_BR -ro -ru -sh -si -sk -sl -sr -sv -ta -te -th -tr -ug -uk -uz -vi -zh_CN -zh_TW" 0 kB
[ebuild   R   ] x11-libs/cairo-1.10.2-r1  USE="X opengl static-libs svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) (-openvg) -qt4*" 0 kB
[ebuild  N    ] x11-libs/qt-opengl-4.7.2  USE="exceptions qt3support (-aqua) -debug -egl -pch" 0 kB
[ebuild   R   ] dev-util/cmake-2.8.1-r2  USE="ncurses -emacs -qt4* -vim-syntax" 0 kB
[ebuild     U ] www-plugins/adobe-flash-10.2.153.1 [10.2.152.27] USE="-vdpau (-multilib%) (-nspluginwrapper%)" 0 kB
[ebuild     U ] mail-client/thunderbird-bin-3.1.9 [3.1.7] LINGUAS="it -af -ar -be -bg -bn -bn_BD -ca -cs -da -de -el -en -en_GB -en_US -es -es_AR -es_ES -et -eu -fi -fr -fy -fy_NL -ga -ga_IE -he -hu -id -is -ja -ko -lt -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -si -sk -sl -sq -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW" 168 kB
[ebuild  N    ] x11-libs/qt-gui-4.6.3-r2  USE="accessibility cups dbus exceptions glib gtk mng qt3support tiff (-aqua) -debug -nas -nis -pch -raster -trace -xinerama" 0 kB
[ebuild  N    ] x11-libs/qt-qt3support-4.6.3  USE="accessibility exceptions kde (-aqua) -debug -pch -phonon" 0 kB
[ebuild     U ] x11-libs/pango-1.28.3-r1 [1.28.3] USE="X -debug -doc (-introspection) -test" 0 kB
[ebuild  N    ] kde-base/oxygen-icons-4.5.5  USE="(-aqua) (-kdeenablefinal) (-kdeprefix)" 0 kB
[ebuild   R   ] media-plugins/gst-plugins-meta-0.10-r4  USE="X a52 alsa dvd ffmpeg flac mad mpeg ogg theora vorbis xv -dvb -esd -lame -mythtv -oss -pulseaudio -taglib -v4l2 (-v4l%)" 0 kB
[ebuild     U ] xfce-base/xfce4-panel-4.8.2 [4.8.0] USE="-debug" 1,153 kB
[ebuild     U ] x11-terms/terminal-0.4.6 [0.4.5] USE="dbus -debug" 1,541 kB
[ebuild     U ] xfce-extra/xfce4-battery-plugin-1.0.0 [0.5.1] USE="-debug" 350 kB
[ebuild     U ] xfce-extra/xfce4-sensors-plugin-1.0.0-r1 [1.0.0] USE="acpi -debug -hddtemp -libnotify -lm_sensors" 0 kB
[ebuild   R   ] dev-libs/cyrus-sasl-2.1.23-r1  USE="berkdb crypt gdbm kerberos ldap mysql* pam ssl -authdaemond -java -ntlm_unsupported_patch -postgres -sample -sqlite -srp -urandom" 0 kB
[ebuild  N    ] virtual/mta-0  0 kB
[ebuild   R   ] dev-lang/php-5.3.5  USE="apache2 berkdb bzip2 cli crypt ctype exif fileinfo filter gd gdbm hash iconv ipv6 json kerberos ldap mysql* mysqli nls phar posix readline session simplexml spell ssl tokenizer truetype unicode xml zlib -adabas -bcmath -birdstep -calendar -cdb -cgi -cjk -curl -curlwrappers -db2 -dbmaker -debug -doc -embed -empress -empress-bcs -enchant -esoob -firebird -flatfile -fpm -frontbase -ftp -gd-external -gmp -imap -inifile -interbase -intl -iodbc -kolab -ldap-sasl -libedit -mhash -mssql -mysqlnd -oci8 -oci8-instant-client -odbc* -pcntl -pdo -pic -postgres -qdbm -recode -sapdb -sharedext -sharedmem -snmp -soap -sockets -solid -sqlite -sqlite3 -suhosin -sybase-ct -sysvipc -threads -tidy -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -zip" 0 kB
[ebuild     U ] app-crypt/gnupg-2.0.17 [2.0.16-r1] USE="bzip2 ldap nls -adns -caps -doc -openct -pcsc-lite (-selinux) -smartcard -static" 3,904 kB
[ebuild     U ] sys-auth/polkit-0.101 [0.100] USE="gtk kde nls pam -debug -doc -examples (-introspection)" 1,042 kB
[ebuild     U ] gnome-extra/polkit-gnome-0.101-r1 [0.99] USE="-doc -examples (-introspection)" 399 kB
[ebuild  N    ] sys-auth/polkit-qt-0.99.0  USE="-debug -examples" 0 kB
[ebuild   R   ] net-print/cups-1.4.6  USE="X acl dbus gnutls jpeg kerberos ldap pam perl php* png python ssl static-libs threads tiff usb -debug -java -samba -slp -xinetd" LINGUAS="it -da -de -es -eu -fi -fr -id -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW" 0 kB
[ebuild     U ] www-client/chromium-10.0.648.204 [9.0.597.107] USE="cups gecko-mediaplayer gnome -gnome-keyring -test% (-system-v8%)" 140,806 kB
[ebuild  N    ] media-libs/phonon-4.4.4  USE="gstreamer vlc -debug -pulseaudio -xine" 0 kB
[ebuild  N    ] x11-libs/qt-webkit-4.6.3-r1  USE="dbus exceptions kde (-aqua) -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qtscriptgenerator-0.1.0  USE="kde -debug" 0 kB
[ebuild  N    ] kde-base/kdelibs-4.5.5  USE="acl alsa bzip2 fam handbook kerberos mmx nls opengl policykit spell sse ssl -3dnow (-altivec) (-aqua) -bindist -debug -doc -jpeg2k (-kdeenablefinal) (-kdeprefix) -lzma -openexr -semantic-desktop -sse2 -test -zeroconf" 0 kB
[ebuild  N    ] sys-auth/polkit-kde-0.95.1-r1  USE="(-aqua) -debug (-kdeenablefinal)" LINGUAS="-da -en_GB -et -gl -lt -nl -pt -pt_BR -sk -sv -uk -zh_TW" 0 kB
[ebuild  N    ] kde-base/khelpcenter-4.5.5  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB
[ebuild  N    ] kde-base/phonon-kde-4.5.5  USE="alsa (-aqua) -debug (-kdeenablefinal) (-kdeprefix) -xine" 0 kB
[ebuild   R   ] dev-vcs/subversion-1.6.16  USE="apache2* berkdb dso kde nls perl python webdav-neon -bash-completion -ctypes-python -debug -doc -emacs -extras -gnome-keyring -java -ruby -sasl -test -vim-syntax -webdav-serf" 0 kB
[ebuild     U ] net-wireless/bluez-4.87 [4.82] USE="alsa consolekit cups gstreamer usb -attrib -caps -debug -health -maemo6 -old-daemons -pcmcia -pnat -test-programs" 3,364 kB
[ebuild I   U ] net-wireless/broadcom-sta-5.100.82.38 [5.60.48.36-r1] 1,168 kB
[ebuild  NS   ] sys-kernel/vanilla-sources-2.6.36.4 [2.6.35.8, 2.6.36.2] USE="-build -deblob -symlink" 0 kB
[ebuild   R   ] media-video/cheese-2.32.0  USE="-doc (-v4l%)" 0 kB
[ebuild     U ] x11-drivers/xf86-input-keyboard-1.6.0 [1.5.0] 0 kB
[ebuild     U ] x11-drivers/xf86-input-mouse-1.7.0 [1.6.0] 0 kB
[ebuild   R   ] app-mobilephone/gnokii-0.6.29  USE="X bluetooth mysql* nls usb -debug -ical -irda -postgres -sms" LINGUAS="it -cs -de -et -fi -fr -nl -pl -pt -sk -sl -sv -zh_CN" 0 kB
[ebuild     U ] media-sound/clementine-0.6-r2 [0.5.3] USE="dbus%* lastfm%* udev%* (-ayatana) -ios% -ipod -mtp -projectm -wiimote (-iphone%)" LINGUAS="it -ar -be% -bg -br% -ca -cs -cy% -da -de -el -en_CA -en_GB -eo% -es -et% -eu% -fi -fr -gl -he% -hi% -hu -ja% -kk -lt -nb -nl -oc -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -tr -uk -zh_CN -zh_TW" 5,480 kB
[ebuild   R   ] sys-power/upower-0.9.8  USE="-debug -doc (-introspection) -ios% (-ipod%)" 0 kB
[ebuild     U ] net-libs/xulrunner-1.9.2.15 [1.9.2.13] USE="alsa dbus gnome ipc startup-notification -custom-optimization -debug -java -libnotify -system-sqlite -wifi" 34,874 kB
[ebuild   R   ] app-office/mdbtools-0.6_pre2-r2  USE="gnome static-libs -odbc*" 0 kB
[ebuild   R   ] media-video/vlc-1.1.7  USE="X a52 aac aalib alsa bidi cdda dbus dts dvd ffmpeg flac gcrypt gnome gnutls httpd jack kde live matroska mmx mp3 mpeg ncurses nsplugin ogg opengl png sdl sse stream svg svga theora truetype udev vlm vorbis x264 xcb xml xv (-altivec) -atmo -avahi -cddb -dc1394 -debug -dirac -directfb -dvb -fbcon -fluidsynth -fontconfig -ggi -gme -id3tag -ieee1394 -kate -libass -libcaca -libnotify -libproxy -libtiger -libv4l -libv4l2 -lirc -lua -modplug -mtp -musepack -optimisememory -oss -projectm -pulseaudio -pvr -qt4* -remoteosd -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -skins -speex -sqlite -taglib -twolame -upnp -v4l -v4l2 -vaapi -vcdx -win32codecs -wma-fixed -xosd -zvbi" 5 kB
[ebuild   R   ] gnome-base/gvfs-1.6.6-r1  USE="bluetooth gdu gnome http udev -archive -avahi -bash-completion -cdda -doc -fuse -gnome-keyring -gphoto2 (-hal) -ios% -samba (-iphone%)" 0 kB
[ebuild     U ] xfce-base/thunar-1.2.1 [1.2.0] USE="dbus exif pcre startup-notification udev -debug -libnotify -test" XFCE_PLUGINS="trash" 4,084 kB
[ebuild     U ] xfce-extra/thunar-archive-plugin-0.3.0 [0.2.4-r2] USE="-debug" 310 kB
[ebuild   R   ] gnome-base/gnome-applets-2.32.1.1  USE="gnome gstreamer ipv6 networkmanager policykit (-battstat%) (-hal%)" 0 kB
[ebuild   R   ] x11-apps/fusion-icon-0.1-r1  USE="gtk -qt4*" 0 kB
[blocks B     ] >x11-libs/qt-svg-4.6.3-r9999 (">x11-libs/qt-svg-4.6.3-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3)
[blocks B     ] <x11-libs/qt-webkit-4.7.2 ("<x11-libs/qt-webkit-4.7.2" is blocking x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-sql-4.7.2, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-script-4.7.2)
[blocks B     ] <x11-libs/qt-test-4.7.2 ("<x11-libs/qt-test-4.7.2" is blocking x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-sql-4.7.2, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-script-4.7.2)
[blocks B     ] >x11-libs/qt-core-4.6.3-r9999 (">x11-libs/qt-core-4.6.3-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3)
[blocks B     ] >x11-libs/qt-opengl-4.6.3-r9999 (">x11-libs/qt-opengl-4.6.3-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3)
[blocks B     ] >x11-libs/qt-sql-4.6.3-r9999 (">x11-libs/qt-sql-4.6.3-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3)
[blocks B     ] <x11-libs/qt-xmlpatterns-4.7.2 ("<x11-libs/qt-xmlpatterns-4.7.2" is blocking x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-sql-4.7.2, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-script-4.7.2)
[blocks B     ] >=sys-auth/polkit-qt-0.99 (">=sys-auth/polkit-qt-0.99" is blocking sys-auth/polkit-kde-0.95.1-r1)
[blocks B     ] >x11-libs/qt-script-4.6.3-r9999 (">x11-libs/qt-script-4.6.3-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3)
[blocks B     ] >x11-libs/qt-gui-4.6.3-r9999 (">x11-libs/qt-gui-4.6.3-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3)
[blocks B     ] >x11-libs/qt-qt3support-4.6.3-r9999 (">x11-libs/qt-qt3support-4.6.3-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3)
[blocks B     ] >x11-libs/qt-dbus-4.6.3-r9999 (">x11-libs/qt-dbus-4.6.3-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3)

Total: 67 packages (21 upgrades, 1 downgrade, 27 new, 1 in new slot, 17 reinstalls, 1 interactive), Size of downloads: 209,218 kB
Conflict: 12 blocks (12 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-auth/polkit-kde-0.95.1-r1, ebuild scheduled for merge) pulled in by
    >=sys-auth/polkit-kde-0.95.1 required by (kde-base/kdelibs-4.5.5, ebuild scheduled for merge)
    sys-auth/polkit-kde required by (sys-auth/polkit-0.101, ebuild scheduled for merge)

  (x11-libs/qt-opengl-4.7.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-opengl-4.6.0:4 required by (media-libs/phonon-gstreamer-4.4.4, installed)
    >=x11-libs/qt-opengl-4.6.3:4 required by (kde-base/kdelibs-4.5.5, ebuild scheduled for merge)
    >=x11-libs/qt-opengl-4.6.3:4 required by (kde-base/kwin-4.5.5, installed)
    (and 2 more)

  (x11-libs/qt-core-4.7.2-r1, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-core-4.6.3:4[qt3support,ssl] required by (kde-base/solid-runtime-4.5.5, installed)
    >=x11-libs/qt-core-4.6.3:4[qt3support,ssl] required by (kde-base/kwin-4.5.5, installed)
    x11-libs/qt-core:4 required by (app-misc/strigi-0.7.1, installed)
    (and 34 more)

  (x11-libs/qt-dbus-4.7.2, ebuild scheduled for merge) pulled in by
    x11-libs/qt-dbus:4 required by (net-im/skype-2.1.0.81, installed)
    >=x11-libs/qt-dbus-4.6.0:4 required by (media-libs/phonon-vlc-0.3.2, installed)
    x11-libs/qt-dbus:4 required by (app-misc/strigi-0.7.1, installed)
    (and 7 more)

  (x11-libs/qt-qt3support-4.7.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (kde-base/kwin-4.5.5, installed)
    >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (kde-base/liboxygenstyle-4.5.5, installed)
    >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] required by (kde-base/kdebase-kioslaves-4.5.5, installed)
    (and 17 more)

  (x11-libs/qt-svg-4.7.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-svg-4.6.3:4 required by (kde-base/kdialog-4.5.5, installed)
    >=x11-libs/qt-svg-4.6.0:4 required by (net-irc/konversation-1.3.1, installed)
    >=x11-libs/qt-svg-4.6.0:4 required by (x11-libs/compizconfig-backend-kconfig4-0.8.4, installed)
    (and 17 more)

  (sys-auth/polkit-qt-0.99.0, ebuild scheduled for merge) pulled in by
    sys-auth/polkit-qt required by (kde-base/kdelibs-4.5.5, ebuild scheduled for merge)
    >=sys-auth/polkit-qt-0.95.1 required by (sys-auth/polkit-kde-0.95.1-r1, ebuild scheduled for merge)

  (x11-libs/qt-xmlpatterns-4.6.3, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-xmlpatterns-4.6.3[-aqua,-debug] required by (x11-libs/qt-webkit-4.6.3-r1, ebuild scheduled for merge)
    x11-libs/qt-xmlpatterns:4 required by (x11-libs/qtscriptgenerator-0.1.0, ebuild scheduled for merge)

  (x11-libs/qt-test-4.6.3, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-test-4.6.3:4 required by (kde-base/phonon-kde-4.5.5, ebuild scheduled for merge)
    x11-libs/qt-test:4 required by (media-sound/clementine-0.6-r2, ebuild scheduled for merge)
    >=x11-libs/qt-test-4.6.0:4 required by (net-p2p/ktorrent-4.0.5, installed)
    (and 18 more)

  (x11-libs/qt-webkit-4.6.3-r1, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-webkit-4.6.3:4[kde] required by (kde-base/kdelibs-4.5.5, ebuild scheduled for merge)
    x11-libs/qt-webkit:4 required by (x11-libs/qtscriptgenerator-0.1.0, ebuild scheduled for merge)

  (x11-libs/qt-script-4.7.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-script-4.6.3:4 required by (kde-base/kwalletd-4.5.5, installed)
    x11-libs/qt-script required by (media-sound/amarok-2.3.2-r1, installed)
    >=x11-libs/qt-script-4.6.0:4 required by (x11-libs/compizconfig-backend-kconfig4-0.8.4, installed)
    (and 19 more)

  (x11-libs/qt-sql-4.7.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-sql-4.6.3:4[qt3support] required by (kde-base/kwalletd-4.5.5, installed)
    >=x11-libs/qt-sql-4.6.3:4[qt3support] required by (kde-base/liboxygenstyle-4.5.5, installed)
    >=x11-libs/qt-sql-4.6.3:4[qt3support] required by (kde-base/kdepimlibs-4.5.5, installed)
    (and 20 more)

  (x11-libs/qt-gui-4.7.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-gui-4.5:4[dbus] required by (media-sound/clementine-0.6-r2, ebuild scheduled for merge)
    >=x11-libs/qt-gui-4.6.0:4[accessibility,dbus] required by (x11-libs/compizconfig-backend-kconfig4-0.8.4, installed)
    >=x11-libs/qt-gui-4.6.3:4[accessibility,dbus] required by (kde-base/khelpcenter-4.5.5, ebuild scheduled for merge)
    (and 32 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org


Last edited by mattylux on Sat Apr 09, 2011 12:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri Apr 01, 2011 3:01 pm    Post subject: Reply with quote

Prova a controllare che ogni pacchetto x11-libs/qt abbia almeno una versione del 4.7.2 smascherata. Se anche uno solo non ce l'ha allora viene proposto il downgrade di tutte con conseguenti (possibili) blocchi.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Fri Apr 01, 2011 5:42 pm    Post subject: Reply with quote

sono riuscito a sbloccare la situazione pero c'e questa cosa che firefox mi sta dando

Code:
>>> Emerging (2 of 64) www-client/firefox-bin-3.6.15
>>> Downloading 'http://releases.mozilla.org/pub/mozilla.org/firefox/releases//3.6.15/linux-i686/en-US/firefox-3.6.15.tar.bz2'
--2011-04-01 19:42:33--  http://releases.mozilla.org/pub/mozilla.org/firefox/releases//3.6.15/linux-i686/en-US/firefox-3.6.15.tar.bz2
Risoluzione di releases.mozilla.org... 129.101.198.59, 131.188.12.212, 155.98.64.83, ...
Connessione a releases.mozilla.org|129.101.198.59|:80... connesso.
HTTP richiesta inviata, in attesa di risposta... 404 Not Found
2011-04-01 19:42:34 ERRORE 404: Not Found.

!!! Couldn't download 'firefox-3.6.15.tar.bz2'. Aborting.
 * Fetch failed for 'www-client/firefox-bin-3.6.15', Log file:
 *  '/var/tmp/portage/www-client/firefox-bin-3.6.15/temp/build.log'

>>> Failed to emerge www-client/firefox-bin-3.6.15, Log file:

>>>  '/var/tmp/portage/www-client/firefox-bin-3.6.15/temp/build.log'

 * Messages for package www-client/firefox-bin-3.6.15:

 * Fetch failed for 'www-client/firefox-bin-3.6.15', Log file:
 *  '/var/tmp/portage/www-client/firefox-bin-3.6.15/temp/build.log'

 * GNU info directory index is up-to-date.

 * IMPORTANT: 10 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.


non riesco a capire il perchè, pero se installo la verione 3.6.16 da locale compila senza problemi
_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Fri Apr 01, 2011 9:08 pm    Post subject: Reply with quote

molto semplice, quel bin viene scaricato sul sito di mozilla che avrà cambiato/rimosso il link
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Fri Apr 01, 2011 9:29 pm    Post subject: Reply with quote

avevo intuito che non ci stava piu il link del download di firefox comunque non è un problema
il problema vero e proprio e questo nella compilazione del gcc

configure: error: C compiler cannot create executables
See `config.log' for more details.

_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Fri Apr 01, 2011 9:57 pm    Post subject: Reply with quote

mattylux wrote:
avevo intuito che non ci stava piu il link del download di firefox comunque non è un problema
il problema vero e proprio e questo nella compilazione del gcc

configure: error: C compiler cannot create executables
See `config.log' for more details.


normalmente quanto mi capita io risolvo banalmente così:
Code:
gcc-config -l
 [1] x86_64-pc-linux-gnu-4.4.5

Code:
gcc-config x86_64-pc-linux-gnu-4.4.5


cioè, spesso non è inserito il profilo corretto.
_________________
Darkman
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sat Apr 02, 2011 6:39 am    Post subject: Reply with quote

ok grazie provo e vi faccio sapere, dovro stare più attento nelle prossime volte nell'installare pacchetti che non stanno in tree.
certi eperimenti possono essere nocivi
_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sat Apr 02, 2011 9:56 am    Post subject: Reply with quote

il problema persiste

comunque questo è il mio

gcc-config -l
[1] i686-pc-linux-gnu-4.4.5 *

Code:
  gcc-config i686-pc-linux-gnu-4.4.5



Code:

Calculating dependencies... done!
[ebuild     U ] dev-lang/nasm-2.09.04 [2.08.02] USE="-doc" 0 kB
[ebuild   R   ] dev-db/sqlite-3.7.5  USE="extensions fts3 readline threadsafe -debug -doc -icu* -secure-delete -soundex -tcl -test -unlock-notify" 0 kB
[ebuild   R   ] media-video/recordmydesktop-0.3.8.1-r4  USE="alsa -jack*" 0 kB
[ebuild     U ] dev-libs/glib-2.28.5 [2.28.4] USE="fam static-libs -debug -doc (-introspection) (-selinux) -test -xattr" 0 kB
[ebuild     U ] app-office/openoffice-bin-3.3.0 [3.2.1] USE="gnome -java (-kde%*)" LINGUAS="it -ar -as -ast -be_BY% -bg -bn -ca -ca_XV% -cs -da -de -dz -el -en -en_GB -eo -es -et -eu -fi -fr -ga -gl -gu -he% -hi -hu -id -is -ja -ka -km -kn -ko -ku -lt -lv -mk -ml -mr -my -nb -nl -nn -oc -om -or -pa_IN -pl -pt -pt_BR -ro -ru -sh -si -sk -sl -sr -sv -ta -te -th -tr -ug -uk -uz -vi -zh_CN -zh_TW" 0 kB
[ebuild   R   ] net-libs/gupnp-0.13.4  USE="(-introspection) -networkmanager*" 0 kB
[ebuild   R   ] net-nds/openldap-2.4.24  USE="berkdb crypt gnutls ipv6 kerberos minimal perl ssl tcpd -cxx -debug -experimental -icu* -iodbc -odbc -overlays -samba -sasl (-selinux) -slp -smbkrb5passwd -syslog" 0 kB
[ebuild   R   ] dev-util/cmake-2.8.1-r2  USE="ncurses -emacs -qt4* -vim-syntax" 0 kB
[ebuild     U ] www-plugins/adobe-flash-10.2.153.1 [10.2.152.27] USE="-vdpau (-multilib%) (-nspluginwrapper%)" 0 kB
[ebuild     U ] mail-client/thunderbird-bin-3.1.9 [3.1.7] LINGUAS="it -af -ar -be -bg -bn -bn_BD -ca -cs -da -de -el -en -en_GB -en_US -es -es_AR -es_ES -et -eu -fi -fr -fy -fy_NL -ga -ga_IE -he -hu -id -is -ja -ko -lt -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -si -sk -sl -sq -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW" 0 kB
[ebuild     U ] dev-python/python-ldap-2.3.13 [2.3.12] USE="ssl -doc -examples -sasl" 0 kB
[ebuild   R   ] x11-libs/cairo-1.10.2-r1  USE="X opengl static-libs svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) (-openvg) -qt4*" 0 kB
[ebuild     U ] x11-libs/pango-1.28.3-r1 [1.28.3] USE="X -debug -doc (-introspection) -test" 0 kB
[ebuild   R   ] media-video/ffmpeg-0.6_p25767  USE="3dnow 3dnowext X alsa bzip2 encode hardcoded-tables mmx mmxext mp3 sdl ssse3 static-libs theora threads vorbis x264 xvid zlib (-altivec) -amr -bindist -cpudetection -custom-cflags -debug -dirac -doc -faac -frei0r -gsm -ieee1394 -jack* -jpeg2k -network -oss -pic -qt-faststart -rtmp -schroedinger -speex -test -v4l -v4l2 -vaapi -vdpau -vpx" VIDEO_CARDS="-nvidia" 0 kB
[ebuild   R   ] media-sound/mpg123-1.12.1  USE="alsa ipv6 mmx sdl sse -3dnow -3dnowext (-altivec) -jack* -nas -oss -portaudio -pulseaudio" 0 kB
[ebuild   R   ] media-video/mplayer-1.0_rc4_p20101114  USE="X a52 aalib alsa ass cddb cdio dirac dts dv dvd dvdnav enca encode faac faad gif iconv ipv6 jpeg live mad mmx mng mp3 network opengl osdmenu png quicktime rar real rtc schroedinger sdl shm speex sse theora toolame tremor truetype twolame unicode vorbis x264 xscreensaver xv xvid -3dnow -3dnowext (-altivec) -amr (-aqua) -bidi -bindist -bl (-bluray) -bs2b -cdparanoia -cpudetection -custom-cpuopts -debug -dga -directfb -doc -dvb -dxr3 -esd -fbcon -ftp -ggi -gsm -jack* -joystick -jpeg2k -ladspa -libcaca -libmpeg2 -lirc -lzo -md5sum -mmxext -mpg123 -nas -nut -openal -oss -pnm -pulseaudio -pvr -radio -rtmp -samba -sse2 -ssse3 -tga -v4l -v4l2 -vdpau -vidix -vpx -win32codecs -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx -vesa" 0 kB
[ebuild   R   ] media-video/mjpegtools-1.9.0-r1  USE="dv gtk mmx png sdl -dga -quicktime -v4l -yv12 (-X%*)" 0 kB
[ebuild   R   ] media-plugins/gst-plugins-meta-0.10-r4  USE="X a52 alsa dvd ffmpeg flac mad mpeg ogg theora vorbis xv -dvb -esd -lame -mythtv -oss -pulseaudio -taglib -v4l2 (-v4l%)" 0 kB
[ebuild     U ] xfce-base/xfce4-panel-4.8.2 [4.8.0] USE="-debug" 0 kB
[ebuild     U ] x11-terms/terminal-0.4.6 [0.4.5] USE="dbus -debug" 0 kB
[ebuild   R   ] www-client/opera-11.01.1190  USE="gstreamer gtk -kde*" LINGUAS="it -be -bg -cs -da -de -el -en_GB -es_ES -es_LA -et -fi -fr -fr_CA -fy -hi -hr -hu -id -ja -ka -ko -lt -mk -nb -nl -nn -pl -pt -pt_BR -ro -ru -sk -sr -sv -ta -te -tr -uk -vi -zh_CN -zh_HK -zh_TW" 0 kB
[ebuild     U ] xfce-extra/xfce4-battery-plugin-1.0.0 [0.5.1] USE="-debug" 0 kB
[ebuild  N    ] virtual/mta-0  0 kB
[ebuild     U ] app-crypt/gnupg-2.0.17 [2.0.16-r1] USE="bzip2 ldap nls -adns -caps -doc -openct -pcsc-lite (-selinux) -smartcard -static" 0 kB
[ebuild  N    ] x11-libs/qt-core-4.7.2-r1  USE="exceptions glib iconv jit qt3support ssl (-aqua) -debug -optimized-qmake -pch -private-headers" 0 kB
[ebuild  N    ] x11-libs/qt-script-4.7.2  USE="exceptions iconv jit (-aqua) -debug -pch -private-headers" 0 kB
[ebuild  N    ] x11-libs/qt-dbus-4.7.2  USE="exceptions (-aqua) -debug -pch" 0 kB
[ebuild  N    ] x11-libs/qt-gui-4.7.2  USE="accessibility cups dbus exceptions glib gtk mng qt3support tiff (-aqua) -debug -egl -nas -nis -pch -private-headers -raster -trace -xinerama" 0 kB
[ebuild     UD] dev-libs/libdbusmenu-qt-0.6.2 [0.7.0] USE="-debug -test" 0 kB
[ebuild  N    ] x11-libs/qt-opengl-4.7.2  USE="exceptions qt3support (-aqua) -debug -egl -pch" 0 kB
[ebuild     U ] sys-auth/polkit-0.101 [0.100] USE="gtk nls pam -debug -doc -examples (-introspection) -kde*" 0 kB
[ebuild     U ] gnome-extra/polkit-gnome-0.101-r1 [0.99] USE="-doc -examples (-introspection)" 0 kB
[ebuild   R   ] sys-auth/pambase-20101024  USE="consolekit cracklib gnome-keyring* sha512 -debug -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)" 0 kB
[ebuild I   U ] net-wireless/broadcom-sta-5.100.82.38 [5.60.48.36-r1] 0 kB
[ebuild  NS   ] sys-kernel/vanilla-sources-2.6.36.4 [2.6.35.8, 2.6.36.2] USE="-build -deblob -symlink" 0 kB
[ebuild   R   ] media-video/cheese-2.32.0  USE="-doc (-v4l%)" 0 kB
[ebuild   R   ] sys-power/pm-utils-1.4.1  USE="alsa -debug -networkmanager* -ntp" VIDEO_CARDS="intel -radeon" 0 kB
[ebuild     U ] x11-drivers/xf86-input-keyboard-1.6.0 [1.5.0] 0 kB
[ebuild     U ] x11-drivers/xf86-input-mouse-1.7.0 [1.6.0] 0 kB
[ebuild   R   ] sys-block/parted-2.3  USE="debug* device-mapper nls readline (-selinux)" 0 kB
[ebuild   R   ] sys-power/upower-0.9.8  USE="-debug -doc (-introspection) -ios% (-ipod%)" 0 kB
[ebuild   R   ] dev-libs/apr-util-1.3.10  USE="berkdb gdbm ldap mysql* -doc -freetds -odbc -postgres -sqlite -sqlite3" 0 kB
[ebuild  N    ] x11-libs/qt-sql-4.7.2  USE="exceptions iconv mysql qt3support sqlite (-aqua) -debug -firebird -freetds -odbc -pch -postgres" 0 kB
[ebuild   R   ] dev-libs/cyrus-sasl-2.1.23-r1  USE="berkdb crypt gdbm kerberos ldap mysql* pam ssl -authdaemond -java -ntlm_unsupported_patch -postgres -sample -sqlite -srp -urandom" 0 kB
[ebuild  N    ] x11-libs/qt-qt3support-4.7.2  USE="accessibility exceptions kde (-aqua) -debug -pch -phonon" 0 kB
[ebuild   R   ] dev-lang/php-5.3.5  USE="apache2 berkdb bzip2 cli crypt ctype exif fileinfo filter gd gdbm hash iconv ipv6 json kerberos ldap mysql* mysqli nls phar posix readline session simplexml spell ssl tokenizer truetype unicode xml zlib -adabas -bcmath -birdstep -calendar -cdb -cgi -cjk -curl -curlwrappers -db2 -dbmaker -debug -doc -embed -empress -empress-bcs -enchant -esoob -firebird -flatfile -fpm -frontbase -ftp -gd-external -gmp -imap -inifile -interbase -intl -iodbc -kolab -ldap-sasl -libedit -mhash -mssql -mysqlnd -oci8 -oci8-instant-client -odbc* -pcntl -pdo -pic -postgres -qdbm -recode -sapdb -sharedext -sharedmem -snmp -soap -sockets -solid -sqlite -sqlite3 -suhosin -sybase-ct -sysvipc -threads -tidy -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -zip" 0 kB
[ebuild   R   ] net-print/cups-1.4.6  USE="X acl dbus gnutls jpeg kerberos ldap pam perl php* png python ssl static-libs threads tiff usb -debug -java -samba -slp -xinetd" LINGUAS="it -da -de -es -eu -fi -fr -id -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW" 0 kB
[ebuild     U ] net-wireless/bluez-4.87 [4.82] USE="alsa consolekit cups gstreamer usb -attrib -caps -debug -health -maemo6 -old-daemons -pcmcia -pnat -test-programs" 0 kB
[ebuild     U ] www-client/chromium-10.0.648.204 [9.0.597.107] USE="cups gecko-mediaplayer gnome gnome-keyring* -test% (-system-v8%)" 0 kB
[ebuild   R   ] app-emulation/wine-1.2.1  USE="X alsa cups dbus gecko jpeg lcms ldap mp3 ncurses opengl oss perl png ssl threads truetype win32 xml -capi -custom-cflags -esd -fontconfig -gnutls -gphoto2 -gsm (-hal) -jack* -nas -openal -pulseaudio -samba -scanner -test (-win64) -xcomposite -xinerama" 0 kB
[ebuild   R   ] app-mobilephone/gnokii-0.6.29  USE="X bluetooth mysql* nls usb -debug -ical -irda -postgres -sms" LINGUAS="it -cs -de -et -fi -fr -nl -pl -pt -sk -sl -sv -zh_CN" 0 kB
[ebuild   R   ] gnome-base/gnome-settings-daemon-2.32.1  USE="libnotify* policykit -debug -pulseaudio -smartcard" 0 kB
[ebuild  N    ] dev-python/notify-python-0.1.1-r1  0 kB
[ebuild   R   ] gnome-extra/zenity-2.32.1  USE="compat libnotify* -debug" 0 kB
[ebuild     U ] xfce-extra/xfce4-sensors-plugin-1.0.0-r1 [1.0.0] USE="acpi libnotify* -debug -hddtemp -lm_sensors" 0 kB
[ebuild   R   ] net-irc/xchat-2.8.8-r1  USE="dbus gtk ipv6 libnotify* mmx nls perl python spell ssl -debug -fastscroll -ntlm -tcl -xchatdccserver" 0 kB
[ebuild   R   ] gnome-extra/gnome-screensaver-2.30.2  USE="branding libnotify* opengl pam -debug -doc" 0 kB
[ebuild   R   ] net-misc/vino-2.32.1  USE="crypt gnome-keyring* ipv6 jpeg libnotify* ssl telepathy zlib -avahi -debug -networkmanager*" 0 kB
[ebuild   R   ] app-crypt/seahorse-2.32.0  USE="ldap libnotify* -avahi -debug -doc (-introspection) -test" 0 kB
[ebuild   R   ] sys-apps/gnome-disk-utility-2.32.0-r1  USE="gnome-keyring* nautilus* -avahi -doc -fat -remote-access" 0 kB
[ebuild   R   ] app-arch/file-roller-2.32.1  USE="nautilus*" 0 kB
[ebuild   R   ] app-text/evince-2.32.0-r1  USE="dbus djvu gnome gnome-keyring* nautilus* tiff -debug -doc -dvi (-introspection) -t1lib" 0 kB
[ebuild     U ] net-libs/xulrunner-1.9.2.15 [1.9.2.13] USE="alsa dbus gnome ipc libnotify* startup-notification -custom-optimization -debug -java -system-sqlite -wifi" 0 kB
[ebuild   R   ] net-misc/wicd-1.7.0  USE="X gtk libnotify* ncurses nls pm-utils (-ioctl)" 0 kB
[ebuild   R   ] app-office/mdbtools-0.6_pre2-r2  USE="gnome static-libs -odbc*" 0 kB
[ebuild   R   ] gnome-base/gdm-2.20.11  USE="branding consolekit gnome-keyring* ipv6 pam tcpd -accessibility -afs -debug -dmx -remote (-selinux) -xinerama" 0 kB
[ebuild   R   ] net-libs/libproxy-0.4.6  USE="gnome perl python xulrunner -kde* -mono -networkmanager* -test -webkit" 0 kB
[ebuild   R   ] media-video/vlc-1.1.7  USE="X a52 aac aalib alsa bidi cdda dbus dts dvd ffmpeg flac gcrypt gnome gnutls httpd libnotify* live matroska mmx mp3 mpeg ncurses nsplugin ogg opengl png sdl sse stream svg svga theora truetype udev vlm vorbis x264 xcb xml xv (-altivec) -atmo -avahi -cddb -dc1394 -debug -dirac -directfb -dvb -fbcon -fluidsynth -fontconfig -ggi -gme -id3tag -ieee1394 -jack* -kate -kde* -libass -libcaca -libproxy -libtiger -libv4l -libv4l2 -lirc -lua -modplug -mtp -musepack -optimisememory -oss -projectm -pulseaudio -pvr -qt4* -remoteosd -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -skins -speex -sqlite -taglib -twolame -upnp -v4l -v4l2 -vaapi -vcdx -win32codecs -wma-fixed -xosd -zvbi" 0 kB
[ebuild   R   ] gnome-base/gvfs-1.6.6-r1  USE="bluetooth gdu gnome gnome-keyring* http udev -archive -avahi -bash-completion -cdda -doc -fuse -gphoto2 (-hal) -ios% -samba (-iphone%)" 0 kB
[ebuild   R   ] www-client/epiphany-2.30.6  USE="nss -avahi -debug -doc (-introspection) -networkmanager* -test" 0 kB
[ebuild   R   ] gnome-extra/evolution-data-server-2.32.2  USE="gnome-keyring* ipv6 kerberos ldap ssl weather -doc -test" 0 kB
[ebuild   R   ] app-cdr/brasero-2.32.1  USE="cdr css libburn nautilus* -doc (-introspection) -playlist -test" 0 kB
[ebuild     U ] xfce-base/thunar-1.2.1 [1.2.0] USE="dbus exif libnotify* pcre startup-notification udev -debug -test" XFCE_PLUGINS="trash" 0 kB
[ebuild   R   ] media-video/totem-2.32.0  USE="bluetooth iplayer nautilus* nsplugin python youtube -debug -doc -galago -lirc (-tracker) -upnp" 0 kB
[ebuild   R   ] gnome-base/gnome-panel-2.32.1-r1  USE="bonobo eds* -doc (-introspection) -networkmanager*" 0 kB
[ebuild   R   ] gnome-base/gnome-control-center-2.32.1  USE="eds* -debug" 0 kB
[ebuild     U ] dev-python/evolution-python-2.32.0 [2.30.2] 0 kB
[ebuild  N    ] gnome-extra/nautilus-sendto-2.32.0  USE="cdr mail -debug -doc -gajim -pidgin -upnp" 0 kB
[ebuild   R   ] app-mobilephone/obexd-0.37  USE="eds* usb -debug -nokia -server" 0 kB
[ebuild   R   ] media-sound/rhythmbox-0.12.8-r1  USE="cdr gnome-keyring* libnotify* nsplugin python udev -daap -debug -doc -ipod -lirc -mtp -musicbrainz -test -upnp -webkit (-hal%)" 0 kB
[ebuild     U ] xfce-extra/thunar-archive-plugin-0.3.0 [0.2.4-r2] USE="-debug" 0 kB
[ebuild   R   ] mail-client/evolution-2.32.2  USE="crypt gstreamer kerberos ldap python ssl (-clutter) -doc -networkmanager*" 0 kB
[ebuild   R   ] gnome-extra/bug-buddy-2.32.0-r2  USE="eds*" 0 kB
[ebuild   R   ] x11-wm/compiz-0.8.6-r3  USE="cairo dbus gconf gnome gtk svg -fuse -kde*" 0 kB
[ebuild   R   ] net-wireless/gnome-bluetooth-2.32.0  USE="nautilus* -debug -doc (-introspection)" 0 kB
[ebuild   R   ] gnome-base/gnome-applets-2.32.1.1  USE="gnome gstreamer ipv6 policykit -networkmanager* (-battstat%) (-hal%)" 0 kB
[ebuild   R   ] gnome-extra/deskbar-applet-2.32.0  USE="eds* spell" 0 kB
[ebuild   R   ] gnome-extra/hamster-applet-2.32.1  USE="eds* libnotify*" 0 kB
[ebuild   R   ] x11-plugins/compiz-plugins-extra-0.8.6-r1  USE="gconf libnotify*" 0 kB
[ebuild   R   ] x11-apps/fusion-icon-0.1-r1  USE="gtk -qt4*" 0 kB
[ebuild   R   ] x11-wm/compiz-fusion-0.8.6  USE="emerald gnome -kde* -unsupported" 0 kB

Total: 91 packages (23 upgrades, 1 downgrade, 10 new, 1 in new slot, 56 reinstalls, 1 interactive), Size of downloads: 0 kB

*** Resuming merge...

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 91) dev-lang/nasm-2.09.04
openpty failed: 'out of pty devices'
 * nasm-2.09.04.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                  [ ok ]
 * Package:    dev-lang/nasm-2.09.04
 * Repository: gentoo
 * Maintainer: mr_bones_@gentoo.org
 * USE:        elibc_glibc kernel_linux userland_GNU x86
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking nasm-2.09.04.tar.bz2 to /var/tmp/portage/dev-lang/nasm-2.09.04/work
>>> Source unpacked in /var/tmp/portage/dev-lang/nasm-2.09.04/work
>>> Preparing source in /var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04 ...
./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04':
configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04/config.log
 * ERROR: dev-lang/nasm-2.09.04 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 2466:  Called econf
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =dev-lang/nasm-2.09.04',
 * the complete build log and the output of 'emerge -pqv =dev-lang/nasm-2.09.04'.
 * The complete build log is located at '/var/tmp/portage/dev-lang/nasm-2.09.04/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/nasm-2.09.04/temp/environment'.
 * S: '/var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04'

>>> Failed to emerge dev-lang/nasm-2.09.04, Log file:

>>>  '/var/tmp/portage/dev-lang/nasm-2.09.04/temp/build.log'

 * Messages for package dev-lang/nasm-2.09.04:

 * ERROR: dev-lang/nasm-2.09.04 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 2466:  Called econf
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =dev-lang/nasm-2.09.04',
 * the complete build log and the output of 'emerge -pqv =dev-lang/nasm-2.09.04'.
 * The complete build log is located at '/var/tmp/portage/dev-lang/nasm-2.09.04/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/nasm-2.09.04/temp/environment'.
 * S: '/var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


qualche cosciglio?
_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Sat Apr 02, 2011 10:01 am    Post subject: Reply with quote

Code:
revdep-rebuild -i -p

che ti dice?

anzi prova a compilare il seguente file:

Code:

#include <stdio.h>
void main ()
{
printf{"Hello world\n"};
return 0;
}


vediam che ti dice
_________________
Darkman
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sat Apr 02, 2011 10:53 am    Post subject: Reply with quote

mi sa che c'e qualcosa che non va, su debian lo copila bene

qui su gentoo invece

Code:
 gcc ciao.c -o ciao
./ciao
/usr/libexec/gcc/i686-pc-linux-gnu/4.4.5/cc1plus: error while loading shared libraries: libmpfr.so.1: cannot open shared object file: No such file or directory

_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sat Apr 02, 2011 10:59 am    Post subject: Reply with quote

scusami dimenticavo revdep-rebuild tutte le librerie saltate
un bel casino porcaccia

Code:
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/klettres (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libQtXml.so.4
libkdecore.so.5
libkdeui.so.5
libknewstuff3.so.4
libphonon.so.4)
 *   broken /usr/bin/klines (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/klines.kss (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/klorenz.kss (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kmahjongg (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/kmimetypefinder (requires libQtCore.so.4
libkdecore.so.5)
 *   broken /usr/bin/kmines (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kmplot (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libkparts.so.4)
 *   broken /usr/bin/knetwalk (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5
libknotifyconfig.so.4)
 *   broken /usr/bin/knotify4 (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libphonon.so.4
libsolid.so.4)
 *   broken /usr/bin/kolf (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kollision (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5
libphonon.so.4)
 *   broken /usr/bin/kolourpaint (requires libQt3Support.so.4
libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libkprintutils.so.4)
 *   broken /usr/bin/konquest (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/konversation (requires libQt3Support.so.4
libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libQtNetwork.so.4
libQtXml.so.4
libkabc.so.4
libkde3support.so.4
libkdecore.so.5
libkdeui.so.5
libkemoticons.so.4
libkidletime.so.4
libkio.so.5
libknotifyconfig.so.4
libkparts.so.4
libphonon.so.4
libsolid.so.4)
 *   broken /usr/bin/kopete (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libknotifyconfig.so.4
libsolid.so.4)
 *   broken /usr/bin/kpartsaver.kss (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libkparts.so.4)
 *   broken /usr/bin/kpat (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libQtXml.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/kpendulum.kss (requires libQtCore.so.4
libQtGui.so.4
libQtOpenGL.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kpolygon.kss (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kquitapp (requires libQtCore.so.4
libQtDBus.so.4
libkdecore.so.5)
 *   broken /usr/bin/krandom.kss (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/krandrtray (requires libQtCore.so.4
libQtGui.so.4
libkcmutils.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/krcdnotifieritem (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libsolidcontrol.so.4)
 *   broken /usr/bin/krdc (requires libQtCore.so.4
libQtGui.so.4
libQtXml.so.4
libkcmutils.so.4
libkdecore.so.5
libkdeui.so.5
libkdnssd.so.4
libkio.so.5
libknotifyconfig.so.4)
 *   broken /usr/bin/kreadconfig (requires libQtCore.so.4
libkdecore.so.5)
 *   broken /usr/bin/kreversi (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/krfb (requires libQtCore.so.4
libQtGui.so.4
libQtNetwork.so.4
libkdecore.so.5
libkdeui.so.5
libkdnssd.so.4)
 *   broken /usr/bin/krotation.kss (requires libQtCore.so.4
libQtGui.so.4
libQtOpenGL.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kruler (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/ksame (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kscd (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5
libphonon.so.4
libsolid.so.4)
 *   broken /usr/bin/kscience.kss (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kshisen (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libphonon.so.4)
 *   broken /usr/bin/ksirk (requires libQtCore.so.4
libQtGui.so.4
libQtNetwork.so.4
libQtSvg.so.4
libQtXml.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libknewstuff3.so.4
libphonon.so.4)
 *   broken /usr/bin/ksirkskineditor (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libQtXml.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/kslideshow.kss (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/ksnapshot (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/ksolarwinds.kss (requires libQtCore.so.4
libQtGui.so.4
libQtOpenGL.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kspaceduel (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/ksplashx_scale (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5)
 *   broken /usr/bin/ksquares (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kstars (requires libQt3Support.so.4
libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libkde3support.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libknewstuff3.so.4)
 *   broken /usr/bin/kstart (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kstartupconfig4 (requires libkdefakes.so.5)
 *   broken /usr/bin/ksudoku (requires libQtCore.so.4
libQtGui.so.4
libQtOpenGL.so.4
libQtSvg.so.4
libQtXml.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/ksvgtopng (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdeui.so.5)
 *   broken /usr/bin/ksystemlog (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/ksystraycmd (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
[ 16% ]  *   broken /usr/bin/kteatime (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libknotifyconfig.so.4)
 *   broken /usr/bin/ktesnippets_editor (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libQtXml.so.4
libkdecore.so.5
libkdeui.so.5
libktexteditor.so.4)
 *   broken /usr/bin/ktimer (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/ktouch (requires libQtCore.so.4
libQtGui.so.4
libQtXml.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/ktraderclient (requires libQtCore.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/ktron (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/ktuberling (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libQtXml.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libphonon.so.4)
 *   broken /usr/bin/kturtle (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libknewstuff3.so.4)
 *   broken /usr/bin/ktux (requires libQt3Support.so.4
libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kubrick (requires libQtCore.so.4
libQtGui.so.4
libQtOpenGL.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/kuser (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libkldap.so.4
libkntlm.so.4)
 *   broken /usr/bin/kvm.kss (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kwalletmanager (requires libQt3Support.so.4
libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libQtXml.so.4
libkde3support.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/kwave.kss (requires libQtCore.so.4
libQtGui.so.4
libQtOpenGL.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/kwikdisk (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/kwordquiz (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libknewstuff3.so.4
libknotifyconfig.so.4
libkprintutils.so.4
libphonon.so.4)
 *   broken /usr/bin/kwriteconfig (requires libQtCore.so.4
libkdecore.so.5)
 *   broken /usr/bin/lancelot (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libkcmutils.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libplasma.so.3)
 *   broken /usr/bin/libpala-puzzlebuilder (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
[ 17% ]  *   broken /usr/bin/lskat (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/marble (requires libQtCore.so.4
libQtGui.so.4
libQtNetwork.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libknewstuff3.so.4
libkparts.so.4)
[ 18% ]  *   broken /usr/bin/mplayerthumbsconfig (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
[ 19% ]  *   broken /usr/bin/nspluginscan (requires libQtCore.so.4
libQtDBus.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/nspluginviewer (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libkparts.so.4)
 *   broken /usr/bin/okteta (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/okular (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libkparts.so.4)
 *   broken /usr/bin/onto2vocabularyclass (requires libQtCore.so.4)
[ 20% ]  *   broken /usr/bin/oxygen-demo (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/oxygen-settings (requires libQtCore.so.4
libQtGui.so.4
libkdecore.so.5
libkdeui.so.5)
 *   broken /usr/bin/palapeli (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5)
 *   broken /usr/bin/parley (requires libQtCore.so.4
libQtDBus.so.4
libQtGui.so.4
libQtSvg.so.4
libkcmutils.so.4
libkdecore.so.5
libkdeui.so.5
libkhtml.so.5
libkio.so.5
libknewstuff3.so.4
libkrosscore.so.4
libphonon.so.4)
 *   broken /usr/bin/plasmapkg (requires libQtCore.so.4
libQtDBus.so.4
libkdecore.so.5
libkdeui.so.5
libplasma.so.3)
[ 21% ]  *   broken /usr/bin/qcatool2 (requires libQtCore.so.4)
 *   broken /usr/bin/rdfproc (requires libmpfr.so.1)
[ 22% ]  *   broken /usr/bin/redland-db-upgrade (requires libmpfr.so.1)
 *   broken /usr/bin/rocs (requires libQtCore.so.4
libQtGui.so.4
libQtSvg.so.4
libkdecore.so.5
libkdeui.so.5
libkio.so.5
libktexteditor.so.4)

_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Apr 02, 2011 11:01 am    Post subject: Reply with quote

prova con un revdep-rebuild e/o a ricompilare dev-libs/mpfr
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Sat Apr 02, 2011 11:03 am    Post subject: Reply with quote

evidentemente non hai seguito il messaggio che dev-libs/mpfr ti ha dato quando è stato aggiornato: prima lanciare il revdep-rebuild sulla libreria e poi rimuoverla...

Soluzione? devi trovare un bel binario precompilato di gcc, installarlo e poi riemergere gcc stesso. Se cerchi gentoo binhost con google (e credo anche qui nel forum) dovresti trovare istruzioni su come reperire precompilati per gentoo. Controlla che siano linkati alla nuova libreria, altrimenti il problema rimane.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Sat Apr 02, 2011 11:04 am    Post subject: Reply with quote

ago wrote:
prova con un revdep-rebuild e/o a ricompilare dev-libs/mpfr

Se il gcc non gli funziona, come fa a ricompilare la libreria?
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sat Apr 02, 2011 11:31 am    Post subject: Reply with quote

ora ho lanciato revdep-rebuild quando termina vedro dev-libs/mpfr che mi dice comuque questo e quello che mi sta dando


Code:
  /usr/lib/gnome-settings-daemon-2.0/liba11y-keyboard.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libbackground.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libclipboard.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libfont.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libhousekeeping.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libkeybindings.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libkeyboard.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libmedia-keys.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libmouse.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libsound.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libtyping-break.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libxrandr.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libxrdb.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gnome-settings-daemon-2.0/libxsettings.so -> gnome-base/gnome-settings-daemon
 *   /usr/lib/gstreamer-0.10/libgstsouphttpsrc.la -> media-plugins/gst-plugins-soup
 *   /usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so -> x11-libs/gtk+
 *   /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.la -> media-libs/libcanberra
 *   /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so -> media-libs/libcanberra
 *   /usr/lib/gtk-2.0/modules/libgnomesegvhandler.la -> gnome-extra/bug-buddy
 *   /usr/lib/kconf_update_bin/krdb_clearlibrarypath -> kde-base/systemsettings
 *   /usr/lib/kde4/arkpart.so -> kde-base/ark
 *   /usr/lib/kde4/cantor_creatematrixassistant.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_differentiateassistant.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_eigenvaluesassistant.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_eigenvectorsassistant.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_integrateassistant.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_invertmatrixassistant.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_maximabackend.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_nullbackend.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_plot2dassistant.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_plot3dassistant.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_runscriptassistant.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_sagebackend.so -> kde-base/cantor
 *   /usr/lib/kde4/cantor_solveassistant.so -> kde-base/cantor
 *   /usr/lib/kde4/classic_mode.so -> kde-base/systemsettings
 *   /usr/lib/kde4/concentrationCalculator.so -> kde-base/kalzium
 *   /usr/lib/kde4/devinfo.so -> kde-base/kinfocenter
 *   /usr/lib/kde4/dolphinpart.so -> kde-base/dolphin
 *   /usr/lib/kde4/dragonpart.so -> kde-base/dragonplayer
 *   /usr/lib/kde4/ffmpegthumbs.so -> kde-base/ffmpegthumbs
 *   /usr/lib/kde4/fileshare_propsdlgplugin.so -> kde-base/kdenetwork-filesharing
 *   /usr/lib/kde4/fixhosturifilter.so -> kde-base/kurifilter-plugins
 *   /usr/lib/kde4/fontthumbnail.so -> kde-base/systemsettings
 *   /usr/lib/kde4/gasCalculator.so -> kde-base/kalzium
 *   /usr/lib/kde4/gsthumbnail.so -> kde-base/thumbnailers
 *   /usr/lib/kde4/gvpart.so -> kde-base/gwenview
 *   /usr/lib/kde4/icon_mode.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kate_kttsd.so -> kde-base/kate
 *   /usr/lib/kde4/katebacktracebrowserplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katebuildplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katectagsplugin.so -> kde-base/kate
 *   /usr/lib/kde4/kateexternaltoolsplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katefilebrowserplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katefiletemplates.so -> kde-base/kate
 *   /usr/lib/kde4/katefindinfilesplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katekonsoleplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katemailfilesplugin.so -> kde-base/kate
 *   /usr/lib/kde4/kateopenheaderplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katequickdocumentswitcherplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katesnippets_tngplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katesymbolviewerplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katetabbarextensionplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katetabifyplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katetextfilterplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katexmlcheckplugin.so -> kde-base/kate
 *   /usr/lib/kde4/katexmltoolsplugin.so -> kde-base/kate
 *   /usr/lib/kde4/kcm_access.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_attica.so -> kde-base/attica
 *   /usr/lib/kde4/kcm_audiocd.so -> kde-base/kdemultimedia-kioslaves
 *   /usr/lib/kde4/kcm_autostart.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_bell.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_cddb.so -> kde-base/libkcddb
 *   /usr/lib/kde4/kcm_clock.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_colors.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_cron.so -> kde-base/kcron
 *   /usr/lib/kde4/kcm_desktoppaths.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_desktoptheme.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_device_automounter.so -> kde-base/solid-runtime
 *   /usr/lib/kde4/kcm_display.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_dolphingeneral.so -> kde-base/dolphin
 *   /usr/lib/kde4/kcm_dolphinnavigation.so -> kde-base/dolphin
 *   /usr/lib/kde4/kcm_dolphinservices.so -> kde-base/dolphin
 *   /usr/lib/kde4/kcm_dolphinviewmodes.so -> kde-base/dolphin
 *   /usr/lib/kde4/kcm_fileshare.so -> kde-base/kdenetwork-filesharing
 *   /usr/lib/kde4/kcm_filetypes.so -> kde-base/keditfiletype
 *   /usr/lib/kde4/kcm_fontinst.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_fonts.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_history.so -> kde-base/konqueror
 *   /usr/lib/kde4/kcm_hotkeys.so -> kde-base/khotkeys
 *   /usr/lib/kde4/kcm_info.so -> kde-base/kinfocenter
 *   /usr/lib/kde4/kcm_infosummary.so -> kde-base/kinfocenter
 *   /usr/lib/kde4/kcm_input.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_joystick.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_kamera.so -> kde-base/kamera
 *   /usr/lib/kde4/kcm_kcmsambaconf.so -> kde-base/kdenetwork-filesharing
 *   /usr/lib/kde4/kcm_kdf.so -> kde-base/kdf
 *   /usr/lib/kde4/kcm_kdm.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_keyboard.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_keys.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_kgamma.so -> kde-base/kgamma
 *   /usr/lib/kde4/kcm_kget_checksumsearchfactory.so -> kde-base/kget
 *   /usr/lib/kde4/kcm_kget_contentfetchfactory.so -> kde-base/kget
 *   /usr/lib/kde4/kcm_kget_metalinkfactory.so -> kde-base/kget
 *   /usr/lib/kde4/kcm_kget_mirrorsearchfactory.so -> kde-base/kget
 *   /usr/lib/kde4/kcm_kget_multisegkiofactory.so -> kde-base/kget
 *   /usr/lib/kde4/kcm_kio.so -> kde-base/konqueror
 *   /usr/lib/kde4/kcm_knetworkconfmodule.so -> kde-base/knetworkconf
 *   /usr/lib/kde4/kcm_konq.so -> kde-base/konqueror
 *   /usr/lib/kde4/kcm_konqhtml.so -> kde-base/konqueror
 *   /usr/lib/kde4/kcm_kopete_accountconfig.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_addbookmarks.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_appearanceconfig.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_autoreplace.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_behaviorconfig.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_chatwindowconfig.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_highlight.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_history.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_nowlistening.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_pipes.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_pluginconfig.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_privacy.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_statusconfig.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_texteffect.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_translator.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_kopete_urlpicpreview.so -> kde-base/kopete
 *   /usr/lib/kde4/kcm_krdc_rdpplugin.so -> kde-base/krdc
 *   /usr/lib/kde4/kcm_krunner_audioplayercontrol.so -> kde-base/kdeplasma-addons
 *   /usr/lib/kde4/kcm_krunner_charrunner.so -> kde-base/kdeplasma-addons
 *   /usr/lib/kde4/kcm_krunner_spellcheck.so -> kde-base/kdeplasma-addons
 *   /usr/lib/kde4/kcm_ksplashthemes.so -> kde-base/ksplash
 *   /usr/lib/kde4/kcm_kurifilt.so -> kde-base/konqueror
 *   /usr/lib/kde4/kcm_kwallet.so -> kde-base/kwallet
 *   /usr/lib/kde4/kcm_launch.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_memory.so -> kde-base/kinfocenter
 *   /usr/lib/kde4/kcm_nic.so -> kde-base/kinfocenter
 *   /usr/lib/kde4/kcm_opengl.so -> kde-base/kinfocenter
 *   /usr/lib/kde4/kcm_pci.so -> kde-base/kinfocenter
 *   /usr/lib/kde4/kcm_performance.so -> kde-base/konqueror
 *   /usr/lib/kde4/kcm_powerdevilconfig.so -> kde-base/powerdevil
 *   /usr/lib/kde4/kcm_randr.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_remotecontrol.so -> kde-base/kremotecontrol
 *   /usr/lib/kde4/kcm_samba.so -> kde-base/kinfocenter
 *   /usr/lib/kde4/kcm_screensaver.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_smserver.so -> kde-base/ksmserver
 *   /usr/lib/kde4/kcm_standard_actions.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_style.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kcm_usb.so -> kde-base/kinfocenter
 *   /usr/lib/kde4/kcm_useraccount.so -> kde-base/kdepasswd
 *   /usr/lib/kde4/kcm_workspaceoptions.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kded_activitymanager.so -> kde-base/activitymanager
 *   /usr/lib/kde4/kded_device_automounter.so -> kde-base/solid-runtime
 *   /usr/lib/kde4/kded_dnssdwatcher.so -> kde-base/kdnssd
 *   /usr/lib/kde4/kded_favicons.so -> kde-base/libkonq
 *   /usr/lib/kde4/kded_freespacenotifier.so -> kde-base/freespacenotifier
 *   /usr/lib/kde4/kded_keyboard.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kded_khotkeys.so -> kde-base/khotkeys
 *   /usr/lib/kde4/kded_konqy_preloader.so -> kde-base/konqueror
 *   /usr/lib/kde4/kded_kpasswdserver.so -> kde-base/kpasswdserver
 *   /usr/lib/kde4/kded_kremotecontroldaemon.so -> kde-base/kremotecontrol
 *   /usr/lib/kde4/kded_ktimezoned.so -> kde-base/ktimezoned
 *   /usr/lib/kde4/kded_kwrited.so -> kde-base/kwrited
 *   /usr/lib/kde4/kded_powerdevil.so -> kde-base/powerdevil
 *   /usr/lib/kde4/kded_randrmonitor.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kded_solidautoeject.so -> kde-base/solid-runtime
 *   /usr/lib/kde4/kded_soliduiserver.so -> kde-base/solid-runtime
 *   /usr/lib/kde4/kerfuffle_cli7z.so -> kde-base/ark
 *   /usr/lib/kde4/kerfuffle_clirar.so -> kde-base/ark
 *   /usr/lib/kde4/kerfuffle_clizip.so -> kde-base/ark
 *   /usr/lib/kde4/kerfuffle_libarchive.so -> kde-base/ark
 *   /usr/lib/kde4/kerfuffle_libbz2.so -> kde-base/ark
 *   /usr/lib/kde4/kerfuffle_libgz.so -> kde-base/ark
 *   /usr/lib/kde4/keyboard_layout_widget.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kfontviewpart.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kget_browser_integration.so -> kde-base/kget
 *   /usr/lib/kde4/kget_checksumsearchfactory.so -> kde-base/kget
 *   /usr/lib/kde4/kget_contentfetchfactory.so -> kde-base/kget
 *   /usr/lib/kde4/kget_kiofactory.so -> kde-base/kget
 *   /usr/lib/kde4/kget_metalinkfactory.so -> kde-base/kget
 *   /usr/lib/kde4/kget_mirrorsearchfactory.so -> kde-base/kget
 *   /usr/lib/kde4/kget_multisegkiofactory.so -> kde-base/kget
 *   /usr/lib/kde4/khtmlkttsdplugin.so -> kde-base/konqueror
 *   /usr/lib/kde4/kigpart.so -> kde-base/kig
 *   /usr/lib/kde4/kio_audiocd.so -> kde-base/kdemultimedia-kioslaves
 *   /usr/lib/kde4/kio_fonts.so -> kde-base/systemsettings
 *   /usr/lib/kde4/kio_kamera.so -> kde-base/kamera
 *   /usr/lib/kde4/kio_zeroconf.so -> kde-base/kdnssd
 *   /usr/lib/kde4/konq_aboutpage.so -> kde-base/konqueror
 *   /usr/lib/kde4/konq_shellcmdplugin.so -> kde-base/konqueror
 *   /usr/lib/kde4/konq_sidebar.so -> kde-base/konqueror
 *   /usr/lib/kde4/konq_sidebartree_bookmarks.so -> kde-base/konqueror
 *   /usr/lib/kde4/konq_sidebartree_dirtree.so -> kde-base/konqueror
 *   /usr/lib/kde4/konq_sound.so -> kde-base/libkonq
 *   /usr/lib/kde4/konqsidebar_history.so -> kde-base/konqueror
 *   /usr/lib/kde4/konqsidebar_places.so -> kde-base/konqueror

_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sat Apr 02, 2011 11:54 am    Post subject: Reply with quote

ecco revdep-rebuild termina cosi

Code:
 *   /usr/libexec/gcc/i686-pc-linux-gnu/4.4.5/f951 -> sys-devel/gcc
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
[ebuild   R   ] dev-libs/rasqal-0.9.17
[ebuild   R   ] media-plugins/gst-plugins-soup-0.10.23
[ebuild  N    ] x11-libs/qt-core-4.7.2-r1
[ebuild  N    ] x11-libs/qt-script-4.7.2
[ebuild  N    ] x11-libs/qt-dbus-4.7.2
[ebuild   R   ] app-crypt/qca-2.0.2-r2
[ebuild  N    ] x11-libs/qt-gui-4.7.2
[ebuild  N    ] x11-libs/qt-svg-4.7.2
[ebuild   R   ] app-crypt/qca-ossl-2.0.0_beta3-r2
[ebuild  N    ] x11-libs/qt-core-4.6.2-r1
[ebuild  N    ] x11-libs/qt-test-4.6.2
[ebuild  N    ] x11-libs/qt-dbus-4.6.2
[ebuild  N    ] x11-libs/qt-script-4.6.2
[ebuild  N    ] x11-libs/qt-xmlpatterns-4.6.2
[ebuild  N    ] x11-libs/qt-sql-4.7.2
[ebuild  N    ] x11-libs/qt-sql-4.6.2
[ebuild   R   ] dev-libs/redland-1.0.10-r1
[ebuild  N    ] x11-libs/qt-qt3support-4.7.2
[ebuild   R   ] sys-devel/gcc-4.4.5
[ebuild   R   ] media-libs/liblastfm-0.3.0
[ebuild   R   ] x11-libs/cairo-1.10.2-r1
[ebuild  N    ] x11-libs/qt-opengl-4.7.2
[ebuild   R   ] dev-util/cmake-2.8.1-r2
[ebuild  N    ] x11-libs/qt-gui-4.6.2-r1
[ebuild  N    ] x11-libs/qt-qt3support-4.6.2
[ebuild  N    ] kde-base/oxygen-icons-4.4.5
[ebuild     UD] dev-libs/libattica-0.1.2 [0.2.0]
[ebuild   R   ] media-libs/qimageblitz-0.0.4
[ebuild  N    ] app-misc/strigi-0.7.1
[ebuild  N    ] dev-util/automoc-0.9.88
[ebuild   R   ] dev-cpp/cairomm-1.8.6
[ebuild  N    ] dev-libs/qjson-0.6.3
[ebuild     UD] dev-libs/libdbusmenu-qt-0.6.2 [0.7.0]
[ebuild  N    ] media-libs/libechonest-1.1.4
[ebuild  N    ] virtual/ffmpeg-0.6
[ebuild  N    ] virtual/mta-0
[ebuild   R   ] x11-libs/gtk+-2.22.1-r1
[ebuild   R   ] media-libs/libcanberra-0.26
[ebuild   R   ] gnome-base/librsvg-2.32.1
[ebuild   R   ] gnome-base/libgnomecanvas-2.30.3
[ebuild   R   ] app-text/poppler-0.14.5
[ebuild   R   ] gnome-base/libgnomekbd-2.32.0
[ebuild   R   ] dev-cpp/gtkmm-2.22.0
[ebuild   R   ] media-libs/mlt-0.5.10
[ebuild   R   ] net-libs/webkit-gtk-1.2.7
[ebuild     UD] dev-libs/soprano-2.4.4 [2.6.0]
[ebuild   R   ] gnome-extra/gnome-media-2.32.0
[ebuild   R   ] gnome-base/gnome-desktop-2.32.1
[ebuild  N    ] app-office/akonadi-server-1.3.1
[ebuild   R   ] net-libs/gtk-vnc-0.4.2-r2
[ebuild   R   ] app-office/abiword-2.8.6-r1
[ebuild   R   ] gnome-base/gnome-keyring-2.32.1
[ebuild   R   ] gnome-base/libbonoboui-2.24.4-r1
[ebuild   R   ] gnome-base/libgnomeui-2.24.5
[ebuild   R   ] net-libs/libproxy-0.4.6
[ebuild   R   ] media-gfx/f-spot-0.8.2
[ebuild   R   ] dev-libs/libgdata-0.8.0
[ebuild   R   ] dev-libs/libgweather-2.30.3
[ebuild   R   ] gnome-extra/evolution-data-server-2.32.2
[ebuild   R   ] gnome-base/gnome-panel-2.32.1-r1
[ebuild   R   ] gnome-extra/bug-buddy-2.32.0-r2
[ebuild   R   ] mail-client/evolution-2.32.2
[ebuild   R   ] net-voip/ekiga-3.2.7
[ebuild  N    ] sys-auth/polkit-qt-0.96.1
[ebuild   R   ] gnome-base/gnome-settings-daemon-2.32.1
[ebuild   R   ] x11-libs/libgksu-2.0.12-r1
[ebuild  N    ] media-libs/phonon-4.4.4
[ebuild  N    ] x11-libs/qt-webkit-4.6.2
[ebuild  N    ] kde-base/kdelibs-4.4.5-r4
[ebuild  N    ] sys-auth/polkit-kde-0.95.1-r1
[ebuild  N    ] kde-base/khelpcenter-4.4.5
[ebuild  N    ] kde-base/kdepimlibs-4.4.5
[ebuild   R   ] net-irc/konversation-1.3.1
[ebuild   R   ] media-video/vlc-1.1.7
[ebuild   R   ] media-libs/phonon-vlc-0.3.2
[ebuild     U ] media-sound/clementine-0.7 [0.5.3]
[ebuild   R   ] app-cdr/brasero-2.32.1
[ebuild   R   ] media-video/totem-2.32.0
[ebuild   R   ] x11-wm/compiz-0.8.6-r3
[ebuild  N    ] gnome-extra/nautilus-sendto-2.32.0
[ebuild   R   ] media-sound/rhythmbox-0.12.8-r1
[ebuild   R   ] net-print/gnome-cups-manager-0.33-r2
[ebuild   R   ] net-wireless/gnome-bluetooth-2.32.0
[ebuild     U ] sys-auth/polkit-0.101 [0.100]
[ebuild     U ] gnome-extra/polkit-gnome-0.101-r1 [0.99]
[blocks B     ] <x11-libs/qt-webkit-4.7.2 ("<x11-libs/qt-webkit-4.7.2" is blocking x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-sql-4.7.2, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-script-4.7.2)
[blocks B     ] <x11-libs/qt-test-4.7.2 ("<x11-libs/qt-test-4.7.2" is blocking x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-sql-4.7.2, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-script-4.7.2)
[blocks B     ] >x11-libs/qt-opengl-4.6.2-r9999 (">x11-libs/qt-opengl-4.6.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-test-4.6.2)
[blocks B     ] <x11-libs/qt-xmlpatterns-4.7.2 ("<x11-libs/qt-xmlpatterns-4.7.2" is blocking x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-sql-4.7.2, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-script-4.7.2)
[blocks B     ] >x11-libs/qt-script-4.6.2-r9999 (">x11-libs/qt-script-4.6.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-test-4.6.2)
[blocks B     ] >x11-libs/qt-svg-4.6.2-r9999 (">x11-libs/qt-svg-4.6.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-test-4.6.2)
[blocks B     ] >x11-libs/qt-qt3support-4.6.2-r9999 (">x11-libs/qt-qt3support-4.6.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-test-4.6.2)
[blocks B     ] >x11-libs/qt-dbus-4.6.2-r9999 (">x11-libs/qt-dbus-4.6.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-test-4.6.2)
[blocks B     ] >x11-libs/qt-core-4.6.2-r9999 (">x11-libs/qt-core-4.6.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-test-4.6.2)
[blocks B     ] >x11-libs/qt-sql-4.6.2-r9999 (">x11-libs/qt-sql-4.6.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-test-4.6.2)
[blocks B     ] >x11-libs/qt-gui-4.6.2-r9999 (">x11-libs/qt-gui-4.6.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-webkit-4.6.2, x11-libs/qt-test-4.6.2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-libs/qt-opengl-4.7.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-opengl-4.6.0:4 required by (kde-base/kdelibs-4.4.5-r4, ebuild scheduled for merge)
    >=x11-libs/qt-opengl-4.6.0:4 required by (media-libs/phonon-gstreamer-4.4.4, installed)
    >=x11-libs/qt-opengl-4.5:4 required by (media-sound/clementine-0.7, ebuild scheduled for merge)

  (x11-libs/qt-core-4.7.2-r1, ebuild scheduled for merge) pulled in by
    x11-libs/qt-core:4 required by (dev-util/automoc-0.9.88, ebuild scheduled for merge)
    >=x11-libs/qt-core-4.6.0:4[qt3support,ssl] required by (kde-base/kdepimlibs-4.4.5, ebuild scheduled for merge)
    x11-libs/qt-core:4 required by (app-misc/strigi-0.7.1, ebuild scheduled for merge)
    (and 20 more)

  (x11-libs/qt-dbus-4.7.2, ebuild scheduled for merge) pulled in by
    x11-libs/qt-dbus:4 required by (net-im/skype-2.1.0.81, installed)
    >=x11-libs/qt-dbus-4.6.0:4 required by (media-libs/phonon-vlc-0.3.2, ebuild scheduled for merge)
    x11-libs/qt-dbus:4 required by (app-misc/strigi-0.7.1, ebuild scheduled for merge)
    (and 3 more)

  (x11-libs/qt-qt3support-4.7.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-qt3support-4.6.0:4[accessibility,kde] required by (kde-base/kdepimlibs-4.4.5, ebuild scheduled for merge)
    >=x11-libs/qt-qt3support-4.6.0:4[accessibility,kde] required by (kde-base/kdelibs-4.4.5-r4, ebuild scheduled for merge)
    >=x11-libs/qt-qt3support-4.6.0:4[accessibility,kde] required by (kde-base/khelpcenter-4.4.5, ebuild scheduled for merge)
    (and 3 more)

  (x11-libs/qt-sql-4.7.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-sql-4.5:4 required by (media-libs/liblastfm-0.3.0, ebuild scheduled for merge)
    >=x11-libs/qt-sql-4.6.0:4[qt3support] required by (kde-base/khelpcenter-4.4.5, ebuild scheduled for merge)
    >=x11-libs/qt-sql-4.5:4[sqlite] required by (media-sound/clementine-0.7, ebuild scheduled for merge)
    (and 6 more)

  (x11-libs/qt-webkit-4.6.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-webkit-4.6.0:4[kde] required by (kde-base/kdelibs-4.4.5-r4, ebuild scheduled for merge)

  (x11-libs/qt-test-4.6.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-test-4.6.0:4 required by (kde-base/khelpcenter-4.4.5, ebuild scheduled for merge)
    >=x11-libs/qt-test-4.5.0:4 required by (app-office/akonadi-server-1.3.1, ebuild scheduled for merge)
    >=x11-libs/qt-test-4.6.0:4 required by (sys-auth/polkit-kde-0.95.1-r1, ebuild scheduled for merge)
    (and 7 more)

  (x11-libs/qt-svg-4.7.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-svg-4.6.0:4 required by (sys-auth/polkit-kde-0.95.1-r1, ebuild scheduled for merge)
    >=x11-libs/qt-svg-4.6.0:4 required by (kde-base/kdelibs-4.4.5-r4, ebuild scheduled for merge)
    >=x11-libs/qt-svg-4.6.0:4 required by (kde-base/khelpcenter-4.4.5, ebuild scheduled for merge)
    (and 2 more)

  (x11-libs/qt-script-4.7.2, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-script-4.6.0:4 required by (kde-base/khelpcenter-4.4.5, ebuild scheduled for merge)
    >=x11-libs/qt-script-4.6.0:4 required by (net-irc/konversation-1.3.1, ebuild scheduled for merge)
    >=x11-libs/qt-script-4.6.0:4 required by (sys-auth/polkit-kde-0.95.1-r1, ebuild scheduled for merge)
    (and 3 more)

  (x11-libs/qt-gui-4.7.2, ebuild scheduled for merge) pulled in by
    x11-libs/qt-gui:4 required by (app-text/poppler-0.14.5, ebuild scheduled for merge)
    >=x11-libs/qt-gui-4.6.3:4[dbus] required by (dev-libs/libdbusmenu-qt-0.6.2, ebuild scheduled for merge)
    x11-libs/qt-gui:4 required by (app-misc/strigi-0.7.1, ebuild scheduled for merge)
    (and 19 more)

 *
 * Warning: Failed to resolve package order.
 * Will merge in arbitrary order
 *
Possible reasons:
- An ebuild is no longer in the portage tree.
- An ebuild is masked, use /etc/portage/packages.keyword
and/or /etc/portage/package.unmask to unmask it
.....
 * All prepared. Starting rebuild
emerge --oneshot --pretend  app-cdr/brasero:0
app-crypt/qca-ossl:2
app-crypt/qca:2
app-office/abiword:2
app-text/poppler:0
dev-cpp/cairomm:0
dev-cpp/gtkmm:2.4
dev-libs/libattica:0
dev-libs/libdbusmenu-qt:0
dev-libs/libgdata:0
dev-libs/libgweather:2
dev-libs/rasqal:0
dev-libs/redland:0
dev-libs/soprano:0
dev-util/cmake:0
gnome-base/gnome-desktop:2
gnome-base/gnome-keyring:0
gnome-base/gnome-panel:0
gnome-base/gnome-settings-daemon:0
gnome-base/libbonoboui:0
gnome-base/libgnomecanvas:0
gnome-base/libgnomekbd:0
gnome-base/libgnomeui:0
gnome-base/librsvg:2
gnome-extra/bug-buddy:2
gnome-extra/evolution-data-server:0
gnome-extra/gnome-media:2
gnome-extra/polkit-gnome:0
kde-base/activitymanager:4.5
kde-base/amor:4.5
kde-base/ark:4.5
kde-base/attica:4.5
kde-base/blinken:4.5
kde-base/bomber:4.5
kde-base/bovo:4.5
kde-base/cantor:4.5
kde-base/dolphin:4.5
kde-base/dragonplayer:4.5
kde-base/drkonqi:4.5
kde-base/ffmpegthumbs:4.5
kde-base/freespacenotifier:4.5
kde-base/granatier:4.5
kde-base/gwenview:4.5
kde-base/juk:4.5
kde-base/kalgebra:4.5
kde-base/kalzium:4.5
kde-base/kamera:4.5
kde-base/kanagram:4.5
kde-base/kapman:4.5
kde-base/kate:4.5
kde-base/katomic:4.5
kde-base/kbattleship:4.5
kde-base/kblackbox:4.5
kde-base/kblocks:4.5
kde-base/kbounce:4.5
kde-base/kbreakout:4.5
kde-base/kbruch:4.5
kde-base/kcalc:4.5
kde-base/kcharselect:4.5
kde-base/kcminit:4.5
kde-base/kcmshell:4.5
kde-base/kcolorchooser:4.5
kde-base/kcron:4.5
kde-base/kdeartwork-kscreensaver:4.5
kde-base/kdeartwork-styles:4.5
kde-base/kdebase-data:4.5
kde-base/kdebase-menu:4.5
kde-base/kdebugdialog:4.5
kde-base/kdegraphics-strigi-analyzer:4.5
kde-base/kdemultimedia-kioslaves:4.5
kde-base/kdenetwork-filesharing:4.5
kde-base/kdepasswd:4.5
kde-base/kdeplasma-addons:4.5
kde-base/kdf:4.5
kde-base/kdialog:4.5
kde-base/kdiamond:4.5
kde-base/kdnssd:4.5
kde-base/keditbookmarks:4.5
kde-base/keditfiletype:4.5
kde-base/kfile:4.5
kde-base/kfind:4.5
kde-base/kfmclient:4.5
kde-base/kfourinline:4.5
kde-base/kgamma:4.5
kde-base/kgeography:4.5
kde-base/kget:4.5
kde-base/kglobalaccel:4.5
kde-base/kgoldrunner:4.5
kde-base/kgpg:4.5
kde-base/khangman:4.5
kde-base/khotkeys:4.5
kde-base/kiconfinder:4.5
kde-base/kig:4.5
kde-base/kigo:4.5
kde-base/killbots:4.5
kde-base/kinfocenter:4.5
kde-base/kioclient:4.5
kde-base/kiriki:4.5
kde-base/kiten:4.5
kde-base/kjumpingcube:4.5
kde-base/klettres:4.5
kde-base/klines:4.5
kde-base/klipper:4.5
kde-base/kmahjongg:4.5
kde-base/kmenuedit:4.5
kde-base/kmimetypefinder:4.5
kde-base/kmines:4.5
kde-base/kmix:4.5
kde-base/kmplot:4.5
kde-base/knetattach:4.5
kde-base/knetwalk:4.5
kde-base/knetworkconf:4.5
kde-base/knewstuff:4.5
kde-base/knotify:4.5
kde-base/kolf:4.5
kde-base/kollision:4.5
kde-base/kolourpaint:4.5
kde-base/konqueror:4.5
kde-base/konquest:4.5
kde-base/konsole:4.5
kde-base/kopete:4.5
kde-base/kpasswdserver:4.5
kde-base/kpat:4.5
kde-base/kquitapp:4.5
kde-base/krdc:4.5
kde-base/kreadconfig:4.5
kde-base/kremotecontrol:4.5
kde-base/kreversi:4.5
kde-base/krfb:4.5
kde-base/krosspython:4.5
kde-base/kruler:4.5
kde-base/krunner:4.5
kde-base/ksame:4.5
kde-base/kscd:4.5
kde-base/kscreensaver:4.5
kde-base/kshisen:4.5
kde-base/ksirk:4.5
kde-base/ksmserver:4.5
kde-base/ksnapshot:4.5
kde-base/kspaceduel:4.5
kde-base/ksplash:4.5
kde-base/ksquares:4.5
kde-base/kstars:4.5
kde-base/kstart:4.5
kde-base/kstartupconfig:4.5
kde-base/kstyles:4.5
kde-base/ksudoku:4.5
kde-base/ksysguard:4.5
kde-base/ksystemlog:4.5
kde-base/ksystraycmd:4.5
kde-base/kteatime:4.5
kde-base/ktimer:4.5
kde-base/ktimezoned:4.5
kde-base/ktouch:4.5
kde-base/ktraderclient:4.5
kde-base/ktron:4.5
kde-base/ktuberling:4.5
kde-base/kturtle:4.5
kde-base/ktux:4.5
kde-base/kubrick:4.5
kde-base/kuiserver:4.5
kde-base/kurifilter-plugins:4.5
kde-base/kuser:4.5
kde-base/kwallet:4.5
kde-base/kwordquiz:4.5
kde-base/kwrite:4.5
kde-base/kwrited:4.5
kde-base/libkcddb:4.5
kde-base/libkcompactdisc:4.5
kde-base/libkdcraw:4.5
kde-base/libkdeedu:4.5
kde-base/libkdegames:4.5
kde-base/libkexiv2:4.5
kde-base/libkipi:4.5
kde-base/libkmahjongg:4.5
kde-base/libkonq:4.5
kde-base/libplasmaclock:4.5
kde-base/libplasmagenericshell:4.5
kde-base/libtaskmanager:4.5
kde-base/lskat:4.5
kde-base/marble:4.5
kde-base/mplayerthumbs:4.5
kde-base/nsplugins:4.5
kde-base/okteta:4.5
kde-base/okular:4.5
kde-base/palapeli:4.5
kde-base/parley:4.5
kde-base/plasma-apps:4.5
kde-base/plasma-runtime:4.5
kde-base/powerdevil:4.5
kde-base/pykde4:4.5
kde-base/qguiplatformplugin_kde:4.5
kde-base/renamedlg-plugins:4.5
kde-base/rocs:4.5
kde-base/solid-runtime:4.5
kde-base/step:4.5
kde-base/superkaramba:4.5
kde-base/svgpart:4.5
kde-base/sweeper:4.5
kde-base/systemsettings:4.5
kde-base/thumbnailers:4.5
mail-client/evolution:2.0
media-gfx/f-spot:0
media-libs/libcanberra:0
media-libs/liblastfm:0
media-libs/mlt:0
media-libs/phonon-gstreamer:0
media-libs/phonon-vlc:0
media-libs/qimageblitz:0
media-plugins/gst-plugins-soup:0.10
media-sound/clementine:0
media-sound/rhythmbox:0
media-video/totem:0
media-video/vlc:0
net-irc/konversation:4
net-libs/gtk-vnc:0
net-libs/libproxy:0
net-libs/webkit-gtk:2
net-print/gnome-cups-manager:0
net-voip/ekiga:0
net-wireless/gnome-bluetooth:2
sys-devel/gcc:4.4
x11-libs/cairo:0
x11-libs/gtk+:2
x11-libs/libgksu:2
x11-wm/compiz:0

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "kde-base/activitymanager:4.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/activitymanager-4.5.5 (masked by: ~x86 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

 *
 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 *
 * To remove temporary files, please run:
 * rm /var/cache/revdep-rebuild/*.rr
(chroot) debian mattylux #

_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
marziods
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2009
Posts: 118
Location: <Roma>par lavor | Udine | Friul | Italie

PostPosted: Sat Apr 02, 2011 11:55 am    Post subject: Reply with quote

scusate, forse dico una str...ata ma non è che per caso hai fatto come me con python? prova a vedere che versione hai installato
Code:
eix -e python

e quale stai usando... con
Code:
python -v

io distrattamente avevo tutta una seri di errori strani...
se cosi fosse qui la soluzione
_________________
linux user #493115
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Apr 02, 2011 1:09 pm    Post subject: Reply with quote

Onip wrote:
Se il gcc non gli funziona, come fa a ricompilare la libreria?


ricompilare era per modo di dire :)
Code:
md64box ~ # emerge -gkav mpfr

These are the packages that would be merged, in order:

Calculating dependencies... done!
[binary   R   ] dev-libs/mpfr-3.0.0_p3

Total: 1 package (1 reinstall, 1 binary), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]


P.S. @mattylux, se proprio non sai dove mettere mani posso consigliarti una serie di workaround un po' sporchi
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sat Apr 02, 2011 2:26 pm    Post subject: Reply with quote

niente da fare sempre quel maledetto messaggio

Code:
alculating dependencies... done!
[ebuild   R   ] dev-libs/mpfr-3.0.0_p3  0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-libs/mpfr-3.0.0_p3
openpty failed: 'out of pty devices'
 * mpfr-3.0.0.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                    [ ok ]
 * Package:    dev-libs/mpfr-3.0.0_p3
 * Repository: gentoo
 * Maintainer: toolchain@gentoo.org
 * USE:        elibc_glibc kernel_linux userland_GNU x86
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking mpfr-3.0.0.tar.bz2 to /var/tmp/portage/dev-libs/mpfr-3.0.0_p3/work
 * Applying patch01 ...                                                  [ ok ]
 * Applying patch02 ...                                                  [ ok ]
 * Applying patch03 ...                                                  [ ok ]
>>> Source unpacked in /var/tmp/portage/dev-libs/mpfr-3.0.0_p3/work
>>> Compiling source in /var/tmp/portage/dev-libs/mpfr-3.0.0_p3/work/mpfr-3.0.0 ...
 * econf: updating mpfr-3.0.0/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating mpfr-3.0.0/config.guess with /usr/share/gnuconfig/config.guess
./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to disable maintainer-specific portions of Makefiles... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/dev-libs/mpfr-3.0.0_p3/work/mpfr-3.0.0':
configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-libs/mpfr-3.0.0_p3/work/mpfr-3.0.0/config.log
 * ERROR: dev-libs/mpfr-3.0.0_p3 failed (compile phase):
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 2150:  Called _eapi0_src_compile
 *     ebuild.sh, line  623:  Called econf
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =dev-libs/mpfr-3.0.0_p3',
 * the complete build log and the output of 'emerge -pqv =dev-libs/mpfr-3.0.0_p3'.
 * The complete build log is located at '/var/tmp/portage/dev-libs/mpfr-3.0.0_p3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/mpfr-3.0.0_p3/temp/environment'.
 * S: '/var/tmp/portage/dev-libs/mpfr-3.0.0_p3/work/mpfr-3.0.0'

>>> Failed to emerge dev-libs/mpfr-3.0.0_p3, Log file:

>>>  '/var/tmp/portage/dev-libs/mpfr-3.0.0_p3/temp/build.log'

 * Messages for package dev-libs/mpfr-3.0.0_p3:

 * ERROR: dev-libs/mpfr-3.0.0_p3 failed (compile phase):
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 2150:  Called _eapi0_src_compile
 *     ebuild.sh, line  623:  Called econf
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =dev-libs/mpfr-3.0.0_p3',
 * the complete build log and the output of 'emerge -pqv =dev-libs/mpfr-3.0.0_p3'.
 * The complete build log is located at '/var/tmp/portage/dev-libs/mpfr-3.0.0_p3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/mpfr-3.0.0_p3/temp/environment'.
 * S: '/var/tmp/portage/dev-libs/mpfr-3.0.0_p3/work/mpfr-3.0.0'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Apr 02, 2011 4:03 pm    Post subject: Reply with quote

mattylux wrote:
niente da fare sempre quel maledetto messaggio

Code:
PORTAGE_BINHOST="http://tinderbox.dev.gentoo.org/default-linux/x86" emerge -gkav mpfr

_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sat Apr 02, 2011 6:48 pm    Post subject: Reply with quote

allora il binario sono riuscito ad installarlo ma purtropo il problema persiste

configure: error: in `/var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04':
configure: error: C compiler cannot create executables
See `config.log' for more details.



Code:
>> Emerging (1 of 133) dev-lang/nasm-2.09.04
openpty failed: 'out of pty devices'
 * nasm-2.09.04.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                  [ ok ]
 * Package:    dev-lang/nasm-2.09.04
 * Repository: gentoo
 * Maintainer: mr_bones_@gentoo.org
 * USE:        elibc_glibc kernel_linux userland_GNU x86
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking nasm-2.09.04.tar.bz2 to /var/tmp/portage/dev-lang/nasm-2.09.04/work
>>> Source unpacked in /var/tmp/portage/dev-lang/nasm-2.09.04/work
>>> Preparing source in /var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04 ...
./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04':
configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04/config.log
 * ERROR: dev-lang/nasm-2.09.04 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 2467:  Called econf
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =dev-lang/nasm-2.09.04',
 * the complete build log and the output of 'emerge -pqv =dev-lang/nasm-2.09.04'.
 * The complete build log is located at '/var/tmp/portage/dev-lang/nasm-2.09.04/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/nasm-2.09.04/temp/environment'.
 * S: '/var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04'

>>> Failed to emerge dev-lang/nasm-2.09.04, Log file:

>>>  '/var/tmp/portage/dev-lang/nasm-2.09.04/temp/build.log'

 * Messages for package dev-lang/nasm-2.09.04:

 * ERROR: dev-lang/nasm-2.09.04 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 2467:  Called econf
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =dev-lang/nasm-2.09.04',
 * the complete build log and the output of 'emerge -pqv =dev-lang/nasm-2.09.04'.
 * The complete build log is located at '/var/tmp/portage/dev-lang/nasm-2.09.04/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/nasm-2.09.04/temp/environment'.
 * S: '/var/tmp/portage/dev-lang/nasm-2.09.04/work/nasm-2.09.04'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


questo è il mio make.conf
Code:

CHOST="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"

USE="X  apache2 php mysql mysqli ssl -qt4  udev   dvd dvdr gconf vala cdr mp3 mp4  wav  alsa  embedded  kde kdrive  fbcondecor firefox git teamarena gstreamer mmx  mpeg jpeg static-libs avi -doc intel  gnome pdf gtk startup-notification usb xml python kerberos acl winbind  perl theora  compiz-fusion cairo emerald ogg flac xulrunner aac sse -svg unicode dbus  svg djvu dv evo exif ssl ffmpeg aalib iplayer nsplugin kde qt"

INPUT_DEVICES="keyboard mouse  evdev void synaptics"
VIDEO_CARDS="intel"
LINGUAS="it"
MAKEOPTS="-j3"
LINGUAGE="it"
GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo/"
ACCEPT_LICENSE="*"
GENTOO_MIRRORS="http://gentoo.modulix.net/gentoo/ ftp://de-mirror.org/distro/ge$
FEATURES="${FEATURES} metadata-transfer"
#PORTAGE_BINHOST="http://tinderbox.dev.gentoo.org/default-linux/x86"

source /var/lib/layman/make.conf


a questo punto non ho proprio idea di che cosa possa essere
questo è il mio eix -I


[
Code:
D] sys-devel/gcc
     Available versions: 
   (2.95)   2.95.3-r9 ~2.95.3-r10!s
   (3.1)   3.1.1-r2
   (3.2)   **3.2.2!s 3.2.3-r4
   (3.3)   ~3.3.6-r1!s
   (3.4)   3.4.6-r2!s
   (4.0)   ~*4.0.4!s
   (4.1)   4.1.2!s
   (4.2)   ~4.2.4-r1!s
   (4.3)   ~4.3.3-r2!s 4.3.4!s ~4.3.5!s
   (4.4)   ~4.4.2!s 4.4.3-r2!s ~4.4.3-r3!s ~4.4.4-r1!s 4.4.4-r2!s ~4.4.5!s
   (4.5)   ~4.5.1-r1!s
   {altivec bootstrap boundschecking build d doc fixed-point fortran gcj graphite gtk hardened ip28 ip32r10k java libffi lto mudflap multilib multislot n32 n64 nls nocxx nopie nossp nptl objc objc++ objc-gc openmp static test vanilla}
     Installed versions:  4.4.5(4.4)!s(23:32:12 06/03/2011)(fortran gtk mudflap nls nptl openmp -altivec -bootstrap -build -doc -fixed-point -gcj -graphite -hardened -libffi -multilib -multislot -n32 -n64 -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla)
     Homepage:            http://gcc.gnu.org/
     Description:         The GNU Compiler Collection

[I] sys-devel/gcc-config
     Available versions:  1.3.16 1.4.0-r4 1.4.1 **1.5
     Installed versions:  1.4.1(18:54:57 21/09/2010)
     Homepage:            http://www.gentoo.org/
     Description:         Utility to change the gcc compiler being used

Found 2 matches.

_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Mon Apr 04, 2011 8:19 am    Post subject: Reply with quote

mattylux wrote:

a questo punto non ho proprio idea di che cosa possa essere


Come già scritto sopra non devi re-installare la libreria, quella è a posto. Ma fare in modo di avere un compilatore funzionante.

Prova, in sequenza, a
1) mettere il binario di sys-devel-gcc (il comando è simile a quello che ti ha dato ago) e vedi se compila.
2) se la 1 non funziona prova a mettere una versione vecchia di mpfr con
Code:
PORTAGE_..... emerge =dev-libs/mpfr-VECCHIA
in modo da avere la libreria nella versiona giusta per far funzionare il tuo gcc.
Una volta che funziona procedi alla ricompilazione di mpfr nuova e subito dopo gcc seguendo le istruzioni che l'upgrade di mpfr ti da in elog.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum