Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Richiesta downgrade forzato Qt
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
merlok
n00b
n00b


Joined: 01 Apr 2011
Posts: 3

PostPosted: Fri Apr 01, 2011 2:10 pm    Post subject: [RISOLTO] Richiesta downgrade forzato Qt Reply with quote

Salve a tutti ho un piccolo problema tentando d aggiornare.
Giorni fà ho deciso di fare il salto e passare a kde 4.6.1, ho smascherato il necessario e tutto è filato liscio fino ad oggi.
Ora non capisco quale pacchetto mi forza a fare il downgrade delle qt da 4.7.2 a 4.6.3 :? .
Code:
masamune  # emerge -DNtupv @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge      ] media-video/mplayer-1.0_rc4_p20101114  USE="X a52 alsa ass cddb cdio dirac dts dv dvd dvdnav enca encode esd faac faad gif iconv ipv6 jpeg live mad mmx mng mp3 network opengl osdmenu png pulseaudio quicktime rar real rtc schroedinger sdl shm speex sse sse2 ssse3 theora toolame tremor truetype twolame unicode vorbis x264 xscreensaver xv xvid -3dnow -3dnowext -aalib (-altivec) -amr (-aqua) -bidi -bindist -bl (-bluray) -bs2b -cdparanoia -cpudetection -custom-cpuopts -debug -dga -directfb -doc -dvb -dxr3 -fbcon -ftp -ggi -gsm -jack -joystick -jpeg2k -ladspa -libcaca -libmpeg2 -lirc -lzo -md5sum -mmxext -mpg123 -nas -nut -openal -oss -pnm -pvr -radio -rtmp -samba -tga -v4l -v4l2 -vdpau (-vidix) -vpx (-win32codecs) -xanim -xinerama -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx -vesa"  [0]
[nomerge      ]  media-libs/libass-0.9.11  USE="enca fontconfig"  [0]
[nomerge      ]   app-i18n/enca-1.13  USE="recode -doc"  [0]
[ebuild   R   ]    app-text/recode-3.6_p17-r2  USE="nls -static-libs%" 0 kB [0]
[ebuild     U ]  media-libs/schroedinger-1.0.10 [1.0.8] 974 kB [0]
[ebuild     U ] app-shells/zsh-completion-20091203-r1 [20080310] 0 kB [?=>0]
[ebuild   R   ] media-gfx/gimp-2.6.11-r1  USE="alsa dbus exif jpeg lcms mmx mng pdf png python smp sse svg tiff -aalib (-altivec) -curl -debug -doc -gnome -webkit -wmf (-hal%*)" 0 kB [0]
[ebuild     U ] net-misc/wicd-1.7.1_beta2-r3 [1.7.0] USE="X libnotify ncurses nls pm-utils -gtk (-ioctl)" 499 kB [?=>0]
[ebuild     U ] www-client/firefox-4.0-r2 [4.0-r1] USE="alsa dbus ipc libnotify startup-notification webm wifi -bindist -custom-optimization -debug -system-sqlite" LINGUAS="en it -af -ak -ar -ast -be -bg -bn -bn_BD -bn_IN -br -bs -ca -cs -cy -da -de -el -en_ZA -eo -es -es_ES -et -eu -fa -fi -fr -fy -fy_NL -ga -ga_IE -gd -gl -gu -gu_IN -he -hi -hi_IN -hr -hu -hy -hy_AM -id -is -ja -kk -kn -ko -ku -lg -lt -lv -mai -mk -ml -mr -nb -nb_NO -nl -nn -nn_NO -nso -or -pa -pa_IN -pl -pt -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zu" 0 kB [0]
[ebuild   R   ] www-plugins/adobe-flash-10.2.153.1  USE="-vdpau (-nspluginwrapper%*)" 0 kB [0]
[nomerge      ] app-emulation/vmware-workstation-7.1.3.324285  USE="vmware-tools -doc -vix"  [1]
[ebuild     U ]  app-emulation/vmware-modules-238.3-r8 [238.3-r5] 0 kB [1=>0]
[nomerge      ] net-misc/wicd-1.7.1_beta2-r3 [1.7.0] USE="X libnotify ncurses nls pm-utils -gtk (-ioctl)"  [?=>0]
[ebuild     U ]  dev-python/notify-python-0.1.1-r2 [0.1.1-r1] USE="-examples%" 0 kB [?=>0]
[nomerge      ] kde-base/kdebase-runtime-meta-4.6.1  USE="handbook (-aqua) (-kdeprefix) -semantic-desktop"  [0]
[nomerge      ]  kde-base/ktimezoned-4.6.1  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)"  [0]
[nomerge      ]   kde-base/kdelibs-4.6.1-r2  USE="acl alsa bzip2 fam handbook mmx nls opengl policykit spell sse sse2 ssl udev -3dnow (-altivec) (-aqua) -bindist -debug -doc -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma -openexr -semantic-desktop -test -zeroconf"  [0]
[nomerge      ]    media-libs/phonon-4.4.4  USE="pulseaudio vlc -debug -gstreamer -xine"  [0]
[nomerge      ]     media-libs/phonon-vlc-0.3.2  USE="-debug -v4l2"  [0]
[ebuild     U ]      media-video/vlc-1.1.8 [1.1.7] USE="X a52 aac alsa dbus dts dvd ffmpeg flac gcrypt libnotify mmx mp3 mpeg ncurses ogg opengl png pulseaudio sdl sse svg truetype udev vorbis x264 xcb xml xv -aalib (-altivec) -atmo -avahi -bidi -cdda -cddb -dc1394 -debug -dirac -directfb -dvb -fbcon -fluidsynth -fontconfig -ggi -gme -gnome -gnutls -httpd -id3tag -ieee1394 -jack -kate -kde -libass -libcaca -libproxy -libtiger -libv4l -libv4l2 -lirc -live -lua -matroska -modplug -mtp -musepack -nsplugin -optimisememory -oss -projectm -pvr -qt4 -remoteosd -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -skins -speex -sqlite -stream (-svga) -taglib -theora -twolame -upnp -v4l -v4l2 -vaapi -vcdx -vlm (-win32codecs) -wma-fixed -xosd -zvbi" 24,626 kB [0]
[ebuild     U ]       x11-libs/libnotify-0.7.2 [0.5.2] USE="-doc% (-introspection) (-test)" 314 kB [0]
[nomerge      ] app-text/texlive-2008  USE="X graphics png science truetype xml -cjk -context -cyrillic -detex -doc -dvi2tty -dvipdfm -extra -games -humanities -jadetex -latex3 -music -omega -pstricks -publishers -tex4ht -xetex -xindy" LINGUAS="en it -af -ar -bg -bn -bo -cs -cy -da -de -el -en_GB -eo -es -et -fi -fr -ga -he -hi -hr -hsb -hu -hy -id -is -ja -ko -la -ml -mn -nl -no -pl -pt -ro -ru -sk -sl -sr -sv -ta -th -tr -uk -vi -zh"  [0]
[nomerge      ]  dev-tex/latex-beamer-3.07  USE="-doc -examples -lyx"  [0]
[nomerge      ]   dev-tex/pgf-2.00  USE="-doc"  [0]
[nomerge      ]    dev-texlive/texlive-latexrecommended-2008-r2  USE="-doc -source"  [0]
[nomerge      ]     dev-texlive/texlive-latex-2008-r2  USE="-doc -source"  [0]
[nomerge      ]      dev-tex/luatex-0.63.0  USE="-doc"  [0]
[ebuild     U ]       dev-libs/zziplib-0.13.60-r1 [0.13.60] USE="sdl -doc -static-libs -test" 0 kB [0]
[nomerge      ] kde-base/kdm-4.6.1  USE="consolekit handbook pam (-aqua) -debug (-kdeenablefinal) (-kdeprefix) -kerberos"  [0]
[nomerge      ]  kde-base/kdepasswd-4.6.1  USE="handbook (-aqua) -debug (-kdeenablefinal) (-kdeprefix)"  [0]
[nomerge      ]   kde-base/kdelibs-4.6.1-r2  USE="acl alsa bzip2 fam handbook mmx nls opengl policykit spell sse sse2 ssl udev -3dnow (-altivec) (-aqua) -bindist -debug -doc -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma -openexr -semantic-desktop -test -zeroconf"  [0]
[nomerge      ]    kde-misc/polkit-kde-kcmodules-0.98_pre20101127  USE="(-aqua) -debug (-kdeenablefinal)"  [0]
[ebuild     UD]     x11-libs/qt-qt3support-4.6.3 [4.7.2] USE="accessibility exceptions kde (-aqua) -debug -pch -phonon" 0 kB [0]
[ebuild     UD]      x11-libs/qt-sql-4.6.3-r2 [4.7.2] USE="exceptions iconv qt3support sqlite (-aqua) -debug (-firebird) -freetds -mysql -odbc -pch -postgres" 0 kB [0]
[ebuild     UD]      x11-libs/qt-gui-4.6.3-r2 [4.7.2] USE="accessibility cups dbus exceptions glib mng qt3support tiff (-aqua) -debug -gtk -nas -nis -pch -raster -trace -xinerama (-egl%) (-private-headers%)" 0 kB [0]
[ebuild     UD]       x11-libs/qt-dbus-4.6.3 [4.7.2] USE="exceptions (-aqua) -debug -pch" 0 kB [0]
[ebuild     UD]       x11-libs/qt-script-4.6.3 [4.7.2] USE="exceptions iconv (-aqua) -debug -pch (-jit%*) (-private-headers%)" 0 kB [0]
[ebuild     UD]        x11-libs/qt-core-4.6.3 [4.7.2] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -doc% -optimized-qmake -pch (-jit%*) (-private-headers%)" 0 kB [0]
[nomerge      ] app-emulation/vmware-workstation-7.1.3.324285  USE="vmware-tools -doc -vix"  [1]
[nomerge      ]  x11-libs/libgksu-2.0.12-r1  USE="nls -doc"  [?]
[nomerge      ]   app-admin/sudo-1.7.4_p5  USE="ldap pam -offensive (-selinux) -skey"  [0]
[ebuild  N    ]    virtual/mta-0  0 kB [?=>0]
[ebuild  NS   ] sys-kernel/gentoo-sources-2.6.38-r1 [2.6.38] USE="symlink -build -deblob" 63 kB [0]
[ebuild     U ] www-servers/apache-2.2.17 [2.2.16] USE="ldap ssl threads -debug -doc (-selinux) -static -suexec" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias -asis -auth_digest -authn_dbd -cern_meta -charset_lite -dbd -dumpio -ident -imagemap -log_forensic -proxy -proxy_ajp -proxy_balancer -proxy_connect -proxy_ftp -proxy_http -proxy_scgi% -reqtimeout% -substitute -version" APACHE2_MPMS="-event -itk -peruser -prefork -worker" 4,897 kB [0]
[ebuild     U ]  app-admin/apache-tools-2.2.17 [2.2.16] USE="ssl" 0 kB [0]
[nomerge      ] media-libs/schroedinger-1.0.10 [1.0.8] [0]
[ebuild  N    ]  dev-lang/orc-0.4.11  USE="-examples -static-libs" 661 kB [0]
[ebuild     U ] net-misc/rsync-3.0.8 [3.0.7] USE="acl iconv ipv6 -static -xattr" 773 kB [?=>0]
[blocks B     ] <x11-libs/qt-sql-4.7.2 ("<x11-libs/qt-sql-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-declarative-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-opengl-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B     ] >x11-libs/qt-dbus-4.6.3-r9999 (">x11-libs/qt-dbus-4.6.3-r9999" is blocking x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-script-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3)
[blocks B     ] >x11-libs/qt-qt3support-4.6.3-r9999 (">x11-libs/qt-qt3support-4.6.3-r9999" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-sql-4.6.3-r2)
[blocks B     ] >x11-libs/qt-gui-4.6.3-r9999 (">x11-libs/qt-gui-4.6.3-r9999" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3)
[blocks B     ] >x11-libs/qt-script-4.6.3-r9999 (">x11-libs/qt-script-4.6.3-r9999" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3)
[blocks B     ] mail-mta/ssmtp ("virtual/mta" is blocking mail-mta/ssmtp-2.62-r8)
[blocks B     ] >x11-libs/qt-sql-4.6.3-r9999 (">x11-libs/qt-sql-4.6.3-r9999" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3)
[blocks B     ] >x11-libs/qt-opengl-4.6.3-r9999 (">x11-libs/qt-opengl-4.6.3-r9999" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3)
[blocks B     ] >x11-libs/qt-xmlpatterns-4.6.3-r9999 (">x11-libs/qt-xmlpatterns-4.6.3-r9999" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3)
[blocks B     ] <x11-libs/qt-dbus-4.7.2 ("<x11-libs/qt-dbus-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-declarative-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-opengl-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B     ] >x11-libs/qt-core-4.6.3-r9999 (">x11-libs/qt-core-4.6.3-r9999" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-sql-4.6.3-r2)
[blocks B     ] <x11-libs/qt-qt3support-4.7.2 ("<x11-libs/qt-qt3support-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-declarative-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-opengl-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B     ] <x11-libs/qt-core-4.7.2 ("<x11-libs/qt-core-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-declarative-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-opengl-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B     ] >x11-libs/qt-svg-4.6.3-r9999 (">x11-libs/qt-svg-4.6.3-r9999" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3)
[blocks B     ] <x11-libs/qt-script-4.7.2 ("<x11-libs/qt-script-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-declarative-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-opengl-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B     ] >x11-libs/qt-test-4.6.3-r9999 (">x11-libs/qt-test-4.6.3-r9999" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3)
[blocks B     ] >x11-libs/qt-webkit-4.6.3-r9999 (">x11-libs/qt-webkit-4.6.3-r9999" is blocking x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3)

Total: 24 packages (12 upgrades, 6 downgrades, 2 new, 1 in new slot, 3 reinstalls), Size of downloads: 32,802 kB
Conflict: 17 blocks (17 unsatisfied)
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/vmware
 [?] indicates that the source repository could not be determined

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-libs/qt-script-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-script-4.7.0:4 required by (kde-base/libtaskmanager-4.6.1::gentoo, installed)
    >=x11-libs/qt-script-4.7.0:4 required by (kde-base/kstartupconfig-4.6.1::gentoo, installed)
    >=x11-libs/qt-script-4.7.0:4 required by (kde-base/plasma-runtime-4.6.1::gentoo, installed)
    (and 78 more)

  (x11-libs/qt-test-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-test-4.7.0:4 required by (kde-base/kdelibs-4.6.1-r2::gentoo, installed)
    >=x11-libs/qt-test-4.7.0:4 required by (kde-base/knetattach-4.6.1::gentoo, installed)
    >=x11-libs/qt-test-4.7.0:4 required by (kde-base/kioclient-4.6.1::gentoo, installed)
    (and 77 more)

  (x11-libs/qt-qt3support-4.6.3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-qt3support-4.6.0:4[accessibility,kde] required by (net-wireless/bluedevil-1.0.3::gentoo, installed)
    >=x11-libs/qt-qt3support-4.6.0:4[accessibility,kde] required by (sys-auth/polkit-kde-agent-0.99.0::gentoo, installed)
    ~x11-libs/qt-qt3support-4.6.3[-aqua,-debug] required by (x11-libs/qt-gui-4.6.3-r2::gentoo, ebuild scheduled for merge)
    (and 2 more)

  (virtual/mta-0::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/mta-0 required by (app-admin/sudo-1.7.4_p5::gentoo, installed)
    =virtual/mta-0 required by (dev-lang/php-5.3.5::gentoo, installed)
    =virtual/mta-0 required by (app-crypt/gnupg-2.0.17::gentoo, installed)

  (x11-libs/qt-sql-4.6.3-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-sql-4.6.0:4[qt3support] required by (sys-auth/polkit-kde-agent-0.99.0::gentoo, installed)
    >=x11-libs/qt-sql-4.6.0:4[qt3support] required by (kde-misc/polkit-kde-kcmodules-0.98_pre20101127::gentoo, installed)
    >=x11-libs/qt-sql-4.6.2:4 required by (dev-python/PyQt4-4.8.3::gentoo, installed)
    (and 3 more)

  (x11-libs/qt-dbus-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-dbus-4.6.2:4 required by (dev-python/PyQt4-4.8.3::gentoo, installed)
    >=x11-libs/qt-dbus-4.6.0:4 required by (media-libs/phonon-4.4.4::gentoo, installed)
    >=x11-libs/qt-dbus-4.6.0:4 required by (media-libs/phonon-vlc-0.3.2::gentoo, installed)
    (and 2 more)

  (x11-libs/qt-core-4.6.3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-core-4.6.3:4 required by (dev-libs/libdbusmenu-qt-0.6.2::gentoo, installed)
    >=x11-libs/qt-core-4.6.0:4 required by (media-libs/phonon-4.4.4::gentoo, installed)
    ~x11-libs/qt-core-4.6.3[-aqua,-debug,glib,qt3support] required by (x11-libs/qt-gui-4.6.3-r2::gentoo, ebuild scheduled for merge)
    (and 13 more)

  (x11-libs/qt-gui-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-gui-4.7.0:4[accessibility,dbus] required by (kde-base/kcmshell-4.6.1::gentoo, installed)
    >=x11-libs/qt-gui-4.7.0:4[accessibility,dbus] required by (kde-base/systemsettings-4.6.1::gentoo, installed)
    >=x11-libs/qt-gui-4.7.0:4[accessibility,dbus] required by (kde-base/krunner-4.6.1::gentoo, installed)
    (and 88 more)

  (x11-libs/qt-script-4.6.3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/qt-script-4.6.0:4 required by (net-libs/libbluedevil-1.8::gentoo, installed)
    >=x11-libs/qt-script-4.6.0:4 required by (kde-misc/polkit-kde-kcmodules-0.98_pre20101127::gentoo, installed)
    >=x11-libs/qt-script-4.6.2:4 required by (dev-python/PyQt4-4.8.3::gentoo, installed)
    (and 3 more)

  (x11-libs/qt-sql-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/khotkeys-4.6.1::gentoo, installed)
    >=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/dolphin-4.6.1::gentoo, installed)
    >=x11-libs/qt-sql-4.7.0:4[qt3support] required by (kde-base/kate-4.6.1::gentoo, installed)
    (and 78 more)

  (x11-libs/qt-qt3support-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-qt3support-4.7.0:4[accessibility,kde] required by (kde-base/kmix-4.6.1::gentoo, installed)
    >=x11-libs/qt-qt3support-4.7.0:4[accessibility,kde] required by (kde-base/drkonqi-4.6.1::gentoo, installed)
    >=x11-libs/qt-qt3support-4.7.0:4[accessibility,kde] required by (kde-base/kcminit-4.6.1::gentoo, installed)
    (and 77 more)

  (x11-libs/qt-opengl-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-opengl-4.7.0:4 required by (kde-base/systemsettings-4.6.1::gentoo, installed)
    >=x11-libs/qt-opengl-4.7.0:4[-egl] required by (dev-python/PyQt4-4.8.3::gentoo, installed)
    >=x11-libs/qt-opengl-4.7.0:4 required by (kde-base/krunner-4.6.1::gentoo, installed)
    (and 6 more)

  (x11-libs/qt-core-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-core-4.7.0:4[qt3support,ssl] required by (kde-base/kcminit-4.6.1::gentoo, installed)
    >=x11-libs/qt-core-4.7.0:4[qt3support,ssl] required by (kde-base/kdebase-data-4.6.1::gentoo, installed)
    >=x11-libs/qt-core-4.7.0:4[qt3support,ssl] required by (kde-base/kcontrol-4.6.1::gentoo, installed)
    (and 92 more)

  (x11-libs/qt-dbus-4.6.3::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-dbus-4.6.3[-aqua,-debug] required by (x11-libs/qt-gui-4.6.3-r2::gentoo, ebuild scheduled for merge)
    >=x11-libs/qt-dbus-4.6.0:4 required by (media-libs/phonon-vlc-0.3.2::gentoo, installed)
    >=x11-libs/qt-dbus-4.6.0:4 required by (media-libs/phonon-4.4.4::gentoo, installed)
    (and 1 more)

  (x11-libs/qt-declarative-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-declarative-4.6.2:4 required by (dev-python/PyQt4-4.8.3::gentoo, installed)
    >=x11-libs/qt-declarative-4.7.0:4 required by (kde-base/kdelibs-4.6.1-r2::gentoo, installed)
    >=x11-libs/qt-declarative-4.7.0:4 required by (kde-base/plasma-runtime-4.6.1::gentoo, installed)

  (x11-libs/qt-svg-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-svg-4.7.0:4 required by (kde-base/khotkeys-4.6.1::gentoo, installed)
    >=x11-libs/qt-svg-4.7.0:4 required by (kde-base/activitymanager-4.6.1::gentoo, installed)
    >=x11-libs/qt-svg-4.7.0:4 required by (kde-base/kdelibs-4.6.1-r2::gentoo, installed)
    (and 77 more)

  (x11-libs/qt-webkit-4.7.2::gentoo, installed) pulled in by
    >=x11-libs/qt-webkit-4.7.0:4[kde] required by (kde-base/kdelibs-4.6.1-r2::gentoo, installed)
    >=x11-libs/qt-webkit-4.6.2:4 required by (dev-python/PyQt4-4.8.3::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


invece questo è il package.keywords riguardante le qt

Code:
=x11-libs/qt-script-4.7.2 ~amd64
=x11-libs/qt-core-4.7.2 ~amd64
=x11-libs/qt-gui-4.7.2 ~amd64
=x11-libs/qt-dbus-4.7.2 ~amd64
=x11-libs/qt-qt3support-4.7.2 ~amd64
=x11-libs/qt-sql-4.7.2 ~amd64
=x11-libs/qt-test-4.7.2 ~amd64
=x11-libs/qt-svg-4.7.2 ~amd64
=sys-auth/polkit-qt-0.99.0 ~amd64
=x11-libs/qt-webkit-4.7.2 ~amd64
=x11-libs/qt-declarative-4.7.2 ~amd64
=media-libs/phonon-4.4.4 ~amd64
=x11-libs/qt-opengl-4.7.2 ~amd64
=dev-libs/libattica-0.2.0 ~amd64
=sys-auth/polkit-kde-agent-0.99.0 ~amd64
=x11-libs/qt-xmlpatterns-4.7.2 ~amd64
# move media-sound/phonon-vlc media-libs/phonon-vlc
=media-libs/phonon-vlc-0.3.2 ~amd64
=net-wireless/bluedevil-1.0.3 ~amd64
=net-libs/libbluedevil-1.8 ~amd64
=dev-python/PyQt4-4.8.3 ~amd64
=dev-python/sip-4.12.1 ~amd64


Qualche idea?
Grazie anticipatamente :D


Last edited by merlok on Fri Apr 01, 2011 3:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri Apr 01, 2011 2:59 pm    Post subject: Reply with quote

hai smascherato tutto con =...-4.7.2, ma per alcuni pacchetti la 4.7.2 è stata sostituita da 4.7.2-rX. una soluzione rapida è quella di sostituire gli = con dei ~. e riprovare
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
merlok
n00b
n00b


Joined: 01 Apr 2011
Posts: 3

PostPosted: Fri Apr 01, 2011 3:17 pm    Post subject: Reply with quote

Grazie mille risolto, avevo controllato tutto tranne la versione delle qt disponibili :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum