Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Problema con x11-libs/fltk:1.1 ed emerge
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Mar 30, 2011 11:57 am    Post subject: [RISOLTO] Problema con x11-libs/fltk:1.1 ed emerge Reply with quote

Salve a tutti,

è da un po' di tempo che ottengo questo messaggio ogni volta che faccio un emerge -uDNav world.
Code:
!!! Problems have been detected with your world file
!!! Please run emaint --check world


!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
x11-libs/fltk:1.1

Ho provato anche a fare emaint --check world come dice il messaggio ma non risolve il problema. Non capisco perché si lamenti di ciò.
Code:
$ eix -e fltk
[I] x11-libs/fltk
     Available versions: 
        (1)     1.1.9-r1 ~1.1.9-r2 ~1.1.10-r1 ~1.1.10-r2 ~1.3.0_rc3-r1
        (2)     2.0_pre6970 ~2.0_pre6970-r1
        {cairo debug doc examples games +jpeg opengl pdf +png threads (+)xft xinerama zlib}
     Installed versions:  1.1.9-r1(1)(09:53:01 PM 03/22/2011)(opengl -doc -examples -games -threads -xft -xinerama) 2.0_pre6970(2)(03:23:39 PM 06/28/2010)(cairo jpeg opengl png xft zlib -debug -doc -xinerama)
     Homepage:            http://www.fltk.org/
     Description:         C++ user interface toolkit for X and OpenGL

Qualcuno sa come fare ad eliminare quel messaggio e soprattutto perché accade?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered


Last edited by fbcyborg on Wed Mar 30, 2011 1:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Wed Mar 30, 2011 12:50 pm    Post subject: Reply with quote

Lui ti dice che x11-libs/fltk:1.1, non esiste. Ed infatti è vero: esistono solamente gli slot 1 e 2. In quanto ad eliminare il messaggio secondo me devi cercare di capire chi è che te lo richiede (con -t ad esempio) e vedere di correggere (o far correggere) le dipendenze nell'ebuild. Se, invece, ce l'hai in world per qualche motivo allora puoi correggere a mano la voce nel file (voce che, per dirla tutta non dovrebbe esserci, in quanto fltk è quasi sicuramente dipendenza di qualcos'altro).
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Mar 30, 2011 1:09 pm    Post subject: Reply with quote

OK, grazie. Non sono riuscito a capire quale fosse il pacchetto che richiedeva quel fltk:1.1.
Comunque dopo vari tentativi e un
Code:
emaint --fix world
sono riuscito a risolvere finalmente!

Grazie ancora!
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Wed Mar 30, 2011 7:43 pm    Post subject: Reply with quote

in generale anche regenworld ti può essere d'aiuto ;)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Mar 30, 2011 7:48 pm    Post subject: Reply with quote

Grazie!
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum