Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] Failed Running libtoolize! (Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
nexus6
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2007
Posts: 92

PostPosted: Tue Mar 29, 2011 10:51 pm    Post subject: [emerge] Failed Running libtoolize! (Résolu) Reply with quote

Salut !

En ce moment, j'ai mon manchot qui fais sa mue vers KDE, mais le petit Tux n'arrive pas à compiler correctement dés lors qu'il s'agit de 'libtoolsizer' un paquet, exemple :


Code:

* dev-db/mysql-5.1.51

│INFO: setup                                                                   │
│Package:    dev-db/mysql-5.1.51                                               │
│Repository: gentoo                                                            │
│Maintainer: mysql-bugs@gentoo.org                                             │
│USE:        amd64 community elibc_glibc kernel_linux multilib static          │
│userland_GNU                                                                  │
│FEATURES:   ccache sandbox userpriv usersandbox                               │
│INFO: unpack

│Using default MY_DATADIR                                                      │
│                                                                              │
│LOG: unpack                                                                   │
│MySQL MY_DATADIR is /var/lib/mysql                                            │
│                                                                              │
│INFO: prepare                                                                 │
│using '00350_x86_asm-pic-fixes-5.1.41.patch'                                  │

│>    remove page relocations
│>    Most of the original patch has already been accepted by MysQL,           │
│>    here is the remaining.                                                   │
│>    _many_ thanks to pageexec@freemail.hu                                    │
│using '01050_all_mysql_config_cleanup-5.1.41.patch'                           │
│>    fix bug #156301 mysql_config wrongly retains too much info from CFLAGS   │
│using '02040_all_embedded-library-shared-5.1.50.patch'                        │
│>    Take libmysqld to be a proper shared library.                            │
│using '07040_all_disable_mybug_9735_test-5.1.41.patch' 
│>    disable a test that fail on longtext field length, the expected value is │
│>    three times the returned one, look like a multibyte character related    │
│>    failure.                                                                 │
│using '07110_all_mysql_gcc-4.2_5.1.51.patch'                                  │
│>    Replace max() and min() macro with MYSQL_MIN() and MYSQL_MAX()           │
│>    FIXME: Testing patch - applies cleanly                                   │
│using '07250_all_testcase_latin1_fix-5.1.42.patch'                            │
│>    Latin1 is assumed by the testsuite even with --with-charset=utf8
│>    is passed to configure. Fix mysql_comments test.                         │
│using '07260_all_testsuite_mtr_latin1_fix-5.1.42.patch'                       │
│>    Latin1 is assumed by the testsuite even with --with-charset=utf8         │
│>    is passed to configure. Fix information_schema test.                     │
│using '07280_all_stdbool-5.1.44.patch'                                        │
│>    Fix GCC4.4 stdbool requirement.                                          │
│Applying various patches (bugfixes/updates) ...                               │
│  01050_all_mysql_config_cleanup-5.1.41.patch ...   
│  02040_all_embedded-library-shared-5.1.50.patch ...                          │
│  07040_all_disable_mybug_9735_test-5.1.41.patch ...                          │
│  07110_all_mysql_gcc-4.2_5.1.51.patch ...                                    │
│  07250_all_testcase_latin1_fix-5.1.42.patch ...                              │
│  07260_all_testsuite_mtr_latin1_fix-5.1.42.patch ...                         │
│  07280_all_stdbool-5.1.44.patch ...                                          │
│Done with patching                                                            │
│Cleaning up old buildscript files 
│Reconfiguring dir '.'                                                         │
│Running eautoreconf in '/var/tmp/portage/dev-db/mysql-5.1.51/work/mysql' ...  │
│Running aclocal ...                                                           │
│Running libtoolize --copy --force --install --automake ...                    │
│                                                                              │
│ERROR: prepare                                                                │
│Failed Running libtoolize !

│Include in your bugreport the contents of:                                    │
│                                                                              │
│  /var/tmp/portage/dev-db/mysql-5.1.51/temp/libtoolize.out                    │
│ERROR: dev-db/mysql-5.1.51 failed (prepare phase):                            │
│  Failed Running libtoolize !                                                 │
│                                                                              │
│Call stack:                                                                   │
│    ebuild.sh, line   56:  Called src_prepare                                 │
│                                                   
│  environment, line 4291:  Called mysql_src_prepare                           │
│  environment, line 3901:  Called eautoreconf                                 │
│  environment, line 1337:  Called _elibtoolize '--copy' '--force' '--install' │
│  environment, line  432:  Called autotools_run_tool 'libtoolize' '--copy' '--│
│force' '--install' '--automake'                                               │
│  environment, line  712:  Called die                                         │
│The specific snippet of code:                                                 │
│          die "Failed Running $1 !";
│                                                                              │
│If you need support, post the output of 'emerge --info =dev-db/mysql-5.1.51', │
│the complete build log and the output of 'emerge -pqv =dev-db/mysql-5.1.51'.  │
│The complete build log is located at '/var/tmp/portage/dev-                   │
│db/mysql-5.1.51/temp/build.log'.                                              │
│The ebuild environment file is located at '/var/tmp/portage/dev-              │
│db/mysql-5.1.51/temp/environment'.                                            │
│S: '/var/tmp/portage/dev-db/mysql-5.1.51/work/mysql' 



L'environnement système :

Code:
Portage 2.1.9.42 (default/linux/amd64/10.0/desktop/kde, gcc-4.4.5, glibc-2.11.3-r0, 2.6.36-gentoo-r8-4657-MED-FR x86_64)
=================================================================
System uname: Linux-2.6.36-gentoo-r8-4657-MED-FR-x86_64-Intel-R-_Atom-TM-_CPU_230_@_1.60GHz-with-gentoo-1.12.14
Timestamp of tree: Wed, 23 Mar 2011 17:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p9
dev-lang/python:     2.6.6-r2, 3.1.3-r1
dev-util/ccache:     2.4-r9
dev-util/cmake:      2.8.4
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.65-r1
sys-devel/automake:  1.9.6-r3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ABI="amd64"
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
ACCEPT_PROPERTIES="*"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol"
APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ARCH="amd64"
ASFLAGS_x86="--32"
AUTOCLEAN="yes"
CAMERAS="ptp2"
CBUILD="x86_64-pc-linux-gnu"
CCACHE_DIR="/var/tmp/ccache"
CCACHE_SIZE="2G"
CFLAGS="-march=native -O2 -pipe -s -fomit-frame-pointer"
CFLAGS_x86="-m32"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
COLLISION_IGNORE="/lib/modules"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CVS_RSH="ssh"
CXXFLAGS="-O2 -pipe"
DEFAULT_ABI="amd64"
DISTDIR="/usr/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--jobs=3 --load-average=5.0 --with-bdeps y --keep-going --verbose"
EMERGE_WARNING_DELAY="10"
EPREFIX=""
EROOT="/"
FCFLAGS=""
FEATURES="assume-digests binpkg-logs buildpkg candy ccache distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FETCHCOMMAND="/usr/bin/wget -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
FETCHCOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
FETCHCOMMAND_SFTP="bash -c "x=\${2#sftp://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec sftp -P \${port} \"\${host}:/\${x#*/}\" \"\$1\"" sftp "${DISTDIR}/${FILE}" "${URI}""
FETCHCOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}""
FFLAGS=""
GCC_SPECS=""
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx"
HG="/usr/bin/hg"
HOME="/root"
INFOPATH="/usr/share/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.20.1/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.5/info"
INPUT_DEVICES="evdev keyboard mouse"
KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LDFLAGS_x86="-m elf_i386"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LIBDIR_amd64="lib64"
LIBDIR_amd64_fbsd="lib64"
LIBDIR_ppc="lib32"
LIBDIR_ppc64="lib64"
LIBDIR_s390="lib32"
LIBDIR_s390x="lib64"
LIBDIR_sparc32="lib32"
LIBDIR_sparc64="lib64"
LIBDIR_x86="lib32"
LIBDIR_x86_fbsd="lib32"
LINGUAS="fr fr_FR"
LOGNAME="root"
LS_COLORS="rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:"
MAIL="/var/mail/marco"
MAKEOPTS="-j3 -l3"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.20.1/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.5/man"
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib32 /lib /usr/lib32 /usr/lib /usr/kde/*/lib32 /usr/kde/*/lib /usr/qt/*/lib32 /usr/qt/*/lib /usr/X11R6/lib32 /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage)"
NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/sbin:/bin:/usr/sbin:/usr/bin"
PHP_TARGETS="php5-3"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="ppc sparc64-freebsd ppc-openbsd x86-openbsd ppc64 x86-winnt x86-fbsd ppc-aix alpha arm x86-freebsd s390 amd64 arm-linux x86-macos x64-openbsd ia64-hpux hppa x86-netbsd x86-cygwin amd64-linux ia64-linux x86 sparc-solaris x64-freebsd sparc64-solaris x86-linux x64-macos sparc m68k-mint ia64 mips ppc-macos x86-interix hppa-hpux amd64-fbsd x64-solaris mips-irix m68k sh x86-solaris sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="error info log warn"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="echo:log,warn save:error,info,log,warn syslog:error,warn"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_NICENESS="0"
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="-1"
PORTAGE_SANDBOX_COMPAT_LEVEL="16"
PORTAGE_SYNC_STALE="30"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_VERBOSE="1"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/zugaina /var/lib/layman/rion /usr/local/portage/layman/zugaina /usr/local/portage/layman/rion"
PRELINK_PATH_MASK="/usr/lib64/klibc:/usr/lib64/libfreebl3.so:/usr/lib64/libnssdbm3.so:/usr/lib64/libsoftokn3.so"
PROFILE_ONLY_VARIABLES="ARCH ELIBC KERNEL USERLAND"
PWD="/home/marco"
PYTHONDONTWRITEBYTECODE="1"
RESUMECOMMAND="/usr/bin/wget -c -t 3 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
RESUMECOMMAND_RSYNC="rsync -avP "${URI}" "${DISTDIR}/${FILE}""
RESUMECOMMAND_SSH="bash -c "x=\${2#ssh://} ; host=\${x%%/*} ; port=\${host##*:} ; host=\${host%:*} ; [[ \${host} = \${port} ]] && port=22 ; exec rsync --rsh=\"ssh -p\${port}\" -avP \"\${host}:/\${x#*/}\" \"\$1\"" rsync "${DISTDIR}/${FILE}" "${URI}""
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.4.5"
RPMDIR="/usr/portage/rpm"
RUBY_TARGETS="ruby18"
SANE_CONFIG_DIR="/etc/sane.d"
SHELL="/bin/bash"
SHLVL="2"
SSH_CLIENT="192.168.1.3 53147 22"
SSH_CONNECTION="192.168.1.3 53147 192.168.1.2 22"
SSH_TTY="/dev/pts/0"
STAGE1_USE="multilib nptl nptlonly unicode"
SYMLINK_LIB="yes"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
TERM="xterm"
USB_DEVFS_PATH="/dev/bus/usb"
USE="X a52 aac acl acpi alsa amd64 apm bash-completion berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups custom-cflags cxx dbus directfb dri dts dvd dvdr emboss encode exif fam fbcon fbcondecor firefox flac fortran gdbm gdu gif git gpm gtk iconv jpeg kde lcms ldap libnotify lm_sensors mad mercurial mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses networkmanager nls nptl nptlonly ntp ogg opengl openmp optimization pam pango pcre pdf perl png policykit ppds pppd python qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification static static-libs strong-optimization subversion svg symlink sysfs syslog tcpd tiff tools truetype udev unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel v4l vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USER="root"
USERLAND="GNU"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS APACHE2_MODULES APACHE2_MPMS CAMERAS COLLECTD_PLUGINS CROSSCOMPILE_OPTS DRACUT_MODULES DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS GPSD_PROTOCOLS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS NETBEANS_MODULES NGINX_MODULES_HTTP NGINX_MODULES_MAIL PHP_TARGETS QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS RUBY_TARGETS SANE_BACKENDS USERLAND VIDEO_CARDS XFCE_PLUGINS XTABLES_ADDONS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="intel v4l vesa"
XDG_CONFIG_DIRS="/etc/xdg"
XDG_DATA_DIRS="/usr/local/share:/usr/share"
XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
_="/usr/bin/emerge"



L'installation est relativement fraîche, et voici le make.conf actuel :

Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.

CFLAGS="-march=native -O2 -pipe -s -fomit-frame-pointer"
CXXFLAGS="-O2 -pipe"

LDFLAGS="-Wl,-O1 -Wl,--as-needed"

CHOST="x86_64-pc-linux-gnu"

# These are the USE flags that were used in addition to what is provided by the
# profile used for building.

USE="apm bash-completion custom-cflags directfb -dso fbcon fbcondecor git -ipv6$

ACCEPT_KEYWORDS="amd64"

LINGUAS="fr fr_FR"

EMERGE_DEFAULT_OPTS="--jobs=3 --load-average=5.0 --with-bdeps y --keep-going --$

PORTAGE_NICENESS="0"
MAKEOPTS="-j3 -l3"


FEATURES="buildpkg candy ccache strict userfetch userpriv usersandbox parallel-$
CCACHE_SIZE="2G"
CCACHE_DIR="/var/tmp/ccache"

GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"

PORTAGE_ELOG_CLASSES="error info log warn"
PORTAGE_ELOG_SYSTEM="echo:log,warn save:error,info,log,warn syslog:error,warn"

source /usr/local/portage/layman/make.conf
PKGDIR="/usr/portage/packages"
source /var/lib/layman/make.conf

INPUT_DEVICES="evdev keyboard mouse"
VIDEO_CARDS="intel v4l vesa"




J'ai recherché une solution sur Internet et le forum, mais je n'ai encore rien trouvé pouvant m'aider. J'ai aussi tenté de ré-emerger libtool (--one-shot) mais ce fut également un échec :

Code:

Traceback (most recent call last):
  File "/usr/bin/emerge", line 43, in <module>
    retval = emerge_main()
  File "/usr/lib64/portage/pym/_emerge/main.py", line 1458, in emerge_main
    ext = os.path.splitext(x)[1]
  File "/usr/lib64/portage/pym/portage/__init__.py", line 218, in __call__
    for x in args]
  File "/usr/lib64/portage/pym/portage/__init__.py", line 218, in <listcomp>
    for x in args]
  File "/usr/lib64/portage/pym/portage/__init__.py", line 179, in _unicode_encode
    s = s.encode(encoding, errors)
UnicodeEncodeError: 'utf-8' codec can't encode character '\udce2' in position 0: surrogates not allowed


Si un quelqu'un peut me tuyauter, je lui en serai très reconnaissant.


Last edited by nexus6 on Thu Jun 02, 2011 11:58 pm; edited 2 times in total
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Wed Mar 30, 2011 6:38 am    Post subject: Reply with quote

'alute

a vue de museau d'après la trace sur libtool je penche vers python3 activé et tu devrais avoir ce genre d'erreur quel que soit le package concerné normalement -> #eselect donne quelle version active ?

Edit: vérifie aussi quels sont les USE activés sur portage genre "python2" ou "python3"
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
nexus6
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2007
Posts: 92

PostPosted: Wed Mar 30, 2011 5:14 pm    Post subject: Reply with quote

Oui, je retrouve la même erreur sur d'autres paquets. Par défaut, j'ai Python v.3.1 et je peux le rétrograder vers vers la v.2.6.

C'est d'ailleurs ce que j'ai tenté de faire, en vain...

J'ai essayer d'emerger kde-meta avec USE="-unicode", mais j'ai pas plus de chance de ce côté-là.

Je ne peux pas non plus ré-emerger libtool, c'est assez étrange...

Est-ce que cela pourrait-être un bug ? Faut-il recompiler Python avec ou sans support unicode ?
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Wed Mar 30, 2011 9:40 pm    Post subject: Reply with quote

Fait un #eselect python set <num_python_2> puis lance un #python-updater ça devrait être suffisant normalement

Edit: ps: pourrais-tu éditer ton premier message pour avoir un titre plus en accord avec le problème ? parce que mysql n'a rien à voir avec le schmilblic là et c'est pas top pour les recherches ;-p
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
nexus6
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2007
Posts: 92

PostPosted: Thu Mar 31, 2011 12:01 am    Post subject: Reply with quote

Salut boozo,


J'ai suivi tes conseils mais cela n'a malheureusement pas fonctionné. J'ai donc repassé Python en version 3 et refais un python-updater. Là par contre, je dois recompiler environ 80 paquets :roll:

Je te tiens au jus :wink:
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Mar 31, 2011 9:45 am    Post subject: Reply with quote

NON surtout pas ! Python 3 n'est pas marqué stable pour une utilisation intégrée dans gentoo ! Il y a 2 slots c'est pas pour rien !
Toi tu es en "stable" avec portage en version 2.1.9 -> il n'y a que l'ABI de python 2 qui soit supportée.

Il faut rester selectionné sur 2.7 faire un python-updater en premier et ensuite on voit ce qui cloche encore avec les messages et logs d'erreurs
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
nexus6
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2007
Posts: 92

PostPosted: Thu Mar 31, 2011 3:56 pm    Post subject: Reply with quote

J'étais en 2.6 et j'ai donc upgradé en 2.7 puis ai effectué un python-updater.

Ca compile en keep-going, mais je vois encore des erreurs. Je vais attendre la fin de la compilation et en faire une seconde.


Voici déjà quelques erreurs :

Code:

libtoolize can not copy '/usr/share/aclocal/lt~obsolete-m4' to 'm4'


Code:

Merging of intermediate installation image for Python ABI '2.7 into installation image failed.



J'ai comme l'impression que ma Gentoo est cassée et que je suis reparti pour tout ré-installer ...


Bon, je re-synchronise portage et tente un emerge -uDN world.
Back to top
View user's profile Send private message
nexus6
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2007
Posts: 92

PostPosted: Thu Mar 31, 2011 5:15 pm    Post subject: Reply with quote

Ca ne fonctionne toujours pas, je tente un emerge -e1 libtool ...
Back to top
View user's profile Send private message
nexus6
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2007
Posts: 92

PostPosted: Fri Jun 03, 2011 12:02 am    Post subject: Reply with quote

Solution trouvée : palliative.


En fait, je pense qu'il y eu un bug d'origine inconnu, j'ai tout simplement refait l'installation (portage + stage3) en conservant /etc. Tout est passer comme une lettre à la Poste.

Le point négatif, c'est qu'il a fallu tout recompiler :p Mais le résultat est correct :)


Merci pour tout ;)
Back to top
View user's profile Send private message
mamac
l33t
l33t


Joined: 29 Feb 2004
Posts: 890

PostPosted: Wed Jul 06, 2011 10:58 am    Post subject: Reply with quote

Salut,

J'ai la meme chose ici quand j'essaye de compiler libgamin: "Failed running libtoolize".

Sauf que je suis en cours d'installation, je voudrais juste emerger syslog-ng...

Python-updater ne reinstalle aucun package.

Je continue mes recherches.
_________________
Powered by Gentoo Linux since 2003
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum