Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Wicd] Problème avec Dbus [RESOLU]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
tux03
n00b
n00b


Joined: 23 Apr 2010
Posts: 20

PostPosted: Sat Mar 26, 2011 2:42 pm    Post subject: [Wicd] Problème avec Dbus [RESOLU] Reply with quote

Salut !

J'ai un problème avec wicd sur ma Gentoo stable, wicd qui est en 1.7.0 et python en 2.7

En effet, après une erreur de ma part je ne pouvait plus utiliser d'applications en python jusqu'au moment ou j'ai effectué un python-updater.

Les applications utilisant python on donc fonctionné, sauf Wicd.

En effet au démarrage il me demande le mot de passe root pour accéder à la carte Wifi.
Après cet étape j'ai droit à ces deux erreurs :

Code:
Could not connect to wicd's D-Bus interface.  Check the wicd log for error messages.


Code:
Le démon wicd s'est éteint. L'interface graphique ne marchera pas correctement tant que le démon n'est pas redémarré.


Et je ne peut pas redémarrer le daemon wicd...

Code:
/etc/init.d/wicd restart
 * Caching service dependencies ...                                       [ ok ]

 * Please use 'svc_stop; svc_start' and not 'stop; start' to
 * restart the service in its custom 'restart()' function.
 * Run wicd without arguments for more info.

 * Service wicd stopping
 * WARNING:  you are stopping a boot service.
 * Stopping wicd daemon and closing connections ...                       [ !! ]
 * ERROR:  wicd failed to stop


Ni le daemon dbus :

Code:
/etc/init.d/dbus restart
 * Service dbus stopping
 * Service wicd stopping
 * Service hald stopping
 * WARNING:  you are stopping a boot service.
 * Service hald stopped                                                   [ !! ]
 * ERROR:  wicd failed to stop
 * ERROR:  cannot stop dbus as wicd is still up.
 * ERROR:  dbus failed to stop
 * Service hald starting
 * Service hald started


Voci une partie des logs de Wicd.
http://pastebin.com/TaeMPXyV

J'ai donc emerger de nouveau dbus, dbus-python et wicd, seulement j'ai toujours les mêmes erreurs.

Je ne sait pas quoi faire, donc je me tourne vers vos réponses :P

Merci d'avance pour vos réponses.

Bonne journée


Last edited by tux03 on Sat Mar 26, 2011 9:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Sat Mar 26, 2011 4:03 pm    Post subject: Reply with quote

Étant donné que tu ne peux pas l'arrêter, es-tu sûr d'avoir démarré le daemon wicd ?
Back to top
View user's profile Send private message
tux03
n00b
n00b


Joined: 23 Apr 2010
Posts: 20

PostPosted: Sat Mar 26, 2011 4:14 pm    Post subject: Reply with quote

Oui il est bien lancé, il est ajouté au runlevel boot.
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Sat Mar 26, 2011 4:20 pm    Post subject: Reply with quote

Et lorsque tu démarres, il démarre bien ou il y a une erreur aussi ?
Back to top
View user's profile Send private message
tux03
n00b
n00b


Joined: 23 Apr 2010
Posts: 20

PostPosted: Sat Mar 26, 2011 4:32 pm    Post subject: Reply with quote

Il démarre correctement.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7899
Location: ~Brussels - Belgique

PostPosted: Sat Mar 26, 2011 6:45 pm    Post subject: Reply with quote

Hello,

La version 1.7.0 ne fonctionne pas bien avec cette version de python. Démasque la version 1.7.1_beta2-r2 qui fonctionne sans problème.
Voir le bug 333001
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
tux03
n00b
n00b


Joined: 23 Apr 2010
Posts: 20

PostPosted: Sat Mar 26, 2011 9:21 pm    Post subject: Reply with quote

Oh mais c'était juste ça !

Mon Wicd fonctionne à nouveau !

Du coup il me suffit juste ajouter une ligne au package.keywords pour passer wicd en 1.7.1 beta.

Sinon merci beaucoup et bonne soirée !

A++
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum