Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wireless issue with Intel agn driver [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
bnbrown52
n00b
n00b


Joined: 17 Mar 2011
Posts: 2

PostPosted: Mon Mar 21, 2011 3:09 pm    Post subject: Wireless issue with Intel agn driver [SOLVED] Reply with quote

i new to gentoo and i am having trouble activating the wireless on my laptop. I am using an HP elitebook 8440p and it has the Intel Advanced-N 6200 AGN wireless device.

when i run 'wpa_supplicant start' , it fails with the following error:
Code:

worklappy linux # /etc/init.d/wpa_supplicant start
 * Starting WPA Supplicant Daemon ...
Could not set interface wlan0 flags: Unknown error 132
Failed to initialize driver interface
 * start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'
 * Failed to start wpa_supplicant                                                        [ !! ]
 * ERROR: wpa_supplicant failed to start


this is my wpa_supplicant config:
Code:

modules=( "wpa_supplicant" )
wpa_supplicant_wlan0="-Dwext"
#wpa_supplicant_wlan0="-Dmadwifi"


dmesg | grep -i iwl
Code:
worklappy linux # dmesg | grep -i iwl
[    1.336383] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[    1.337091] iwlagn: Copyright(c) 2003-2010 Intel Corporation
[    1.337514] iwlagn 0000:44:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[    1.337913] iwlagn 0000:44:00.0: setting latency timer to 64
[    1.337935] iwlagn 0000:44:00.0: Detected Intel(R) Centrino(R) Advanced-N 6200 AGN, REV=0x74
[    1.348567] iwlagn 0000:44:00.0: device EEPROM VER=0x436, CALIB=0x6
[    1.348970] iwlagn 0000:44:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[    1.349791] iwlagn 0000:44:00.0: irq 46 for MSI/MSI-X
[    4.527882] iwlagn 0000:44:00.0: RF_KILL bit toggled to disable radio.
[    8.952067] iwlagn 0000:44:00.0: loaded firmware version 9.221.4.1 build 25532
[    8.953566] phy0: Selected rate control algorithm 'iwl-agn-rs'
[   13.379352] iwlagn 0000:44:00.0: RF_KILL bit toggled to enable radio.
[   16.652242] iwlagn 0000:44:00.0: RF_KILL bit toggled to disable radio.


Last edited by bnbrown52 on Tue Mar 22, 2011 2:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
cach0rr0
Bodhisattva
Bodhisattva


Joined: 13 Nov 2008
Posts: 4123
Location: Houston, Republic of Texas

PostPosted: Mon Mar 21, 2011 11:22 pm    Post subject: Reply with quote

first thing that immediately jumps out at me:

Code:

[   16.652242] iwlagn 0000:44:00.0: RF_KILL bit toggled to disable radio.


might merge the "rfkill" package, and do an "rfkill unblock all"

...unless of course just hitting the little toggle button on your laptop happens to do the trick.

Not sure if that's the root cause, but it's certainly not going to help matters.
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2588
Location: Near Toronto

PostPosted: Tue Mar 22, 2011 12:47 am    Post subject: Reply with quote

One thing to check is RFKILL in the kernel - for my
thinkpad x300 I had to *disable* RFKILL.
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Mar 22, 2011 12:57 am    Post subject: Reply with quote

Yep, me too with my Thinkpad T60P.
Back to top
View user's profile Send private message
bnbrown52
n00b
n00b


Joined: 17 Mar 2011
Posts: 2

PostPosted: Tue Mar 22, 2011 2:28 pm    Post subject: Reply with quote

cach0rr0 wrote:
first thing that immediately jumps out at me:

Code:

[   16.652242] iwlagn 0000:44:00.0: RF_KILL bit toggled to disable radio.


might merge the "rfkill" package, and do an "rfkill unblock all"

...unless of course just hitting the little toggle button on your laptop happens to do the trick.

Not sure if that's the root cause, but it's certainly not going to help matters.



Thanks for the quick responses! I found out that this model laptop will hard block the wireless as long as a physical network connection (eth0) is established. Once eth0 was disconnected wpa_supplicant started working.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Mar 23, 2011 3:33 am    Post subject: Reply with quote

Nice :P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum