Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Altro errore durante la compilazione
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sun Mar 20, 2011 9:50 am    Post subject: Altro errore durante la compilazione Reply with quote

Ebbene si: credevo di riuscire a terminare la compilazione di kde incolume e invece mi sono dovuto rassegnare.
Quando provo ad emergere il pacchetto kde-base/system-config-printer-kde mi restituisce questo errore:
Code:
 * Package:    kde-base/system-config-printer-kde-4.6.1
 * Repository: gentoo
 * Maintainer: kde@gentoo.org
 * USE:        elibc_glibc kernel_linux userland_GNU x86
 * FEATURES:   sandbox
>>> Unpacking source...
 * Unpacking parts of kdeadmin-4.6.1.tar.bz2 to /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work ...
tar extract command failed at least partially - continuing anyway
 [ ok ]
>>> Source unpacked in /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work
>>> Preparing source in /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1_build"
cmake --no-warn-unused-cli -C /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/temp/gentoo_common_config.cmake -DCMAKE_INSTALL_PREFIX=/usr -DKDE4_BUILD_TESTS=OFF -DCMAKE_INSTALL_PREFIX=/usr -DSYSCONF_INSTALL_DIR=/etc -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/temp/gentoo_rules.cmake  /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1
Not searching for unused variables given on the command line.
loading initial cache file /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/temp/gentoo_common_config.cmake
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.7.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Found Phonon: /usr/include
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Failed
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.6 include dir: /usr/include
-- Found KDE 4.6 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found PythonInterp: /usr/bin/python
-- Found Python executable: /usr/bin/python
-- Found Python version: 2.6.6
-- Found Python library: /usr/lib/libpython2.6.so
-- Found SIP version: 4.12.1
-- Found PyQt4 version: 4.8.3
Traceback (most recent call last):
  File "/usr/share/apps/cmake/modules/FindPyKDE4.py", line 8, in <module>
    import PyKDE4.pykdeconfig
ImportError: No module named PyKDE4.pykdeconfig
-- Found PyCups
-- Found System Config Printer

-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
-----------------------------------------------------------------------------
   * PyKDE4  <http://websvn.kde.org/trunk/KDE/kdebindings/python/pykde4/>
     PyKDE4 was not found.  It is needed by system-config-printer-kde to run.  (Use -DINSTALL_SYSTEM_CONFIG_PRINTER=TRUE to install anyway)

-----------------------------------------------------------------------------

-- <<< Gentoo configuration >>>
Build type      Gentoo
Install path    /usr
Compiler flags:
C               -O2 -march=i686 -pipe  -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common
C++             -O2 -march=i686 -pipe  -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Werror=return-type -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden
Linker flags:
Executable      -Wl,--enable-new-dtags -Wl,-O1 -Wl,--as-needed
Module          -Wl,--enable-new-dtags -Wl,--fatal-warnings -Wl,--no-undefined -lc -Wl,-O1 -Wl,--as-needed
Shared          -Wl,--enable-new-dtags -Wl,--fatal-warnings -Wl,--no-undefined -lc -Wl,-O1 -Wl,--as-needed

-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1_build
>>> Source configured.
>>> Compiling source in /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1_build"
make -j3
>>> Source compiled.
>>> Test phase [not enabled]: kde-base/system-config-printer-kde-4.6.1

>>> Install system-config-printer-kde-4.6.1 into /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/image/ category kde-base
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1_build"
make -j3 DESTDIR=/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/image/ install
make: *** Nessuna regola per generare l'obiettivo «install».  Stop.
emake failed
 * ERROR: kde-base/system-config-printer-kde-4.6.1 failed (install phase):
 *   died running make install, base_src_install
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_install
 *   environment, line 6449:  Called kde4-meta_src_install
 *   environment, line 3904:  Called kde4-base_src_install
 *   environment, line 3451:  Called cmake-utils_src_install
 *   environment, line 1729:  Called _execute_optionaly 'src_install'
 *   environment, line  675:  Called enable_cmake-utils_src_install
 *   environment, line 2053:  Called base_src_install
 *   environment, line 1369:  Called die
 * The specific snippet of code:
 *       emake DESTDIR="${D}" "$@" install || die "died running make install, $FUNCNAME";
 *
 * If you need support, post the output of 'emerge --info =kde-base/system-config-printer-kde-4.6.1',
 * the complete build log and the output of 'emerge -pqv =kde-base/system-config-printer-kde-4.6.1'.
 * The complete build log is located at '/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/temp/environment'.
 * S: '/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1'

Ho già provato ad usare i parametri MAKEOPTS="-j1" FEATURES="-ccache" per emergere quel pacchetto, come è stato suggerito nella sezione inglese, e ad aggiornare world ma l'installazione fallisce comunque. Qualche aiutino? Grazie in anticipo!
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Sun Mar 20, 2011 12:47 pm    Post subject: Reply with quote

hai anche provato un revdep-rebuild per vedere se ci sono librerie scazzate?

comunque..
io ho la versione 4.6.0 installata e si installa.
prova ad installare la 4.6.0

magari funziona meglio, chissà... tanto comunque credo che non ti cambi niente (tanto è sempre compatibile con il branch 4.6 di kde)
_________________
Darkman
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sun Mar 20, 2011 1:27 pm    Post subject: Reply with quote

Il comando revdep-rebuild mi conferma che tutto è in regola. Ho provato a dare un emerge kde-base/system-config-printer-kde:4.6 ma cerca di installarmi comunque la versione 4.6.1. Cosa ho toppato?
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sun Mar 20, 2011 1:33 pm    Post subject: Reply with quote

Code:
emerge =kde-base/system-config-printer-kde-4.6.0
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sun Mar 20, 2011 1:55 pm    Post subject: Re: Altro errore durante la compilazione Reply with quote

davedeth wrote:
Code:
Traceback (most recent call last):
  File "/usr/share/apps/cmake/modules/FindPyKDE4.py", line 8, in <module>
    import PyKDE4.pykdeconfig
ImportError: No module named PyKDE4.pykdeconfig
-----------------------------------------------------------------------------
   * PyKDE4  <http://websvn.kde.org/trunk/KDE/kdebindings/python/pykde4/>
     PyKDE4 was not found.  It is needed by system-config-printer-kde to run.  (Use -DINSTALL_SYSTEM_CONFIG_PRINTER=TRUE to install anyway)


L'errore dovrebbe essere abbastanza chiaro...hai pykde4 ? Se si, ricompilalo
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sun Mar 20, 2011 2:37 pm    Post subject: Reply with quote

Pessime notizie: la compilazione della versione 4.6.0 mi da lo stesso errore della versione 4.6.1; ho installato pykde4 ma l'installazione fallisce comunque.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sun Mar 20, 2011 6:34 pm    Post subject: Reply with quote

ma tu hai kde4.6.1 o 4.6.0 ?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Sun Mar 20, 2011 6:53 pm    Post subject: Reply with quote

Sto cercando di compilare kde 4.6.1
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Mon Mar 21, 2011 10:06 am    Post subject: Reply with quote

adesso che hai installato pykde4, l'errore (quello segnalato da ago) rimane?

Quote:
Sto cercando di compilare kde 4.6.1


quindi, tu ora hai provato ad installare
Code:
emerge =kde-base/system-config-printer-kde-4.6.1

e non funziona.
hai installato
Code:
kde-base/pykde4-4.6.1


ed installando
Code:
emerge =kde-base/system-config-printer-kde-4.6.1


ti rimane sempre lo stesso errore? non è che l'errore cambi, ora?
_________________
Darkman
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Mon Mar 21, 2011 11:46 am    Post subject: Re: Altro errore durante la compilazione Reply with quote

Code:

-- Found SIP version: 4.12.1
-- Found PyQt4 version: 4.8.3
Traceback (most recent call last):
  File "/usr/share/apps/cmake/modules/FindPyKDE4.py", line 8, in <module>
    import PyKDE4.pykdeconfig
ImportError: No module named PyKDE4.pykdeconfig
-- Found PyCups
-- Found System Config Printer

-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
-----------------------------------------------------------------------------
   * PyKDE4  <http://websvn.kde.org/trunk/KDE/kdebindings/python/pykde4/>
     PyKDE4 was not found.  It is needed by system-config-printer-kde to run.  (Use -DINSTALL_SYSTEM_CONFIG_PRINTER=TRUE to install anyway)

-----------------------------------------------------------------------------

Alle volte è l'insieme sip/PyQt4/ecc. che crea problemi, e portage te lo segnala.
Se non lo hai già fatto, prova a ricompilare questi pacchetti così:
Code:
emerge -1 sip PyQt4 pykde4

Se tutto va a buon fine, riprova a compilare system-config-printer
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Mon Mar 21, 2011 8:38 pm    Post subject: Reply with quote

Ho provato sia con le proposte di xdarma che di darkmanPPT ma ancora niente da fare. Per sicurezza riposto il file .log
Code:
 * Package:    kde-base/system-config-printer-kde-4.6.1
 * Repository: gentoo
 * Maintainer: kde@gentoo.org
 * USE:        elibc_glibc kernel_linux userland_GNU x86
 * FEATURES:   sandbox
>>> Unpacking source...
 * Unpacking parts of kdeadmin-4.6.1.tar.bz2 to /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work ...
tar extract command failed at least partially - continuing anyway
 [ ok ]
>>> Source unpacked in /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work
>>> Preparing source in /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1_build"
cmake --no-warn-unused-cli -C /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/temp/gentoo_common_config.cmake -DCMAKE_INSTALL_PREFIX=/usr -DKDE4_BUILD_TESTS=OFF -DCMAKE_INSTALL_PREFIX=/usr -DSYSCONF_INSTALL_DIR=/etc -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/temp/gentoo_rules.cmake  /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1
Not searching for unused variables given on the command line.
loading initial cache file /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/temp/gentoo_common_config.cmake
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.7.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Found Phonon: /usr/include
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Failed
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.6 include dir: /usr/include
-- Found KDE 4.6 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found PythonInterp: /usr/bin/python
-- Found Python executable: /usr/bin/python
-- Found Python version: 2.6.6
-- Found Python library: /usr/lib/libpython2.6.so
-- Found SIP version: 4.12.1
-- Found PyQt4 version: 4.8.3
Traceback (most recent call last):
  File "/usr/share/apps/cmake/modules/FindPyKDE4.py", line 8, in <module>
    import PyKDE4.pykdeconfig
ImportError: No module named PyKDE4.pykdeconfig
-- Found PyCups
-- Found System Config Printer

-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
-----------------------------------------------------------------------------
   * PyKDE4  <http://websvn.kde.org/trunk/KDE/kdebindings/python/pykde4/>
     PyKDE4 was not found.  It is needed by system-config-printer-kde to run.  (Use -DINSTALL_SYSTEM_CONFIG_PRINTER=TRUE to install anyway)

-----------------------------------------------------------------------------

-- <<< Gentoo configuration >>>
Build type      Gentoo
Install path    /usr
Compiler flags:
C               -O2 -march=i686 -pipe  -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common
C++             -O2 -march=i686 -pipe  -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Werror=return-type -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden
Linker flags:
Executable      -Wl,--enable-new-dtags -Wl,-O1 -Wl,--as-needed
Module          -Wl,--enable-new-dtags -Wl,--fatal-warnings -Wl,--no-undefined -lc -Wl,-O1 -Wl,--as-needed
Shared          -Wl,--enable-new-dtags -Wl,--fatal-warnings -Wl,--no-undefined -lc -Wl,-O1 -Wl,--as-needed

-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1_build
>>> Source configured.
>>> Compiling source in /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1_build"
make -j3
>>> Source compiled.
>>> Test phase [not enabled]: kde-base/system-config-printer-kde-4.6.1

>>> Install system-config-printer-kde-4.6.1 into /var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/image/ category kde-base
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1_build"
make -j3 DESTDIR=/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/image/ install
make: *** Nessuna regola per generare l'obiettivo «install».  Stop.
emake failed
 * ERROR: kde-base/system-config-printer-kde-4.6.1 failed (install phase):
 *   died running make install, base_src_install
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_install
 *   environment, line 6448:  Called kde4-meta_src_install
 *   environment, line 3903:  Called kde4-base_src_install
 *   environment, line 3450:  Called cmake-utils_src_install
 *   environment, line 1728:  Called _execute_optionaly 'src_install'
 *   environment, line  674:  Called enable_cmake-utils_src_install
 *   environment, line 2052:  Called base_src_install
 *   environment, line 1368:  Called die
 * The specific snippet of code:
 *       emake DESTDIR="${D}" "$@" install || die "died running make install, $FUNCNAME";
 *
 * If you need support, post the output of 'emerge --info =kde-base/system-config-printer-kde-4.6.1',
 * the complete build log and the output of 'emerge -pqv =kde-base/system-config-printer-kde-4.6.1'.
 * The complete build log is located at '/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/temp/environment'.
 * S: '/var/tmp/portage/kde-base/system-config-printer-kde-4.6.1/work/system-config-printer-kde-4.6.1'
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Mon Mar 21, 2011 8:44 pm    Post subject: Reply with quote

Leggendo l'errore, dice che non trova /usr/share/apps/cmake/modules/FindPyKDE4.py

Dunque:
Code:
# equery b /usr/share/apps/cmake/modules/FindPyKDE4.py
 * Searching for /usr/share/apps/cmake/modules/FindPyKDE4.py ...
kde-base/kdelibs-4.6.1-r1 (/usr/share/apps/cmake/modules/FindPyKDE4.py)

Dato che costui fa parte delle kdelibs, direi di provare a riemergerle.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Mon Mar 21, 2011 9:05 pm    Post subject: Reply with quote

ha ragione pierino...sai che però ad occhio ingannava :P
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Tue Mar 22, 2011 7:03 am    Post subject: Reply with quote

Provato a compilare kdelibs ma l'errore rimane. :cry:
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Wed Mar 23, 2011 1:50 am    Post subject: Reply with quote

Hai ragione, sono stato ingenuo. In effetti non dice che non trova quel file, ma che fallisce un import dentro quel file. E il modulo di cui si lamenta è pykde4.
Ora tu hai detto di aver già ricompilato pyqt4, pykde4, sip e compari, e che non si è risolto. Quindi opterei per reimpostare la versione di python corretta con eselect, per poi lanciare python-updater. Questo dovrebbe risolvere la questione.

[edit]
un approccio più specifico sarebbe stato
Code:
$ equery b /usr/lib/python2.7/site-packages/PyKDE4/pykdeconfig.py

ma mi ha detto che non appartiene a nessuno.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Wed Mar 23, 2011 7:48 am    Post subject: Reply with quote

pierino_89 wrote:
ma mi ha detto che non appartiene a nessuno.


Appartiene a pykde4 solo che il percorso cambia da python 2.7 a python 2.6..probabilmente sono stati fatti dei casini con l'aggiornamento di py
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Wed Mar 23, 2011 8:33 am    Post subject: Reply with quote

e questo è solo un esempietto di quello che può capitare a stare con il sistema tutto quanto in ~.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Wed Mar 23, 2011 1:11 pm    Post subject: Reply with quote

Provato con l'ultimo suggerimento di pierino_89 ma niente da fare. A questo punto mi sa che converrebbe reinstallare tutto utilizzando i repo stable.
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Wed Mar 23, 2011 1:53 pm    Post subject: Reply with quote

ago wrote:
pierino_89 wrote:
ma mi ha detto che non appartiene a nessuno.

Appartiene a pykde4 solo che il percorso cambia da python 2.7 a python 2.6..probabilmente sono stati fatti dei casini con l'aggiornamento di py

Non è logico, io uso python 2.7 e quindi dovrebbe rilevarlo. Anche perché nella cartella del 2.6 e del 3.1 non c'è.

@davedeth: puoi vedere cosa restituisce
Code:
locate pykdeconfig.py
? (se non hai locate usa find)
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Wed Mar 23, 2011 2:35 pm    Post subject: Reply with quote

pierino_89 wrote:
Non è logico, io uso python 2.7 e quindi dovrebbe rilevarlo. Anche perché nella cartella del 2.6 e del 3.1 non c'è.


Un qfile mi da esito positivo...da me c'è
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Wed Mar 23, 2011 2:50 pm    Post subject: Reply with quote

ago wrote:
pierino_89 wrote:
Non è logico, io uso python 2.7 e quindi dovrebbe rilevarlo. Anche perché nella cartella del 2.6 e del 3.1 non c'è.


Un qfile mi da esito positivo...da me c'è


Anche a me qfile funziona... A te "equery belongs" dà lo stesso risultato? In caso contrario dev'esserci un bug.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Wed Mar 23, 2011 6:59 pm    Post subject: Reply with quote

Code:
find pykdeconfig.py

Mi risulta che il file o la directory è inesistente.
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Wed Mar 23, 2011 7:33 pm    Post subject: Reply with quote

davedeth wrote:
Code:
find pykdeconfig.py

Mi risulta che il file o la directory è inesistente.

perché find non si usa così :D
prova
Code:
find / -name pykdeconfig.py

_________________
Linux registered user 461710
Back to top
View user's profile Send private message
davedeth
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2010
Posts: 81
Location: Cesena

PostPosted: Wed Mar 23, 2011 8:01 pm    Post subject: Reply with quote

Quote:
perché find non si usa così :D

Non c'è proprio limite alla niubbaggine :(
Code:
find / -name pykdeconfig.py

Restituisce un:
Code:
/usr/lib/python3.1/site-packages/PyKDE4/pykdeconfig.py
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Wed Mar 23, 2011 10:58 pm    Post subject: Reply with quote

Mi posteresti anche un
Code:
eselect python list
?
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum