Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] nvidia drivers problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
danilo2
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2010
Posts: 75

PostPosted: Sun May 06, 2012 3:18 pm    Post subject: [SOLVED] nvidia drivers problem Reply with quote

Hi!
I'm trying to fix an issue for veryl ong time but without success. I would be very thnakfully for any help with my problem.

I'm using funtoo with standard kernel (sysrescue-std) build with genkernel. I've installed nvidia-drivers (295.40) and everything seems to emerge good. I have exactly the same system configuration on my laptop and on my desktop computer. On laptop everything works but on desktop when I start gdm there is no "nvidia logo", gnome falls in fallback mode, and when I'm trying to run some cuda examples, I get error: "cudaSafeCall() Runtime API error 46: all CUDA-capable devices are busy or unavailable."

When I run nvidia-settings then after switching to tab "OpenGL/GLX Information" it crashesh with error:
Code:
The program 'nvidia-settings' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 309 error_code 9 request_code 72 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


I suspect the problem is with communication with my graphics card or something like that.
my dmesg: https://gist.github.com/2622841
xorg.conf: https://gist.github.com/2622845
.xsession-errors: https://gist.github.com/2622868
lspci: https://gist.github.com/2622874

Thank you very much for any help!


Last edited by danilo2 on Tue May 22, 2012 11:19 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39297
Location: 56N 3W

PostPosted: Sun May 06, 2012 3:48 pm    Post subject: Reply with quote

danilo2,

Code:
[   38.250536] nouveau: Unknown parameter `blacklist'

Thats a bad sign. It looks like you may be loading two drivers for your video card.

I'll move this thread to unsupported software as this is a Funtoo install
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39297
Location: 56N 3W

PostPosted: Sun May 06, 2012 3:49 pm    Post subject: Reply with quote

Moved from Kernel & Hardware to Unsupported Software.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
danilo2
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2010
Posts: 75

PostPosted: Sun May 06, 2012 4:19 pm    Post subject: Reply with quote

Thabnk you, I didnt noticed this message.
Could you maybe tell me why it is happening and what should I do? (exactly the same configuration works on my laptop :/)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39297
Location: 56N 3W

PostPosted: Sun May 06, 2012 5:57 pm    Post subject: Reply with quote

danilo2,

It appears that you have both the nouveau and nvidia binary blob drivers installed.
You have attempted to not use nouveau by black listing it, so that its not loaded.
The message I quoted from dmesg shows that your blacklisting has failed, rather nouveau appears to have loaded and been passed 'blacklist' as a module parameter, which it doesn't understand.

Boot normally, get a root shell then do
Code:
modprobe -l | grep nouveau

This will tell you where the kernel module is.
Go into
Code:
/lib/modules/`uname -r`/...
and rename the nouveau modules so it cannot be loaded. Reboot to test.

If that works, fix your blacklisting and name the module back.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
danilo2
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2010
Posts: 75

PostPosted: Sun May 06, 2012 6:49 pm    Post subject: Reply with quote

Thank you very much for yours reply!
I've renamed the module and rebooted the system. Still no progress with this issue :(
I'm sure that nvidia is running. When I unmerge nvidia-drivers xorg does not want to run.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39297
Location: 56N 3W

PostPosted: Sun May 06, 2012 8:04 pm    Post subject: Reply with quote

danilo2,

Pastebin /var/log/Xorg.o.log that will tell what Xorg did when it started.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
danilo2
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2010
Posts: 75

PostPosted: Sun May 06, 2012 8:37 pm    Post subject: Reply with quote

here it is: https://gist.github.com/2624277
:)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39297
Location: 56N 3W

PostPosted: Sun May 06, 2012 9:00 pm    Post subject: Reply with quote

danilo2,

[ 179.149] (**) NVIDIA(0): Enabling 2D acceleration
[ 179.149] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[ 179.149] (EE) NVIDIA(0): log file that the GLX module has been loaded in your X
[ 179.149] (EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
[ 179.149] (EE) NVIDIA(0): you continue to encounter problems, Please try
[ 179.149] (EE) NVIDIA(0): reinstalling the NVIDIA driver.


What does
Code:
 $ eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11
show for you?
Make sure its nvidia selected.

Code:
[   180.581] (II) NVIDIA(0): kernel module enabled successfully
Is a good sign.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
danilo2
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2010
Posts: 75

PostPosted: Tue May 08, 2012 10:13 am    Post subject: Reply with quote

Thank you for your reply and time!

I really dont know how this happened, but yes, I've got xorg-x11 set as opengl implementation. (i'm suer i set it while installing he system to nbvidia, but maybe after removing nvidia-drivers it was set to default?).

Anyway after setting it to the proper value there was another error. After rebooting gdm was really slow showing everythoin (to show top panel with its animation it took about 5 minutes and then freezes - I was able to switch to tty after waiuting about next 5 minutes). After switching to xorg-x11 opengl implementation, gdm works fast as normal :(
The nvidia logo while starting is not shown either way.

If it would be helpfull I attach my current log files. In the files I have found line that says
Code:
[   242.444] (II) NVIDIA(0): Assigned Display Devices: CRT-0, CRT-1
[   242.444] (II) NVIDIA(0): Using MetaMode string: "1680x1024 1280x1024"
[   242.444] (II) NVIDIA(0): Requested modes:
[   242.444] (II) NVIDIA(0):     "1680x10241280x1024"
[   242.444] (WW) NVIDIA(0): No valid modes for "1680x10241280x1024"; removing.
[   242.444] (WW) NVIDIA(0):
[   242.444] (WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
[   242.444] (WW) NVIDIA(0):     "nvidia-auto-select".

and
Code:
[   242.482] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[   242.482] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[   242.482] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[   242.482] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[   242.482] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[   242.482] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[   242.482] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[   242.482] (II) NVIDIA(0):     Config Options in the README.
[   242.489] (II) NVIDIA(0): Setting mode "nvidia-auto-select"

maybe it is related to this error :roll:

xsession-errors: https://gist.github.com/2634021
dmesg: https://gist.github.com/2634033
Xorg.0.log: https://gist.github.com/2634027
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2655
Location: Slovenia

PostPosted: Tue May 08, 2012 10:48 am    Post subject: Reply with quote

I don't know what family your Quadro card belongs to, but some families of cards are seriously screwed up in 295.40. Try 295.49 or the 302.07 beta.

Also, you can trim down your xorg.conf to just this:
Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    Option         "TripleBuffer" "true"
    Option         "TwinView"  "true"
EndSection

Add TwinViewOrientation if neceesary. Everything else you have in there does effectively nothing.
Back to top
View user's profile Send private message
danilo2
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2010
Posts: 75

PostPosted: Thu May 17, 2012 9:17 pm    Post subject: Reply with quote

Hi!
Thank you for reply and sorry for my late response - I had some complications I had to solve, but now I will response faster.

unfortunately no of these works - I've tried a lot of nvidia-drivers-versions - always the smae result :(
Back to top
View user's profile Send private message
danilo2
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2010
Posts: 75

PostPosted: Mon May 21, 2012 2:43 pm    Post subject: Reply with quote

Has somebody got an idea what should I do to solve this problem?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39297
Location: 56N 3W

PostPosted: Mon May 21, 2012 5:42 pm    Post subject: Reply with quote

danilo2,

Code:
[   242.177] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[   242.177] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[   242.177] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[   242.177] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[   242.177] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.


suggests the the nvidia kernel module may not be loaded. look in lsmod or do
Code:
modprobe nvidia
to see if you get any errors.

When nvidia-drivers builds, it installs the kernel module for the kernel pointed to by /usr/src/linux. That need not be the kernel you are actually running.
Compare the kernel versions from
Code:
uname -a
and
Code:
readlink /usr/src/linux


Your dmesg
Code:
[   38.358211] [drm] Initialized drm 1.1.0 20060810
[   38.594448] nvidia: module license 'NVIDIA' taints kernel.
[   38.594453] Disabling lock debugging due to kernel taint
[   38.768101] nvidia 0000:02:00.0: PCI INT A -> GSI 52 (level, low) -> IRQ 52
[   38.768111] nvidia 0000:02:00.0: setting latency timer to 64
[   38.768115] vgaarb: device changed decodes: PCI:0000:02:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[   38.768322] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  295.40  Thu Apr  5 21:37:00 PDT 2012

suggests you do indeed have nvidia built against the running kernel but the first line could be a problem
nvidia does it own thing for drm - kernel drm should be disabled. That may be an issue, since having two drivers for the same piece of hardware usually fails as neither can work properly.
Find out where that drm is coming from and remove it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
danilo2
Tux's lil' helper
Tux's lil' helper


Joined: 01 Oct 2010
Posts: 75

PostPosted: Tue May 22, 2012 11:19 am    Post subject: Reply with quote

Thnak you very much for yours help!

the driver was loaded succesfully (lsmod showed him and modprobe nvidia had no errors).
It was not working up to yesterdays system update. I didnt change anything - after worlds update it started working!
I'm happy that now its ok but i'm thinkinking what was the problem.

Anyway thank you so much for your time and yours help!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum