Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema con emerge @preserved-rebuild
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
sacchi
n00b
n00b


Joined: 28 May 2004
Posts: 57

PostPosted: Mon Feb 06, 2017 2:32 pm    Post subject: Problema con emerge @preserved-rebuild Reply with quote

Ciao a tutti,

ho bisogno di una dritta, per cortesia...
Dando il comando in oggetto, ottengo:

# emerge @preserved-rebuild
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-db/sqlite:0".
(dependency required by "@preserved-rebuild" [argument])

....qualcuno sa come ne posso uscire?
emerge dev-db/sqlite non ha aiutato.

Molte grazie!

Sacchi
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 15496
Location: here

PostPosted: Mon Feb 06, 2017 2:47 pm    Post subject: Reply with quote

Prova a lanciare un
Code:
$ equery d dev-db/sqlite

e riportare l'output.
Il problema che c'e' qualcosa (ho magari ce l'hai in qualche /etc/portage/package.*) che richiede dev-db/sqlite con slot 0 ma in portage ora esiste solo lo slot 3
Code:
$ eix  dev-db/sqlite
[I] dev-db/sqlite
     Available versions:  (3) 3.12.0 ~3.12.1 ~3.12.2 3.13.0 ~3.14.1 ~3.14.2 ~3.15.1 ~3.15.2 ~3.16.2
       {debug doc icu +readline secure-delete static-libs tcl test tools ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  3.13.0(3)(08:05:46 06. 12. 16)(icu readline -debug -doc -secure-delete -static-libs -tcl -test -tools ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
     Homepage:            https://sqlite.org/
     Description:         A SQL Database Engine in a C Library

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 376
Location: Italia

PostPosted: Mon Feb 06, 2017 2:50 pm    Post subject: Reply with quote

Questo comando io lo lancio dopo aver effettuato l'aggiornamento del sistema, e anche dopo aver fatto

Code:
emerge --ask --depclean


e

Code:
revdep-rebuild


Magari il primo comando cancella dev-db/sqlite perchè non più necessario.
Infatti se vedi questo link

https://packages.gentoo.org/packages/dev-db/sqlite

questo pacchetto dal 29 gennaio è "dropped" (omesso).
Back to top
View user's profile Send private message
sacchi
n00b
n00b


Joined: 28 May 2004
Posts: 57

PostPosted: Mon Feb 06, 2017 2:54 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Prova a lanciare un
Code:
$ equery d dev-db/sqlite

e riportare l'output.


Ti ringrazio per l'aiuto!

Ho lanciato prima eix:
Code:

# eix  dev-db/sqlite
[?] dev-db/sqlite
     Available versions:
     (0)    2.8.16-r5^t
     (3)    3.8.2 ~3.8.3 ~3.8.3.1 ~3.8.4 ~3.8.4.1 ~3.8.4.3
       {debug doc icu nls +readline secure-delete static-libs tcl test ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32"}
     Installed versions:  2.8.16-r5^t(11:29:03 PM 09/10/2011)(nls -doc -tcl) 3.13.0(3)(03:22:08 PM 02/06/2017)(-debug -doc -icu -readline -secure-delete -static-libs -tcl -test -tools ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")     


equery riporta:
Code:

# equery d dev-db/sqlite
 * These packages depend on dev-db/sqlite:
app-crypt/gnupg-2.1.15 (tofu ? >=dev-db/sqlite-3.7)
app-portage/eix-0.31.7-r1 (sqlite ? >=dev-db/sqlite-3)
dev-lang/php-5.6.30 (sqlite ? >=dev-db/sqlite-3.7.6.3)
dev-lang/python-2.7.12 (sqlite ? >=dev-db/sqlite-3.3.8:3)
dev-lang/python-3.4.5 (sqlite ? >=dev-db/sqlite-3.3.8:3)
dev-libs/apr-util-1.5.4 (sqlite ? dev-db/sqlite:3)
dev-vcs/subversion-1.9.5 (>=dev-db/sqlite-3.7.12)
net-fs/nfs-utils-1.3.1-r5 (nfsdcld ? >=dev-db/sqlite-3.3)
net-ftp/proftpd-1.3.5b (sqlite ? dev-db/sqlite:3)
net-mail/dovecot-2.2.27 (sqlite ? dev-db/sqlite)
net-misc/asterisk-11.25.1 (dev-db/sqlite:3)
net-misc/minidlna-1.1.5-r1 (dev-db/sqlite:3)
net-wireless/hostapd-2.6 (sqlite ? >=dev-db/sqlite-3)
sys-apps/lshw-02.16b-r2 (sqlite ? dev-db/sqlite:3)
www-apps/trac-1.0.9 (sqlite ? >=dev-db/sqlite-3.3.4:3)
www-servers/lighttpd-1.4.42 (webdav ? >=dev-db/sqlite-3)   


È forse dovecot che usa sqlite versione 2.8?
Basta che lo riemerga? Intanto provo...

Molte grazie!

Sacchi
Back to top
View user's profile Send private message
sacchi
n00b
n00b


Joined: 28 May 2004
Posts: 57

PostPosted: Mon Feb 06, 2017 2:57 pm    Post subject: Reply with quote

Maxxx wrote:
Questo comando io lo lancio dopo aver effettuato l'aggiornamento del sistema, e anche dopo aver fatto

Code:
emerge --ask --depclean


e

Code:
revdep-rebuild


Magari il primo comando cancella dev-db/sqlite perchè non più necessario.
Infatti se vedi questo link

https://packages.gentoo.org/packages/dev-db/sqlite

questo pacchetto dal 29 gennaio è "dropped" (omesso).


Grazie per l'aiuto!
provo subito!

Molte grazie a tutti! :-)
Back to top
View user's profile Send private message
sacchi
n00b
n00b


Joined: 28 May 2004
Posts: 57

PostPosted: Mon Feb 06, 2017 4:13 pm    Post subject: Reply with quote

Maxxx wrote:
Questo comando io lo lancio dopo aver effettuato l'aggiornamento del sistema, e anche dopo aver fatto

Code:
emerge --ask --depclean


e

Code:
revdep-rebuild


Magari il primo comando cancella dev-db/sqlite perchè non più necessario.
Infatti se vedi questo link

https://packages.gentoo.org/packages/dev-db/sqlite

questo pacchetto dal 29 gennaio è "dropped" (omesso).


Ok ho dato
Code:

emerge --ask --depclean


e mi ha rimosso un po' di pacchetti, ma nulla riguardo sqlite.

Poi:

Code:

# revdep-rebuild
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Checking dynamic linking consistency
 * Assign files to packages

 !!! Broken orphaned files: No installed package was found for the following:
        * /usr/lib64/python3.1/lib-dynload/readline.so

There is nothing to emerge. Exiting.


a parte quell'orfano in giro (posso segarlo a mano?), non trova nulla.
A questo punto ho provato a ridare il comando
Code:

emerge @preserved-rebuild

ma l'errore è sempre quello....
Back to top
View user's profile Send private message
sacchi
n00b
n00b


Joined: 28 May 2004
Posts: 57

PostPosted: Wed Mar 08, 2017 7:16 pm    Post subject: Reply with quote

sacchi wrote:
ma l'errore è sempre quello....


..nessuno che sappia darmi una dritta?
Molte grazie!
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 15496
Location: here

PostPosted: Wed Mar 08, 2017 7:42 pm    Post subject: Reply with quote

Potresti provare a disinstallare sqlite:0 (e' sempre quello il problema?), ma prima creati il pacchetto binario di quel programma.
Code:
# quickpkg dev-db/sqlite:0
# emerge -C dev-db/sqlite:0
# emerge @preserved-rebuild

Dalla lista dei pacchetti che dipendono da dev-db/sqlite non mi pare che nessuno lo necessita
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
Guru
Guru


Joined: 03 Jan 2012
Posts: 431

PostPosted: Thu Mar 09, 2017 11:31 am    Post subject: Reply with quote

ciao

a suo tempo risolsi rimuovendo sqlite:0 con

e revdep ,

Code:
# emerge -C sqlite && emerge @preserved-rebuild

_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
sacchi
n00b
n00b


Joined: 28 May 2004
Posts: 57

PostPosted: Thu Mar 09, 2017 5:57 pm    Post subject: Reply with quote

sabayonino wrote:
ciao

a suo tempo risolsi rimuovendo sqlite:0 con

e revdep ,

Code:
# emerge -C sqlite && emerge @preserved-rebuild


..e ho risolto pure io! G R A Z I E ! ! !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum