Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Xorg 1.9 and Wacom tablet digitizer
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
pneula
n00b
n00b


Joined: 16 Jan 2009
Posts: 37

PostPosted: Tue Jan 04, 2011 4:38 pm    Post subject: [SOLVED] Xorg 1.9 and Wacom tablet digitizer Reply with quote

Hi forum,

The recent change of Xorg from HAL to udev seems to cause me plenty of problems. The latest is with Wacom pen touchscreen on Fujitsu T5010. The touchscreen worked fine beforehands with HAL but with Xorg 1.9 and udev it has gone completely unresponsive. I believe I have related ebuilds correctly installed but still the device is somehow lost, because when trying to debug it I get this while moving the pen on the screen:

Code:

# isdv4-serial-debugger -v /dev/ttyS0
... Opening device '/dev/ttyS0'.
... Baud rate is 38400
... Querying tablet.
... Writing STOP command.
... Written '0'.
... Written '*'.
... Reading 11 bytes from device.
... read 2 bytes in one chunk.
... read 1 bytes in one chunk.
... read 9 bytes in one chunk.
... Read 12 bytes.
... skipping over 3 bytes.
... 3 bytes garbage.
... read 1 bytes in one chunk.
... read 3 bytes in one chunk.
... Read 13 bytes.
... 2 bytes unexpected data.
... 0x1e ... 0x1e ...
... +++ out of cheese error +++ redo from start +++
... Reading 11 bytes from device.
... read 8 bytes in one chunk.
... read 2 bytes in one chunk.
... read 2 bytes in one chunk.
... Read 12 bytes.
... 1 bytes unexpected data.
... 0x1e ...
... Parsing query reply.
parsing error code -1
error during query.


dmesg has only this for the device:
Code:

# dmesg | grep ttyS
[    1.560570] 00:05: ttyS0 at I/O 0x220 (irq = 4) is a 16550A


I have all Wacom and Fujitsu touchscreen related things compiled in the kernel. Here are the USE flags for the related ebuilds:
Code:

[ebuild   R   ] x11-base/xorg-drivers-1.9  INPUT_DEVICES="evdev synaptics wacom -acecad -aiptek -elographics -fpit -joystick -keyboard -mouse -penmount -tslib -virtualbox -vmmouse -void" VIDEO_CARDS="intel -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-geode) -glint -i128 (-i740) (-impact) -mach64 -mga -neomagic (-newport) -nouveau -nv -nvidia -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -via -virtualbox -vmware (-voodoo) (-xgi)" 0 kB

Code:

[ebuild   R   ] x11-drivers/xf86-input-wacom-0.10.8  USE="-debug -hal" 0 kB


And finally my emerge --info if it helps here:
Code:

Portage 2.1.9.25 (default/linux/amd64/10.0/desktop, gcc-4.4.4, glibc-2.11.2-r3, 2.6.36-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.36-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9400_@_2.53GHz-with-gentoo-1.12.14
Timestamp of tree: Tue, 04 Jan 2011 09:15:01 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11-r1
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-9.0.31.0 AdobeFlash-10.1 dlj-1.1 googleearth skype-eula"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ http://de-mirror.org/distro/gentoo/ http://gentoo.mneisen.org/"
LANG="fi_FI.UTF-8@euro"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="  "
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage/"
USE="X a52 aac acl acpi alsa amd64 bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dhcp djvu dri dts dvd dvdr dvdread emboss encode exif fam ffmpeg firefox flac fortran gcj gdbm gdu gif gpm gtk iconv java jpeg lcms ldap libnotify mad mikmod mmx mng mozdevelop mp3 mp4 mpeg mudflap multilib ncurses network-cron nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support qt4 readline sdl session speex spell sse sse2 ssl startup-notification svg sysfs tcpd theora tiff truetype udev unicode usb v4l v4l2 vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


I really appreciate your help here! I have been testing different configuration combinations for hours already.


Last edited by pneula on Wed Mar 16, 2011 4:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Tue Jan 04, 2011 4:59 pm    Post subject: Reply with quote

What do you see in the logs about this device ?
Did you reemerge the driver after server upgrade ?
Do you have an entry that assigns the driver to the device ?
Back to top
View user's profile Send private message
pneula
n00b
n00b


Joined: 16 Jan 2009
Posts: 37

PostPosted: Tue Jan 04, 2011 10:23 pm    Post subject: Reply with quote

Yes, I reemerged the driver.

I can't give you printouts now because I'm away from the affected computer, but Xorg doesn't recognize the digitizer even if there are promisingly looking default rules in /usr/share/X11/xorg.conf.d/50-wacom.conf. I also tried to copy my old xorg.conf input sections to /etc/X11/xorg.conf.d/50-wacom.conf but no luck there.

xinput does not show devices that would be related to the digitizer according to the /usr/share/X11/xorg.conf.d/50-wacom.conf. This makes me doubt that introducing these devices doesn't get done correctly by udev.
Back to top
View user's profile Send private message
priiice
n00b
n00b


Joined: 15 Jan 2011
Posts: 5

PostPosted: Sat Jan 15, 2011 7:34 pm    Post subject: Reply with quote

Has there been any news or revelation here? I'm having identically the same problem. Same laptop, same situation (migration from HAL to udev), same output from dmesg and the serial debugger, same USE flags for xorg-drivers and xf86-input-wacom, and also have promising entries in 50-wacom.conf. I also had a working tablet under HAL and would like to reclaim that functionality.

I still very much consider myself a Gentoo neophyte but can post whatever reports you might deem necessary to help resolve this.

Thanks in advance!
Back to top
View user's profile Send private message
pneula
n00b
n00b


Joined: 16 Jan 2009
Posts: 37

PostPosted: Wed Mar 16, 2011 4:23 pm    Post subject: Reply with quote

Hello after a while...

Eventually, I got my touchscreen working by checking my Xorg configuration according to Linux Wacom wiki: http://sourceforge.net/apps/mediawiki/linuxwacom/index.php?title=Configuring_X

I can't define whether I was lacking something or whether the upgrade of the xf86-input-wacom helped. However, when I newly made up a xorg.conf for the touchscreen, the touchscreen devices began to run as smoothly as before the forementioned Xorg upgrade.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum