Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[CG] Pilote propriétaire [Résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
mysix
Apprentice
Apprentice


Joined: 26 Mar 2010
Posts: 183

PostPosted: Wed Mar 09, 2011 7:39 pm    Post subject: [CG] Pilote propriétaire [Résolu] Reply with quote

J'ai deux Ati Radeon HD 6950 en crossfire.
J'ai voulu installer les pilotes propriétaire pour avoir du bon 3D mais malheureusement ca ne fonctionne pas.
J'avais comme message d'erreur qu'il ne trouvait pas d'écran ?!
Quelqu'un à une idée ?
Pourtant, j'ai vu que la série 6xxx est pourtant supportée... Je me trompe ?

Alors en attendant je suis en VESA et le screen est assez moisi dans le sens ou je ne peux même pas régler ma résolution d'écran. Alors je voulais le modifier dans xorg.conf manuellement cependant il ne se trouve pas dans /etc/X11/xorg.conf. :roll:


Last edited by mysix on Wed Mar 16, 2011 8:03 am; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7897
Location: ~Brussels - Belgique

PostPosted: Wed Mar 09, 2011 8:18 pm    Post subject: Reply with quote

Code:
emerge --info
stp ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
mysix
Apprentice
Apprentice


Joined: 26 Mar 2010
Posts: 183

PostPosted: Wed Mar 09, 2011 8:33 pm    Post subject: Reply with quote

vala :roll:
Code:
Portage 2.1.9.42 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.11.3-r0, 2.6.36-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.36-gentoo-r5-x86_64-AMD_Phenom-tm-_II_X6_1100T_Processor-with-gentoo-1.12.14
Timestamp of tree: Wed, 09 Mar 2011 17:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p9
dev-lang/python:     2.6.6-r2, 3.1.3-r1
dev-util/ccache:     2.4-r9
dev-util/cmake:      2.8.4
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-fomit-frame-pointer -mtune=amdfam10 -O2 -mabm -msse -msse2 -msse3 -mmmx -m3dnow -msse4a -mabm -march=amdfam10 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-fomit-frame-pointer -mtune=amdfam10 -O2 -mabm -msse -msse2 -msse3 -mmmx -m3dnow -msse4a -mabm -march=amdfam10 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=7 --load-average=7.0 --with-bdeps y"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://de-mirror.org/distro/gentoo/"
LANG="fr_CH.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr"
MAKEOPTS="-j7 -l7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/dottout"
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 berkdb branding bzip2 cairo ccache cdr cli cracklib crypt cups cxx dbus device-mapper dri dvd extras fortran gdbm gdu gnome gpm gtk hald iconv icu ipv6 java jpeg mmx modules mudflap multilib ncurses nls nptl nptlonly opengl openmp pam pcre perl policykit pppd python readline session sqlite sse sse2 ssl sysfs tcpd threads unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa fbdev radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
mysix
Apprentice
Apprentice


Joined: 26 Mar 2010
Posts: 183

PostPosted: Thu Mar 10, 2011 9:34 am    Post subject: Reply with quote

J'ai un message à la fin de l'installation de ati-drivers :

Code:
 * Messages for package x11-drivers/ati-drivers-10.12:

 * You have DRM support built in to the kernel
 * Direct rendering will not work.


Ca signifie que je dois désactiver le DRM dans le kernel pour que le DRI fonctionne ?
C'est quoi ce DRM ?

Et voilà quand je veux faire un petit aticonfig :
Code:
aticonfig: No supported adapters detected
Back to top
View user's profile Send private message
mp342
Apprentice
Apprentice


Joined: 03 Aug 2010
Posts: 165
Location: France

PostPosted: Mon Mar 14, 2011 6:44 pm    Post subject: Reply with quote

DRM, c'est pour Direct Rendering Manager (http://dri.freedesktop.org/wiki/DRM en anglais)

As tu essayé de compiler ton noyau avec drm en module voir, si ça ne marche pas, le supprimer complètement ?
Back to top
View user's profile Send private message
ultrabug
Developer
Developer


Joined: 24 Jan 2005
Posts: 698
Location: Paris

PostPosted: Tue Mar 15, 2011 11:20 am    Post subject: Reply with quote

Pour compléter mp342, cet article t'aidera à configurer ton noyau correctement pour le direct rendering : http://www.gentoo.org/doc/en/dri-howto.xml
Back to top
View user's profile Send private message
mysix
Apprentice
Apprentice


Joined: 26 Mar 2010
Posts: 183

PostPosted: Wed Mar 16, 2011 8:02 am    Post subject: Reply with quote

C'est tout bon, il me fallait la dernière version des drivers ati du paquet ati-drivers qui était masqué.

Merci !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum