Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failed to submit batch buffer, expect rendering.. [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 436
Location: Ljubljana, Slovenia

PostPosted: Tue Mar 08, 2011 10:35 am    Post subject: Failed to submit batch buffer, expect rendering.. [SOLVED] Reply with quote

Ola

I am newbie, and I am on RatPoison two weeks now and I love it so much,
that I decided to put RP on my second laptop
I did all the steps that I did on my first laptop,
but I have some problems.

Simptoms:
Starting rp there is no startup message in rp bar.
For that matter, there is no rp bar
I can not split frames, but I can open xterm, or two,
but as I exit one, there is still 'leftover gui' from xterm
Also typing in xterm surf www.google.com does not bring up the frame,
but moving the rat around rat's pointer does change icon
from pointer to hand, as it is hovering over some link.
Also, C-t stops working after some time,
and exiting the rp I have all screen written with this line:

(EE) intel(0): Failed to submit batch buffer, expect rendering corruption or even a frozen display: No such device

I searched on internet, and all points to graphics (or so I understand).

I found only these concerning gentoo:
https://bugs.gentoo.org/354653
pointing to
https://bugs.freedesktop.org/show_bug.cgi?id=33016
but I can not find that patch, nor less how to apply patch...

I had working xfce 4.8, and all worked fine,
I unmerged xfce and emerged ratpoison,
and now I have this problem.

Help most appreciated.

Thank you

EDIT:

khuh, I do not know what or how, but I found a solution,
I downgraded xf84-video-intel and now it is working....

Thank you
_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
noisebleed
Apprentice
Apprentice


Joined: 03 Oct 2006
Posts: 177
Location: Porto, Portugal

PostPosted: Wed Mar 23, 2011 5:44 pm    Post subject: Re: Failed to submit batch buffer, expect rendering.. [SOLVE Reply with quote

while true wrote:

EDIT:

khuh, I do not know what or how, but I found a solution,
I downgraded xf84-video-intel and now it is working....

Thank you


Got trapped into the same issue and your edit saved my KDE. So, thank you!
_________________
Please add [SOLVED] to the subject line if the posted issue is resolved.
Back to top
View user's profile Send private message
noisebleed
Apprentice
Apprentice


Joined: 03 Oct 2006
Posts: 177
Location: Porto, Portugal

PostPosted: Wed Mar 23, 2011 5:50 pm    Post subject: Reply with quote

Looks like this has been fixed in recent kernels as seen in Bug 301282 and Bug 354653.

I'm running 2.6.32-tuxonice-r7 and I'm upgrading to a newer kernel (2.6.36). What kernel are you running? Have you tried to update yet?
_________________
Please add [SOLVED] to the subject line if the posted issue is resolved.
Back to top
View user's profile Send private message
while true
Guru
Guru


Joined: 07 Apr 2010
Posts: 436
Location: Ljubljana, Slovenia

PostPosted: Wed Mar 23, 2011 6:13 pm    Post subject: Re: Failed to submit batch buffer, expect rendering.. [SOLVE Reply with quote

noisebleed wrote:
Got trapped into the same issue and your edit saved my KDE. So, thank you!


Oh, this is my first help to somebody here on this forum, kheh thank you..

I am running 2.6.32 kernel,
as newbie I am still afraid to take the step of upgrading my kernel,
but I guess I will be forced soon...
_________________
Kind regards, Goran Mitic

alive
while true
kick ass
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum