Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Building sys-libs/glibc-2.11.2-r2 fails on 1 of 2 64-bit box
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
Tanktalus
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2005
Posts: 75

PostPosted: Fri Oct 29, 2010 4:08 pm    Post subject: Building sys-libs/glibc-2.11.2-r2 fails on 1 of 2 64-bit box Reply with quote

I have two 64-bit boxes, both set up with crossdev to cross-compile 32-bit, and distcc, to allow them not only to help each other, but to also help update an older 32-bit box (running email and dns servers).

Today, the new glibc comes out - one of my boxes has no problem compiling it. The other gets an error like this:

Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: i386:x86-64 architecture of input file `/var/tmp/portage/sys-libs/glibc-2.11.2-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/math/libm_pic.a(k_standard.os)' is incompatible with i386 output


(This is repeated dozens of times)

I don't think this is (necessarily) a bug in the build since it worked fine on my other machine. But any ideas on where to look to get this working would be appreciated.

Code:
# gcc-config -l
 [1] i686-pc-linux-gnu-4.4.4 *

 [2] x86_64-pc-linux-gnu-4.3.4
 [3] x86_64-pc-linux-gnu-4.4.4 *


Thanks,
Back to top
View user's profile Send private message
selig
Guru
Guru


Joined: 31 Jul 2005
Posts: 425
Location: Prague, Czech Republic

PostPosted: Sat Oct 30, 2010 11:18 am    Post subject: Reply with quote

Hello! I have run into the same issue and I do not know what to do about it...
Code:

collect2: ld returned 1 exit status
distcc[12136] ERROR: compile (null) on localhost failed
make[2]: *** [/var/tmp/portage/sys-libs/glibc-2.11.2-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/csu/crt1.o] Error 1
make[2]: *** Waiting for unfinished jobs....
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: i386:x86-64 architecture of input file `/var/tmp/portage/sys-libs/glibc-2.11.2-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/csu/init.o' is incompatible with i386 output
collect2: ld returned 1 exit status
distcc[12137] ERROR: compile (null) on localhost failed
make[2]: *** [/var/tmp/portage/sys-libs/glibc-2.11.2-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/csu/Scrt1.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.11.2-r2/work/glibc-2.11.2/csu'
make[1]: *** [csu/subdir_lib] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.11.2-r2/work/glibc-2.11.2'
make: *** [all] Error 2
Back to top
View user's profile Send private message
selig
Guru
Guru


Joined: 31 Jul 2005
Posts: 425
Location: Prague, Czech Republic

PostPosted: Sat Oct 30, 2010 12:11 pm    Post subject: Reply with quote

Well, I managed to get it to compile... I had to disable distcc and use MAKEOPTS="-j2" (instead of -j4). Some packages just do not like distcc.
Back to top
View user's profile Send private message
Tanktalus
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2005
Posts: 75

PostPosted: Tue Nov 02, 2010 4:13 am    Post subject: Reply with quote

selig wrote:
Well, I managed to get it to compile... I had to disable distcc and use MAKEOPTS="-j2" (instead of -j4). Some packages just do not like distcc.


Well, given that I get it to compile with distcc just fine on my other x86-64 box, which also uses distcc, I'm trying to figure out what the issue is.

I've also noticed that when I compile the kernel on my 32-bit box, anything that goes to the failing 64-bit box for cross compilation actually does not get compiled as 32-bit, but instead comes back as a 64-bit binary, and has to be recompiled locally. But anything going to the box that successfully compiles glibc as 64-bit will cross-compile properly as well. I wonder if there is something wrong with the cross-compilation or distcc setup. Any experts on either of these topics - I'd appreciate any advice :-)
Back to top
View user's profile Send private message
xathin
n00b
n00b


Joined: 05 Sep 2006
Posts: 64
Location: Vancouver, BC

PostPosted: Sun Mar 06, 2011 9:50 am    Post subject: Reply with quote

I seem to be having the same issue with distcc and glibc. I also have ccache in use, but glibc builds just fine with only ccache. As far as I can see, it seems to be an issue with distcc.

Has anyone been able to find out what the problem with this is? I am using 2 nearly identical machines, both running gentoo on amd64. One is ~amd64, other is amd64, but both have the same glibc, distcc and gcc versions. So far, I have only tried going one way with this build. I am trying to perform a complete rebuild, but glibc keeps coming up with errors while using distcc.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum