Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Portage pulling in htdig on a world update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
pcameron
n00b
n00b


Joined: 04 Aug 2011
Posts: 43

PostPosted: Thu Oct 27, 2011 6:04 am    Post subject: [Solved] Portage pulling in htdig on a world update Reply with quote

Hi all.

I have a little bit of a simple question, but im not sure how you would find the answer.

Every time I perform a emerge -uND world, portage installs htdig onto the server. I then go an unmerge the software manually. This has happened the last 3 updates.

I was wondering how I would track down why emerge thinks htdig should be installed system. I'm unsure how to troubleshoot this issue.

Reason why is; i'm running my own home web server which faces the internet, and I don't want to be offering dig through a webpage.

Thanks
Lock


Last edited by pcameron on Thu Oct 27, 2011 9:44 am; edited 1 time in total
Back to top
View user's profile Send private message
pcameron
n00b
n00b


Joined: 04 Aug 2011
Posts: 43

PostPosted: Thu Oct 27, 2011 9:24 am    Post subject: Reply with quote

ok so noob me has figured out that equery shows the packages which are dependent on.

Calculating dependencies... done!
[ebuild N ] www-misc/htdig-3.2.0_beta6-r3 USE="-ssl" 0 kB
[ebuild R ] kde-base/khelpcenter-4.7.2 USE="(-aqua) -debug (-kdeenablefinal)" 0 kB

I guess I have to unmerge the help. I really don't want it.

:)
Back to top
View user's profile Send private message
pcameron
n00b
n00b


Joined: 04 Aug 2011
Posts: 43

PostPosted: Thu Oct 27, 2011 9:27 am    Post subject: Reply with quote

pcameron wrote:

I guess I have to unmerge the help. I really don't want it.

:)


:( will keep looking further, just attempted to pull both packages back in
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1091
Location: Romania

PostPosted: Thu Oct 27, 2011 9:32 am    Post subject: Reply with quote

The "handbook" USE flag is the culprit.
Back to top
View user's profile Send private message
pcameron
n00b
n00b


Joined: 04 Aug 2011
Posts: 43

PostPosted: Thu Oct 27, 2011 9:42 am    Post subject: Reply with quote

With some equery here and equery there,

Ive figured out that its the handbook flag which is not in my default /etc/make.conf file. This is pulling in htdig into khelpcenter, think its just better to remove it completely and work backwards for specific packages which i want the handbook in.
Back to top
View user's profile Send private message
pcameron
n00b
n00b


Joined: 04 Aug 2011
Posts: 43

PostPosted: Thu Oct 27, 2011 9:43 am    Post subject: Reply with quote

sebaro wrote:
The "handbook" USE flag is the culprit.


Just refreshed the screen, thanks mate :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum