Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bridging eth to wlan, enters promiscuous mode, loose connect
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ManDay
Apprentice
Apprentice


Joined: 22 Jan 2008
Posts: 229

PostPosted: Tue Mar 01, 2011 1:56 pm    Post subject: Bridging eth to wlan, enters promiscuous mode, loose connect Reply with quote

I try to brige a

Code:
03:00.0 Ethernet controller: Attansic Technology Corp. Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller (rev b0)
   Subsystem: ASUSTeK Computer Inc. Device 8324
   Flags: bus master, fast devsel, latency 0, IRQ 41
   Kernel driver in use: ATL1E


with to a

Code:
01:00.0 Network controller: RaLink RT2860
   Subsystem: RaLink Device 2790
   Physical Slot: eeepc-wifi
   Flags: bus master, fast devsel, latency 0, IRQ 19
   Kernel driver in use: rt2860
   Kernel modules: rt2860sta


with connectivity to the AP by

Code:
brctl addbr br0 && brctl addif wlan0


Upon the second command dmesg reports that

Code:
device wlan0 entered promiscuous mode


and I loose all sorts of connectivity, with ifconfig still claiming that

Code:
wlan0     Link encap:Ethernet  HWaddr 00:22:43:43:75:6e 
          inet addr:192.168.2.121  Bcast:192.168.2.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2413223 errors:1325 dropped:0 overruns:0 frame:0
          TX packets:219998 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:725162598 (691.5 MiB)  TX bytes:37301961 (35.5 MiB)
          Interrupt:19


wpa_supplicant claims to still be connected, too, so does iwconfig:

Code:
wlan0     Ralink STA  ESSID:"XXXXXXXXXX"  Nickname:"RT2860STA"
          Mode:Managed  Frequency=2.427 GHz  Access Point: 00:1C:4A:07:7F:76   
          Bit Rate=54 Mb/s   
          RTS thr:off   Fragment thr:off
          Encryption key: XXXXXXXXX
          Link Quality=100/100  Signal level:-62 dBm  Noise level:-81 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
.

When I remove the interface from the bridge

Code:
device wlan0 left promiscuous mode
br0: port 1(wlan0) entering disabled state


operations resume as normal. Any clue? Thanks!
Back to top
View user's profile Send private message
ianw1974
Guru
Guru


Joined: 18 Oct 2006
Posts: 387
Location: UK and Poland

PostPosted: Wed Mar 02, 2011 8:33 pm    Post subject: Reply with quote

You cannot bridge wireless. As soon as you do, this is what happens.

There are ways of doing it with creating tap devices.
_________________
Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Linux Systems Limited | Masternode Monitoring
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum