Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] KDE 4.6... dove sono gli usb storage?!?!?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
guerro
Guru
Guru


Joined: 21 Jun 2004
Posts: 374
Location: Brescia

PostPosted: Thu Feb 24, 2011 10:46 am    Post subject: [RISOLTO] KDE 4.6... dove sono gli usb storage?!?!? Reply with quote

Ciao a tutti,
il problema in sostanza è semplice, quando inserisco una pennina usb ad esempio nulla compare nella lista dei dispositivi del notificatore...
se però vado a vedere nei dispositivi removibili il dispositivo compare....

C'è qualche bug dietro che voi sappiate?

Alla fine per ora stò ovviando montando il dispositivo manualmente dalla console con "mount", però è avvilente...
Sul forum ho provato a cercare, ma con scarsi risultati e le soluzioni proposte non hanno prodotto effetti...
_________________
(.(*. .*).)
.. G u e r r o ..
(.(.* *.).)


Last edited by guerro on Mon Feb 28, 2011 11:35 am; edited 2 times in total
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Thu Feb 24, 2011 12:58 pm    Post subject: Reply with quote

1) hai avuto altre versioni di kde precedentemente? se si, ti andava?

2) kde 4.6.0 non usa più hal ma udisk. che possa esserti d'aiuto?

3) Spiegati meglio:
Quote:
quando inserisco una pennina usb ad esempio nulla compare nella lista dei dispositivi del notificatore...
se però vado a vedere nei dispositivi removibili il dispositivo compare


i "dispositivi removibili" intendi l'applet di plasma? (vedi link sotto)
http://www.google.it/imgres?imgurl=http://polishlinux.org/reviews/kde-4-rev-790000/kde4_790000_device.jpg&imgrefurl=http://polishlinux.org/kde/kde-4-rev-790000-better-stability-and-performance/&usg=__sJ433ZGsfaiKs6NR8ggDdFzvvdw=&h=361&w=399&sz=47&hl=it&start=0&zoom=1&tbnid=MddHwwnvsQrP8M:&tbnh=141&tbnw=156&ei=m1VmTf-tFcmfOvK45ZAL&prev=/images%3Fq%3Dnotifier%2Bdevices%2Bkde%2B4%2Bplasma%2Bapplet%26um%3D1%26hl%3Dit%26client%3Dfirefox-a%26rls%3Dorg.gentoo:en-US:unofficial%26biw%3D1389%26bih%3D583%26tbs%3Disch:1&um=1&itbs=1&iact=hc&vpx=626&vpy=235&dur=3196&hovh=214&hovw=236&tx=156&ty=116&oei=m1VmTf-tFcmfOvK45ZAL&page=1&ndsp=21&ved=1t:429,r:10,s:0


dispositivi del notificatore che cosa intendi?
_________________
Darkman
Back to top
View user's profile Send private message
guerro
Guru
Guru


Joined: 21 Jun 2004
Posts: 374
Location: Brescia

PostPosted: Thu Feb 24, 2011 2:54 pm    Post subject: Reply with quote

1) si, prima avevo la 4.5.5 e funzionava bene

2) L'ho visto ed infatti ho eliminato hal utilizzando udisk

3) Hai ragione, probabilmente mi son spiegato male... allora: il "notificatore" è l'oggetto plamoid che si attiva quando ad esempio inserisci un CD-rom, piuttosto che una pennina e ti fa vedere in una tendina l'elenco dei dispositivi collegati, e cliccando su uno di essi ti propone le azioni da fare (aprire, ecc....) e ti permette poi in un secondo tempo di smontare (bottone eject a fianco del dispositivo)
Quando scrivo "..vado a vedere nei dispositivi removibili il dispositivo compare" intendevo dire che andando nelle impostazioni di sistema > Hardware > Dispositivi removibili il dispositivo lo vedo

Spero di essere stato più chiaro... :)
_________________
(.(*. .*).)
.. G u e r r o ..
(.(.* *.).)
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sat Feb 26, 2011 12:55 pm    Post subject: Reply with quote

Strano, a me funziona benissimo... Su dolphin ti appaiono i dispositivi?
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
guerro
Guru
Guru


Joined: 21 Jun 2004
Posts: 374
Location: Brescia

PostPosted: Sun Feb 27, 2011 11:24 am    Post subject: Reply with quote

pierino_89 wrote:
Strano, a me funziona benissimo... Su dolphin ti appaiono i dispositivi?


No i dispositivi non li vedo... purtroppo....
_________________
(.(*. .*).)
.. G u e r r o ..
(.(.* *.).)
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sun Feb 27, 2011 3:15 pm    Post subject: Reply with quote

Allora occhio, potrebbe non essere una questione di kde malconfigurato. I dispositivi che vedi sotto le impostazioni sono lì per effetto memoria.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
guerro
Guru
Guru


Joined: 21 Jun 2004
Posts: 374
Location: Brescia

PostPosted: Mon Feb 28, 2011 7:39 am    Post subject: Reply with quote

l'ho pensato anche io, infatto ho provato a ripulire tutta la fuffa e quando l'ho attaccata la prima volta è comparsa, quindi l'ha rilevata.... ...quello che non capisco è perchè il "notificatore" non li rileva e di conseguenza non è possibile nemmeno far fare il montaggio del dispositivo....

EDIT:
ho provato a lanciare "udisks --monitor" e lui rileva che attacco e stacco la pennina...
Ho sempre più la convinzione che sia proprio il "notificatore dei dispositivi" che rompe le scatole.....


RISOLTOOO!!!
HO DOVUTO EDITARE
/lib/udev/rules.d/80-udisks.rules:
questa linea
KERNEL=="sd*|hd*|sr*|mmcblk*|mspblk*", ENV{UDISKS_PRESENTATION_NOPOLICY}="0"
con questa
KERNEL=="sd*|hd*|sr*|ub*|mmcblk*|mspblk*", ENV{UDISKS_PRESENTATION_NOPOLICY}="0"


Dovuto aggiungere "ub*" in quanto le mie usbpen vengono censite come ub*

Non so se è da considerarsi un bug oppure è ANORMALE che le memorie di massa usb vengano censite come ub*.....
_________________
(.(*. .*).)
.. G u e r r o ..
(.(.* *.).)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum