Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
BCM4312: Can't use encryption?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 226
Location: Clarkston, Michigan

PostPosted: Sun Feb 20, 2011 1:58 am    Post subject: BCM4312: Can't use encryption? Reply with quote

Hi,

I have a Dell Inspiron 1525 with the BCM4312 wi-fi card. I have tried setting up the wireless connection in several ways, including using the b43 driver, using ndiswrapper, and using Broadcom's driver(net-wireless/broadcom-sta in portage). All of them see my card, and it is always able to connect to un-encrypted wireless networks, but it just won't play nice with encrypted ones. All of the networks I've tried have been encrypted with WPA/WPA2 keys. The closest any of the drivers has gotten is ndiswrapper. It was hard to test because as soon as ndiswrapper catches wind of another driver for my wifi card it refuses to load(how do you turn this detection off BTW?), but when I connect to the wifi network using NetworkManager and run NetworkManager using the --no-daemon option, it gets as far as asking for an IP address, and eventually just times out. I can't show any output right now because I'm not near any of the encrypted networks that I use. Unfortunately, if I was, I wouldn't be able to get on the internet :P

So what's going on? Could I be lacking kernel support for the encryption methods or something?
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1404
Location: Montréal

PostPosted: Sun Feb 20, 2011 2:56 am    Post subject: Reply with quote

Hi,
I have the BCM4312 chip in an eMachines E627. I use Debian and ArchLinux. No one of the two can use the b43 and the ndiswrapper drivers. I can not see network and connect with the first and the second give a kernel Oops at load time. I haven't try to go deeper to make them work, I use the Broadcom-sta module with enough success to continue with it.

To disable a module, I do not blacklist it, I use the install command of the modprobe.conf file in /etc/modprobe.d/modprobe.conf:
Code:
install b43 /bin/true
install ndiswrapper /bin/true
install ssb /bin/true
install wl /bin/true

I use the -i or --ignore-install option of the modprobe command when I want to use one of the module. In that way, I have full control and both the kernel and udev cannot load the module. It is good for manual configuration of the network but will make boot network script fail if not adapted.

I connect using the wl module with WPA version 1 encryption authentification with the help of wpa_supplicant and several dhcp clients like dhclient dhcpcd and pump. I was using an AD-HOC network with wl Broadcom-sta module. I saw that the parameters I pass to the card need time to become active. It is possible that the commit parameter of the iwconfig command need to be use with the BCM4312 chipset to force the card to apply the configuration changes. More information in the man iwconfig.
_________________
Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum