Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] problema con la localizzazione
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
uoslagelo
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jul 2009
Posts: 81

PostPosted: Fri Feb 18, 2011 3:27 pm    Post subject: [RISOLTO] problema con la localizzazione Reply with quote

Salve compari gentooiniani,
ho un piccolo problema con la localizzazione. Son passato da poco a UTF-8 perché gvfs con gdu attivo faceva i capricci. Ora il problema è che tutto il sistema è in inglese invece di essere in italiano. Vi posto qualche info:

Code:
cat /etc/env.d/02locale
LANG="it_IT_UTF-8"
LC_COLLATE="C"
LC_CTYPE="it_IT.UTF-8"


Code:
cat /etc/locale.gen
it_IT.UTF-8 UTF-8


Code:
locale
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=it_IT_UTF-8
LC_CTYPE=it_IT.UTF-8
LC_NUMERIC="it_IT_UTF-8"
LC_TIME="it_IT_UTF-8"
LC_COLLATE=C
LC_MONETARY="it_IT_UTF-8"
LC_MESSAGES="it_IT_UTF-8"
LC_PAPER="it_IT_UTF-8"
LC_NAME="it_IT_UTF-8"
LC_ADDRESS="it_IT_UTF-8"
LC_TELEPHONE="it_IT_UTF-8"
LC_MEASUREMENT="it_IT_UTF-8"
LC_IDENTIFICATION="it_IT_UTF-8"
LC_ALL=


Code:
emerge --info
Portage 2.1.9.25 (default/linux/x86/10.0/desktop, gcc-4.4.4, glibc-2.13-r0, 2.6.37-gentoo i686)
=================================================================
System uname: Linux-2.6.37-gentoo-i686-AMD_Sempron-tm-_Processor_3100+-with-gentoo-1.12.14
Timestamp of tree: Fri, 11 Feb 2011 12:30:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT_UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/sunrise /var/lib/layman/sara"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa applet automount berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups custom-optimization cxx dbus device-mapper dri dts dvd dvdr emboss emerlad encode exif extras fam fat fbcondecor ffmpeg firefox flac fortran fts3 gdbm gdu gif gnome gpm gstreamer gtk gvfs hddtemp iconv jpeg lcdfilter lcms ldap libnotify lm_sensors mad mikmod mmx mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl nptlonly ntfs ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support readline sdl secure-delete sensord session spell sse sse2 ssl startup-notification svg sysfs tcpd theora tiff tordns truetype udev unicode usb v4l2 vorbis webcam wifi x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa via radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Ho già dato i comandi:
Code:

locale-gen
localedef -i it_IT -f UTF-8 it_IT.UTF-8


Last edited by uoslagelo on Mon Feb 28, 2011 12:43 am; edited 1 time in total
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Fri Feb 18, 2011 4:00 pm    Post subject: Re: problema con la localizzazione Reply with quote

Code:
cat /etc/env.d/02locale
LANG="it_IT_UTF-8"


Credo debba essere:
LANG="it_IT.UTF-8"
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sat Feb 19, 2011 10:09 pm    Post subject: Reply with quote

Quoto, però direi di controllare con
Code:
locale -a

Io pur avendo definito gli stessi parametri l'italiano utf8, ho:
Code:
# locale -a
C
en_US
en_US.iso88591
en_US.utf8
italian
it_IT
it_IT@euro
it_IT.iso88591
it_IT.iso885915@euro

it_IT.utf8

POSIX

_________________
Linux registered user 461710
Back to top
View user's profile Send private message
uoslagelo
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jul 2009
Posts: 81

PostPosted: Mon Feb 28, 2011 12:42 am    Post subject: Reply with quote

il problema era proprio il trattino in LANG. Corretto in LANG="it_IT.UTF-8" e ora tutto risolto. Grazie a tutti
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum