Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[EMERGE] mise a jour (RESOLU)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
floc_12
Apprentice
Apprentice


Joined: 28 Jun 2006
Posts: 191

PostPosted: Thu Feb 17, 2011 7:53 pm    Post subject: [EMERGE] mise a jour (RESOLU) Reply with quote

Bonjour,

Je rencontre des problèmes lors de mes mises à jour :

Quote:
emerge -NDuav world


Quote:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] x11-proto/bigreqsproto-1.1.1 [1.1.0] USE="-doc%" 0 kB
[ebuild U ] x11-proto/xcmiscproto-1.2.1 [1.2.0] USE="-doc%" 66 kB
[ebuild N ] x11-apps/xinit-1.3.0-r2 USE="-minimal" 136 kB
[ebuild U ] x11-base/xorg-server-1.9.4 [1.7.7-r1] USE="ipv6 kdrive nptl udev%* xorg -dmx -doc% -minimal -static-libs% -tslib (-debug%) (-hal%*) (-sdl%*)" 5,071 kB
[blocks b ] <x11-base/xorg-server-1.8.0 ("<x11-base/xorg-server-1.8.0" is blocking x11-apps/xinit-1.3.0-r2)
[ebuild N ] app-admin/eselect-php-0.6.2 2 kB
[uninstall ] app-admin/php-toolkit-1.0.1
[blocks b ] app-admin/php-toolkit ("app-admin/php-toolkit" is blocking app-admin/eselect-php-0.6.2)
[ebuild NS ] dev-lang/php-5.3.5 [5.3.3-r1] USE="berkdb bzip2 cli crypt ctype exif fileinfo filter gd gdbm hash iconv ipv6 json ldap nls phar posix readline session simplexml spell sqlite ssl tokenizer truetype unicode xml zlib (-adabas) -apache2 -bcmath (-birdstep) -calendar -cdb -cgi -cjk -curl -curlwrappers -db2 (-dbmaker) -debug -doc -embed (-empress) (-empress-bcs) -enchant (-esoob) (-firebird) -flatfile -fpm (-frontbase) -ftp -gd-external -gmp -imap -inifile -interbase -intl -iodbc -kerberos -kolab -ldap-sasl -libedit -mhash -mssql -mysql -mysqli -mysqlnd -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -postgres -qdbm -recode -sapdb -sharedext -sharedmem -snmp -soap -sockets (-solid) -sqlite3 -suhosin (-sybase-ct) -sysvipc -threads -tidy -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -zip" 10,563 kB
[uninstall ] dev-lang/php-5.3.3-r1 USE="berkdb bzip2 cli crypt ctype exif fileinfo filter gd gdbm hash iconv ipv6 json ldap nls phar posix readline session simplexml spell sqlite ssl tokenizer truetype unicode xml xmlreader xmlwriter zlib (-adabas) -apache2 -bcmath (-birdstep) -calendar -cdb -cgi -cjk -concurrentmodphp -curl -curlwrappers -db2 (-dbmaker) -debug -doc -embed (-empress) (-empress-bcs) -enchant (-esoob) (-firebird) -flatfile -fpm (-frontbase) -ftp -gd-external -gmp -imap -inifile -interbase -intl -iodbc -kerberos -kolab -ldap-sasl -libedit -mssql -mysql -mysqli -mysqlnd -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -postgres -qdbm -recode -sapdb -sharedext -sharedmem -snmp -soap -sockets (-solid) -sqlite3 -suhosin (-sybase-ct) -sysvipc -threads -tidy -wddx -xmlrpc -xpm -xsl -zip"
[blocks b ] dev-lang/php:5 ("dev-lang/php:5" is blocking dev-lang/php-5.3.5)

Total: 6 packages (3 upgrades, 2 new, 1 in new slot, 2 uninstalls), Size of downloads: 15,835 kB
Conflict: 3 blocks


J'ai beau essayer de masquer xinit, xorg et php, mais les erreurs persistent. Je viens de supprimer xinit, mais c'est identique.
Si je masque xorg, j'ai une alerte a chaque emerge.
Apparemment, le problème est connu, mais je ne trouve pas vraiment de solution.

Quelqu un aurait il deja eu ce problème ?

Merci


Last edited by floc_12 on Thu Feb 17, 2011 9:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Thu Feb 17, 2011 8:36 pm    Post subject: Reply with quote

xorg est dorénavant stable en 1.9.4. Est-ce que tu as essayé de nettoyer ton packages.keywords, ou autre ?
D'ailleurs, la 1.8.0 n'est plus disponible normalement.
Back to top
View user's profile Send private message
floc_12
Apprentice
Apprentice


Joined: 28 Jun 2006
Posts: 191

PostPosted: Thu Feb 17, 2011 8:42 pm    Post subject: Reply with quote

merci de ta réponse cr0k.

J'ai effectivement regardé, mais je ne vois pas ce qui pourrais bloquer la maj. Du coup, je viens d'essayer de la forcer ...

cat /etc/portage/package.keywords

Quote:
# ---- vlc ----#
media-video/vlc ~amd64

# ---- flash ----#
www-plugins/adobe-flash ~amd64

# ---- compiz ---#
dev-libs/protobuf
dev-util/intltool
dev-python/compizconfig-python
x11-apps/ccsm
x11-libs/libcompizconfig
x11-libs/compizconfig-backend-gconf
x11-libs/compizconfig-backend-kconfig
x11-libs/compizconfig-backend-kconfig4
x11-libs/compiz-bcop
x11-plugins/compiz-plugins-main
x11-plugins/compiz-plugins-extra
x11-plugins/compiz-plugins-unsupported
x11-themes/emerald-themes
x11-wm/compiz
x11-wm/compiz-fusion
x11-wm/emerald
x11-apps/fusion-icon

# ---- conky ----#
app-admin/conkyforecast ~amd64

# ---- xbmc ----#
media-tv/xbmc ~amd64

# ---- Qemu ----#
games-emulation/epsxe ~amd64
app-emulation/qemu-kvm ~amd64

# ---- Virtual manager ----#
app-emulation/virt-manager ~amd64
app-emulation/virt-manager ~amd64
app-emulation/virtinst ~amd64
app-emulation/libvirt ~amd64
net-analyzer/netcat6 ~amd64
app-emulation/qemu-kvm ~amd64
dev-libs/yajl ~amd64

#---- Thunar -----#
xfce-extra/thunar-thumbnailers ~amd64

#---- CairoDock -----#
x11-misc/cairo-dock ~amd64
x11-misc/cairo-dock-plugins ~amd64

Quand au package.mask, tout est en commentaire :

cat /etc/portage/package.mask

Quote:
#>=x11-base/xorg-server-1.9.2
#<=x11-base/xorg-server-1.8.0
#>=x11-wm/compiz-0.9.2
#>=x11-wm/compiz-fusion-0.9.2
#>=x11-apps/ccsm-0.9.2
#>=dev-python/compizconfig-python-0.9.2
#>=x11-libs/compizconfig-backend-gconf-0.9.2
#>=x11-libs/libcompizconfig-0.9.2
#>=x11-plugins/compiz-plugins-extra-0.9.2
#>=x11-plugins/compiz-plugins-main-0.9.2
#>=x11-plugins/compiz-plugins-unsupported-0.9.2
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Thu Feb 17, 2011 9:25 pm    Post subject: Re: [EMERGE] mise a jour Reply with quote

floc_12 wrote:
Bonjour,

Je rencontre des problèmes lors de mes mises à jour :

Quote:
emerge -NDuav world


Quote:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] x11-proto/bigreqsproto-1.1.1 [1.1.0] USE="-doc%" 0 kB
[ebuild U ] x11-proto/xcmiscproto-1.2.1 [1.2.0] USE="-doc%" 66 kB
[ebuild N ] x11-apps/xinit-1.3.0-r2 USE="-minimal" 136 kB
[ebuild U ] x11-base/xorg-server-1.9.4 [1.7.7-r1] USE="ipv6 kdrive nptl udev%* xorg -dmx -doc% -minimal -static-libs% -tslib (-debug%) (-hal%*) (-sdl%*)" 5,071 kB
[blocks b ] <x11-base/xorg-server-1.8.0 ("<x11-base/xorg-server-1.8.0" is blocking x11-apps/xinit-1.3.0-r2)
[ebuild N ] app-admin/eselect-php-0.6.2 2 kB
[uninstall ] app-admin/php-toolkit-1.0.1
[blocks b ] app-admin/php-toolkit ("app-admin/php-toolkit" is blocking app-admin/eselect-php-0.6.2)
[ebuild NS ] dev-lang/php-5.3.5 [5.3.3-r1] USE="berkdb bzip2 cli crypt ctype exif fileinfo filter gd gdbm hash iconv ipv6 json ldap nls phar posix readline session simplexml spell sqlite ssl tokenizer truetype unicode xml zlib (-adabas) -apache2 -bcmath (-birdstep) -calendar -cdb -cgi -cjk -curl -curlwrappers -db2 (-dbmaker) -debug -doc -embed (-empress) (-empress-bcs) -enchant (-esoob) (-firebird) -flatfile -fpm (-frontbase) -ftp -gd-external -gmp -imap -inifile -interbase -intl -iodbc -kerberos -kolab -ldap-sasl -libedit -mhash -mssql -mysql -mysqli -mysqlnd -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -postgres -qdbm -recode -sapdb -sharedext -sharedmem -snmp -soap -sockets (-solid) -sqlite3 -suhosin (-sybase-ct) -sysvipc -threads -tidy -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -zip" 10,563 kB
[uninstall ] dev-lang/php-5.3.3-r1 USE="berkdb bzip2 cli crypt ctype exif fileinfo filter gd gdbm hash iconv ipv6 json ldap nls phar posix readline session simplexml spell sqlite ssl tokenizer truetype unicode xml xmlreader xmlwriter zlib (-adabas) -apache2 -bcmath (-birdstep) -calendar -cdb -cgi -cjk -concurrentmodphp -curl -curlwrappers -db2 (-dbmaker) -debug -doc -embed (-empress) (-empress-bcs) -enchant (-esoob) (-firebird) -flatfile -fpm (-frontbase) -ftp -gd-external -gmp -imap -inifile -interbase -intl -iodbc -kerberos -kolab -ldap-sasl -libedit -mssql -mysql -mysqli -mysqlnd -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -postgres -qdbm -recode -sapdb -sharedext -sharedmem -snmp -soap -sockets (-solid) -sqlite3 -suhosin (-sybase-ct) -sysvipc -threads -tidy -wddx -xmlrpc -xpm -xsl -zip"
[blocks b ] dev-lang/php:5 ("dev-lang/php:5" is blocking dev-lang/php-5.3.5)

Total: 6 packages (3 upgrades, 2 new, 1 in new slot, 2 uninstalls), Size of downloads: 15,835 kB
Conflict: 3 blocks


J'ai beau essayer de masquer xinit, xorg et php, mais les erreurs persistent. Je viens de supprimer xinit, mais c'est identique.
Si je masque xorg, j'ai une alerte a chaque emerge.
Apparemment, le problème est connu, mais je ne trouve pas vraiment de solution.

Quelqu un aurait il deja eu ce problème ?

Merci


Salut,

Essai ça:
Code:
emerge -avC =x11-base/xorg-server-1.8.0 php-toolkit  php:5 &&  emerge -NDuav world

_________________
Get Up and Go !
Back to top
View user's profile Send private message
floc_12
Apprentice
Apprentice


Joined: 28 Jun 2006
Posts: 191

PostPosted: Thu Feb 17, 2011 9:50 pm    Post subject: Reply with quote

Problème résolu : J'y ai été a la bourrin. J"ai forcé la mise à jour en ignorant l'erreur, recompilé mon driver nvidia et evdev, et ca refonctionne 8O .... Mon emerge ne me fait plus de caprice a présent :D

emerge -NDuav world
Quote:

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

Nothing to merge; would you like to auto-clean packages? [Yes/No] y
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum