Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemi con emerge gentoo-source
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
oPKo
n00b
n00b


Joined: 15 Feb 2011
Posts: 4

PostPosted: Tue Feb 15, 2011 8:19 pm    Post subject: Problemi con emerge gentoo-source Reply with quote

Salve a tutti,

ho un problema nell'installazione di gentoo. Qualche anno fa (2008) ho installato con successo gentoo, ma dopo la sostituzione del disco mi ritrovo a dover reinstallare da zero.
Dopo aver scaricato e installato stage3-i686-20110208.tar.bz2 e portage-latest.tar.bz2, e aver fatto il chroot, non riesco a completare l'emerge dei sorgenti del kernel.

Sono molteplici errori del tipo:

* Messages for package <nome del package>:
* The ebuild phase 'postrm' has exited unexpectedly.

dopo di che non è più possibile utilizzare emerge o qualsiasi altro comando come ls ottenendo l'errore

"bash: /bin/ls: No such file or directory"

La sequenza che eseguo è quella indicata in http://www.gentoo.org/doc/it/handbook/handbook-x86.xml
Potete darmi una mano?

Grzie in anticipo
Back to top
View user's profile Send private message
marziods
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2009
Posts: 124
Location: <Roma>par lavor | Udine | Friul | Italie

PostPosted: Tue Feb 15, 2011 8:53 pm    Post subject: Reply with quote

scusami la domanda... hai seguito *esattamente* la guida? non è che per caso hai saltato qualche comando... qualche errore magari in fase di chroot...
hai fatto un solo tentativo o piu tentativi e gli errori sono gli stessi? architettura del sistema?
benvenuto :P
_________________
linux user #493115
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Tue Feb 15, 2011 8:57 pm    Post subject: Reply with quote

uhm... molto strano il tuo errore, sembra che portage sia scazzato
e che anche $PATH sia andato in malora.


hai già provato a scaricare i files da altri mirror? stesso errore?
ti da errori strani quando scompatti i suddetti files?

visto che esegui alla lettera i passaggi, non mi viene in mente altro, sinceramente.
per caso, puoi spostarti su un'altra shell e vedere se dentro messages (della gentoo chroottata) ci sono errori di qualche tipo. portage tiene un log, prova a postarlo.
_________________
Darkman
Back to top
View user's profile Send private message
oPKo
n00b
n00b


Joined: 15 Feb 2011
Posts: 4

PostPosted: Tue Feb 15, 2011 9:35 pm    Post subject: Reply with quote

nel mentre ho ripreso dallo stage scaricato e in sequenza ho eseguito:

1)
Code:
cd /mnt/gentoo

2)
Code:
tar xvjpf stage3-*.tar.bz2

3)
Code:
rm -r -f /usr/portage


4)
Code:
tar xvjf portage-latest.tar.bz2 -C /mnt/gentoo/usr

5)
Code:
nano -w /mnt/gentoo/etc/make.conf

inserendo
USE="-gtk -gnome qt4 kde dvd alsa cdr"
6)
Code:
mirrorselect -i -o >> /mnt/gentoo/etc/make.conf

7)
Code:
mirrorselect -i -r -o >> /mnt/gentoo/etc/make.conf

utilizzando questa volta mirror americani invece che europei

8)
Code:
cp -L /etc/resolv.conf /mnt/gentoo/etc/


9) i mount di proc e bind mi davano errore in quanto già presenti

10) Chroot nel nuovo ambiente
Code:

chroot /mnt/gentoo /bin/bash
env-update
source /etc/profile
export PS1="(chroot) $PS1"


Dato che ho rimesso lo stage3, bash ha ripreso a funzionare

11)
Code:
emerge --sync
( che mi indica che i timestampe sono praticamente uguali. Cmq ho anche tentato la strada della rimozione del timestamp.x)
12) Come profilo ho lascito quello di defaultdefault/linux/x86/10.0 *

13)
Code:
cp /usr/share/zoneinfo/GMT /etc/localtime


14)
Code:
emerge gentoo-sources >> error.log


e qui iniziano i problemi dandomi come primo errore:

Code:

...
>>> Unmerging dev-libs/libxml2-2.7.7...
<<< /usr/lib/python2.6/site-packages/drv_libxml2.py[co]
<<< /usr/lib/python2.6/site-packages/libxml2.py[co]
>>> Unmerging dev-libs/mpfr-2.4.2_p3...
>>> Unmerging dev-perl/IO-Socket-SSL-1.35...
>>> Unmerging dev-perl/Net-SSLeay-1.36...
>>> Unmerging sys-apps/baselayout-1.12.14-r1...
>>> Unmerging sys-apps/module-init-tools-3.5...
>>> Unmerging sys-apps/portage-2.1.9.25...
/usr/bin/python2.6: can't open file '/usr/lib/portage/bin/filter-bash-environme$
 * ERROR: sys-apps/portage-2.1.9.25 failed:
 *   filter-bash-environment.py failed
 *
 * Call stack:
 *   ebuild.sh, line 1926:  Called preprocess_ebuild_env
 *   ebuild.sh, line 1813:  Called filter_readonly_variables
 *   ebuild.sh, line 1794:  Called die
 * The specific snippet of code:
 *      "${PORTAGE_PYTHON:-/usr/bin/python}" "${PORTAGE_BIN_PATH}"/filter-bash-$
 *

 *   filter-bash-environment.py failed
 *
 * Call stack:
 *   ebuild.sh, line 1926:  Called preprocess_ebuild_env
 *   ebuild.sh, line 1813:  Called filter_readonly_variables
 *   ebuild.sh, line 1794:  Called die
 * The specific snippet of code:
 *      "${PORTAGE_PYTHON:-/usr/bin/python}" "${PORTAGE_BIN_PATH}"/filter-bash-$
 *
 * If you need support, post the output of 'emerge --info =sys-apps/portage-2.1$
 * the complete build log and the output of 'emerge -pqv =sys-apps/portage-2.1.$
 * The complete build log is located at '/var/tmp/binpkgs/sys-apps/portage-2.1.$
 * The ebuild environment file is located at '/var/tmp/binpkgs/sys-apps/portage$
 * S: '/var/tmp/binpkgs/sys-apps/portage-2.1.9.25/work/portage-2.1.9.25'
/usr/lib/portage/bin/isolated-functions.sh: line 222: /usr/lib/portage/bin/ebui$
 * The ebuild phase 'postrm' has exited unexpectedly. This type of behavior
 * is known to be triggered by things such as failed variable assignments
 * (bug #190128) or bad substitution errors (bug #200313). Normally, before
 * exiting, bash should have displayed an error message above. If bash did
 * not produce an error message above, it's possible that the ebuild has
* The complete build log is located at '/var/tmp/binpkgs/sys-apps/portage-2.1.$
* The ebuild environment file is located at '/var/tmp/binpkgs/sys-apps/portage$
* S: '/var/tmp/binpkgs/sys-apps/portage-2.1.9.25/work/portage-2.1.9.25'
usr/lib/portage/bin/isolated-functions.sh: line 222: /usr/lib/portage/bin/ebui$
* The ebuild phase 'postrm' has exited unexpectedly. This type of behavior
* is known to be triggered by things such as failed variable assignments
* (bug #190128) or bad substitution errors (bug #200313). Normally, before
* exiting, bash should have displayed an error message above. If bash did
* not produce an error message above, it's possible that the ebuild has
* called `exit` when it should have called `die` instead. This behavior
* may also be triggered by a corrupt bash binary or a hardware problem
* such as memory or cpu malfunction. If the problem is not reproducible or
* it appears to occur randomly, then it is likely to be triggered by a
* hardware problem. If you suspect a hardware problem then you should try
* some basic hardware diagnostics such as memtest. Please do not report
* this as a bug unless it is consistently reproducible and you are sure
* that your bash binary and hardware are functioning properly.


architettura e' un x86 (Intel(R) Xeon(R) CPU 3040 @ 1.86GHz GenuineIntel) e ho già provato un paio di volte. nella scompatazione non segnala alcun errore.

proverè riformattando il disco
Back to top
View user's profile Send private message
marziods
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2009
Posts: 124
Location: <Roma>par lavor | Udine | Friul | Italie

PostPosted: Tue Feb 15, 2011 10:24 pm    Post subject: Reply with quote

Quote:
14)
Codice:
Code:
emerge gentoo-sources >> error.log



scusami, ma perche mandi tutto ad >> error.log?
per la cronaca sto eseguendo anche io un installazione su una macchina con processore intel e non mi ha dato alcun problema a parte un mio errore di battitura sul make.conf... nn è che per caso sia successo anche a te??? prova a postare il tuo make.conf
(io per la cronaca uso un mirror francese)
_________________
linux user #493115
Back to top
View user's profile Send private message
marziods
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2009
Posts: 124
Location: <Roma>par lavor | Udine | Friul | Italie

PostPosted: Tue Feb 15, 2011 10:46 pm    Post subject: Reply with quote

interessante... durante la compilazione del kernel mi è andato in kernel panic... ma credo sia la piastra che da i numeri... oppure qualcosa che non va nei vari stage...
_________________
linux user #493115
Back to top
View user's profile Send private message
oPKo
n00b
n00b


Joined: 15 Feb 2011
Posts: 4

PostPosted: Wed Feb 16, 2011 7:41 am    Post subject: Reply with quote

marziods wrote:
Quote:
14)
Codice:
Code:
emerge gentoo-sources >> error.log



scusami, ma perche mandi tutto ad >> error.log?
per la cronaca sto eseguendo anche io un installazione su una macchina con processore intel e non mi ha dato alcun problema a parte un mio errore di battitura sul make.conf... nn è che per caso sia successo anche a te??? prova a postare il tuo make.conf
(io per la cronaca uso un mirror francese)


Mando sul error.log perché altrimenti non riesco a vedere il priimo errore da console.

Ho provato anche con un mirror francese.

Proverò a rifare tutto da capo e vediamo....
Back to top
View user's profile Send private message
oPKo
n00b
n00b


Joined: 15 Feb 2011
Posts: 4

PostPosted: Wed Feb 16, 2011 9:42 am    Post subject: Reply with quote

Rieseguendo i passi da 0, compresa la ripartizione del disco rigido tutto è andato liscio.

Grazie comunque per il supporto!
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Wed Feb 16, 2011 9:43 am    Post subject: Reply with quote

oPKo wrote:
nel mentre ho ripreso dallo stage scaricato e in sequenza ho eseguito:

3)
Code:
rm -r -f /usr/portage


4)
Code:
tar xvjf portage-latest.tar.bz2 -C /mnt/gentoo/usr



HANDBOOK wrote:

tar xvjf /mnt/gentoo/portage-latest.tar.bz2 -C /mnt/gentoo/usr


non cancellare /usr/portage/

riprova seguendo pedissequamente. non mi ricordo bene cosa faccia xvjf, ma supponi che dentro /usr/portage/ ci siano dei files che non verranno sovrascritti.
dopotutto, l'errore ti dice che non riesce a trovare dei file, guarda caso, proprio dentro /usr/portage/

-------------------
edit: vedo che hai già risolto nel mentre ho scritto il mio messaggio.
bene!
_________________
Darkman
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum