Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Aiuto: installazione src kernel failure
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
giuwalker
n00b
n00b


Joined: 27 Jan 2011
Posts: 5

PostPosted: Thu Jan 27, 2011 6:23 pm    Post subject: [Risolto] Aiuto: installazione src kernel failure Reply with quote

Salve a tutti, sono un nuovo utente e, vorrei fare i complimenti a tutta la comunità gentoo per l'ottimo supporto che fornisce (guide e forum) :)

Vengo al dunque.
Sto cercando di installare gentoo sul mio portatile:
apple ibook g4 12" 800MHz, 256MB di ram, ati mobility radeon 9200.
Sono arrivato al punto di installare i sorgenti kernel gentoo per poi proseguire con la configurazione e compilazione del kernel. Purtroppo anche facendo svariati tentativi (cambiando la config. del file make.conf e anche del profilo di sistema), l'installazione fallisce sempre :(
Nella speranza che qualcuno possa aiutarmi, incollo di seguito l'output a video del mio terminale:

(chroot) ubuntu / # more /etc/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -mcpu=7455 -mtune=7455 -maltivec -mabi=altivec -fno-strict-aliasing -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="powerpc-unknown-linux-gnu"
GENTOO_MIRRORS="http://gentoo.inode.at/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo http://de-mirror.org/distro/gentoo/"
SYNC="rsync://gd.tuwien.ac.at/opsys/linux/gentoo/ rsync://rsync.fr.gentoo.org rsync://rsync9.de.gentoo.org"
#USE="altivec glade lock consolekit fortune gnome-keyring keyboard sound thunar grace libmpd audacious mpd chromium firefox -gtk -gnome -qt4 -kde dvd alsa cdr"

(chroot) ubuntu / # eselect profile list
Available profile symlink targets:
[1] default/linux/powerpc/ppc32/10.0
[2] default/linux/powerpc/ppc32/10.0/desktop *
[3] default/linux/powerpc/ppc32/10.0/desktop/gnome
[4] default/linux/powerpc/ppc32/10.0/desktop/kde
[5] default/linux/powerpc/ppc32/10.0/developer
[6] default/linux/powerpc/ppc32/10.0/server
[7] default/linux/powerpc/ppc64/10.0/32bit-userland
[8] default/linux/powerpc/ppc64/10.0/32bit-userland/desktop
[9] default/linux/powerpc/ppc64/10.0/32bit-userland/desktop/gnome
[10] default/linux/powerpc/ppc64/10.0/32bit-userland/desktop/kde
[11] default/linux/powerpc/ppc64/10.0/32bit-userland/developer
[12] default/linux/powerpc/ppc64/10.0/32bit-userland/server
[13] hardened/linux/powerpc/ppc32
[14] hardened/linux/powerpc/ppc64/32bit-userland
(chroot) ubuntu / # eselect profile set 3
(chroot) ubuntu / # clear




(chroot) ubuntu / # emerge gentoo-sources

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-kernel/gentoo-sources-2.6.32-r20
openpty failed: 'out of pty devices'
* linux-2.6.32.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* genpatches-2.6.32-24.base.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* genpatches-2.6.32-24.extras.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* Package: sys-kernel/gentoo-sources-2.6.32-r20
* Repository: gentoo
* Maintainer: kernel@gentoo.org
* USE: elibc_glibc kernel_linux ppc userland_GNU
>>> Preparing to unpack ...
>>> Unpacking source...
>>> Unpacking linux-2.6.32.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/work
>>> Unpacking genpatches-2.6.32-24.base.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/work/patches
>>> Unpacking genpatches-2.6.32-24.extras.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/work/patches
* Applying 1000_linux-2.6.32.1.patch (-p0+) ... [ ok ]
* Applying 1001_linux-2.6.32.2.patch (-p0+) ... [ ok ]
* Applying 1002_linux-2.6.32.3.patch (-p0+) ... [ ok ]
* Applying 1003_linux-2.6.32.4.patch (-p0+) ... [ ok ]
* Applying 1004_linux-2.6.32.5.patch (-p0+) ... [ ok ]
* Applying 1005_linux-2.6.32.6.patch (-p0+) ... [ ok ]
* Applying 1006_linux-2.6.32.7.patch (-p0+) ... [ ok ]
* Applying 1007_linux-2.6.32.8.patch (-p0+) ... [ ok ]
* Applying 1008_linux-2.6.32.9.patch (-p0+) ... [ ok ]
* Applying 1009_linux-2.6.32.10.patch (-p0+) ... [ ok ]
* Applying 1010_linux-2.6.32.11.patch (-p0+) ... [ ok ]
* Applying 1011_linux-2.6.32.12.patch (-p0+) ... [ ok ]
* Applying 1012_linux-2.6.32.13.patch (-p0+) ... [ ok ]
* Applying 1013_linux-2.6.32.14.patch (-p0+) ... [ ok ]
* Applying 1014_linux-2.6.32.15.patch (-p0+) ... [ ok ]
* Applying 1015_linux-2.6.32.16.patch (-p0+) ... [ ok ]
* Applying 1016_linux-2.6.32.17.patch (-p0+) ... [ ok ]
* Applying 1017_linux-2.6.32.18.patch (-p0+) ... [ ok ]
* Applying 1018_linux-2.6.32.19.patch (-p0+) ... [ ok ]
* Applying 1019_linux-2.6.32.20.patch (-p0+) ... [ ok ]
* Applying 1020_linux-2.6.32.21.patch (-p0+) ... [ ok ]
* Applying 1021_linux-2.6.32.22.patch (-p0+) ... [ ok ]
* Applying 1022_linux-2.6.32.23.patch (-p0+) ... [ ok ]
* Applying 1023_linux-2.6.32.24.patch (-p0+) ... [ ok ]
* Applying 2500_libata-fix-truncated-LBA48-ret-vals.patch (-p0+) ... [ ok ]
* Applying 4100_dm-bbr.patch (-p0+) ... [ ok ]
* Applying 4200_fbcondecor-0.9.6.patch (-p0+) ... [ ok ]
* Applying 4400_alpha-sysctl-uac.patch (-p0+) ... [ ok ]
touch: setting times of `/var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/.unpacked': No such file or directory
* ERROR: sys-kernel/gentoo-sources-2.6.32-r20 failed:
* IO Failure -- Failed 'touch .unpacked' in /var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20
*
* Call stack:
* ebuild.sh, line 2320: Called ebuild_main
* ebuild.sh, line 2227: Called dyn_unpack
* ebuild.sh, line 746: Called die
* The specific snippet of code:
* touch "${PORTAGE_BUILDDIR}/.unpacked" || die "IO Failure -- Failed 'touch .unpacked' in ${PORTAGE_BUILDDIR}"
*
* If you need support, post the output of 'emerge --info =sys-kernel/gentoo-sources-2.6.32-r20',
* the complete build log and the output of 'emerge -pqv =sys-kernel/gentoo-sources-2.6.32-r20'.
* The complete build log is located at '/var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/temp/environment'.
* S: '/var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/work/linux-2.6.32-gentoo-r20'

>>> Failed to emerge sys-kernel/gentoo-sources-2.6.32-r20, Log file:

>>> '/var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/temp/build.log'

* Messages for package sys-kernel/gentoo-sources-2.6.32-r20:

* ERROR: sys-kernel/gentoo-sources-2.6.32-r20 failed:
* IO Failure -- Failed 'touch .unpacked' in /var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20
*
* Call stack:
* ebuild.sh, line 2320: Called ebuild_main
* ebuild.sh, line 2227: Called dyn_unpack
* ebuild.sh, line 746: Called die
* The specific snippet of code:
* touch "${PORTAGE_BUILDDIR}/.unpacked" || die "IO Failure -- Failed 'touch .unpacked' in ${PORTAGE_BUILDDIR}"
*
* If you need support, post the output of 'emerge --info =sys-kernel/gentoo-sources-2.6.32-r20',
* the complete build log and the output of 'emerge -pqv =sys-kernel/gentoo-sources-2.6.32-r20'.
* The complete build log is located at '/var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/temp/environment'.
* S: '/var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/work/linux-2.6.32-gentoo-r20'

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


Last edited by giuwalker on Thu Feb 03, 2011 1:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Jan 27, 2011 7:16 pm    Post subject: Reply with quote

Code:
openpty failed: 'out of pty devices'
iniziamo da questo.
quando monti dev proc e sys per il chroot usa --rbind non --bind
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
giuwalker
n00b
n00b


Joined: 27 Jan 2011
Posts: 5

PostPosted: Thu Jan 27, 2011 9:27 pm    Post subject: Reply with quote

Prima di tutto grazie per l'aiuto e la tempestività della risposta :D

djinnZ wrote:
Code:
openpty failed: 'out of pty devices'
iniziamo da questo.
quando monti dev proc e sys per il chroot usa --rbind non --bind


Ho provato, purtroppo con esito negativo. L'errore è sempre lo stesso.
Listo comunque la sequenza dei comandi utilizzati, magari sbaglio qualcosa (le opzioni di configurazione che riporta la guida di installazione ppc sono state precedentemente effettuate fino al punto 7:Config. del kernel):

Code:

ubuntu@ubuntu:~$ sudo su -
root@ubuntu:~# mkdir /mnt/gentoo
root@ubuntu:~# mount -t ext3 /dev/hda4 /mnt/gentoo/
root@ubuntu:~# mount -t proc none /mnt/gentoo/proc/ (provato anche con: mount -t proc rbind /mnt/gentoo/proc/ )
root@ubuntu:~# mount -o rbind /dev/ /mnt/gentoo/dev/ (provato anche con: mount -o bind /dev/ /mnt/gentoo/dev/)
root@ubuntu:~# chroot /mnt/gentoo/ /bin/bash
ubuntu / # env-update
>>> Regenerating /etc/ld.so.cache...
ubuntu / # source /etc/profile
ubuntu / # export PS1="(chroot) $PS1"
(chroot) ubuntu / #
(chroot) ubuntu / # emerge gentoo-sources
...elaborazione...errore
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Jan 28, 2011 1:32 pm    Post subject: Reply with quote

:? i comandi corretti sono
Code:
mount --rbind /dev /mnt/gentoo/dev
mount --rbind /proc /mnt/gentoo/proc
mount --rbind /sys /mnt/gentoo/sys
verifica con
Code:
ls /dev/pts
ls /mnt/gentoo/dev/pts
se corrispondono e se
mount | grep devpts:
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600)
restituisce qualcosa del genere.
( mi sa che nella giuda la cosa non è mai stata spiegata bene... e non posso più neppure sfottere scen :cry: )
spero che non sei in ~arch (t'arrangi in questo caso) e verifica se il kernel che stai usando per il chroot ha il supporto pty attivo.
Prova a cambiare versione del kernel da installare e ripulisci tmp prima di provare
Code:
rm -Rf /var/tmp/portage/*

vedi se c'è roba in /var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20 o se non si ferma per spazio esaurito
e vedi se c'è qualche messaggio d'errore in /var/tmp/portage/sys-kernel/gentoo-sources-2.6.32-r20/temp

altro non mi viene in mente, mai usato il profilo ppc ma l'errore è generico e mi ricorda un vecchio bug.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
giuwalker
n00b
n00b


Joined: 27 Jan 2011
Posts: 5

PostPosted: Fri Jan 28, 2011 6:42 pm    Post subject: Reply with quote

Quote:
[/code]verifica con
Code:
ls /dev/pts
ls /mnt/gentoo/dev/pts
se corrispondono

si, corrispondono (mi ritorna 0)

Quote:

e se
mount | grep devpts:
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600)
restituisce qualcosa del genere.

si, mi ritorna qualcosa del genere

Quote:

( mi sa che nella giuda la cosa non è mai stata spiegata bene... e non posso più neppure sfottere scen :cry: )
spero che non sei in ~arch (t'arrangi in questo caso)

Scusa se magari può sembrare stupida come domanda, ma cosa intendi per ~arch ?
Per quanto riguarda la guida magari sarebbe da aggiornare a questo punto ! :?

Quote:

altro non mi viene in mente, mai usato il profilo ppc ma l'errore è generico e mi ricorda un vecchio bug.

Non saprei se sia un bug, comunque, dopo aver montato i filesystems con le direttive --rbind che mi hai indicato, ho provato a installare i sorgenti
1. gentoo-sources
2. ck-sources
3. vanilla-sources

e il risultato è sempre uguale. La macchina si impalla e mi ritorna lo stesso errore :( [/quote]
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Jan 28, 2011 8:44 pm    Post subject: Reply with quote

se in make.conf metti ACCEPT_KEYWORDS="~arch" (per me che uso amd64 è ~amd64 o ~x86 per i pc a 32 bit etc) ammetti tutti i pacchetti marcati come instabili (cosa valida solo per chi sa cosa sta facendo). Sulle prime molti fanno questo errore per questo te lo ho detto.
Mi pare strano che hai solo un device pseudoterminale attivo vedi se
cat /proc/sys/kernel/pty/max :
4096
altrimenti vedi se rientri in questi due casi
zcat /proc/config.gz | grep PTY:
CONFIG_UNIX98_PTYS=y
# CONFIG_LEGACY_PTYS is not set
zcat /proc/config.gz | grep PTY:
CONFIG_UNIX98_PTYS=y
CONFIG_LEGACY_PTYS=Y

se invece hai
zcat /proc/config.gz | grep DEVPTS:
CONFIG_DEVPTS_MULTIPLE_INSTANCES =Y
potresti provare nel chroot un
Code:
mount -o newinstance -t devpts devpts /dev/pts
vedi anche con free e df se hai abbastanza risorse libere.
Che stai usando per avviare il chroot?
esattamente mount cosa riporta per devpts?

Se vai di fretta c'è anche irc, ovviamente.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
giuwalker
n00b
n00b


Joined: 27 Jan 2011
Posts: 5

PostPosted: Sat Jan 29, 2011 3:28 pm    Post subject: Reply with quote

djinnZ wrote:
se in make.conf metti ACCEPT_KEYWORDS="~arch" (per me che uso amd64 è ~amd64 o ~x86 per i pc a 32 bit etc) ammetti tutti i pacchetti marcati come instabili (cosa valida solo per chi sa cosa sta facendo). Sulle prime molti fanno questo errore per questo te lo ho detto.

Non ce l'ho messo.

djinnZ wrote:

Mi pare strano che hai solo un device pseudoterminale attivo vedi se
cat /proc/sys/kernel/pty/max :
4096
altrimenti vedi se rientri in questi due casi
zcat /proc/config.gz | grep PTY:
CONFIG_UNIX98_PTYS=y
# CONFIG_LEGACY_PTYS is not set
zcat /proc/config.gz | grep PTY:
CONFIG_UNIX98_PTYS=y
CONFIG_LEGACY_PTYS=Y

se invece hai
zcat /proc/config.gz | grep DEVPTS:
CONFIG_DEVPTS_MULTIPLE_INSTANCES =Y
potresti provare nel chroot un
Code:
mount -o newinstance -t devpts devpts /dev/pts
vedi anche con free e df se hai abbastanza risorse libere.
esattamente mount cosa riporta per devpts?

Ti riporto per semplicità l'output a video:
Code:

root@ubuntu:~# cat /proc/sys/kernel/pty/max
4096
root@ubuntu:~# zcat /proc/config.gz | grep PTY
zcat: /proc/config.gz: No such file or directory
root@ubuntu:~#
root@ubuntu:~# zcat /proc/config.gz | grep DEVPTS
zcat: /proc/config.gz: No such file or directory


djinnZ wrote:

Che stai usando per avviare il chroot?

Sto usando un livecd ppc di ubuntnu ver. 5.10 (è un pò vecchiotta come live...)

djinnZ wrote:

Se vai di fretta c'è anche irc, ovviamente.

Il portatile in questo perido lo sto usando poco, e lo voglio ottimizzare con un so ad hoc.
Ci metto mani la sera quando torno a casa, quindi non ho fretta.
Grazie comunque per la disponibiltà e la pazienza che stai dimostrando :D
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Feb 01, 2011 7:53 pm    Post subject: Reply with quote

giuwalker wrote:
Sto usando un livecd ppc di ubuntnu ver. 5.10 (è un pò vecchiotta come live...)
forse è il caso di prendere una versione un pochino più aggiornata.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
giuwalker
n00b
n00b


Joined: 27 Jan 2011
Posts: 5

PostPosted: Wed Feb 02, 2011 11:20 am    Post subject: Reply with quote

Alla fine ho provato a continuare l'installazione dei sorgenti avviando il computer con l'iso ppc minimal di gentoo.
L'installazione è andata a buon fine e anche la compilazione del kernel.
Ieri sera ho potuto avviare finalmente il sistema base. :D

djinnZ wrote:
giuwalker wrote:
Sto usando un livecd ppc di ubuntnu ver. 5.10 (è un pò vecchiotta come live...)
forse è il caso di prendere una versione un pochino più aggiornata.


Alla fine mi sa proprio che era il cd live di ubuntu che mi dava errore... 8O

Di nuovo un grazie a djinnZ per l'aiuto offertomi con tanta pazienza :)

Per me si può quindi aggiornare il titolo del post con "risolto"
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Feb 02, 2011 1:48 pm    Post subject: Reply with quote

giuwalker wrote:

Per me si può quindi aggiornare il titolo del post con "risolto"

:lol:
tu sei l'unico che può farlo, accedendo in edit al post iniziale.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Feb 03, 2011 8:02 pm    Post subject: Reply with quote

giuwalker wrote:
Di nuovo un grazie a djinnZ
Non sono portato ad apprezzare ringraziamenti ed apprezzamenti sulla mia persona.

Mi fa piacere che hai risolto anche se, se avessi detto subito che utilizzavi una versione tanto datata (probabilmente avrà i legacy pty abilitati e gli unix 98 disabilitati), ci saremmo risparmiati tempo e fatica ma è normale bloccarsi su simili inezie piuttosto che su questioni più "serie" e complesse, come disse un tizio il problema non è tanto giungere alla conoscenza nascosta, con tempo ed impegno ci si arriva sempre, il problema è trovare quello che è banale od abbiamo davanti agli occhi.

Per il resto mi sa che dovrai arrangiarti (quindi mi hai incensato inutilmente) visto che probabilmente dovrò abbandonare di nuovo gentoo e forse in via definitiva.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum