Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Conflict between polkit AND polkit-gnome
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Salem
Tux's lil' helper
Tux's lil' helper


Joined: 10 Nov 2002
Posts: 103
Location: Bayreuth, Germany

PostPosted: Sun Jan 16, 2011 6:21 am    Post subject: Conflict between polkit AND polkit-gnome Reply with quote

Hello,

i'm searching for a solution for this conflict:
Code:
sys-auth/polkit:0

  (sys-auth/polkit-0.99-r1, ebuild scheduled for merge) conflicts with
    <sys-auth/polkit-0.99 required by (gnome-extra/polkit-gnome-0.96-r1, ebuild scheduled for merge)


I tried to mask it, but didn't help :(

Thanks
_________________
Salem
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 873
Location: Germany

PostPosted: Sun Jan 16, 2011 7:48 am    Post subject: Reply with quote

Hi,

try upgrading polkit-gnome so it won't depend on <sys-auth/polkit-0.99 anymore.
You could also mask >=polkit-0.96.

Polkit-0.99 is not yet marked stable in my portage tree, so if you don't actually need the latest version of polkit, just stick* with 0.96 and you should be fine.
Alternatively upgrade polkit-gnome (put "sys-auth/polkit-gnome ~arch", where arch is your processor architecture (amd64, x86, sparc, ppc...) into /etc/portage/package.keywords), but I can't guarantee that this won't cause other dependency issues.

If you get circular dependencies (because you still have polkit-0.96 or something on your system and gnome-polkit-0.99 needs a higher version of polkit to be upgraded, but polkit can't be upgraded, because polkit-gnome is still installed and depends on polkit-96 etc ad nauseam) unmerge polkit-gnome, upgrade polkit, re-emerge polkit-gnome.
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
Salem
Tux's lil' helper
Tux's lil' helper


Joined: 10 Nov 2002
Posts: 103
Location: Bayreuth, Germany

PostPosted: Tue Jan 18, 2011 12:19 am    Post subject: Reply with quote

Thanks :-)

i masked polkit>=0.96. Should be enough for the moment.
_________________
Salem
Back to top
View user's profile Send private message
dalek
Veteran
Veteran


Joined: 19 Sep 2003
Posts: 1344
Location: Mississippi USA

PostPosted: Fri Jan 28, 2011 7:19 am    Post subject: Reply with quote

I had to unmask and keyword gnome-extra/polkit-gnome-0.99 to get rid of this message. I'm on amd64.

:D :D
_________________
My rig: Gigabyte GA-970A-UD3P mobo, AMD FX-8350 Eight-Core CPU, ZALMAN CNPS10X Performa CPU cooler,
G.SKILL 32GB DDR3 PC3 12800 Memory Nvidia GTX-650 video card LG W2253 Monitor
9TBs of hard drive space using LVM
Cooler Master HAF-932 Case
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum