Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[VirtualBox] VMs ne démarrent plus suite à la mise à jour
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Thu Jan 13, 2011 2:57 pm    Post subject: [VirtualBox] VMs ne démarrent plus suite à la mise à jour Reply with quote

Bonjour,

J'ai mis Virtualbox-bin à jour (3.2.12-r1 -> 4.0.0-r1)

Depuis, impossible de démarrer les VMs. Que ce soit les anciennes, ou une nouvelle crée avec cette version.

J'obtient ce message:
Code:

RTR3Init failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing

'/etc/init.d/vboxdrv setup'

may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.


Quelqu'un aurait une idée?

Note: J'ai bien modprobe -r les_modulesVB, et modprobe de nouveau (en fait j'ai même redémarrer la machine depuis et aucun résultat)
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Thu Jan 13, 2011 3:02 pm    Post subject: Reply with quote

Tu devrais lire ce que tu nous montre comme message d'erreur. C'est aussi gros qu'une maison.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Thu Jan 13, 2011 3:05 pm    Post subject: Reply with quote

Sauf que d'après emerge, tout s'est bien passé.
que /etc/init.d/vboxdrv n'existe pas
que virtualbox-modules-4 est installé (et, toujours d'après emerge, sans soucis)
Et a priori, je n'ai rien mixé comme version (juste emerge virtualbox-bin)
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu Jan 13, 2011 3:19 pm    Post subject: Reply with quote

Tu peux nous faire un uname -r ainsi qu'un eselect kernel show ?
Sinon, si tu avais utilisé virtualbox juste avant de le mettre à jour, il faut peut-être faire un rmmod suivi d'un modprobe des modules ...


Last edited by ghoti on Thu Jan 13, 2011 3:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Thu Jan 13, 2011 3:22 pm    Post subject: Reply with quote

linux-2.6.34-gentoo-r12 des deux côtés. Ce n'est pas si vieux si? :p
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu Jan 13, 2011 3:23 pm    Post subject: Reply with quote

Arf, j'éditais au moment où tu as répondu : veux-tu voir la fin de mon post précédent ?
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Thu Jan 13, 2011 3:24 pm    Post subject: Reply with quote

ghoti wrote:

Sinon, si tu avais utilisé virtualbox juste avant de le mettre à jour, il faut peut-être faire un rmmod suivi d'un modprobe des modules ...


Ca a été fait (enfin, via modprobe -r)
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu Jan 13, 2011 3:26 pm    Post subject: Reply with quote

Au fait, ma première question n'était pas pour vérifier la version particulière du noyau mais plutôt pour contrôler que les sources correspondaient bien à ton noyau actif, ce qui semble être le cas ... ;-)
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Thu Jan 13, 2011 3:30 pm    Post subject: Reply with quote

c'est bien le cas oui :)
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu Jan 13, 2011 3:38 pm    Post subject: Reply with quote

Quelqu'un semble avoir le même message que toi sur le forum de Virtualbox.
D'après le gars, c'est parce qu'il essayait d'utiliser une version 32 bits sur une plateforme 64 bits.
Ça évoque quelque-chose pour toi ?
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Thu Jan 13, 2011 3:47 pm    Post subject: Reply with quote

Moui, j'ai bien un système en amd64 (multilib), mais l'ebuild test cela et configure SRC_URI en conséquence.
Dans le doute dans mes distfiles, il s'agit bien de VirtualBox-4.0.0-69151-Linux_amd64.run

Et puis, en version 3.2.12, ça fonctionnait :/
Back to top
View user's profile Send private message
freezby
Tux's lil' helper
Tux's lil' helper


Joined: 07 Sep 2006
Posts: 103
Location: Angers, France

PostPosted: Thu Jan 13, 2011 3:50 pm    Post subject: Reply with quote

Salut,

Les modules ont également été recompilés/updatés à la version 4 ?
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Thu Jan 13, 2011 4:01 pm    Post subject: Reply with quote

Oui oui:

Code:

[I] app-emulation/virtualbox-modules
     Available versions:  3.1.8 (~)3.2.10 3.2.12{tbz2} (~)4.0.0{tbz2} {kernel_linux}
     Installed versions:  4.0.0{tbz2}(12:55:28 AM 01/11/2011)(kernel_linux)
     Homepage:            http://www.virtualbox.org/
     Description:         Kernel Modules for Virtualbox
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu Jan 13, 2011 4:32 pm    Post subject: Reply with quote

Tu as fait l'emerge de virtualbox-bin aujourd'hui ou bien le 11/01 ?
Je demande ça parce qu'il me semble que les modules v4 sont sortis avant le package lui-même et qu'ils ont donc peut-être été compilés pour vbox 3.2 ... :?
Essaye peut-être de recompiler les modules : ce n'est pas pour le temps que ça prend ! ;-)
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Thu Jan 13, 2011 5:30 pm    Post subject: Reply with quote

La version qu'on prends sur le site de VBox fonctionne très bien, et /etc/init.d/vboxdrv existe
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu Jan 13, 2011 10:38 pm    Post subject: Reply with quote

Cr0k wrote:
La version qu'on prends sur le site de VBox fonctionne très bien, et /etc/init.d/vboxdrv existe

Heu, mais la version utilisée par l'ebuild provient directement du site de VBox ! :
Quote:
SRC_URI="amd64? ( http://download.virtualbox.org/virtualbox/${PV}/${MY_P}_amd64.run )

Je ne sais pas ce que fait /etc/init.d/vboxdrv mais j'imagine qu'il ne fait rien d'autre que charger les modules, ce que gentoo réalise par ses propres méthodes (/etc/conf.d/modules).
Avant de casser la distrib en contournant le système de packages, je crois qu'il vaudrait mieux s'assurer que l'ebuild a réellement un problème ! ;-)
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Fri Jan 14, 2011 1:26 am    Post subject: Reply with quote

Hello,
C'est bizarre, moi ça fonctionne bien. Essai avec un kernel plus récent (perso je suis sur le 2.6.37-gentoo)
Mais avant réinstalle à nouveau virtualbox (bin et module), peut-être que dans la copie de fichier ça a merdé quelque part...
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum