Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Multiple packet instances issue while installing kde
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
LaFolle
n00b
n00b


Joined: 07 Jul 2010
Posts: 34
Location: Aryadesa

PostPosted: Wed Jan 12, 2011 11:04 pm    Post subject: Multiple packet instances issue while installing kde Reply with quote

I am stuck here. This is what I am getting on this command:
Code:
 USE="qt4 sql svg webkit mng opengl" emerge --newuse kde-meta

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-core:4

  ('installed', '/', 'x11-libs/qt-core-4.7.1-r1', 'nomerge') pulled in by
    >=x11-libs/qt-core-4.6.3:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/kollision-4.5.4', 'merge')
    >=x11-libs/qt-core-4.6.3:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/kdeartwork-styles-4.5.4', 'merge')
    >=x11-libs/qt-core-4.6.3:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/kdebase-wallpapers-4.5.4', 'merge')
    (and 204 more)

  ('ebuild', '/', 'x11-libs/qt-core-4.7.1-r1', 'merge') pulled in by
    ~x11-libs/qt-core-4.7.1[glib,-debug,-aqua,-qt3support] required by ('ebuild', '/', 'x11-libs/qt-gui-4.7.1-r1', 'merge')
    (and 3 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously. You may want to try a larger value of the
--backtrack option, such as --backtrack=30, in order to see if that will
solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

I do not know which package to mask.

Thanks

EDIT: This is solved by adding 'qt3support' to USE flag.


Last edited by LaFolle on Sun Jan 16, 2011 5:33 pm; edited 2 times in total
Back to top
View user's profile Send private message
LaFolle
n00b
n00b


Joined: 07 Jul 2010
Posts: 34
Location: Aryadesa

PostPosted: Thu Jan 13, 2011 7:58 pm    Post subject: Reply with quote

Anyone there??
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1265

PostPosted: Fri Jan 14, 2011 8:36 am    Post subject: Reply with quote

well, first instead of using then USE="<stuff>" emerge <package>, I would suggest that the use should be set in /etc/portage/package.use or /etc/make.conf. This helps avoid problems with upgrades.
I do not think you what to mask anything, because it looks like problems with the use fags and/or dependency calculation.
Three things I can think of to try
1. run
Code:
emerge --newuse --deep kde-meta

2. add kde to you use fags
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
phajdan.jr
Developer
Developer


Joined: 23 Mar 2006
Posts: 1764
Location: Poland

PostPosted: Fri Jan 14, 2011 11:26 am    Post subject: Reply with quote

See https://forums.gentoo.org/viewtopic-t-835218-start-0.html . Does it help? Also, rather avoid passing USE from command-line, it's very error-prone (i.e. those USE flag settings are later forgotten).
_________________
http://phajdan-jr.blogspot.com/
Back to top
View user's profile Send private message
LaFolle
n00b
n00b


Joined: 07 Jul 2010
Posts: 34
Location: Aryadesa

PostPosted: Fri Jan 14, 2011 3:52 pm    Post subject: Reply with quote

phajdan.jr wrote:
See https://forums.gentoo.org/viewtopic-t-835218-start-0.html . Does it help? Also, rather avoid passing USE from command-line, it's very error-prone (i.e. those USE flag settings are later forgotten).


Thanks, it did the job.
Back to top
View user's profile Send private message
LaFolle
n00b
n00b


Joined: 07 Jul 2010
Posts: 34
Location: Aryadesa

PostPosted: Fri Jan 14, 2011 4:07 pm    Post subject: Reply with quote

penguin swordmaster wrote:
well, first instead of using then USE="<stuff>" emerge <package>, I would suggest that the use should be set in /etc/portage/package.use or /etc/make.conf. This helps avoid problems with upgrades.
I do not think you what to mask anything, because it looks like problems with the use fags and/or dependency calculation.
Three things I can think of to try
1. run
Code:
emerge --newuse --deep kde-meta

2. add kde to you use fags


I actually I started with
Code:
emerge kde-meta
As I proceeded, portage told me to use particular use flags to resolve dependency issues. Thats why I added them to bash environment variable. Now, I have added some that I really need to the appropriate files.

Thanks.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Mon Jan 17, 2011 7:35 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads, please follow up to [SOLVED] qt-core conflict: +/- qt3support.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum