Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Problema busybox
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Jan 09, 2011 7:32 pm    Post subject: [RISOLTO] Problema busybox Reply with quote

Salve a tutti avrei un problema in fase di ricompilazione della busybox questo è l'errore
Code:
make: i686-pc-linux-gnu-strip: Command not found
make: *** [busybox] Error 127
 * ERROR: sys-apps/busybox-1.17.4 failed:
 *   build failed
 *
 * Call stack:
 *     ebuild.sh, line  47:  Called src_compile
 *   environment, line 2746:  Called die
 * The specific snippet of code:
 *       emake busybox || die "build failed";
 *
 * If you need support, post the output of 'emerge --info =sys-apps/busybox-1.17.4',
 * the complete build log and the output of 'emerge -pqv =sys-apps/busybox-1.17.4'.
 * The complete build log is located at '/var/tmp/portage/sys-apps/busybox-1.17.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/busybox-1.17.4/temp/environment'.
 * S: '/var/tmp/portage/sys-apps/busybox-1.17.4/work/busybox-1.17.4'

Vorrei sapere se qualcuno sa quale pacchetto contiene il comando che non trova ovvero i686-pc-linux-gnu-strip o se l'errore potrebbe dipendere dal fatto che io ho modificato come suggerito dal wiki di gentoo le safe flags da CHOST="i386-pc-linux-gnu" in CHOST="i686-pc-linux-gnu" ed in qualche modo non si è preso qualche dipendenza giusta saltando cosi il pacchetto. Premetto che la modifica del make.conf è fatta in chroot prima ancora di installare il sistema quindi mi sembra difficile che l'errore dipenda da questo.


Last edited by stifler83 on Wed Jan 12, 2011 2:17 am; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Jan 09, 2011 8:01 pm    Post subject: Reply with quote

a me il pacchetto compila.

un modo per verificare l'ipotesi può essere mettere un symlink provvisorio in /usr/lib/gcc/.

in ogni caso, questa è la guida per aggiustare un chroot bacato.

una volta, mi ero semidistrutto il sistema lanciando un improvvido busybox --install e non sapevo capacitarmi delle numerosissime stranezze che accadevano da tutte le parti.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Jan 09, 2011 9:34 pm    Post subject: Reply with quote

C'è qualcosa che non mi torna, se il sistema è "nato" con chost settato a i686 com'è possibile che non vada bene? tra l'altro l'errore nella compilazione richiede proprio lo strip per i686.

Tra l'altro quando vado ad eseguire # gcc-config -l mi restituisce che non ho un comilatore settato e che l'unico in lista è i486. Idee?
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Wed Jan 12, 2011 2:16 am    Post subject: Reply with quote

Ok ho lanciato un bel emerge -e glibc ho controllato che il mio bel compilare che prima era settato su i486 questa volta fosse i686 ed il gioco è fatto ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum